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Designing, Deploying, and
Managing Stationery

Understanding Stationery
Designing Stationery
Deploying Stationery
Managing and Updating Stationery

This section outlines the Stationery design, deployment, and management process. ePublisher Express
projects use Stationery designed in ePublisher Designer to define the appearance and behavior of
generated output. You can use Stationery to define a standard for one or more projects to use. You can
also customize the design to meet your specific needs.

Writers use the Stationery when they create projects. When the Stationery designer changes or updates
the Stationery a project uses, ePublisher prompts writers to synchronize their projects with the updated
Stationery associated with their projects. This powerful feature allows you to quickly deploy and manage
Stationery updates across your organization.
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Understanding Stationery
ePublisher projects use Stationery designed in ePublisher Designer by a Stationery designer to define the
appearance and behavior of generated output. Stationery is a complete set of processing rules and styles
that define all aspects of the output. Writers use the Stationery created by the Stationery designer when
they create projects and generate output. Once the Stationery designer changes or updates the Stationery,
ePublisher prompts writers when they open projects associated with that Stationery to synchronize their
projects with the updated Stationery.

Stationery design projects are not based on Stationery. These projects are created in ePublisher Designer
and are used to create and maintain Stationery. To modify or update Stationery, you need to update the
Stationery design project and then save it as Stationery.

Stationery stores all the style and behavior settings. Stationery also captures the transformation process
and isolates it from changes in future ePublisher releases. Since you can always use ePublisher Designer
to create new Stationery, you can easily maintain the existing Stationery and move forward with a
new ePublisher release. You can also limit the number of formats included in a Stationery to reduce
complexity and potential confusion in your working environment. Each output format, such as HTML
Help, WebWorks Help, and Dynamic HTML, requires certain files to generate output. Without these files,
the formats do not have the components required to generate the correct output.

To create a new project, ePublisher Express users must have Stationery. For more information about
Stationery and how it works, see “Stationery, Projects, and Overrides”.
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Stationery Components
Stationery includes the following components:

Stationery .wxsp file
Contains the style definitions and target settings for the selected output formats and targets. This
file stores the style definitions including paragraph, character, table, page, graphic, and marker
styles. This file also stores the conditions, variable values, cross-reference definitions, and target
settings for each target.

Manifest file
Identifies the files in the Files , Formats , and Targets  folders associated with the Stationery.
Any time a Stationery designer adds, removes, or modifies a file in one of these folders and saves
the Stationery, ePublisher updates the Stationery manifest file.

Files folder
Contains all the files and folders you want to include in the project. ePublisher copies these files
and folders to the output location and includes them in the output.

Formats folder
Contains a complete copy of all the run-time files required to transform your source documents
for specific output formats. In your Stationery design project, this folder contains the customized
files for specific output formats needed to transform your source documents and create your
output files. This folder includes a subfolder for each defined output format with customized files.
These files override the default files used by ePublisher to generate the associated output format.
New ePublisher releases may include changes to the default transformation files. By storing the
customized files in a separate location, ePublisher can override the default files by using these
customized files and it can also protect these customized files when you install a new ePublisher
release.

Targets folder
Contains the customized files for specific targets needed to transform your source documents and
create your output files. This folder includes a subfolder for each defined target with customized
files. These customized files override the files stored in the Formats folder for the output format
related to the target. For example, you can create a customized Page.asp  page layout file for a
specific target.
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Understanding Stationery Synchronization
ePublisher projects use Stationery designed in ePublisher Designer to define the appearance and behavior
of generated output. Stationery is a complete set of processing rules and styles that define all aspects of
the output. Writers use the Stationery created by the Stationery designer when they create projects and
generate output.

Once the Stationery designer changes or updates the Stationery, ePublisher prompts writers when they
open projects associated with that Stationery to synchronize their projects with the updated Stationery.
ePublisher Express prompts you to synchronize your project with its Stationery under the following
conditions:

The project manifest file differs from the Stationery manifest file.

The Stationery settings have been modified.

When writers synchronize their projects with the updated Stationery, all settings in the project are updated
to match the Stationery. For more information, see “Synchronizing Projects with Stationery”.
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Designing Stationery
ePublisher projects use Stationery designed in ePublisher Designer to define the appearance and behavior
of generated output. You can use Stationery to define a standard for one or more projects to use. You can
also customize the design to meet your specific needs. Writers then use the Stationery when they create
projects.

There are many considerations when designing and developing Stationery. A well-designed Stationery is
less costly to maintain and manage into the future.
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Creating a Stationery Design Project
Stationery design projects are not based on Stationery. You create a Stationery design project in
ePublisher Designer and use it to create and maintain Stationery. To create Stationery, you need to save
a project as Stationery. To modify or update Stationery, you need to update the Stationery design project
and then save it as Stationery.

The ePublisher workflow improves productivity and saves time for writers who need to manage online
content. You create Stationery that defines a set of reusable settings to apply to any project. Without any
additional work, writers can load these settings into their projects, and update them automatically when a
change to the Stationery is made.

Note: To create a new Stationery design project from an existing Stationery design
project, you can manually copy the existing Stationery design project .wep
file and associated files and folders.

To create a Stationery design project

1. Open ePublisher Designer.

2. On the File menu, click New Project.

3. In the Project name field, type the name for your Stationery project.

4. In the Format field, select the default output format you want to include in your Stationery, and
then click Next. You can add other output formats at a later time.

5. Click Add and select your standard sample source files to add them to the Source Documents list
box. These files provide all the standards for each input format.

6. When all your sample source files are listed in the Source Documents list box, click Finish.

7. On the Project menu, click Scan All Documents to add all elements defined in your sample source
documents to the project. This process ensures you can define how ePublisher processes each of
these elements, such as styles and variables.

8. On the File menu, click Save to save your Stationery design project.

Next, you can add all the other output formats you want to include in your Stationery.
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Adding Output Formats to Your Stationery Design Project
You can include one or more output formats in your Stationery. To simplify your Stationery, define only
the output formats you need. Writers can then use these output formats defined in the Stationery to create
one or more targets in their projects.

Each output format creates a target in your Stationery design project. You can also define multiple targets
with the same output format. For example, you can define multiple targets, one for each standard OEM
partner you may have. Each of these targets may generate the same output format with settings, such as
company name and address, customized for each partner.

The Stationery Designer properties and options are shared across all targets and output formats. Some
settings, such as the target settings, variable values, conditions, and cross-reference formats, are defined
per target. Some targets and output formats also offer additional features and customizations.
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Adding a Target to Your Stationery Design Project
When you create your Stationery design project, you select the default output format. ePublisher adds the
target for that output format to your project. You can then add more targets and output formats to your
project.

To add a target to your Stationery design project

1. Open your Stationery design project.

2. On the Project menu, click Manage Targets.

3. Click Add.

4. In the Format Type field, select an output format for the target.

5. In the Target Name field, type a name for the target, and then click OK.
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Selecting an Active Target in Your Stationery Design Project
The active target is the target currently selected for your project. ePublisher uses the active target to
identify what output to generate. If you modify settings, such as variable values, that are applied to an
individual target and are not shared across targets in a project, ePublisher saves those changes for the
active target. ePublisher applies the settings defined through the options on the Target menu to the active
target.

To select the active target

1. Open your Stationery design project.

2. On the Project menu, click the target you want in the Active Target menu option.
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Updating a Project to Include All Styles
ePublisher transforms your source documents into content that you can deliver to virtually any online
format or platform. To make sure your content is properly displayed and easy to use for your audience,
you may want to modify the appearance of the online content, as well as add features your audience wants
and needs. However, you do not want to modify the original source documents multiple times to produce
the different types of output you need, such as print, online help, and Web site content.

ePublisher enables you to maintain your source documents as you need to for print delivery. You can
then use Style Designer to define how you want your content transformed for your other output formats.
ePublisher helps you create the appearance you want and the functionality you need for your online
output.

Your project defines how to transform your content based on the paragraph, character, table, graphic,
page, and marker styles in your source documents. If you add new elements to your source documents,
you need to scan your documents to include these new elements, such as new paragraph styles, in your
project.

To scan all your source documents

1. Open your Stationery design project.

2. On the Project menu, click Scan All Documents.
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Understanding Style Designer
Style Designer allows you to modify how various styles appear in your generated output. You can define
how paragraphs, characters, tables, and images are displayed. You can also modify other aspects of your
content, such as page layout and how page breaks are established. Style Designer defines the appearance
of your online content, such as the color or font of a paragraph style, the style of a table border, the layout
of a page, and the file format of your images in your generated output.

ePublisher uses the styles in your source documents to define how to transform and present your content
online. ePublisher intelligently senses the styles in the source documents and presents a list of these styles
in Style Designer. You can then define your generated output by specifying properties and options for
each style. By using styles in your source documents, you have great control over your output. In Style
Designer, the Properties tab controls the appearance of the selected style and the Options tab controls the
behavior of the selected style in your generated output.

For example, if you are using a style called Heading 1 in your source document, ePublisher lists this style
in your project with the other styles used in your source documents. If you select Heading 1 from the list
of styles in Style Designer, you can then define all content that has that style to appear a specific way in
your generated output. These modifications do not affect your source documents. ePublisher is essentially
a filter that transforms your source documents into the output format you need.

You can also use a custom CSS file to modify the appearance of your content instead of using Style
Designer for HTML-based output formats. For more information, see “Using a Custom CSS to Modify
the Appearance of Content”.
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Modifying Output with CSS Properties and Attributes
Cascading style sheet (CSS) properties give you detailed control over the appearance of your generated
output. Style Designer provides an intuitive interface to help you modify your output using CSS
properties. In addition to the online help, additional knowledge of CSS properties and attributes can
help you achieve the results you want. For more information about CSS principals, see W3 Schools at
www.w3schools.com and the World Wide Web Consortium (W3C) at www.w3.org.

Because your online output is HTML- and CSS-based, the appearance of your output can be inconsistent
between different browsers. This inconsistency is a limitation of HTML and CSS, since not all browsers
implement the standards defined by the W3C in a consistent way. In addition, some output formats do not
support all HTML and CSS features. In these cases, ePublisher disables or hides the incompatible options.
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Understanding the CSS Box Model
In accordance with the CSS2 specification, each element on a Web page generates its own invisible,
rectangular box, sometimes referred to as the box model. This box delimits the space that the element
occupies on the page and consists of a content area surrounded by optional blocks related to the border,
margin, or padding around the content. For example, consider the following HTML snippet of a
paragraph on a Web page:

<p>That's one small step for a man, one giant leap for mankind.</p>

Since this content is a paragraph, the text uses a <p>  tag and is contained in a P  box, or paragraph box.
Assuming this paragraph has only a margin applied to it (and no border or padding), its box can be
represented as shown in the following figure:

Other paragraph blocks, heading blocks, table blocks, and so forth may precede or follow this paragraph,
and all blocks fit together inside a page block, which contains all other elements of the page. Boxes
usually correspond to HTML <h> , <p> , or <div>  tags and often contain inline elements within them.
Inline formatting, such as a bold word within a sentence, creates inline invisible boxes within the
paragraph text.

For Western languages, the boxes, and therefore the content within them, are arranged in a left-to-right,
top-to-bottom flow, which is called normal flow. You can reverse normal flow for Eastern languages that
flow from right to left. The normal flow includes all styles unless you move them outside of the normal
flow using the Float or Positioning properties. With the Float or Positioning properties, you can create
multi-column pages and other layouts that, in CSS1, required you to use tables. For more information
about the CSS2 visual formatting model and normal flow, see the W3C documentation at www.w3.org/
TR/REC-CSS2/visuren.html.
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Inheriting Style Properties
Many elements of your online design may have similar properties. For example, paragraphs, bulleted
list items, and numbered list items may all use the same font and vertical spacing. You may also identify
elements that should use settings from your source documents. For example, you may want tables to
use the size defined in your source files. Style Designer allows you to specify a precise value for a
property, or you can specify from where a property inherits its value. The inheritance options are defined
as follows:

Explicit
Ignores all inheritance values and uses the value you specify for this property.

Do not emit
Excludes the property from the generated output for the selected style. This option can help you
troubleshoot a design issue and determine which property or element is associated with the issue.

Inherit from style
Inherits the value for the property from the parent style. You can organize styles in a hierarchy and
then use inherited properties to reduce maintenance costs for future changes. For example, if you
have a Heading 1 and a Heading 2 style, you could make Heading 2 a child of Heading 1. If you
select Inherit from parent style for a property of Heading 2, it inherits the value for that property
from Heading 1. For more information, see “Organizing and Managing Styles”.

Document paragraph style
Inherits the value for the property from the style definition in your source document. By choosing
this option for a property, ePublisher uses the formatting from your source document for that
property.

Document style catalog
Inherits the value for the property from the style definition in the source documents. When you
select this option for a property, ePublisher uses the source document definition and ignores all
manual changes made to the style in the source document.
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Understanding Options in Style Designer
The Options tab allows you to define the behavior of the selected item in Style Designer. For example,
you can set the options for a paragraph style to create an expand/collapse section or to split the content
and start a new output file. The available options depend on the selected item, such as a paragraph style or
a marker style, and the active target, such as WebWorks Help or Eclipse Help.

Note: The options you specify for a parent style are not inherited by child styles.
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Organizing and Managing Styles
In Style Designer, you can organize your styles in a hierarchy and then use inherited properties to reduce
design and maintenance time. You can create a hierarchy of similar styles, set the style property values
once, and have those values inherited by child styles.

The Prototype style, which is essentially the parent style for all styles, allows you to quickly define
properties for all styles. This style allows you to make global changes across all styles that inherit
properties from the Prototype style. For example, you may have all styles inherit their font and vertical
spacing from the Prototype style.

Note: Child styles inherit only property values from a parent style. Child styles do
not inherit additional features specified on the Options tab.

By default, all style properties of a parent style are inherited by its child styles. If you change the property
values of a parent style, those changes are inherited by the child styles of that parent style. You can
override specific properties for a child style to make those not inherited from its parent style. Once the
value of a specific property is set at the child level, changes you make to the parent style for that property
do not affect the child style.

To organize styles in Style Designer

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. Click the type of styles you want to organize, such as Paragraph Styles.

4. If you want to make a style the child of another style, drag and drop the child style on top of the
style you want to make its parent style.

5. Click on the child style and review the properties for that style to make sure it inherits the property
values you want from its parent style.
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Previewing the Output from a Source File
Once you specify or change settings in your Stationery design project, you should generate your output to
review and verify your changes. You can also generate output for an individual source document. As you
develop your Stationery, you will often modify a few settings, generate your output and review the results,
and then continue the process until you have the final results you want.

To quickly review your changes, you can also display a preview of a source document. A preview allows
you to quickly see the affects of the changes you made, without requiring you to generate output for the
project. The preview provides a close approximation of how your generated output will look, but your
generated output may not exactly match the preview.

Note: At intervals while you develop your Stationery, you may want to create a
backup copy of your Stationery design project to serve as a snapshot. This
backup gives you a version to return to and use if you make some changes
that you no longer want. For more information, see “Saving a Snapshot
(Backup Copy) of Your Project”.

To display a preview of a source document

1. Open your Stationery design project.

2. In Document Manager, select the source document for which you want to generate a preview.

3. On the Project menu, click Display Preview.

ePublisher displays a preview of the source document on a preview tab labeled with the name of the
source document you selected. The preview provides you with an idea of how modifications you made to
project settings affect the appearance of your output. However, some output features are not displayed or
active within the preview, such as popup windows, links, and conditions.
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Defining New Pages (Page Breaks)
By default, ePublisher transforms each source document into one output page. You can associate a
page break with specific paragraph styles to split your content into multiple pages, where each page
creates a new output file. By dividing your content, you can present information to your audience in
smaller chunks, organize and focus your content, reduce redundant information through links, and reduce
scrolling by your audience. To avoid empty topics when multiple heading styles occur in a row, you can
also define page break handling based on whether the previous style created a new page. This flexibility
enables you to deliver your content your way.

To create new pages based on styles

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the style for which you want to create a page break.

5. On the Options tab, assign a value to the Page break priority option. For more information about
this option, click Help.

6. Review the target settings to ensure the Page break handling setting will correctly process your
priority level values by completing the following steps:

a. On the Project menu, select the Active Target you want to specify settings for.

b. On the Target menu, click Target Settings.

c. Set the Page break handling setting to the appropriate value. For more information about
this setting, click Help.
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Defining TOCs and Mini-TOCs
ePublisher does not use the table of contents (TOC) in your source document when it generates the
online table of contents. This process allows ePublisher to correctly apply conditions and variables to the
TOC, and to format the TOC as needed for the output format. ePublisher bases the TOC on paragraphs
from your source document. Depending on the output format you select, you can specify whether to
generate the TOC and what file name to assign to the TOC. For more information, see “Generating and
Naming the Table of Contents File”. You can also modify the appearance of the table of contents for some
output formats. For more information, see “Customizing the Navigation Pane in WebWorks Help” and
“Modifying the Appearance of the Table of Contents in Dynamic HTML”.
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Defining the Table of Contents Structure (Levels)
By default, ePublisher attempts to automatically determine your source content’s TOC levels. You can
manually adjust those levels if the settings do not meet your requirements.

To define the table of contents structure (levels)

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the style you want to include in your TOC.

5. On the Options tab, specify a value for the Table of contents level option. The default value,
Auto-Detect, attempts to infer the necessary information based on your source content. Specify a
value that indicates the level of the table of contents entry for the selected paragraph style. When
working with Adobe FrameMaker, you can determine the levels by examining the PDF Bookmark
levels for paragraphs that appear in the table of contents. Here is an example of the Bookmarks
tab from FrameMaker 11, to navigate here, you would select File > Print.... Then click the PDF
Setup... button.
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When working with Microsoft Word sources, the auto-detect values are based on the Outline level of
each paragraph style. Below is a screenshot of the Word 2010 interface for each paragraph’s outline level,
to navigate here, you use the key combination Shift + F1.

Once you click the Outline Level hyperlink, you can select the desired level from the following window.
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DITA XML auto-toc is taken from the map hierarchy. A good example would be from the sample input
provided in the Exp_Design project located in the ePublisher directory in the Documents library, or by the
[program files]\WebWorks\ePublisher\[version]\Helpers\dita-ot\samples

 

30 | Defining the Table of Contents Structure (Levels)



Generating and Naming the Table of Contents File
By default, once you have defined your table of contents structure using Style Designer, ePublisher
generates the table of contents for your output. The Dynamic HTML format provide additional
capabilities for users to prevent generation of the table of contents or to change the file name of the
generated table of contents.

In the File Processing section of the target settings, you can also specify whether to include the table of
contents, front matter, and index from your source documents in your generated output.

To specify additional table of contents target settings

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. If you want to prevent ePublisher from generating the table of contents, set Generate table of
contents to Disabled.

4. If you want to change the file name of the generated table of contents, specify the file name you
want in the Table of Contents filename field.
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Defining the Table of Contents from an Irregular Heading Hierarchy
Many authors follow a regular heading hierarchy in their source documents. A regular heading
hierarchy is one in which no levels are skipped in the hierarchy, as shown in the following example:

First Heading 1

  First Heading 2

    First Heading 3

    Second Heading 3

  Second Heading 2

Another Heading 1

  Another Heading 2

  Yet Another Heading 2

Note: If you use a regular heading hierarchy, this section does not affect your
output.

Some documentation methodologies and processes require authors to skip levels in the hierarchy, which
produces irregular heading hierarchies like the one shown in the following example:

First Heading 1

    First Heading 4

    Second Heading 4

  First Heading 3

Second Heading 1

  Another Heading 3

  Still Another Heading 3

Final Heading 1

This heading hierarchy in a source document, produces an irregular table of contents hierarchy. The
previous example is irregular because all Heading 2  levels are skipped and several Heading 3  levels are
skipped in the hierarchy.

Since your generated table of contents is created from paragraphs in the source documents, irregular
hierarchies can cause an aesthetically displeasing table of contents in your output. ePublisher provides
several settings for how to transform irregular heading hierarchies, such as Fully collapse, Don’t
collapse, Smart collapse, and Re-label. By default, ePublisher uses Smart collapse.

To specify how ePublisher transforms irregular heading hierarchies

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. If you want to eliminate skipped levels from the table of contents except where needed to
preserve the correct relative hierarchy, set Collapse table of contents to Smart collapse.
ePublisher removes skipped heading levels from the table of contents. However, if removing
skipped levels results in, for example, a Heading 3  and Heading 4  displaying at the same level,
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ePublisher automatically inserts an entry into the table of contents to preserve the correct relative
hierarchy. The irregular hierarchy in the previous example would be generated as follows.

4. If you want to eliminate all skipped levels from the table of contents, set Collapse table of
contents to Fully collapse. ePublisher removes all skipped levels, regardless of the level at which
they appear in the source documents. The irregular hierarchy in the previous example would be
generated as follows.

5. If you want to duplicate the heading hierarchy of the source document with empty entries in
the table of contents, set Collapse table of contents to Don’t collapse. ePublisher automatically
inserts empty table of contents entries for the skipped levels. The irregular hierarchy in the previous
example would be generated as follows.

6. If you want to duplicate the heading hierarchy of the source document with labels in the
table of contents, set Collapse table of contents to Re-label. ePublisher automatically inserts
labeled entries for the skipped levels. The heading text from the entry level appearing beneath the
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current entry is used as the label. The irregular hierarchy shown in the previous example would be
generated as follows.
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Understanding the Table of Contents and Merge Settings
Not only can the table of contents be generated from defining your heading paragraph styles, the table of
contents can also be generated using Merge Settings. Merge Settings allow you to combine multiple top-
level groups into a single hierarchy. Not all output formats support merging. For more information see
“Merging Top-level Groups (Multivolume Help)”.

Note: Since your Stationery design project is used to create Stationery, and Merge
Settings are not stored in Stationery, you do not need to configure Merge
Settings for your Stationery design project. You can configure the Merge
Settings in your ePublisher Express projects, since these settings vary based
on individual project needs.
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Defining the Icon for a Table of Contents Entry
For some output formats, ePublisher allows you to add a marker to a heading that defines the icon to use
for the table of contents entry for that heading. For example, you can use a unique icon for new topics,
or for specific types of information. ePublisher provides the TOCIconWWHelp, TOCIconHTMLHelp,
TOCIconJavaHelp, and TOCIconOracleHelp markers.
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Creating a Miniature Table of Contents
A miniature table of contents (mini-TOC), also known as a partial table of contents, provides a list of the
topics in the upcoming section. The topic titles are displayed as links beneath the current topic heading for
easier navigation within the section. By default, ePublisher does not create a mini-TOC in topics within
your output. You can configure ePublisher to generate mini-TOCs and you can define your mini-TOC
levels in Style Designer. Before you begin, define the main table of contents for your projects. For more
information, see “Defining the Table of Contents Structure (Levels)”. Your mini-TOC is derived from the
table of contents level settings you define for the project.

To create a mini-TOC

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the style you want to include a mini-TOC after.

5. On the Options tab, specify a value for the Mini-TOC level option. Specify a value that indicates
the levels of the table of contents entries to include in the mini-TOC that follows the selected
paragraph style. For more information about this option, click Help.
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Modifying the Appearance of Mini-TOC Entries
ePublisher stores CSS settings that control the appearance of mini-TOC entries in the webworks.css
file. You can create an override file to modify these settings for specific levels of the mini TOC or for the
entire mini TOC. For example, you can define a different font size and margin for each level in the mini
TOC.

For more information about override files and locations, see “Stationery, Projects, and Overrides”.

To modify the appearance of the mini TOC

1. If you want to override the CSS settings for an output format, complete the following steps:

a. In your Stationery design project, on the View menu, click Format Override Directory.

b. Create the Formats\formattype\Pages\css  folder in your project folder, where
formattype is the name of the output format you want to override, such as Microsoft HTML
Help 1.x .

2. If you want to override the CSS settings for a target, complete the following steps:

a. In your Stationery design project, on the View menu, click Target Override Directory.

b. Create the Targets\targetname\Pages\css  folder in your project folder, where
targetname is the name of the target you want to override.

3. Copy the webworks.css  file from the following folder to the override folder you created within
your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\formattype\Pages\css

4. Open the webworks.css  file you copied to your project override folder.

5. If you want to modify the appearance of the entire mini TOC, find the code for
div.WebWorks_MiniTOC  and modify the values specified within the braces:

To modify the background color, specify the desired RGB color value for the background-
color  option.

To modify the border color, specify the desired RGB color value for the border-color
option.

To modify the border width, specify the number of pixels you want for the border-width
option.

To modify the type of border, specify the appropriate border style value for the border-
style  option.

To modify the spacing between the border and the text, specify the number of pixels you
want for the padding  option.

To modify the font, specify the name of the font you want for the font-family  option.

38 | Modifying the Appearance of Mini-TOC Entries



6. If you want to modify the appearance of a specific level of the mini TOC, find the code for
div.WebWorks_MiniTOC_Levelx, where x is the level number you want to modify. Then, specify
the values within the braces to modify the font or margin:

To modify the font of all mini-TOC entries for the specified level, specify the name of the
font you want, such as font-family: Arial; .

To modify the font size of all mini-TOC entries for the specified level, specify the size of the
font you want, such as font-size: 14pt; .

To modify the left margin indent of all mini-TOC entries for the specified level, specify the
indent you want, such as margin-left: 10px; .

7. Save the webworks.css  file.

8. Regenerate your project to review the changes.

For example, the following figure illustrates how you could customize your mini-TOC entries.

div.WebWorks_MiniTOC_Level1

{ font-size: 14pt;

  font-family: Arial;

  margin-left: 6px;

}

div.WebWorks_MiniTOC_Level2

{ font-size: 12pt;

  font-family: Arial;

  margin-left: 16px;

}

div.WebWorks_MiniTOC_Level3

{ font-size: 10pt;

  font-family: Arial;

  margin-left: 16px;

}
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Modifying the Appearance of Paragraphs
One of the most common modifications for online output is changing the appearance of text. Using Style
Designer, you can select a paragraph style and then define the appearance of that style. This efficient
method allows you to globally change all paragraphs with the same style at once, which increases your
control and reduces maintenance costs.
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The Prototype Style for Paragraphs
The Prototype style is the parent to all other styles. When you set a property for the Prototype paragraph
style, other paragraph styles inherit the value of that property. You can then override that value for
specific styles as needed. The Prototype paragraph style allows you to quickly change a default property
and apply that change to all paragraph styles within your Stationery project.

Depending on how you organized your styles in Style Designer, you may not have one style as the parent
style on which all others are based. In Microsoft Word, usually all styles are based on Normal, but that
may not always be the case. The Prototype style ensures that each of your styles has a parent style within
your Stationery project.
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Setting the Background Color of a Paragraph
In terms of the CSS box model, the background for a paragraph refers to the background of the content
and the padding areas. If you increase the padding for a paragraph style, the background color area for
that style also increases. If you decrease the padding for a paragraph style, the background color area for
that style also decreases.

To set the background color of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click Background.

5. In the Color field, select a color from the drop-down menu, or type the RGB value of the color you
want, such as FFFFFF .
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Setting the Border Style and Color of a Paragraph
Borders are lines that can be drawn around any or all of the four sides of a paragraph. In terms of the CSS
box model, increasing the padding for a paragraph style increases the space between the paragraph and
the border.

Not all browsers display border styles the same way. For example, some browsers may not differentiate
dotted lines from solid lines. The size and spacing of the dots in a dotted line may also be different
between various browsers and operating systems.

To set the border style and color of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click Border.

5. Click the tab for the side of the paragraph you want to display a border, and then specify the color,
style, and width for that border. For more information about a property, click Help.
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Setting the Font for a Paragraph
Setting fonts for online output is an important step in making sure your content is properly displayed
for your audience. Because many browsers and help systems use only the fonts available on the user’s
computer, you may not be able to use specific fonts, such as Times New Roman, as some computers
may not have those fonts installed. You can specify a font family, such as sans-serif, to ensure a font of a
similar type is used on each computer. You can also specify multiple fonts, separated by commas, to allow
the browser to display the first available font.

To set the font of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click Font.

5. Specify the family, size, style, and other properties you want to modify. For more information about
a property, click Help.
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Setting the Width, Height, and Positioning of a Paragraph
In regards to the CSS box model, modifying the width and height of a paragraph adjusts the content
box, which essentially defines the space that the paragraph uses. For example, if an existing paragraph
stretches across the entire page, but you then adjust the width to 200 px, the paragraph is then limited to
only 200 pixels wide.

To set the width, height, and positioning of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click HTML.

5. Specify the appropriate values for the width, height, and positioning properties. For more
information about a property, click Help.
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Adjusting the Space Around a Paragraph
You can adjust the white space around a paragraph by adjusting the margin and the padding. In terms
of the CSS box model, modifying the padding property adjusts the space inside the border area. For
example, if you create a border or background color for a paragraph and you increase the size of the
padding, the border moves away from the text in the paragraph.

Modifying the margin properties adjusts the space outside the border area. For example, if you create
a border or background color for a paragraph and you increase the size of the margins around the
paragraph, the border remains the same distance from the text in the paragraph. However, the position
of the paragraph changes since there is more white space between the modified paragraph and the other
elements on the page. Review the following additional considerations:

Set the right margin on paragraph styles to provide spacing between the text and the right edge of
the window.

For paragraphs used within bulleted and numbered lists, carefully adjust the left margin to correctly
align with the text of the bulleted and numbered list items. Those list items may have different
left margins to leave space for the bullet or number. For more information, see “Defining the
Appearance of Bulleted Lists” and “Defining the Appearance of Numbered Lists”.

When defining the left margin for a paragraph style used in a table, consider the size and weight
of the font as well. For example, bold table headings need less pixels in their left margin than non-
bold table text paragraphs so that both types of text align with each other.

To set the margin and padding of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click Margin.

5. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom margin
properties.

6. On the Properties tab, click Padding.

7. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom padding
properties.
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Setting the Text Color and Other Characteristics of a Paragraph
In general, ePublisher generates output based on the properties of the content from the original source
documents. You can modify the appearance of your online content without modifying your source
documents. The text properties allow you to modify several important characteristics of the text:

Color

Kerning between letters and words

Space between lines of a paragraph, also known as letting or line height

Underlining, overlining, and strikethrough text

Horizontal and vertical alignment of a paragraph

Indentation of a paragraph

To set the text characteristics of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click Text.

5. Specify the appropriate values for the text-related properties, such as Color and Line height. For
more information about a property, click Help.
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Modifying Paragraphs for Bidirectional Languages
In some documents, such as those written with Arabic or Hebrew script, and in some mixed-language
contexts, text within a single paragraph may appear with mixed directionality. For example, some
characters are read from left to right, while others within the paragraph may be read from right to left.
This phenomenon is called bidirectionality, or bidi for short.

If a document contains right-to-left characters, and if the browser is able to display the language with
the proper character set, the browser must apply the bidirectional algorithm. The proper character set
means to not display arbitrary substitutes such as a question mark, a hex code, or a black box for some
characters.

ePublisher allows you to make sure the browser correctly displays the content by offering the Unicode
Direction and Unicode Bidi (bidirectional) properties.

To set the Unicode properties of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Paragraph Styles, select the style you want to modify.

4. On the Properties tab, click Text.

5. Under Unicode, set the appropriate values for the Direction and Unicode Bidi properties. For
more information about these properties, click Help.
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Disabling Autonumbering in Output
In your source documents, you may have autonumbering enabled for print delivery purposes, such as
printed manuals and PDFs. This function allows you to add autogenerated numbers to your chapters,
headings, and figure captions. However, for some online delivery, you may not want to include the
autonumbering in your online help.

To disable autonumbering

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the style that has the autonumbering.

5. On the Options tab, set the Keep paragraph numbering option to Disabled.

6. Repeat steps 4-5 for every paragraph style for which you want to disable autonumbering.
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Defining the Appearance of Notes, Tips, Cautions, and Warnings
If you have the word note , tip , caution , or warning  at the start of the paragraph, and the paragraph is
defined with a hanging indent, increase the Left margin property in ePublisher to correctly align the word
with the appropriate paragraph styles. ePublisher uses the Left margin property to define the hanging
indent margin. It also uses the Text Indent property to place the first line of the paragraph to the left of the
rest of the paragraph. For instructions on changing the handing indent, see “Fixing Paragraph Indentation
Including Hanging Indent”.

You may want to add an image to the left of each note, caution, tip, or warning in your generated output.
ePublisher does not use images from Adobe FrameMaker reference pages. You can use the Bullet
properties of a paragraph format to insert an image to the left of the paragraph. This process is similar to
using an image for the bullet itself.
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Defining the Appearance of Bulleted Lists
By default, ePublisher generates output for bulleted lists based on the properties of the content from the
original source documents. Some tools use the Symbol or Wingdings font for bullets. These fonts may
not be available on all computers, which can cause the bullets in your output to not be displayed correctly.
You can address this issue by using an image for your bullets, or you can create a character style with
a font family assigned, such as sans-serif, and then apply that character style through ePublisher to the
characters you choose to define for your bullets.

You may also need to increase the left margin of your bulleted list item styles to provide the correct
spacing for the bullet and to allow the text to be properly aligned. In addition, you may need to adjust
the left margins of both bulleted and numbered list items to get them to line up with each other. This
alignment can reduce the number of vertical columns on a page, which can help the user scan the
information. This alignment can also let you use the same paragraph formats for paragraphs within either
a bulleted or numbered list. For more information about additional margin adjustments, see “Fixing
Paragraph Indentation Including Hanging Indent”.

To create custom bullets

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the style you want to modify.

5. On the Properties tab, click Bullet.

6. If you want to create a custom bullet based on an image, complete the following steps:

a. Make sure the image you want to use as your bullet image is stored in the Files  folder in
your project. You can copy the image file to this folder.

b. In the Image field under Bullet Info, select the image you want to use.

7. If you want to create a custom bullet based on a special character, complete the following steps:

a. In the Text field, type the special character you want to use. You can type a special character
using the Windows Alt key code.

b. In the Separator field, type the separator characters, such as a non-breaking space, that you
would like to use between the bullet and the beginning of the first line of text.

c. In the Character Style field, select the defined character style you want to apply to the
special character specified in the Text field. You can specify any character style that
already exists in your project. The character style should use a font available on your users’
computers. Avoid custom fonts, which can cause bullet characters to be displayed differently
on various computers.
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Defining the Appearance of Numbered Lists
When you define the appearance of numbered list items, you need to define margins that leave the
correct alignment for the numbers and the hanging indent. Since numbered items have a hanging indent,
ePublisher uses a table in the generated output to create the appropriate format. Increase the Left margin
property in ePublisher to correctly align the the hanging indented text. Then, set the Flow Indent text
property for the paragraph to a negative value to leave enough space for double-digit numbered steps.
For example, if your standard paragraph Left margin property is 30 pixels, you may want to set the
Left margin property for your numbered list items to 70 pixels and set the Flow Indent text property
to -30 pixels for your numbered list items. For instructions on changing the handing indent, see “Fixing
Paragraph Indentation Including Hanging Indent”.

You may also need to work with the left margins of both bulleted and numbered list items to get them to
line up with each other. This alignment can reduce the number of vertical columns on a page, which can
help the user scan the information. This alignment can also allow you to use the same paragraph formats
for paragraphs within either a bulleted or numbered list.
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Fixing Paragraph Indentation Including Hanging Indent
It is very common to create paragraphs that use a hanging indent to offset the first line to the left of
the rest of the paragraph. This can occur with headings, numbered lists, bulleted lists, and any other
paragraph type.

The following figure shows a heading paragraph that has a hanging indent that is not large enough in
the generated output. Also, notice that there is not enough white space between the auto-number and the
paragraph text.

Using ePublisher’s Paragraph Style Designer it is easy to increase the size of the hanging indent and thus
increase the amount of white space between the auto-number and the paragraph text.

Steps for chaning the Hanging Indent

1. Open the Stationery Design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports the Margin Left and Text Ident properties.

4. In Paragraph Styles, select the style you want to modify.

5. On the Properties tab, click the name of the paragraph style to modify.

6. Select Margin and then for the Left, specify a value with units.

7. Select Text and then for the Flow Indent, specify the same value with units. However, the value
must be the negative of that used for the Margin Left.
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You may want to experiment with different values until you get something that looks good in the output.
When generated it will look similar to the updated output shown below.
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Modifying the Appearance of Characters
To modify the appearance of individual characters or words within a paragraph, you can use Style
Designer to adjust the appearance of any character styles used in the source documents. This process
allows you to optimize styles for print, using the styles in the source documents, and optimize the content
for online presentation using the styles defined in ePublisher.
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The Prototype Style for Characters
The Prototype style is the parent to all other styles. When you set a property for the Prototype character
style, other character styles inherit the value of that property. You can then override that value for specific
styles as needed. The Prototype character style allows you to quickly change a default property and apply
that change to all character styles within your Stationery project.

Depending on how you organized your styles in Style Designer, you may not have one style as the parent
style on which all others are based. The Prototype style ensures that each of your styles has a parent style
within your Stationery project.

56 | The Prototype Style for Characters



Setting the Background Color of a Character
In terms of the CSS box model, the background for a style refers to the background of the content and
the padding areas. If you increase the padding for a style, the background color area for that style also
increases.

To set the background color of a character

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Character Styles, select the character style you want to modify.

4. On the Properties tab, click Background.

5. In the Color field, select a color from the list, or specify the RGB value of a color, such as FFFFFF .
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Setting the Border Style and Color of Characters
Borders are lines that can be drawn around any or all of the four sides of a style. In terms of the CSS box
model, increasing the padding for a style increases the space between the content and the border.

Not all browsers display border styles the same way. For example, some browsers may not differentiate
dotted lines from solid lines. The size and spacing of the dots in a dotted line may also be different
between various browsers and operating systems.

To set the border style and color of a character

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Character Styles, select the character style you want to modify.

4. On the Properties tab, click Border.

5. Click the tab for the side of the character you want to display a border, and then specify the color,
style, and width for that border. For more information about a property, click Help.
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Setting the Font for a Character
Setting fonts for online output is an important step in making sure your content is properly displayed
for your audience. Because many browsers and help systems use only the fonts available on the user’s
computer, you may not be able to use specific fonts, such as Times New Roman, as some computers
may not have those fonts installed. You can specify a font family, such as sans-serif, to ensure a font of a
similar type is used on each computer. You can also specify multiple fonts, separated by commas, to allow
the browser to display the first available font.

To set the font of a character

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Character Styles, select the character style you want to modify.

4. On the Properties tab, click Font.

5. Specify the family, size, style, and other properties you want to modify. For more information about
a property, click Help.
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Adjusting the Space Around Characters
You can adjust the white space in all directions around characters by adjusting the margin and the
padding. You can also adjust horizontal spacing by adjusting the kerning.

In terms of the CSS box model, modifying the padding property adjusts the space inside the border area.
For example, if you create a border or background color for a character and you increase the size of the
padding, the border moves away from the character.

Modifying the margin properties adjusts the space outside the border area. For example, if you create a
border or background color for a character and you increase the size of the margins around the character,
the border remains the same distance from the character. However, the position of the character changes
since there is more white space between the modified character and other elements on the page.

To set the margin, padding, and kerning of a character

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Character Styles, select the character style you want to modify.

4. On the Properties tab, click Margin.

5. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom margin
properties.

6. On the Properties tab, click Padding.

7. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom padding
properties.

8. On the Properties tab, click Text.

9. In the Letter spacing field, specify a value and select the unit of measure to adjust the kerning. For
more information about a property, click Help.
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Setting the Color and Other Characteristics of Characters
In general, ePublisher generates output based on the properties of the content from the original source
documents. You can modify the appearance of your online content without modifying your source
documents. The text properties allow you to modify several important characteristics of characters:

Color

Kerning between letters and words

Underlining, overlining, and strikethrough text

Vertical alignment to create subscripts and superscripts

To set the text characteristics of a character

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Character Styles, select the character style you want to modify.

4. On the Properties tab, click Text.

5. Specify the appropriate values on the text-related properties, such as Color and Letter spacing.
For more information about a property, click Help.
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Modifying Characters for Bidirectional Languages
In some documents, such as those written with the Arabic or Hebrew script, and in some mixed-language
contexts, text within a single paragraph may appear with mixed directionality. For example, some
characters are read from left to right, while others within the paragraph may be read from right to left.
This phenomenon is called bidirectionality, or bidi for short.

If a document contains right-to-left characters, and if the browser can display the language with the proper
character set, the browser must apply the bidirectional algorithm. If you prefer to control the handling of
a particular phrase, you can apply a character style to that phrase and then define the character style with
the Direction and Unicode Bidi properties.

To set the Unicode direction of a character

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Character Styles, select the character style you want to modify.

4. On the Properties tab, click Text.

5. Under Unicode, set the appropriate values for the Direction and Unicode Bidi properties. For
more information about these properties, click Help.
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Defining the Appearance of Tables
Modifying the appearance of tables is different from modifying other elements in your content, such as
paragraphs. The properties of tables are controlled by different layers. Some objects are in front of, or
behind, other objects within the table. For example, the background property of the entire table is the first
layer. The body, header, and footer properties reside in the next layer, which is on top of the background
property. Paragraph properties are on top of that, followed by character properties, which are on the
topmost layer.

With this model, you may have difficulty achieving the results you want when you try to adjust the
appearance of a property for a table. You may need to experiment with the different property layers to
fine-tune the appearance of tables. For example, if you try to create a transparent table by properly setting
the body background property, but the table is not transparent, another layer may not be transparent. You
need to make sure the background property is properly set for each layer in the table, including the table
header, the paragraph, and the character styles.

Paragraph styles, such as CellHeading, CellBody, CellStep, and CellBullet give you additional control
over formatting within tables in your generated output. When defining the left margin for a paragraph
style used in a table, consider the size and weight of the font. For example, bold table headings need less
pixels in their left margin than non-bold table text paragraphs so that both types of text align with each
other.
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The Prototype Style for Tables
The Prototype style is the parent to all other styles. When you set a property for the Prototype table
style, other table styles inherit the value of that property. You can then override that value for specific
styles as needed. The Prototype table style allows you to quickly change a default property and apply that
change to all table styles within your Stationery project.
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Setting the Background Color or Image of a Table
You can specify a color to use as the background of a table. You can also make the background
transparent or specify an image to use as the background. In addition, you can specify alternative colors or
images to alternate the appearance of rows or columns. Alternate shading of rows or columns is a useful
layout to help minimize the number of lines and amount of information displayed, while organizing the
data in a way that users can easily read and understand.

The background image for a table is behind other elements in a table. If you set a background color for the
table, you cannot see the background image for the table. In addition, make sure the image is stored in the
Files  folder so it is part of the project.

To set the background color or image of a table

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Table Styles, select the table style you want to modify.

4. On the Properties tab, click Body Background.

5. If you want to specify a color for the background of a table, select a color in the Color field, or
type the RGB value of the color you want, such as FFFFFF . To make the table transparent, click the
Web tab in the Color field, and then click Transparent.

6. If you want to specify an image for the background of a table, complete the following steps:

a. Save the image file in the Files  folder for the project. ePublisher copies files from the
Files  folder when you generate the project.

b. In the Image field under Background Image, select the image you want to use. ePublisher
lists only the image files stored in the Files  folder.

c. Specify the tiling, scrolling, and position properties to position the image as you want it.

7. If you want to alternate the appearance of rows or columns in the table, specify the appropriate
values for the Alternate Information properties. For more information about a property, click
Help.
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Setting the Border Style and Color of a Table
The border properties modify the appearance of the border that surrounds the outside of the table.
However, some browsers display this information in different ways. For example, some browsers use the
color and not the style of the border properties to define all other borders inside the table, unless that color
has been previously defined.

For example, if you choose a red, dotted border for your table, the preview pane displays the outer edge of
the table as a red, dotted border. All table cells inside the table have a red, solid border, unless the border
properties for Body and Header (if applicable) are also defined. Not all browsers display the table the
same way, so verify the results in multiple browsers when defining the table border and style.

To set the border style and color of a table

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Table Styles, select the table style you want to modify.

4. On the Properties tab, click Border.

5. Click the tab for the side of the table you want to display a border, and then specify the color, style,
and width for that border. For more information about a property, click Help.
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Setting the Width and Height of a Table
You can define a fixed width and height for a table style. Make sure all the content of your tables will
fit within the fixed height and width you specify. You can also use the table cell widths defined in your
source documents.

To set the height and width of a table

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Table Styles, select the table style you want to modify.

4. If you want to define a fixed width and height for the table style, complete the following steps:

a. On the Properties tab, click HTML.

b. Specify the appropriate values for the Width and Height properties. For more information
about a property, click Help.

5. If you want to use the cell widths defined in your source documents, on the Options tab, set Use
document cell widths to Enabled.
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Setting the Vertical and Horizontal Alignment within a Table
You can specify the vertical and horizontal alignment of content within table cells. To define the
vertical alignment, set the Alignment property for the table. To define the horizontal alignment, set the
Horizontal alignment property for the paragraph style of the text in the table. These property values take
effect unless a value is set at the paragraph style level, or a value is set for the table Body, Header, or
Footer properties, if applicable.

To set the alignment of content within a table

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Table Styles, select the table style you want to modify.

4. If you want to define the vertical alignment, complete the following steps:

a. On the Properties tab, click Table.

b. Specify the appropriate value in the Vertical field under Alignment.

5. If you want to define the horizontal alignment, complete the following steps:

a. In Paragraph Styles, select the paragraph style you want to modify.

b. On the Properties tab, click Text.

c. Specify the appropriate value in the Horizontal field under Alignment.
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Adjusting the Space Within and Around a Table
After creating the external borders for your table, you can define the padding to specify the distance
between the content and the borders within the table. This feature, which is enabled through CSS, is not
supported by all browsers. View the output in several different browsers to verify your results.

You can also define the space around the table by adjusting the margin properties. Modifying the margin
properties adjusts the space outside of the border area. For example, if you create a border for a table
and you increase the size of the margins around the table, the border remains the same distance from the
content of the table. However, the effective size of the table increases since there is more space between
the table border and the other elements on the page.

To adjust the padding and margin of a table

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Table Styles, select the table style you want to modify.

4. On the Properties tab, click Table.

5. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom padding
properties.

6. On the Properties tab, click Margin.

7. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom margin
properties.
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Modifying Header, Footer, and Body Rows of a Table
In addition to modifying the appearance of an entire table, you can modify portions of a table, such as the
header row, the footer row, and rows within the body of the table. To modify the appearance of a section
of a table, you need to correctly define the parts of the table in your source documents. For example, in
Microsoft Word, you need set the table property to define the header row. If you do not create a header
row for a table in your source document, you cannot modify the header row appearance in your output.
The first row of a table is not, by default, a header row.

To define the appearance of the header rows, specify the appropriate values for the Header and Header
background properties for your table styles. These property values override the values specified for the
Table, Border, and Background properties.

To define the appearance of the body rows, specify the appropriate values for the Body and Body
background properties for your table styles. These property values override the values specified for the
Table, Border, and Background properties.

To define the appearance of the footer rows, specify the appropriate values for the Footer and Footer
background properties for your table styles. These property values override the values specified for the
Table, Border, and Background properties.

Tables created in Microsoft Word do not identify footer rows. To control footer rows with Microsoft Word
and ePublisher, set up your table in your source document to reflect the desired appearance, or use footer
paragraph styles in the footer row of the table. Then, ePublisher can use the table set up from your source
document and you can use the footer paragraph styles to modify the appearance as needed.

Tables created in Adobe FrameMaker identify the footer rows of tables, which allows you to specify the
Footer and Footer background properties to modify footer rows for online delivery.
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Modifying Cells of a Table
Modifying certain aspects of a table cell may also require you to modify the properties associated with the
paragraphs that reside in the table cell. For example, if you make a table background color transparent,
you may also need to modify the background color of the paragraphs in the table to make those cells
transparent.

Cell spacing is used to create a transparent space between cells of a table. This capability allows you to
create unique border structures, as the background color of a table can be seen through the space between
table cells, which can have a different background color.

To adjust the spacing between cells

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Table Styles, select the table style you want to modify.

4. On the Properties tab, click Table.

5. In the Cell spacing field, specify an appropriate value.
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Defining the Appearance of Images
In general, ePublisher automatically transforms images from your source document to an optimized
version for online distribution. However, if necessary, you can manually modify individual images or
groups of images by applying a graphic style to the specific image or images you want to control. For
example, you can define how images are resized, the maximum height and width for images, and the
format for those images.
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Supported Image Formats
ePublisher supports several image formats and rasterizes all other formats:

.jpg files
Provides a good format for photographs and images with many gradual variations in color.
Although this format is compressed, the large number of colors can increase the size of the file
when compared to the other supported image formats. The lossy data compression also reduces
detail each time you save an image in this format. This format is not recommended for screen shots.

.gif files
Provides a good format for screen shots, since the number of colors can be reduced and the need
for gradual variations in color is minimal. This format supports transparency and animation.
However, this format supports a reduced color palette of 256 RGB colors (8-bit).

.png files
Provides a good multipurpose format for online presentation. This format supports up to 16 million
RGB colors (24-bit) and uses lossless data compression.

.svg files
Provides a powerful format that is not supported in all output formats. Some browsers do not
support .svg  image files. If you use .svg  image files, you need to configure the .svg  options to
specify whether to rasterize these images.

You can use passthrough conditions and coding to include any type of file within your final output, such
as Flash .swf  files. For example, you can create a paragraph style in your source documents that is not
included in the print version of your documentation. You can apply a condition to this paragraph that
has the passthrough setting selected in ePublisher. Then, this paragraph can provide the exact coding to
include in your output. Be sure to include any referenced files in your Files  folder of your project so
ePublisher copies those files to your output location.
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Image Quality and Processing
If ePublisher cannot use an original image in the output, or if ePublisher determines it needs to modify
the image based on how it is included in the source document, ePublisher rasterizes the image using the
options you define for your graphic styles in Style Designer. For example, you can define the dots per
inch (DPI) and format for the final images. Rasterization of an image can cause the image to be blurry or
distorted in the output.

For more information and specific considerations about your images, see “Image Formats and
Considerations in FrameMaker” and “Image Styles and Considerations in Word”.
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The Prototype Style for Images
The Prototype style is the parent to all other styles. When you set a property for the Prototype graphic
style, other styles inherit the value of that property. The Prototype graphic style allows you to quickly
change a default property and apply that change to all graphic styles within your Stationery project.
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Defining Graphic Styles
All images are, by default, set to the Prototype style. If you need to modify any image properties, you can
do so through the Prototype style. However, if you want to control a smaller set of images, even just one
image, you need to assign a unique graphic style to those images.

To define a graphic style

1. Create a marker named GraphicStyle in your FrameMaker template.

2. Open your Stationery design project.

3. On the View menu, click Style Designer.

4. In Graphic Styles, define a set of graphic styles. Writers can use a marker or field code to specify
the graphic style to apply to each image.
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Setting the Border Style and Color of an Image
Borders are lines that can be drawn around any or all of the four sides of an image. In terms of the CSS
box model, increasing the padding for a graphic style increases the space between the image and the
border.

Not all browsers display border styles the same way. For example, some browsers may not differentiate
dotted lines from solid lines. The size and spacing of the dots in a dotted line may also be different
between various browsers and operating systems.

To set the border style and color of an image

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Graphic Styles, select the graphic style you want to modify.

4. On the Properties tab, click Border.

5. Click the tab for the side of the image you want to display a border, and then specify the color,
style, and width for that border. For more information about a property, click Help.
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Modifying the Width, Height, and Positioning of an Image
ePublisher automatically transforms images in your source document into Web-ready formats. However,
the size of your print image may not be appropriate for online delivery. ePublisher provides several ways
to modify the size of your images for online delivery without affecting the original images.

If you know the exact dimensions you want to assign to an image, you can use the height and width
properties of a graphic style. However, you are defining the dimensions of all images that use that graphic
style. Unless you want all your images to be the same size, such as 150 pixels high and 275 pixels wide,
this option is not the most effective way to modify the size of your images. For most situations, it is more
efficient to define the maximum height and width for an image as opposed to assigning a fixed height and
width. For more information, see “Setting the Maximum Width and Height for Images” and “Modifying
Image Size by Scale”.

In most cases, you probably want to leave your images positioned as they are in your source documents.
To visually enhance the layout and presentation of your online images, ePublisher allows you to set the
position of any image according to CSS rules.

To set the width, height, and positioning of an image

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Graphic Styles, select the graphic style you want to modify.

4. On the Properties tab, click HTML.

5. Specify the appropriate values for the width, height, and positioning properties.
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Adjusting the Space Around Images
You can adjust the white space around images by adjusting the margin and the padding. In terms of the
CSS box model, modifying the padding property adjusts the space inside the border area. For example, if
you create a border or background color for an image and you increase the size of the padding, the border
moves away from the image.

Modifying the margin properties adjusts the space outside the border area. For example, if you create a
border or background color for an image and you increase the size of the margins around the image, the
border remains the same distance from the image. However, the position of the image changes since there
is more white space between the modified image and other elements on the page.

To set the margin and padding of an image

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Graphic Styles, select the graphic style you want to modify.

4. On the Properties tab, click Margin.

5. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom margin
properties.

6. On the Properties tab, click Padding.

7. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom padding
properties.
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Using Thumbnails for Images
ePublisher allows you to automatically reduce the size of images in your online content to thumbnails,
which are reduced versions of your images. Users can view the full-sized image by clicking on the
thumbnail. If you set the width and height values for thumbnails, ePublisher automatically creates the
thumbnails you need and links them to the full-sized images. If you do not set a width and height for
thumbnails, ePublisher inserts the image itself in your output and does not use thumbnails.

To use thumbnails for images

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, specify values, in pixels, for the Maximum thumbnail width and Maximum
thumbnail height options.
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Setting the Maximum Width and Height for Images
Most images in your content vary in width and height. For your online content, you need to ensure that all
your images fit within the display area. In most cases, you have a maximum width or height constraint.
For example, although some of your images may only be 250 pixels wide, you want to make sure that
none of your images are wider than 275 pixels.

ePublisher allows you to set maximum width and height values for the size of your images. By modifying
the size of your images in this way, you ensure that the resized images retain their original aspect ratio.

To set the maximum width and height of images

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, specify values, in pixels, for the Maximum image width and Maximum
image height options.
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Modifying Image Size by Scale
If you are not concerned with actual width and height of an image, you can specify a scaling percentage to
apply to all images with the selected graphic style. This option allows you to modify the size of all images
associated with the graphic style in relation to their original sizes. Modifying images in this way retains
the original aspect ratio of each image.

To resize images based on a percentage

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, specify a percentage value for the Scale % option. For example, if you specify
50, each image with the selected graphic style will be reduced to half its original size.
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Modifying Image Resolution
If the resolution of the images in your source documents is set for print, such as a resolution of 300 dots
per inch (dpi) or higher, you may want to reduce the image resolution for online delivery. High dpi images
create larger files that require more time to download. In addition, most monitors display a resolution of
96 dpi, so higher resolutions do not increase the quality of the image displayed online.

Although transforming an image from 300 dpi to 96 dpi helps optimize your images for online delivery,
the width and height of your images is also affected. Because a resolution of 300 dpi contains more dots
per inch than a resolution of 96 dpi, when ePublisher transforms the image, the image will be roughly
68% smaller than the original image. For example, a 300 dpi image that is 100 x 100 pixels will be 32 x
32 pixels when transformed to a 96 dpi image.

To counter this effect, use the Scale % option in conjunction with the Render DPI option to control the
size of your images. In the example of transforming a 300 dpi image to 96 dpi, set the Scale % option to
312, which then generates an image that has roughly the same dimensions as the original source image.
You can also use the Scale % and Render DPI options together with the Maximum image height and
Maximum image width options to make sure your images are correctly sized for online delivery.

To set the image resolution (dpi)

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, specify a value in dpi for the Render DPI option.
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Setting Color Bit Depth
The range of colors available through digital computer images is usually expressed in terms of bit depth.
This expression refers to the number of bits of data carrying the color information. Common bit depth
levels for images include 8-bit and 24-bit color. In general, more bits of data make more colors available.
The Color bit depth option applies only to .gif  and .png  images. .jpg  images always generate 32-bit
images.

To set the color-bit depth for .gif and .png images

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, select a value for the Color bit depth option.
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Choosing an Image File Format and Quality Level
By default, if ePublisher needs to rasterize an image, it transforms the image in your source documents,
regardless of what file format it is, to a Web-ready .jpg  image. In some instances, you may want to use
other image formats for online delivery. For example, .gif  images can produce similar quality images
as .jpg , but the file size is smaller. .gif  images can also support transparent colors. You can also create
.png  images, which combine some of the better qualities of both .jpg  and .gif .

If you select JPG in the Format options for a graphic style, you can specify the quality of the images.
The quality level impacts both the visual aspects of your images and the size of the generated files.
Higher-quality images require larger files, which require more time to download and display. The JPG
Quality option does not affect .gif  or .png  images.

To choose the file format and quality for online images

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, select a value for the Format option.

6. In the Output file extension field, specify the proper file extension based on the value you selected
for the Format option, such as .jpg, .gif, or .png.

7. If you selected JPG in the Format option, in the JPG Quality field, specify the percentage value
you want for your online images. A value of 100 creates the highest quality image that mimics your
original image.
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Creating Grayscale Images
ePublisher allows you to transform your original color images into grayscale versions for online viewing.
If you enable the Grayscale option, ePublisher removes the color saturation of the original images when
those images are transformed with your online content. ePublisher displays the color versions of your
images in the preview pane to generate the preview more quickly.

To create grayscale images

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, set the Grayscale option to Enabled.
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Setting Transparency for .gif and .png Images
In some images, you may want to set a color to transparent. For example, if your source document has
a white background, images with a white background appear as though they do not have a background.
However, if your online content has a different color background, the background of these images appear
as white areas. You can enable the transparency option in ePublisher to transform the white background
into a transparent one. Only .gif  and .png  images support transparent colors.

Note: Some browser versions do not support transparent colors, especially in .png
images.

To set transparency for .gif and .png images

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Graphic Styles, select the graphic style you want to modify.

5. On the Options tab, set the Transparent option to Enabled.
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Defining the Appearance of Pages
The way you present your online content greatly impacts the usability and readability of that content
in the online environment. Information layout and design for print and online content are usually very
different. ePublisher allows you to format your source documents to optimize for printed delivery, and
then use ePublisher to deliver the content optimized for online presentation.

Unlike printed content, online documentation can include extra navigation features, follow different rules
regarding topic length and page breaks, and include unique page layouts for specific types of information.
While each output format varies in the types of files that are delivered, most output formats are based
on HTML. Therefore, when you decide how to present your content online, consider the layout of your
content on an HTML page.

In ePublisher, the overall appearance of each topic of your output is controlled by page styles. You can
modify page style properties with Style Designer to define whether to include navigation browse buttons
on each page, whether to include company logo and contact information, and other design elements for
each page that uses a specific page style. To deliver your online content as individual chunks, or pages of
information, define page breaks based on paragraph styles, such as headings. For more information, see
“Defining New Pages (Page Breaks)”.
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The Prototype Style for Pages
The Prototype style is the parent to all other styles. When you set a property for the Prototype page
style, other page styles inherit the value of that property. You can then override that value for specific
styles as needed. The Prototype page style allows you to quickly change a default property and apply that
change to all page styles within your Stationery project.
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Displaying Company Logo and Information on a Page
Most HTML-based output formats support adding company information, such as company name, email
address, and company logo, as part of a page. Once you specify your company information in the Target
Settings for your project, you can select different locations in which to place the content on each page. If
you specify a value for Company webpage, ePublisher links the specified company name to the specified
Web page. If you specify Company email address, ePublisher creates a mailto: link to the specified
address.

If you add a logo image to your project, ePublisher displays the logo next to your company contact
information on the top or the bottom of your output pages. To include a logo, you must first store the
image file in the Files  folder of your project.

To specify your company information and the location on the page

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Specify the appropriate values for the Company Information settings, such as Company name
and Company phone number. If you do not see these fields in the list of target settings, the output
format for the active target does not support this feature. For more information about a setting,
click Help.

4. Click OK to save the target settings.

5. On the View menu, click Style Designer.

6. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

7. In Page Styles, select the page style you want to modify.

8. On the Options tab, specify the appropriate values for the Company info... options. For more
information about an option, click Help.

Note: Company information is not displayed in the Preview pane.
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Modifying the Appearance of the Company Information
You can modify the appearance of the company information by creating an override for the Page.asp
file. This file controls the content coding for each page of your content. When you modify this file, you
need to change the appropriate part of the file based on whether you want to modify the appearance of the
company information at the top of the page or at the bottom of the page. You can also modify many other
aspects of your content pages.

To modify the appearance of the company information

1. Create an override file for the Page.asp  file by copying it from the installation folder to your
format or target override folder in your project, based on whether you want to modify the
appearance of the company information for an output format or for a specific target. For more
information, see “Format and Target Overrides”.

2. Open the Page.asp  file you copied to the Formats\formatname\Pages  or Targets
\targetname\Pages  folder in your project.

3. Locate the code at the top or bottom of the Page.asp  file, based on whether you want to change
the appearance of the information at the top or the bottom of the page.

To modify the top of the page, find the following line of code:

<table wwpage:condition="company-info-top" align="left" wwpage:attribute-
align="company-info-top-alignment">

To modify the bottom of the page, find the following line of code:

<table wwpage:condition="company-info-bottom" align="right"
wwpage:attribute-align="company-info-bottom-alignment">

4. If you want to modify the appearance of the company name, create an override for
webworks.css from the Formats\[your format]\Pages\css installation directory. Then, find
td.WebWorks_Company_Name_Top  in Pages\css\webworks.css , and modify the CSS attributes,
such as the font-size  or font-family , and required.

5. If you want to modify the appearance of the company phone number, find the following code
immediately after the line of code you found at the top or bottom of the file:

<tr wwpage:condition="company-phone-exists">

<td class="WebWorks_Company_Phone_Bottom">

or <td class="WebWorks_Company_Phone_Top">

Look for td .WebWorks_Company_Phone_Bottom or td.WebWorks_Company_Phone_Top  in Pages
\css\webworks.css and change the font-size  or font-family

6. If you want to modify the appearance of the company fax number, find the following code
immediately after the line of code you found at the top or bottom of the file:

<tr wwpage:condition="company-fax-exists">

<td class="WebWorks_Company_Fax_Bottom">
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or <td class="WebWorks_Company_Fax_Top">

Look for td .WebWorks_Company_Fax_Bottom or td.WebWorks_Company_Fax_Top  in Pages\css
\webworks.css and change the font-size  or font-family

7. If you want to modify the appearance of the company email address, find the following code
immediately after the line of code you found at the top or bottom of the file:

<tr wwpage:condition="company-email-exists">

<td class="WebWorks_Company_Email_Bottom">

or <td class="WebWorks_Company_Email_Top">

Look for td .WebWorks_Company_Email_Bottom or td.WebWorks_Company_Email_Top  in Pages
\css\webworks.css and change the font-size  or font-family
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Setting the Background Color or Image of a Page
You can specify a color to use as the background of a page. You can also specify an image to use as the
background. This capability allows you to include a watermark, such as DRAFT  for initial internal versions
of your online content. The background image for a page is behind other elements on the page. If you set
a background color for the page, you cannot see the background image for the page. Make sure the image
is stored in the Files  folder for the project so the image file is copied to your output folder. Also make
sure the image does not make the text too difficult to read.

To set the background color or image of a page

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Page Styles, select the page style you want to modify.

4. On the Properties tab, click Background.

5. If you want to specify a color for the background of a page, select a color in the Color field, or
type the RGB value of the color you want, such as FFFFFF .

6. If you want to specify an image for the background of a page, complete the following steps:

a. Save the image file in the Files  folder for the project. ePublisher copies files from the
Files  folder when you generate the project.

b. In the Image field under Background Image, select the image you want to use. ePublisher
lists only the image files stored in the Files  folder.

c. Specify the tiling, scrolling, and position properties to position the image. For more
information about a property, click Help.
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Setting the Border Style and Color of a Page
Borders are lines that can be drawn around any or all of the four sides of a page. In terms of the CSS box
model, increasing the padding for a page style increases the space between the content within the page
and the border of the page.

Not all browsers display border styles the same way. For example, some browsers may not differentiate
dotted lines from solid lines. The size and spacing of the dots in a dotted line may also be different
between various browsers and operating systems. Some browsers may not display page borders at all. If
you want a page border, view the generated output in multiple browsers to verify that your settings create
the appearance you want.

To set the border style and color for a page

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Page Styles, select the page style you want to modify.

4. On the Properties tab, click Border.

5. Click the tab for the side of the page you want to display a border, and then specify the color, style,
and width for that border. For more information about a property, click Help.
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Adjusting the Space Around a Page
You can adjust the white space around a page by adjusting the margin and the padding. In terms of the
CSS box model, modifying the padding property adjusts the space inside the border area. For example,
if you create a border or background color for a page and you increase the size of the padding, the border
moves away from the content in the page.

Modifying the margin properties adjusts the space outside the border area. For example, if you create
a border or background color for a page and you increase the size of the margins around the page, the
border remains the same distance from the content in the page. However, the position of the content
changes because the space outside the border increases.

To set the margin and padding of a paragraph

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Page Styles, select the page style you want to modify.

4. On the Properties tab, click Margin.

5. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom margin
properties.

6. On the Properties tab, click Padding.

7. Specify a value and select the unit of measure for the Left, Right, Top, and Bottom padding
properties.
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Using a Custom CSS to Modify the Appearance of Content
You can use a custom CSS file to modify the appearance of your content instead of using Style Designer
for HTML-based output formats. By using style names in your source document that match the classes
defined in your custom CSS file, such as div.Heading1, you can make sure your content uses your
custom CSS file. You do not need to create any other association between styles in your source documents
and the styles in Style Designer. Make sure you define each tag and class from your generated output in
your custom CSS file.

To use a custom CSS file with your project

1. Store your custom CSS file in the Files  folder in your project.

2. Open your Stationery design project.

3. On the View menu, click Style Designer.

4. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

5. In Page Styles, select the page style you want to modify.

6. On the Options tab, select your custom CSS file in Custom document css file.
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Modifying the Location and Separators of Breadcrumbs
Breadcrumbs form a linked path to show users the location of the current topic in your online content.
This clickable path steps you through the topics in the hierarchy above the current topic. You can display
breadcrumbs at the top of the page, at the bottom of the page, or both. The breadcrumb trail at the top of
the output page is enabled by default.

To modify the location of the breadcrumb trail

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Page Styles, select the page style you want to modify.

5. On the Options tab, select the appropriate value for the Breadcrumbs shown at top of page and
Breadcrumbs shown at bottom of page options.

6. On the Properties tab, click Navigation.

7. Specify the appropriate values for the Breadcrumbs Separator and Alignment properties. For
more information about a property, click Help.
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Modifying the Appearance of Breadcrumbs
Breadcrumbs form a linked path to show users the location of the current topic in your online content.
If you enabled breadcrumbs for your output, you have several options to define the appearance of the
breadcrumbs. For more information, see “Modifying the Location and Separators of Breadcrumbs”.

For more information about override files and locations, see “Stationery, Projects, and Overrides”.

To modify the appearance of the breadcrumb trail

1. If you want to override the CSS settings for an output format, complete the following steps:

a. In your Stationery design project, on the View menu, click Format Override Directory.

b. Create the Formats\formattype\Pages\css  folder in your project folder, where
formattype is the name of the output format you want to override, such as Microsoft HTML
Help 1.x .

2. If you want to override the CSS settings for a target, complete the following steps:

a. In your Stationery design project, on the View menu, click Target Override Directory.

b. Create the Targets\targetname\Pages\css  folder in your project folder, where
targetname is the name of the target you want to override.

3. Copy the webworks.css  file from the following folder to the override folder you created within
your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\formattype\Pages\css

4. Open the webworks.css  file you copied to your project override folder.

5. Find the code for div.WebWorks_Breadcrumbs  and modify the values specified within the braces:

To modify the text color, specify the desired RGB color value for the color  option.

To modify the font, specify the name of the font you want for the font-family  option.

To modify the size of the font, specify the size you want for the font-size  option.

6. Save the webworks.css  file.

7. Regenerate your project to review the changes.
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Choosing the Location of Navigation Browse Buttons
If you have included navigation buttons in your output, you can specify whether to display the browse
buttons at the top or the bottom of each page. You can also specify whether to align the button along the
right or left side. Not all output formats support navigation browse buttons.

To modify the location of navigation browse buttons

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Page Styles, select the page style you want to modify.

5. On the Options tab, select the appropriate value for the Navigation links shown at top of page
and Navigation links shown at bottom of page options.

6. On the Properties tab, click Navigation.

7. Specify the appropriate values for the Navigation Alignment properties. For more information
about a property, click Help.
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Modifying the Navigation Browse Buttons
You can use customized navigation browse buttons in your online content. For more information about
customizing the WebWorks Help navigation buttons, see “Customizing the Toolbar in WebWorks Help”.

To change the navigation button images

1. If you want to override the images for an output format, complete the following steps:

a. In your Stationery design project, on the View menu, click Format Override Directory.

b. Create the Formats\formattype\Pages\Images  folder in your project folder, where
formattype is the name of the output format you want to override, such as Dynamic HTML .

2. If you want to override the images for a target, complete the following steps:

a. In your Stationery design project, on the View menu, click Target Override Directory.

b. Create the Targets\targetname\Pages\Images  folder in your project folder, where
targetname is the name of the target you want to override.

3. Paste the .gif  files you want to use with names identical to those you want to replace in the
Images  folder you created. The following table lists the default button images and their file names
and sizes.

 

Image Name Image Size Description

prev.gif Width: 0.722 inch
Height: 0.333 inch

Sends the user to the previous HTML
document.

prevx.gif Width: 0.722 inch
Height: 0.333 inch

Displayed when there is no previous
HTML document available.

next.gif Width: 0.722 inch
Height: 0.333 inch

Sends the user to the next HTML
document.

nextx.gif Width: 0.722 inch
Height: 0.333 inch

Displayed when there is no next HTML
document available.

4. Regenerate your project to review the changes.

100 | Modifying the Navigaon Browse Buons



Associating a Page with a Page Style
By default, output is associated with the Prototype page style in ePublisher. Therefore, you do not have
to do anything to associate pages with the Prototype page style. However, if you want to have more than
one page layout, you need to use additional page styles.

To associate a page with a page style

1. Define page breaks based on paragraph styles, such as heading styles.

2. Define additional page styles in the Stationery.

3. If you want to associate a page with a page style other than the Prototype page style, add a
PageStyle marker or field code in your source document after the new page style, such as the
heading that starts the page. The PageStyle marker or field code identifies what page style to use
for that page.

Provide writers with the defined page style names they need to specify in their PageStyle markers or field
codes.
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Defining the Appearance of Links
You can customize the appearance of links, also known as hyperlinks and hypertext links. You can define
the color and text decoration, such as underline, for the currently selected link (active link), links you
have previously visited, links you hover over, and the links you have not previously visited. These link
settings are stored in the webworks.css  file. You can create an override for the webworks.css  file and
then modify the tags that define the links.

Note: These changes do not affect output formats that do not use cascading style
sheets.

In your source files, apply a character style to identify the text to include in each link. The character style
can also affect the appearance of the link.

To change the color of links

1. In your Stationery design project, go to Advanced menu bar item and either click

Manage Format Customizations or Manage Target Customizations.

2. Navigate to Pages\css in this window.

3. Double click the webworks.css  file and it will be bolded to indicate that a customization has been
created.

4. Double click again, and the CSS file should be opened in a text editor:

5. Find the following code and modify the values specified within the braces:

a:link:active { color: #0000CC }

a:link:hover { color: #CC0033 }

a:link { color: #3366CC }

a:visited { color: #9999CC }

To modify the text color, specify the desired RGB color value for the color  option of the
appropriate link type and state.

To add text decoration, such as an underline, add the text-decoration: underline;
option to the type of link you want to have an underline, and add the text-decoration:
none;  option to the other types of link.

To make the link text bold when you hover over the link, add the font-weight: bold;
option to the a:link:hover  definition.

6. Save the webworks.css  file.

7. Save and close your project.

8. Reopen your project and regenerate to review the changes.
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Saving a Snapshot (Backup Copy) of Your Project
As you continue to make changes to your Stationery design project, you may want to revert to a previous
state, before you implemented a specific feature. You can save a backup copy of your project and then use
this backup copy at a later time, if needed.

As you develop your Stationery design project, periodically save a snapshot of your project. You can use
this snapshot to revert to your Stationery design project at a specific point in time. This snapshot can also
help you if your design project or Stationery become corrupted in the future. For more information about
the specific files and folders, see “Backing Up Your Stationery Design Project, Stationery, and Projects”.

To save a snapshot (backup copy) of your project

1. Save your project and close ePublisher.

2. Copy your project folder and all its subfolders and files, and your source documents folder,
maintaining the same structure, to another location. For example, create a folder with the date from
today as the name. Then, copy your project folder and your source documents folder into the folder
you created. This copy is your snapshot.
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Defining Marker Types
If you want to create your own markers, you can define the behavior of each marker you create.
ePublisher provides many default markers to provide various built-in features and capabilities.
 

Default Marker Name Description

AbbreviationTitle Specifies alt text for an abbreviation, such as SS#. This text is displayed when
a user hovers over the abbreviation in the output.

AcronymTitle Specifies alt text for an acronym, which is displayed when a user hovers over
the acronym in the output.

Citation Specifies a citation as alt text for a quote, which is displayed when a user
hovers over the citation in the output.

Context Plugin Specifies context plug-ins for Eclipse help systems. Other Eclipse plug-ins
can use the context plug-in IDs to call the Eclipse help system. For more
information, see “Using Markers to Specify Context Plug-ins in Eclipse Help”.

Description Specifies a formal description for the generated HTML page that from the
source content at this location of the source file. In WebWorks Reverb 2.0, it is
used for the contents of the search result summary.

DropDownEnd Marks the end of an expand/collapse section. For more information, see
“Defining Expand/Collapse Sections (Drop-Down Hotspots)”.

Filename Specifies the name of an output file for a page or an image. For more
information, see “Defining File Names”.

GraphicScale Specifies a percentage to resize an image, such as 50 or 75 percent.

GraphicStyle Specifies the name of a graphic style defined in the project to apply to
an image. This marker is an internal marker name that is not displayed
in Stationery Designer. You cannot create a marker with a different name
and assign it this functionality. For more information, see “Defining the
Appearance of Images”.

ImageAltText Specifies alt text for an image. This text is added to the alt  attribute of the
img  tag in the output.

ImageAreaAltText Specifies alt text for clickable regions in an image map. This text is displayed
when a user hovers over the region in the output.

ImageLongDescByRef Specifies the path to the file that contains the long description for an image.
This description is used when you create accessible content.
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Default Marker Name Description

ImageLongDescNotReq Specifies that a long description is not required for an image, which bypasses
this accessibility check for that image.

ImageLongDescText Specifies the long description for an image. This description is used when you
create accessible content.

Keywords Specifies the keywords to include in the META  tag for the topic. This META
tag improves searchability on the Web.

PageStyle Specifies the name of a page style defined in the project to apply to a topic.
This marker is an internal marker name that is not displayed in Stationery
Designer. You cannot create a marker with a different name and assign it this
functionality. For more information, see “Defining the Appearance of Pages”.

PassThrough Specifies that ePublisher place the contents of the marker directly into the
generated output without processing the content in any way. For example, you
could use a PassThrough marker if you wanted to embed HTML code within
your generated output.

Popup Specifies the start of the content to include in a popup window. The content
is displayed in a popup window when you hover over the link. When you click
the link in some output formats, the topic where the popup content is stored,
such as the glossary, is displayed. For more information, see “Defining Popup
Windows”.

PopupEnd Marks the end of the content to include in a popup window.

PopupOnly Specifies the start of the content to include in a popup window. The content is
displayed in a popup window when you hover over or click the link.

RubiComposite No longer supported.

SeeAlsoKeyword Specifies an internal identifier for a topic. SeeAlsoLink markers in other topics
can list this identifier to create a link to this topic. For more information, see
“Defining See Also Links”.

SeeAlsoLink Identifies an internal identifier from another topic to include in the list of see
also links in this topic.

SeeAlsoLinkDisplayType Specifies whether to display the target topics on a popup menu or in a
window. By default, the links are displayed in the Topics Found window. To
display a popup menu, set the value to menu . This marker is supported only
in HTML Help.

SeeAlsoLinkWindowType Specifies the name of the window defined in the hhp file, such as TriPane
or Main, that the topic opens in when the user clicks the link. This marker is
supported only in HTML Help.

TableStyle Specifies the name of a table style defined in the project to apply to a table in
versions of Microsoft Word that did not support table styles. This marker is an
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Default Marker Name Description

internal marker name that is not displayed in Stationery Designer. You cannot
create a marker with a different name and assign it this functionality.

TableSummary Specifies a summary for a table, which is used when you create accessible
content.

TableSummaryNotReq Specifies that a summary is not required for a table, which bypasses this
accessibility check for that table.

TOCIconHTMLHelp Identifies the image to use as the table of contents icon for this topic in the
HTML Help output format.

TOCIconJavaHelp Identifies the image to use as the table of contents icon for this topic in the
Sun JavaHelp output format.

TOCIconOracleHelp Identifies the image to use as the table of contents icon for this topic in the
Oracle Help output format.

TOCIconWWHelp Identifies the image to use as the table of contents icon for this topic in the
WebWorks Help output format.

TopicAlias Specifies an internal identifier for a topic that can be used to create a context-
sensitive link to that topic. For more information, see “Defining Context-
Sensitive Help Links”.

TopicDescription Specifies a topic description for a context-sensitive help topic in Eclipse
help systems. For more information, see “Using Markers to Specify Topic
Descriptions for Context-Sensitive Help Topics in Eclipse Help”.

WhatIsThisID Identifies a What’s This help internal identifier for creating context-sensitive
What’s This field-level help in the HTML Help output format.

WindowType Specifies the name of the window defined in the help project that the topic
should be displayed in. In HTML Help, the window names are defined in the
hhp file. This marker is supported in HTML Help and Oracle Help.
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Defining File Names
By default, ePublisher automatically assigns file names to your generated output files for topics (pages)
and images (graphics). ePublisher assigns output file names using a default naming rule. You can
customize this naming convention using one of the following methods:

Specifying a different topic (page) or image (graphic) naming pattern for ePublisher to use in the
target settings for your output.

Inserting Filename markers into source documents that specify the topic (page) or image (graphic)
file name ePublisher should use for the file when generating output.
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Specifying File Names for Pages Using Page Naming Patterns
By default, ePublisher uses the following values when specifying file names for pages:

$D;.$DN;.$PN

This specifies that ePublisher name the files using the following syntax when it generates page files for a
target:

SourceDocumentName.SourceDocumentNumber.TopicNumber

The parts of the default naming rule are defined as follows:

SourceDocumentName
Identifies the name of the source document that the topic came from without the file extension.

SourceDocumentNumber
Identifies the number of the source document in the order it is included in its containing group in
the project, such as 1 for the first source document in a group and 2 for the second source document
in a group. This value starts at 1 for the first source document in each group in your project.

TopicNumber
Identifies the number of the topic (output page) generated from the source document, such as 1 for
the first topic generated from a source document and 2 for the second topic generated from a source
document. This value starts at 1 for the first topic in each source document.

For example, if you have a MyFile.fm  source document that contains three topics that start with a
paragraph style that has a page break priority set in Style Designer, ePublisher generates the following
default output file names: MyFile.1.1.html , MyFile.1.2.html , and MyFile.1.3.html . You can
change the default file extension for each page style.

You can use the following values to specify a page file naming pattern for a target:

Note: Each value you specify must begin with a dollar sign ($ ) character and end
with a semicolon (; ) character. Inserting a period (. ) character immediately
before the value specifies that ePublisher use a period to separate the values
when generating output.

 

Value Description

$P; Includes the name of the project in the file name.

$T; Includes the name of the target in the file name.

$G; Includes the name of the group in Document Manager that
contains the file name.

$C; Includes the project to project linking context value of the group
in the file name. WebWorks Help and WebWorks Reverb use the
context value when generating merged, or multivolume help that
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Value Description

includes context-sensitive help. In WebWorks Help/Reverb, you
need to include this context and the TopicAlias value in the help
call to display the correct help topic. For more information, see
“Merging Top-level Groups (Multivolume Help)” and “Opening
Context-Sensitive Help in WebWorks Help using Standard URLs”.

$H; Includes the heading text or title of the topic in the file name.

$D; Includes the name of the source document that the topic came
from in the file name.

$DN; Includes the source document number in the file name. The
source document number is the number that identifies the position
of the source document in the project.

$PN; Includes the page number in the file name. The page number
is the number of the page that the topic is on in the source
document.

You can also specify if you want ePublisher to convert spaces in file names to underscore (_) characters
when generating output. If you enable this setting, when you generate output, spaces in file names
are replaced with the underscore character. For example, with this setting disabled, file names display
as Word1 Word2.html . With this setting enabled, when you generate output file names display as
Word1_Word2.html .

To specify a page file naming patterns for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Files, specify the appropriate values for the page file naming pattern you want to use. For
more information about file settings and values, click Help.
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Specifying File Names for Images Using Graphic Naming Patterns
ePublisher preserves the original file names for images imported by reference. If images are inserted
directly into a source document, or if ePublisher cannot process the image by reference, then ePublisher
assigns a file name using a graphic naming pattern.

By default ePublisher uses the following values when specifying file names for images:

$D;.$DN;.$PN;$.GN

This specifies that ePublisher name the files using the following syntax when it generates image files for a
target:

SourceDocumentName.SourceDocumentNumber.TopicNumber.ImageNumber

The parts of the default naming rule are defined as follows:

SourceDocumentName
Identifies the name of the source document that the topic came from without the file extension.

SourceDocumentNumber
Identifies the number of the source document in the order it is included in its containing group in
the project, such as 1 for the first source document in a group and 2 for the second source document
in a group. This value starts at 1 for the first source document in each group in your project.

TopicNumber
Identifies the number of the topic (output page) generated from the source document, such as 1 for
the first topic generated from a source document and 2 for the second topic generated from a source
document. This value starts at 1 for the first topic in each source document.

ImageNumber
Identifies the number of the image in the topic generated from the source document, such as 1 for
the first image generated in a topic and 2 for the second image generated in a topic. This value
starts at 1 for the first image in each topic.

For example, if you have a source document named MyFile.doc  that contains two images in the first
topic that generates an output file, and three images in the second topic that generates an output file,
and all the images are directly included in the source document, ePublisher generates the following
default output image file names: MyFile.1.1.1.jpg , MyFile.1.1.2.jpg , MyFile.1.2.1.jpg ,
MyFile.1.2.2.jpg , and MyFile.1.2.3.jpg . You can change the default format and file extension for
each graphic style.

You can use the following values to specify an image (graphic) file naming pattern for a target:

Note: Each value you specify must begin with a dollar sign ($ ) character and end with a semicolon
(; ) character. Inserting a period (. ) character immediately before the value specifies that
ePublisher use a period to separate the values when generating output.
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Value Description

$P; Includes the name of the project in the file name.

$T; Includes the name of the target in the file name.

$G; Includes the name of the group in Document Manager that
contains the file name.

$C; Includes the project to project linking context value of the group
in the file name. WebWorks Help and WebWorks Reverb use the
context value when generating merged, or multivolume help that
includes context-sensitive help. In WebWorks Help/Reverb, you
need to include this context and the TopicAlias value in the help
call to display the correct help topic. For more information, see
“Merging Top-level Groups (Multivolume Help)” and “Opening
Context-Sensitive Help in WebWorks Help using Standard URLs”.

$H; Includes the heading text or title of the topic in the file name.

$D; Includes the name of the source document that the topic came
from in the file name.

$DN; Includes the source document number in the file name. The
source document number is the number that identifies the position
of the source document in the project.

$PN; Includes the page number in the file name. The page number
is the number of the page that the topic is on in the source
document.

$GN; Includes the graphic number in the file name. The graphic number
is the sequential number of the graphic in the generated output,
and it is based on the position of the graphic in the generated
output.

You can also specify if you want ePublisher to convert spaces in file names to underscore (_) characters
when generating output. If you enable this setting, when you generate output, spaces in file names
are replaced with the underscore character. For example, with this setting disabled, file names display
as Word1 Word2.jpg . With this setting enabled, when you generate output file names display as
Word1_Word2.html .

To specify an image (graphic) file naming pattern for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.
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2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Files, specify the appropriate values for the graphic file naming pattern you want to use.
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Using Markers to Define File Names
You can use markers and field codes to specify the file name for a topic or image. Writers insert a
Filename marker into their source documents and specify the file name they want to assign to the topic of
image in the marker.

The default name for this marker type or field code is Filename. You can define your own marker style
with a different name in your Stationery and assign the Filename marker type to it. Then, writers can use
this marker type or field code to specify the output file name for each topic and included image.

Note: ePublisher uses page and graphic naming patterns to assign file names to
all topics and images that do not include a Filename marker type or field
code. For more information, see “Specifying File Names for Pages Using
Page Naming Patterns” and “Specifying File Names for Images Using Graphic
Naming Patterns”.

To assign file name behavior to file name markers

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Marker Styles, select the marker style you want to modify.

4. On the Options tab, set Marker type to Filename.
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Defining Context-Sensitive Help Links
Context-sensitive help links provide content based on the context of what the user is doing. In many
cases, this help content is based on the window that is open and active. For example, the Help button on a
window in a software product can open a specific help topic that provides important information about the
window:

What the window allows you to do

Brief concepts needed to understand the window

Guidance for how to use the window

Descriptions about each field on the window, valid values, and related fields

Links to related topics, such as concepts and tasks related to the window

The help topic can also be embedded in the window itself, such as an HTML pane that displays the
content of the help topic. Providing this content when and where the user needs it, without requiring the
user to search through the help, keeps the user productive and focused. This type of help also makes the
product more intuitive by providing answers when and where needed.

There are several methods for creating context-sensitive help. In addition, output formats use different
mechanisms to support context-sensitive help. You can reference a topic in the following ways:

File name
Use a Filename marker to assign a file name to a topic. Each topic can have no more than one
Filename marker by default. However, you can create a custom mapping mechanism using file
names. Then, you can open the specific topic with that file name. However, if your file naming
changes, you need to change the link to the topic. This file naming approach delivers context-
sensitive help capabilities in output formats that do not provide a mapping mechanism.

Internal identifier (topic alias)
Use a TopicAlias marker to define an internal identifier for each topic. The benefit of using an
internal identifier is that it allows file names to change without impacting the links from the
product. The writer inserts this marker in a topic and specifies a unique value for that topic. Then,
the mapping mechanism of your output format determines how that internal identifier is supported.
Some output formats, such as HTML Help, use a mapping file that defines these topic aliases. You
can create more than one TopicAlias marker in a topic to allow multiple context-sensitive links to
display the same topic.

To simplify the coding of your source documents, you can use the same marker to define both the file
name and the topic alias for each topic file. In Style Designer, set the Marker type option for the marker
you want to use to Filename and topic alias.

For more information about using markers to enable context-sensitive help links, see the following topics:

“Defining Filename Markers for Context-Sensitive Help Links”

“Defining Filename Markers for Context-Sensitive Help Links”
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For more output format-specific information about using and customizing context-sensitive help, see the
following topics:

“Using Context-Sensitive Help in WebWorks Help”

“Using Context-Sensitive Help in HTML Help”

“Using Context-Sensitive Help in Oracle Help and Sun JavaHelp”

“Using Context-Sensitive Help in WebWorks Reverb”

“Using Context-Sensitive Help in WebWorks Reverb 2.0”
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Defining Filename Markers for Context-Sensitive Help Links
To enable context-sensitive help links using file names, you need to enable the Filename marker. By
default, ePublisher sets the Marker type option for a marker named Filename to Filename. You can
create a marker with a different name and set the Marker type option for that marker to Filename.

Then, writers can use this marker in the source documents to define a file name for each topic that will be
opened by the application. File names must follow these guidelines:

Must be unique

Can only contain characters valid for file names

To assign file name behavior to file name markers

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Marker Styles, select the marker style you want to modify.

4. On the Options tab, set Marker type to Filename.
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Defining TopicAlias Markers for Context-Sensitive Help Links
To enable context-sensitive help links using topic IDs, you need to enable the TopicAlias marker. By
default, ePublisher sets the Marker type option for a marker named TopicAlias to Topic alias. You can
create a marker with a different name and set the Marker type option for that marker to Topic alias.

Then, writers can use this marker in the source documents to define a topic ID in each topic that will be
opened by the application. Topic IDs must follow these guidelines:

Must be unique

Must begin with an alphabetical character

May contain alphanumeric characters

May not contain special characters or spaces, with the exception of underscores (_ )

To assign topic alias behavior to topic alias markers

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In Marker Styles, select the marker style you want to modify.

4. On the Options tab, set Marker type to Topic alias.

To avoid duplicate topic Alias markers in Word, follow these steps:

1. Always insert topic alias markers at the end of Word headings, never at the start or middle.

2. When you edit the headings, always display hidden text. Otherwise, you might inadvertently move
a topic alias to the middle of the heading, causing problems.
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Defining Expand/Collapse Sections (Drop-Down Hotspots)
You can create sections of content that expand and collapse when you click a link or hot spot. This
structure allows you to create items, such as bulleted lists, that are easy to scan, and then the users
can expand individual items to get additional information. You can also use this structure to provide
definitions.

When you identify the paragraph styles to start expand/collapse sections, you define whether those
sections should initially be expanded (shown) or collapsed (hidden). ePublisher inserts an image
indicating the state of the link. When a user clicks on a hotspot with the initial content collapsed, the
content expands under the hotspot. If the user clicks a second time on the hotspot, the content is hidden
again.
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Using Styles and Markers for Expand/Collapse Sections
To use expand/collapse sections, you need the paragraph styles you want to start these sections, and you
need the DropDownEnd marker in your source documents. Decide which paragraph styles should provide
the link and start an expand/collapse section. For example, you could make Heading 4, Procedure Title,
and Bullet Expand paragraph styles start expand/collapse sections.

To enable expand/collapse sections in your Stationery

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the paragraph style you want to define as the link for the start of an
expand/collapse section.

5. On the Options tab, set Dropdown to Start open or Start closed, based on whether you want the
expand/collapse section to be displayed or hidden by default.

6. On the Options tab, set Dropdown toggle icon position to Left or Right, based on whether you
want the expand/collapse button to be on the left or right of your paragraphs.

7. Repeat steps 3-4 for each paragraph style you want to start expand/collapse sections.

When writers use these styles, they can identify the end of each expand/collapse section with the
DropDownEnd marker. All other paragraph styles should have the Dropdown option set to Continue to be
included in the expand/collapse sections as needed.
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Modifying Images for Expand/Collapse Sections
You can replace the default images ePublisher uses to indicate the state of an expanded or collapsed
hotspot. For more information about override files and locations, see “Stationery, Projects, and
Overrides”.

To modify expand/collapse images

1. If you want to override the images for an output format, complete the following steps:

a. In your Stationery design project, on the View menu, click Format Override Directory.

b. Create the Formats\formattype\Files\images  folder in your project folder, where
formattype is the name of the output format to override, such as Dynamic HTML .

2. If you want to override the images for a target, complete the following steps:

a. In your Stationery design project, on the View menu, click Target Override Directory.

b. Create the Targets\targetname\Files\images  folder in your project folder, where
targetname is the name of the target you want to override.

3. Paste the .gif  files you want to use with names identical to those you want to replace in the
Images  folder you created. The following table lists the default images and their file names and
sizes.

 

Image Image Name Image Size

expanded.gif Width: 8 pixels (0.111 inch)
Height: 6 pixels (0.083 inch)

collapse.gif Width: 6 pixels (0.083 inch)
Height: 8 pixels (0.111 inch)

Note: If you are generating with WebWorks Reverb output, you will modify the
expand/collapse images in the skin.png file located in Pages\images in the
Format or Target override directory for this output. For more information, See
“Changing the Appearance of WebWorks Reverb”.

4. Regenerate your project to review the changes.
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Defining Popup Windows
You can use popup windows to display brief additional information about a word or phrase, such as a
glossary definition for a term in a topic. A popup window displays a link in a topic, which indicates to
users they can hover over or click on the link, which displays the additional content. Popup windows
streamline the initial content and allow users to choose whether the want to view the additional content.

To create a popup window, writers first create a link in the original text to the content it should display.
Writers create this link using the link features in their source document application. Then, the writers can
implement the popup window using markers or paragraph styles.

You need to assign popup behavior options to your paragraph and marker styles in your Stationery.
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Using Marker Styles to Create Popup Windows
The default marker styles that define popup windows are Popup, PopupOnly, and PopupEnd. The writer
inserts these markers into the source documents to specify what content to display through the popup
window, and whether the popup content is displayed in only a popup window or in both a popup window
and a clickable link that displays the content in a different topic. Some output formats support displaying
the content only in a popup window.
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Using Paragraph Styles To Create Popup Windows
You can define paragraph styles in your source documents to create popup windows. This approach
avoids the need for markers, but you may need to create more styles in your source document templates.
You can define both marker styles and paragraph styles to create different popup windows in your
content.

To define paragraph styles for popup windows

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the paragraph style you want to define as the first paragraph of a
popup window.

This paragraph style is applied only to the first paragraph of content that should be displayed in
a popup window. If a popup window may contain more than one paragraph of content, you need
to create a second paragraph style and apply it to all paragraphs following the first paragraph that
should be displayed in the popup window.

5. On the Options tab, select the appropriate value for the Popup option, such as Define or Define
with no output. For more information about this option, click Help.

6. Select the paragraph style you want to define as one of the paragraphs of a popup window that
follows the first paragraph of the popup window.

7. On the Options tab, select the appropriate value for the Popup option, such as Append or Append
with no output. For more information about this option, click Help.
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Assigning a Page Style to Popup Windows
If you have popup windows in your content, the appearance of the popup windows matches the rest of
your topic pages, including breadcrumbs and company information. If you want to assign a different page
style to your popup windows, you need to create a new page style and assign it to your popup paragraph
styles.

Note: If you are using marker styles to create popup windows, you cannot use page
styles to control the appearance of your popup windows. This process applies
only to popup windows created with paragraph styles.

To assign a page style to popup windows

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. Create a new page style for popup windows by completing the following steps:

a. In Page Styles, click the New Style button. ePublisher adds a new page style called Untitled.

b. Enter the name for the new page style, such as Popup Windows .

c. On the Properties tab and the Options tab, select the options you want to assign to this page
style.

5. In Paragraph Styles, select your popup paragraph style.

6. On the Options tab, set Popup page style to the page style you created for popup windows, such
as Popup Windows .
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Defining Related Topics
Related topics provide a list of other topics that may be of interest to the user of the current topic.
For example, you could have a section called Creating Web Pages in your help. You may also have
many other topics, such as HTML Tags and Cascading Style Sheets, that relate to creating Web pages.
Identifying these related topics for users can help them find the information they need and identify
additional topics to consider. However, providing these types of links as cross references within the
content itself may not be the most efficient way to present the information.

Related topics and See Also links provide similar capabilities, but there are several important differences:

Related topics can link to headings in a help set that do not start a new page.

Related topics links are static and defined in the source documents as links. You must have all the
source documents to create the link and generate the output.

If a related topics list contains a broken link in the source document, that link is broken in the
generated output. In a See Also link list, the broken link is not included in the output.

You can configure related topics to be displayed in the following ways:

Included as a list in the topic itself.

Displayed in a popup window when the user clicks a button, as shown in the following figure.

Defining Related Topics | 125



Note: If a related topic link is broken in the source document, in most cases that
link is broken in the generated output. WebWorks Help and WebWorks Reverb
provide an additional feature by removing broken links from related topics
lists that are displayed in a popup window when a user clicks the Related
Topics button.
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Using a Paragraph Style for Related Topics Lists
You can use a paragraph style to define a related topics list. Create a unique paragraph style to use
specifically for the related topics list items. The writer should create a list of links in a topic in the source
document, and apply the paragraph style to each list item.

To define a paragraph style for a related topics list

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. In Paragraph Styles, select the paragraph style you want to define as the related topics list. This
paragraph style is applied to all paragraphs in a related topics list.

5. On the Options tab, select the appropriate value for the Related topic option. For more
information about this option, click Help.

To display the list of related topics in the body of the topic, select Define.

To display the list of related topics only when the Related Topics button is clicked, select
Define with no output.

Note: The Show related topics inline button and the Show related topics
toolbar button target settings specify whether to include related topics
buttons and where to include them. If you select Define for your related
topics paragraph style and you enable the Show related topics inline
button setting, both the list of related topics and the related topics button
itself are displayed in the topics with related topics.
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Defining See Also Links
See Also links are associative links (Alinks) that identify other topics that may be of interest to the user
of the current topic. These links use internal identifiers to define the links and the list is built dynamically
based on the topics available when the user displays the links. See Also links are important to use with
larger help sets and merged help sets.

Related topics and See Also links provide similar capabilities, but there are several important differences:

See Also links must link to styles that start a new topic, such as a heading.

See Also links are dynamic and the lists of links are built at display time instead of during help
generation.

Since See Also link lists are dynamically built, they do not include links to topics that are not
available when the user displays the links. If a related topics list contains a broken link in the
source document, that link is broken in the generated output for most output formats.
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Enabling See Also Functionality
If you want to create a See Also link as inline text without a button, create a unique character style and
select the See Also option for that style. If you want to use a button to display the See Also links, create
a unique paragraph style, select the See Also option for that style, and type the See Also text on that
paragraph. The properties you select for the paragraph style in Style Designer affect the text of the See
Also button. To modify the appearance of the button itself, see “Modifying the Appearance of the See
Also Button”. You also need to create a SeeAlsoLink and SeeAlsoKeyword marker.

HTML Help also supports the SeeAlsoLinkDisplayType and SeeAlsoLinkWindowType markers. These
markers allow you to change how the See Also links are displayed in HTML Help. For example, you can
display the links as a popup menu.

Note: If paragraph and marker styles are created in your source document after
you create a project, scan the document in the project again for the changes
to take effect.

To enable See Also functionality in your Stationery

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. On the Project menu, click a target in the Active Target menu option that is an output format that
supports this option.

4. If you want to use buttons for See Also links, complete the following steps:

a. In Paragraph Styles, select the paragraph style to use for See Also links.

b. On the Options tab, set See Also to Enabled.

5. If you want to use inline text for See Also links, complete the following steps:

a. In Character Styles, select the character style to use for See Also links.

b. On the Options tab, set See Also to Enabled.

6. In Marker Styles, select the SeeAlsoKeyword marker style.

7. On the Options tab, set Marker type to See Also Keywords.

8. In Marker Styles, select the SeeAlsoLink marker style.

9. On the Options tab, set Marker type to See Also Link Keywords.
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Modifying the Appearance of the See Also Button
The properties you select for the paragraph style in Style Designer affect the text of the See Also button.
In some output formats, you can modify the color of the See Also button background and borders. You
must separately modify each button border. You can also modify each of the See Also button colors.

Note: To change the color of the See Also button, you modify the content.xsl  file. If
you modify the content.xsl file, you will be responsible for maintaining your
customizations to the file as needed each time you update your Stationery to
work with a new version of ePublisher.

For more information about override files and locations, see “Stationery, Projects, and Overrides”.

To change the color of the See Also button

1. If you want to override the processing for an output format, complete the following steps:

a. In your Stationery design project, on the View menu, click Format Override Directory.

b. Create the Formats\formattype\Transforms  folder in your project folder, where
formattype is the name of the output format you want to override, such as WebWorks Help
5.0 .

2. If you want to override the processing for a target, complete the following steps:

a. In your Stationery design project, on the View menu, click Target Override Directory.

b. Create the Targets\targetname\Transforms  folder in your project folder, where
targetname is the name of the target you want to override.

3. Copy the content.xsl  file from the following folder to the override folder you created within
your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\formattype\Transforms

4. Open the content.xsl  file you copied to your project override folder.

5. Find the following code section.

<html:table border="0" cellspacing="0" cellpadding="0" onclick="{$VarCargo/

wwalinks:ALink[1]/@onClick}" summary="">

 <html:tr>

  <html:td height="2" colspan="4" bgcolor="#FFFFFF"></html:td>

  <html:td width="2" height="2" background="{$Var_seertup}"></html:td>

 </html:tr>

 <html:tr>

  <html:td width="2" height="2" bgcolor="#FFFFFF"></html:td>
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  <html:td height="2" colspan="3" bgcolor="#EEEEEE"></html:td>

  <html:td width="2" height="2" background="{$Var_seeright}"></html:td>

 </html:tr>

...

6. Modify the RGB color values in the bgcolor  attributes within this table to adjust the colors of the
margins that form parts of the See Also button.

7. Save the content.xsl  file.

8. Regenerate your project to review the changes.
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Define the Default Settings for Each Target
You can have one or more output formats in your Stationery. You can also define multiple targets in
your Stationery. The Stationery Designer properties and options are shared across all targets and output
formats. Some settings, such as the target settings, variable values, conditions, and cross-reference
formats, are defined per target. Some targets and output formats also offer additional features and
customizations.

For each target in your Stationery, define the following default settings in your Stationery. If a writer
installs the support with ePublisher Express, that writer can modify these settings in each project based on
the Stationery:

Target settings, such as the company information and navigation on each page. To specify the target
settings for a target, select the target, and then click Target Settings on the Target menu. For more
information about a setting, click Help.

Index settings. For more information, see “Defining the Default Index Settings”.

Variable values. For more information, see “Defining the Default Processing of Variables”.

Condition visibility. For more information, see “Defining the Default Processing of Conditions”.

Cross Reference formats and rules. For more information, see “Defining the Default Processing of
Cross References”.

PDF integration. For more information, see “Defining Default PDF Generation Settings”.

Output format-specific customizations and features. For more information, see “Customizing
Stationery for Output Format-Specific Features”.

Reporting options, such as accessibility reporting. For more information, see “Defining the
Accessibility Report to Validate Content” and “Defining Other Reporting Options”.
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Defining the Default Index Settings
The index provides the user with a point-and-click resource for quickly navigating your online content.
ePublisher generates the index by default for the available formats, using the native indexing features of
the source document tool used to create the printed index.

The groups and order of index entries in your online index are determined through index entries defined
in the source document, the locales.xml  file in the ePublisher installation folder, and the output format
display environment. The locales.xml  file also defines the text that identifies See  and See also  style
entries in your index. For more information about customizing the index appearance, see “Modifying the
Appearance of the Index in Dynamic HTML”.

Depending on your output format, you can specify the file name for the generated index whether to
generate the index. With the power of many full-text search engines, you may choose not to include an
index in your generated output.

Note: If you selected the WebWorks Help or WebWorks Reverb output format,
you must generate an index with the given file name. These options are
predefined and cannot be changed.

To enable index generation in your online content

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Set Generate index to Enabled.

4. If you want to change your index file name and your output format supports it, specify the new
file name in Index filename.

Defining the Default Index Sengs | 133



Defining the Default Processing of Variables
A variable provides a placeholder for standard terms and for names that may change. By defining
variables in your source documents, you have global control over the values contained within those
variables. For example, you can create a variable for the copyright date of your documentation. You can
then use that variable as needed in your content. Each year when you need to update the copyright, you
can change the variable value in a single location instead of using the search and replace method through
your documents.

In your project, you can specify the value of any variable. When you change the value of a variable in
your project, it changes the value only in your generated output. The variable value is not changed in your
source documents. You can also use the value of the variable defined in your source documents. To use
the value defined in a source document for a variable, select Use Document Value for that variable.

To specify a variable value

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Variables.

3. Find the variable you want to modify.

4. In the Value column, select its current definition and make the desired changes, or select Use
Document Value.

134 | Defining the Default Processing of Variables



Defining the Default Processing of Conditions
In your source documents, you can define conditions and use them to show or hide parts of your content.
ePublisher allows you to define the visibility for each condition in your project. The conditions that are
available in your project come directly from your source documents. You can modify the value for any of
your conditions, which affects how your conditional text is incorporated into your generated output. You
can also select passthrough for a condition to insert the content directly into your output without being
transformed and coded for your output format. This option allows you to directly add HTML coding or
multimedia files to your output.

Note: You can also use PassThrough markers and the Pass Through paragraph style
and character style options to insert content directionly into your output
without being transformed and coded for your output.

To modify the value of a condition

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Conditions.

3. Find the condition you want to modify.

4. In the Value column, select the visibility option you want to use for that condition.
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Defining the Default Processing of Cross References
Cross-references help users navigate through your content. ePublisher automatically transforms cross-
references to links in the generated output. However, you often want cross-references in your online
content to use a different format than your printed content. For example, you usually include page
numbers only in your printed content. ePublisher enables you to add, edit, and delete cross-reference
formats for your online output.

Note: This option is available only for specific source document types and each
defined cross reference rule applies only to the selected source document
type.

To define and manage cross-reference formats

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Cross Reference Rules.

3. In Document type, select the source document type for which you want to define the cross-
references.

4. If you want to add a cross reference format, complete the following steps:

a. Click Add New Cross Reference.

b. In Name, type the format or name of the cross reference format you want to define. For
example, to remove the phrase see page  followed by a page number from a Word source
document, type: see page {PAGEREF \h} . You can find the correct syntax for the search
pattern by inspecting your source documents for the values.

c. In Replacement, type the format or text you want to replace the format you specified in
Name. To replace the format with nothing, leave the Replacement field blank.

d. Click OK.

5. If you want to modify a defined cross-reference format, complete the following steps:

a. Double-click an existing cross-reference format you want to modify.

b. In Replacement, type the format or text you want to replace the format you specified in
Name. To replace the format with nothing, leave the Replacement field blank.

c. Click OK.

6. If you want to change the order in which ePublisher processes the cross-reference formats,
select a cross reference rule in the list, and then use the arrow buttons to arrange the formats from
top to bottom in the order you want ePublisher to process them:

7. If you want to delete a defined cross-reference format, select the cross reference rule in the list,
and then click Delete Cross Reference:

8. Click OK to close the Cross Reference Rules window.
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Defining Default PDF Generation Settings
ePublisher provides PDF options that enable you to generate a PDF file for each source document or to
generate a PDF file for each top-level group in a project. If you generate a PDF for each top-level group,
ePublisher combines all the source documents within a single top-level group, and then generates a single
PDF file for those documents.

You can deliver the PDF files separate from your help system, or in some output formats you can add a
PDF button to your toolbar that displays the PDF files in the window. The PDF file displayed when the
user clicks the PDF button depends on which PDF generation options you chose in your project. If you
have selected to:

Generate PDF files only for the top-level groups, the window displays the PDF file for the top-level
group in which the currently viewed topic is located when the user clicks the PDF button.

Generate PDF files only for each source document, the window displays the PDF file for the source
document in which the currently viewed topic is located when the user clicks the PDF button.

Generate PDF files for all source documents and for all top-level groups, the window displays the
PDF file for the source document in which the currently viewed topic is located when the user
clicks the PDF button.

To specify the PDF file generation settings and enable the PDF toolbar button

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. If you want to generate a PDF file for each source document, set Generate a PDF per
document to Enabled.

4. If you want to generate a PDF file for each top-level group of source documents, set Generate a
PDF per top level group to Enabled.

5. Set Show PDF button to Enabled.

6. Click OK.
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Defining the Accessibility Report to Validate Content
Content that must be accessed by people with disabilities must conform to guidelines published by both
the W3C and the United States government. These guidelines are intended to help authors produce
accessible content. ePublisher helps you produce online content that conforms to the W3C Web Content
Accessibility Guidelines 1.0 (WCAG), Section 508 of the U.S. Rehabilitation Act of 1998, and the
Americans with Disabilities Act (ADA).

If you take certain steps in creating your source documents and setting up your project, your generated
output is accessible through assistive technologies such as screen readers. When you generate your
project, ePublisher can perform several checks to verify that you embedded information and conform to
the accessibility standard in these areas:

Alternate text for all images (ImageAltText marker)

Alternate text for clickable regions in all image maps (ImageAreaAltText marker)

Long descriptions for all images (ImageLongDescText and ImageLongDescByRef markers)

Summaries for all tables (TableSummary marker)

Note: ePublisher does not check to ensure that you have provided expansion
text for abbreviations or acronyms nor does it verify that you have
included citation markers for quotations. You can use the AbbreviationTitle,
AcronymTitle, and Citation markers to add this information to your content.

For more information about producing accessible content, and to check your content further for
compliance, see the following Web sites:

www.w3c.org/TR/WCAG10-CORE-TECHS

www.w3.org/WAI

www.w3.org/WAI/Policy/

ePublisher does not perform accessibility validation by default. You must enable accessibility validation
of the content. ePublisher validates that all images and image maps have alternate text, all images have
long descriptions, and all tables have summaries. You can choose which accessibility validation checks
you want ePublisher to run.

Note: If you disable any of the accessibility validation checks, you cannot consider
your content to be accessible or Section 508 compliant.

To define the accessibility report that validates online content for accessibility compliance

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Set Generate accessibility report to Enabled.

138 | Defining the Accessibility Report to Validate Content

http://www.w3c.org/TR/WCAG10-CORE-TECHS
http://www.w3.org/WAI
http://www.w3.org/WAI/Policy/


4. If you want to exclude the alternate text check for images, disable Validate accessibility image
alternate tags.

5. If you want to exclude the alternate text check for image maps, disable Validate accessibility
image map alternate tags.

6. If you want to exclude the long description check for images, disable Validate accessibility
image long descriptions.

7. If you want to exclude the summary check for tables, disable Validate accessibility table
summaries.

When a project based on this Stationery is generated, the accessibility report is created with the
information you selected to include in that report.
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Defining Other Reporting Options
In addition to the accessibility reporting features, ePublisher provides reports to help you identify and
resolve potential transformation issues. You can define which conditions are informational messages,
warnings, or errors. Errors force ePublisher AutoMap to return a non-zero return code and stops the
output deployment process.

To define the other report options

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Review and define the settings for the following categories of report settings:

Filenames Report

Links Report

Styles Report

Topics Report

4. Click OK.
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Saving and Testing Stationery
Once you have defined your Stationery design project, you need to save and test the Stationery. This
process allows you to adjust the Stationery as needed before further customizing your design and
deploying the Stationery for use.

Note: Document-specific information, such as groups, documents, and changes
made with Document Designer, are not saved in Stationery files.

When you save the Stationery design project as Stationery, ePublisher stores all the style information,
settings, and definitions from the project in the Stationery. ePublisher also copies the user, output format,
and format target override files, and saves them as part of your Stationery.

To save your Stationery design project as Stationery and test it

1. Open your Stationery design project.

2. On the File menu, click Save as Stationery.

3. Specify the Stationery name, location to store the Stationery, and the targets to include in the
Stationery. For more information about an option, click Help.

4. Click OK.

5. Close ePublisher Designer.

6. Open ePublisher Express.

7. On the File menu, click New Project.

8. Specify the project name and the location to store the project.

9. In Stationery, specify your Stationery file, and then click Next.

10. Add your standard sample source document to the project, and then click Finish. For more
information about an option, click Help.

11. On the Project menu, click Scan All Documents.

12. On the Project menu, select the active target you want to test.

13. On the Project menu, click Generate All.

14. Review the generated output.

15. Repeat steps 12-14 for each target in your project.

Once you finish customizing your Stationery, store it in a central location where writers can use it. If you
move the Stationery, ePublisher Express notifies the writers when they open their projects that it cannot
find the Stationery associated with the project. The writers then need to update their projects to use the
Stationery in its new location.
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Backing Up Your Stationery Design Project, Stationery, and Projects
You should save a backup copy of your Stationery design project, your Stationery, and any individual
projects you have. These snapshots can help you revert your project to a specific stage at a point in time.
This snapshot can also help you if your project or Stationery become corrupted or lost.
 

Element to Back Up Description of Process and Considerations

Stationery design project Copy all your sample files, the .wep  file, and the Files , Formats , and
Targets  folders and subfolders. Maintain the same structure of these files
and folders.

Stationery You can create a .zip  file of your Stationery to back it up. If needed, you can
also recreate your Stationery from your Stationery design project. Copy the
.wxsp  file, the .manifest  file, and the Files , Formats , and Targets
folders and subfolders. Maintain the same structure of these files and folders.

Individual project To recreate your generated output, you need the source documents, the
Stationery you used, and your individual project file. Copy your source
documents and the .wrp  file. Maintain the same structure of your source
files and the .wrp  file.
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Deploying Stationery
Once you have saved, tested, and finished customizing your Stationery, you need to deploy it so writers
can use the Stationery for their projects. Review the following considerations when deploying your
Stationery for writers to use in their projects:

Store your Stationery in a central location where writers have read access.

When you save the Stationery design project as Stationery, ePublisher stores all the style
information, settings, and definitions from the project in the Stationery. ePublisher also copies the
user, output format, and format target override files, and saves them as part of your Stationery.

If you move the Stationery, ePublisher Express notifies the writers when they open their projects
that it cannot find the Stationery associated with the project. The writers then need to update their
projects to use the Stationery in its new location.

Make sure your source document templates and standards support your Stationery. Keep these
files updated as a unit. If you add a style to your Word or FrameMaker template, also add it to your
Stationery design project and update your Stationery.

If the source documents for an existing project use only the styles in your standard templates,
writers can use ePublisher Express to synchronize their project with your Stationery. This process
allows you to update the project using the current Stationery for the project, or you can select a
different Stationery to associate with the project.

Schedule a training session with the team about each of the features they can use in their help, how
to use styles and markers to define those features, and how to use ePublisher Express and their
projects to achieve the results they need.

Make sure your Stationery has the output formats and targets you need. Since all output formats
in the Stationery share Style Designer properties and options, if you want different output formats
to have different behaviors or appearance, you may need to create and maintain more than one
Stationery.

Determine whether writers should change target-specific settings, such as variables, conditions,
cross reference rules, and target settings in their projects. When writers install ePublisher Express,
they can specify whether to enable these menu options.

To save your Stationery design project as Stationery

1. Open your Stationery design project.

2. On the File menu, click Save as Stationery.

3. Specify the Stationery name, location to store the Stationery, and the targets to include in the
Stationery. For more information about an option, click Help.

4. Click OK.
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Managing and Updating Stationery
Once you deploy your Stationery, manage its use to make sure it continues to meet your needs. Your
source document templates and standards can change over time. Make sure your source document
templates support your Stationery and keep these files updated as a unit. If you add a style to your Word
or FrameMaker template, also add it to your Stationery design project and update your Stationery.

You may also decide to add a feature to your output, such as expand/collapse sections or popup windows.
To add a feature, you may need to make changes to both your source document templates and your
Stationery. Then, you need to put together a deployment or roll-out plan to help writers decide when and
how each project should use the features.

If you move or change the Stationery, ePublisher Express notifies the writers when they open their
projects. The writers have the opportunity to synchronize their projects with the Stationery and bring
their projects inline with your new standards. For more information, see “Synchronizing Projects with
Stationery”.

Be careful when you update your Stationery to make sure you have the files you need. Review the
following considerations for properly maintaining your Stationery:

Store your Stationery design project and supporting files in a version control system. This process
allows you to monitor how it changes over time and ensures you can return to a previous version, if
needed.

Create a subfolder in your Stationery design project and store a sample of each source document
type in that folder. These files help you test and verify the output as you modify your source
document styles and your ePublisher styles and settings.

Do not directly open and modify the Stationery files. To make sure your Stationery is properly
updated, always open the Stationery design project for the Stationery, make your changes, and then
save a new copy of the Stationery.

Consider saving your updated project as Stationery to a new location and have several writers
test some smaller projects with the updated Stationery before you update your Stationery for all
projects.

When you save your Stationery, ePublisher creates the following folders that contain information about
any customizations or overrides you created when you developed the Stationery:

StationeryName\Formats\OutputFormat

StationeryName\Formats\OutputFormat.base

where StationeryName is the name you specified for the Stationery, and OutputFormat is the type of
output format you specified for a target in the Stationery. You can use these folders to help you identify
any customizations or overrides you specified for your Stationery when updating your Stationery.

The StationeryName\Formats\OutputFormat folder contains any customizations or overrides
you specified when designing the Stationery. ePublisher Express synchronizes with the files in the
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OutputFormat folder and uses the information about customizations and overrides contained in files in
the OutputFormat folder to generate output.

Note: The Stationery may have one or more OutputFormat folders, based on the
settings you specified in your Stationery.

The StationeryName\Formats\OutputFormat.base  folder contains copies of all the files located in the
\Program Files\WebWorks\ePublisher\2023.1\Formats\OutputFormat folder. These files define the
default output format and transforms and are installed by default when you install ePublisher.

You can do a compare, or diff, between the files located in these folders to quickly see any customizations
or overrides specified for the Stationery. You can use this information to help you reapply customizations
and overrides as needed when designing a newer version of the Stationery in ePublisher Designer.

To update your Stationery

1. Open your Stationery design project.

2. Make the desired changes.

3. On the File menu, click Save as Stationery.

4. Specify the Stationery name, location to store the Stationery, and the targets to include in the
Stationery. To replace the existing Stationery, specify the same name and values as the existing
Stationery. You do not have to replace the existing Stationery. You can also create a new Stationery
with a different name, such as by adding a version number to the Stationery name.

5. Click OK.
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Target Settings Reference

Accessibility Settings
Accessibility Report Settings
Analytics Settings
Baggage Files Settings
Baggage Files Report Settings
Company Information Settings
Conditions Report Settings
Cover Settings (eBook - ePUB 2.0)
Eclipse Settings
ePUB Settings (eBook - ePUB 2.0)
File Processing Settings
Filenames Report Settings
Files Settings
Footer Settings
Header Settings
HTML Help Settings
Images Report Settings
Index Settings
JavaHelp Settings
Links Settings
Links Report Settings
Locale Settings
Menu Settings
Oracle Help Settings
Page Settings
PDF Settings
Result Options Settings (PDF - XSL-FO)
Search Settings
Social Settings
Styles Settings (PDF - XSL-FO)
Styles Report Settings
Table of Contents Settings
Title Page Settings (PDF - XSL-FO)
Toolbar Settings
Topics Report Settings
WebWorks Help Settings
WebWorks Reverb Settings
WebWorks Reverb 2.0 Settings

In ePublisher, each output format has a set of configurable target settings that allow features of that
format to be enabled, disabled, or specified from a fixed set of values or even user provided values. Some
settings are specific to one or more output formats. The following are all of the possible target settings
that an output format may have.

Use this section to find and learn more about target settings available in your format. The Target Settings
window for a particular output format will list only settings that are available for that format.
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Accessibility Settings
These settings are not supported in PDF output formats. The settings in this category are defined as
follows:

Add link to skip navigation content
Specifies whether you want screen readers to skip over top-level navigation content on a page,
such as breadcrumbs, previous and next buttons, and company information. If you enable this
setting, when a screen reader reads the content on the page, the screen reader skips over the top-
level navigation content and begins reading the page where the page content begins. This setting
is supported in Dynamic HTML, Eclipse Help, Microsoft HTML Help, Oracle Help, and XML +
XSL, output formats.

Include visible [D] links to images with long descriptions
Specifies whether you want to include a link labeled [D] beside any image for which you provide a
long description. When users click the [D] link, the link takes the user to a long description of the
text. Because the [D] link is a standard hyperlink, it can be processed correctly by browsers and
screen readers. This setting is supported in Microsoft HTML Help, WebWorks Help, Oracle Help,
Dynamic HTML, and XML+XSL output formats.
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Accessibility Report Settings
The settings in this category are defined as follows:

Generate accessibility report
Specifies whether to generate Accessibility reports.

Image links without alternative text
Specifies the notification to receive if any image maps do not have alternative text.

Images without alternative text
Specifies the notification to receive if an image does not have alternate text.

Images without long descriptions
Specifies the notification to receive if an image does not have a long description.

Tables without summaries
Specifies the notification to receive if a table does not have a summary.
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Analytics Settings
These settings apply only to the WebWorks Reverb output format. This allows for better tracking of how
users are using your help system via Google Analytics. For more information on how Google Analytics is
used please refer to the following webpage: http://www.google.com/support/googleanalytics/.

Google Default URL
If a default URL is specified, analytics events will only be captured when the online help files are
hosted from this specified URL.Specifying this setting is useful to prevent analytic events from
being logged during testing from the file system or a test web server.

Google Tracking ID
Enables the use of Google Analytics to measure page activity. Requires that your end-users have a
connection to the Internet so that Google’s tracking urchin can be loaded within their browser when
a page is viewed or an event is captured. If this value is empty, then no analytics tracking will be
enabled.

Page “Was This Helpful?” Buttons
The Page Was This Helpful Buttons provide your end-users with the ability to provide feedback
using analytics events to anonymously record their experience with the current page being viewed.
The name of the page will be recorded along with the end-user’s feedback about the page’s
usefulness. A Google Tracking ID is required for these buttons to be in operation.

Search “Was This Helpful?” Buttons
The Search Was This Helpful Buttons provide your end-users with the ability to provide
feedback using analytics events to anonymously record their experience with the current search
results from a given search query. The search term(s) will be recorded along with the end-user’s
feedback about the search results’ usefulness. A Google Tracking ID is required for these buttons to
be in operation.
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Baggage Files Settings
These settings are only supported in the WebWorks Reverb output format. The settings in this category
are defined as follows:

Baggage files info list
Specifies the path (absolute or relative to the project) to the baggage files info list containing
information related to the baggage files, like title and summary, as well as determining when not to
index a baggage file.

Copy baggage file dependents
Specifies whether you want to include in your output all the dependents of your HTML baggage
files, such as images, CSS files, JS files, videos and audios.

Index baggage files
Specifies whether you want to index baggage files linked to by your source documents.

Index external links
Specifies whether you want to index external links and include those words in the corresponding
index file.
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Baggage Files Report Settings
The settings in this category are defined as follows:

Baggage files without summary
Specifies the notification to receive when baggage files without a summary are found.

Baggage files without title
Specifies the notification to receive when baggage files without a title are found.

Generate baggage files report
Specify whether to generate baggage files report.
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Company Information Settings
The settings in this category are defined as follows:

Company copyright
Specifies company copyright text.

Company email address
Specifies the email address to display for the company in your output. By default, ePublisher
displays this email address as a link using the mailto  command.

Company fax number
Specifies the fax number to display for the company in your output.

Company logo image
Specifies the image to display for the company logo in your output. Store the image file in the
Files  folder within your project. If you want to use a company logo image in your generated
output, press F12 to open the Files  folder and verify that the folder contains the company logo
image you want to use in your generated output.

Company name
Specifies the company name to display in your output. If you specify a company URL in the
Company web page setting, ePublisher displays the company name as a link to the specified URL.

Company phone number
Specifies the company phone number to display in your output.

Company web page
Specifies the company web page URL address. Specify the complete URL, including the prefix,
such as http://www.webworks.com. If you specify this value, ePublisher displays the company
name specified in the Company name setting as a link to the specified URL.
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Conditions Report Settings
The settings in this category are defined as follows:

Generate conditions report
Specify whether to generate Conditions report.

Unknown conditions
Specifies the notification to receive if a condition is encountered that was not defined in the project
being generated.
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Cover Settings (eBook - ePUB 2.0)
These settings apply only to the eBook - ePUB 2.0 output format. The settings in this category are defined
as follows:

Cover page file name
Specifies the name of the file that ePublisher generates for the eBook cover page.

Cover page image
Specifies the image to display on your cover page in your output. Store the image file in the Files
folder within your project. If you want to use an image on your cover page in the generated output,
press F12 to open the Files  folder and verify that the folder contains the cover page image you
want to use in your generated output.

Cover page style
Specifies the ePublisher page style to use for generating the cover page.
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Eclipse Settings
These settings apply only to the Eclipse Help output format. The settings in this category are defined as
follows:

Eclipse Help ID prefix
Specifies the prefix for ePublisher to use when creating the Eclipse Help .jar  file. By default, this
value is set to com.webworks.eclipsehelp , and by default when ePublisher generates Eclipse
Help, ePublisher names the Eclipse Help .jar file com.webworks.eclipsehelp.ProjectName,
where ProjectName is the name of your ePublisher project.

Eclipse Help vendor
Specifies the setting to use for the Vendor parameter in the Eclipse Help Content Plugin manifest
file. By default, this value is set to WEBWORKS.

JDK location
Specifies the location of the Java Development Kit (JDK) used by ePublisher when generating
Eclipse Help system. By default, ePublisher auto-detects and uses the most recent version of the
JDK on the computer where you generate output. Use this field if you have a specific version of the
JDK that you want ePublisher to use when generating Eclipse Help for the specified target.

Manifest bundle version
Specifies the version identifier for the manifest. Defaults to 1.0.0, but can be changed to between
updates of your Eclipse Help deliveries.
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ePUB Settings (eBook - ePUB 2.0)
These settings apply only to the eBook - ePUB 2.0 output format. The settings in this category are defined
as follows:

Author name
Specifies author name metadata value of the generated eBook.

Author name (file as)
Specifies an alternate value for the author name that is used when sorting multiple eBooks
displayed together.
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File Processing Settings
File processing settings define how ePublisher processes front matter, index, and table of contents files. If
you use ePublisher to generate output from Microsoft Word source documents, these settings are related
to the RD field behavior settings you configure for the project on the Input Configurations tab on the
Project Settings window. ePublisher does not use these settings when generating output from DITA-XML
source documents.

The settings in this category are defined as follows:

File processing behavior for front matter
Specifies whether you want to generate output for front matter included in your source documents.
Front matter is all of the content before the table of contents. For example, in Adobe FrameMaker
this setting allows you to use an Adobe FrameMaker .book  file to generate output without
generating output for the front matter included in the Adobe FrameMaker .book  file.

File processing behavior for index files
Specifies whether you want to generate output for index files included in your source documents.
For example, in Adobe FrameMaker this setting allows you to use an Adobe FrameMaker .book
file to generate output without generating output for a generated index (IX) .fm  file included in the
Adobe FrameMaker .book  file.

File processing behavior for TOC files
Specifies whether you want to generate output for table of contents files included in your
source documents. For example, in Adobe FrameMaker this setting allows you to use an Adobe
FrameMaker .book  file to generate output without generating output for a generated table of
contents (TOC) .fm  file included in the Adobe FrameMaker .book  file.

Insert Mark of the Web (MOTW)
Enables the MOTW in the HTML content, used to get rid of the “blocked content message in
Internet Explorer.

Pretty Print
Enables the generation of HTML that is more easily human readable by inserting appropriate white
space and end-of-line characters. By default this setting is disabled to produce smaller file sizes.
Changing this setting should have no noticeable affect on the appearance of your content when
rendered within an HTML browser.
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Filenames Report Settings
The settings in this category are defined as follows:

File named by marker
Specifies the notification to receive if ePublisher created a file using a Filename marker.

Filename marker collision with existing filenames
Specifies the notification to receive if ePublisher detects duplicate Filename markers in the source
documents used by your project to generate output.

Filename marker ignored
Specifies the notification to receive if ePublisher ignored a file name in your source document.

Generate filenames report
Specifies whether to generate Filenames reports.

158 | Filenames Report Sengs



Files Settings
The settings in this category are defined as follows:

Convert name to
Specifies the file naming case you want ePublisher to use when generating output files.

By default, ePublisher uses the Normal value when specifying file naming case.

The values for this setting are defined as follows:
 

Value Description

Normal Keeps the naming with the created case.

Lower case Converts the names to lower case.

Upper case Converts the names to UPPER CASE.

Camel case Converts the names to camel Case.

Pascal case Converts the names to Pascal Case.

For example, with this setting set to Normal, file names display as Great publishing
tool.html . With this setting set to Camel case, when you generate output file names display as
great Publishing Tool.html . With this setting set to Pascal case, when you generate output
file names display as Great Publishing Tool.html . With this setting set to Upper case, when
you generate output file names display as GREAT PUBLISHING TOOL.html . With this setting set to
Lower case, when you generate output file names display as great publishing tool.html .

Graphic naming pattern
Specifies the file naming pattern you want ePublisher to use when generating output files for
images.

ePublisher preserves the original file names for images imported by reference. If images are
inserted directly into a source document, or if ePublisher cannot process the image by reference,
then ePublisher assigns a file name using a graphic naming pattern.

By default, ePublisher uses the following values when specifying the image naming pattern:

$D;.$DN;.$PN;$.GN

This specifies that ePublisher name the files using the following syntax when it generates output:

SourceDocumentName.SourceDocumentNumber.TopicNumber.ImageNumber
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where SourceDocumentName is the name of the source document, SourceDocumentNumber is
the number that identifies the position of the source document in the project, TopicNumber is the
number of the topic (output page) in the source document, and ImageNumber is the number of the
image in the source document.

The values for this setting are defined as follows:

Note: Each value you specify must begin with a dollar sign ($ ) character and end with a semicolon
(; ) character. Inserting a period (. ) character immediately before the value specifies that
ePublisher use a period to separate the values when generating output.

S

Value Description

$P; Includes the name of the project in the file name.

$T; Includes the name of the target in the file name.

$G; Includes the name of the group in Document Manager that
contains the file name.

$C; Includes the project to project linking context value of the group
in the file name. WebWorks Help uses the context value when
generating merged, or multivolume help that includes context-
sensitive help. In WebWorks Help, you need to include this
context and the TopicAlias value in the help call to display the
correct help topic. For more information, see “Merging Top-level
Groups (Multivolume Help)” and “Opening Context-Sensitive Help
in WebWorks Help using Standard URLs”.

$H; Includes the heading text or title of the topic in the file name.

$D; Includes the name of the source document that the topic came
from in the file name.

$DN; Includes the source document number in the file name. The
source document number is the number that identifies the position
of the source document in the project.

$PN; Includes the page number in the file name. The page number
is the number of the page that the topic is on in the source
document.

$GN; Includes the graphic number in the file name. The graphic number
is the sequential number of the graphic in the generated output
and it is based on the position of the graphic in the generated
output.For example, if you have five images in the generated
output and you use this setting, the page with you first image has
the number 1 in the file name, and the page with your fifth image
has the number 5 in the file name.

160 | Files Sengs



Page break handling
Specifies how ePublisher processes the Page break priority value the Stationery designer specifies
in Style Designer for each paragraph style. For example, if you set the Page break handling
format setting to Always, all paragraph styles with the Page break priority set greater than 0 will
create a new page. The default value is Combine. The values for this setting are defined as follows:

 

Value Description

Never Ignores all Page break priority values specified in the Stationery.

Always Creates a new page for all paragraph styles with a Page break
priority value greater than 0.

Combine Creates a new page for all paragraph styles with a Page break
priority value greater than 0 unless the previous paragraph
created a new page and the Page break priority value for
the previous paragraph is a number less than the Page break
priority value for this paragraph.

If not previous Creates a new page for all paragraph styles with a Page break
priority value greater than 0 unless the previous paragraph
created a new page.

Page naming pattern
Specifies the file naming pattern you want ePublisher to use when generating output pages for
topics. By default, ePublisher uses the following values when specifying the page naming pattern:

$D;.$DN;.$PN

This specifies that ePublisher name the files using the following syntax when it generates output:

SourceDocumentName.SourceDocumentNumber.TopicNumber

where SourceDocumentName is the name of the source document, SourceDocumentNumber is the
number that identifies the position of the source document in the project, and TopicNumber is the
number of the topic (output page) in the source document.

The values for this setting are defined as follows:

Note: Each value you specify must begin with a dollar sign ($ ) character and end with a semicolon
(; ) character. Inserting a period (. ) character immediately before the value specifies that
ePublisher use a period to separate the values when generating output.

 

Value Description

$P; Includes the name of the project in the file name.
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Value Description

$T; Includes the name of the target in the file name.

$G; Includes the name of the group in Document Manager that
contains the file name.

$C; Includes the project to project linking context value of the group
in the file name. WebWorks Help uses the context value when
generating merged, or multivolume help that includes context-
sensitive help. In WebWorks Help, you need to include this
context and the TopicAlias value in the help call to display the
correct help topic. For more information, see “Merging Top-level
Groups (Multivolume Help)” and “Opening Context-Sensitive Help
in WebWorks Help using Standard URLs”.

$H; Includes the heading text or title of the topic in the file name.

$D; Includes the name of the source document that the topic came
from in the file name.

$DN; Includes the source document number in the file name. The
source document number is the number that identifies the position
of the source document in the project.

$PN; Includes the page number in the file name. The page number
is the number of the page that the topic is on in the source
document.

Replace spaces
Specifies if you want ePublisher to replace spaces in file names with the string defined in the
setting Replace spaces with when generating output. For example, with this setting Disabled,
file names with spaces would generate to Word1 Word2.html . With this setting Enabled, and the
Replace spaces with setting set to value _, the file name would generate to Word1_Word2.html .

Replace spaces in group names
Specifies if you want ePublisher to replace spaces in group derived file paths with the value defined
in the setting Replace spaces with. For example, with this setting Disabled, group derived file
names with spaces would generate to My Group Name.html . With this setting Enabled, and the
Replace spaces with setting set to value _, the file name would generate to My_Group_Name.html .

Replace spaces with
Specifies the value ePublisher will use to replace spaces in generated file names. There are
predetermined values you can use, but you really can use any string allowed by the file system for a
file name. For example, with this setting set to No space, and if the file name was originally Word1
Word2.html , then the new name would generate to Word1Word2.html .

By default, ePublisher uses the underscore (_) value for this setting.

The predetermined values for this setting are defined as follows:
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Value Description

_ Replaces spaces with the underscore character (default).

- Replaces spaces with the hyphen character.

No space Replaces spaces with the empty character (removes spaces).

Ignore Ignores this setting.

Note: This values will only be used if Replace spaces and/or Replace spaces in group names are
Enabled.

 

Table naming pattern
Specifies the file naming pattern you want ePublisher to use when generating output pages that
contain tables in MoinMoin. By default, ePublisher uses the following values when specifying the
file naming pattern for MoinMoin pages that contain tables:

$D;.$DN;.$PN;.TN

This specifies that ePublisher name the files that contain tables using the following syntax when it
generates output:

SourceDocumentName.SourceDocumentNumber.TopicNumber.TableNumber

where SourceDocumentName is the name of the source document, SourceDocumentNumber is
the number that identifies the position of the source document in the project, TopicNumber is the
number of the topic (output page) in the source document, and TableNumber is the number of the
table in the source document.

Note: Inserting a period (.) character immediately before the value specifies that ePublisher use a
period to separate the values when generating output.

The values for this setting are defined as follows:

Note: Separate values with a semicolon (;) character.
 

Value Description

$P; Includes the name of the project in the file name.

$T; Includes the name of the target in the file name.

$G; Includes the name of the group in Document Manager that
contains the file name.

Files Sengs | 163



Value Description

$C; Includes the project to project linking context value of the group
in the file name. WebWorks Help uses the context value when
generating merged, or multivolume help that includes context-
sensitive help. In WebWorks Help, you need to include this
context and the TopicAlias value in the help call to display the
correct help topic. For more information, see “Merging Top-level
Groups (Multivolume Help)” and “Opening Context-Sensitive Help
in WebWorks Help using Standard URLs”.

$H; Includes the heading text or title of the topic in the file name.

$D; Includes the name of the source document that the topic came
from in the file name.

$DN; Includes the source document number in the file name. The
source document number is the number that identifies the position
of the source document in the project.

$PN; Includes the page number in the file name. The page number
is the number of the page that the topic is on in the source
document.

$TN; Includes the table number in the file name. The table number is
the sequential number of the table in the generated output and it
is based on the position of the table in the generated output. For
example, if you have five tables in the generated output and you
use this setting, the page with your first table has the number 1 in
the file name, and the page with your fifth table has the number 5
in the file name.
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Footer Settings
Allows a footer to be displayed across the bottom of the help system. Typically this area is reserved
for company information and logos. Some footer settings are provided that work with the Company
Information settings and are dependent on them being set.

The settings in this category are defined as follows:

Footer location
Specifies footer location. Choices range from displaying the footer across the entire bottom of the
help system to just along the bottom of the content page.

Footer logo
Specifies a footer logo to be displayed. This logo gets its value from the Company name or
Company logo image.

Footer logo link address
Specifies footer logo link address. Link address can inherit from the home page (splash page or
first page in help set) or the Company webpage. In order for this setting to be displayed in the
output, the target setting: Linked footer logo must be enabled.

Footer logo override
Specifies which image to use as the footer logo. This setting will override the Footer logo setting.
Choose from the image files stored in the Files  folder within your project.

Generate footer
Specifies whether to generate footer.

Linked footer logo
Enables the Footer logo link address to be displayed.
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Header Settings
Allows a header to be displayed across the top of the web page above the Reverb toolbar. Typically this
area is reserved for company information and logos. Some header settings are provided that work with the
Company Information settings and are dependent on them being set.

The settings in this category are defined as follows:

Generate header
Specifies whether to generate header.

Header logo
Specifies a header logo to be displayed. The logo gets its value from the Company name or
Company logo image settings.

Header logo link address
Specifies header logo link address. Link address can inherit from the home page (splash page or
first page in help set) or the Company webpage. In order for this setting to be displayed in the
output, the target setting: Linked header logo must be enabled.

Header logo override
Specifies which image to use as the header logo. This setting will override the Header logo setting.
Choose from the image files stored in the Files  folder within your project.

Linked header logo
Enables the Header logo link address to be displayed
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HTML Help Settings
These settings apply only to the Microsoft HTML Help output format. The settings in this category are
defined as follows:

HTML Help binary index
Specifies whether you want to generate a binary index for Microsoft HTML Help output.

HTML Help binary TOC
Specifies whether you want to generate a binary table of contents for Microsoft HTML Help
output.

HTML Help custom map file
Specifies the location of a custom Microsoft HTML Help map file if you want to use a custom
HTML Help map file to generate Microsoft HTML Help output.
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Images Report Settings
The settings in this category are defined as follows:

Generate images report
Specifies whether to generate images reports

Images in table cells
Specifies the notification to receive if an image appears in a table cell.

Missing by-reference source files
Specifies the notification to receive if an image is referenced but not found in the location where it
is referenced.
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Index Settings
These settings are not supported in the PDF output format. The settings in this category are defined as
follows:

Generate index
Specifies whether you want to generate an index when you generate output.
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JavaHelp Settings
These settings apply only to the Sun JavaHelp output format. The settings in this category are defined as
follows:

Category closed image
Specifies the category closed image you want to use in the table of contents when generating Sun
JavaHelp. This setting applies only to Sun JavaHelp 2.0. By default, Sun JavaHelp uses a closed
folder image for the category closed image in the table of contents for a Sun JavaHelp system.

Category opened image
Specifies the category opened image you want to use when generating Sun JavaHelp. This setting
applies only to Sun JavaHelp 2.0. By default, Sun JavaHelp uses an open folder image for the
category opened image in the table of contents for a Sun JavaHelp system.

Enable favorites tab
Specifies whether you want to display the Favorites tab when generating Sun JavaHelp. This
setting applies only to Sun JavaHelp 2.0.

Enable glossary tab
Specifies whether you want to display the Glossary tab when generating Sun JavaHelp. This setting
applies only to Sun JavaHelp 2.0.

Enable search tab
Specifies whether you want to display the Search tab in your generated Sun JavaHelp.

JavaHelp location
Specifies the location of Sun JavaHelp SDK you want ePublisher to use when generating Sun
JavaHelp output.

JDK location
Specifies the location of the Java Development Kit (JDK) you want ePublisher to use when
generating Sun JavaHelp output.
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Links Settings
These settings apply only to the WebWorks Reverb (1 & 2), Microsoft HTML Help, WebWorks Help,
Dynamic HTML, and XML_XSL output formats. The settings in this category are defined as follows:

Baggage File Target
Specifies how links to baggage files display in your output. A baggage file is any file that your
source document references but is not contained in the ePublisher project, such as a .jpeg , .avi ,
.swf , .gif , or.png  file or a Microsoft Word, Adobe FrameMaker, or XML file. The values for
this setting are defined as follows:

 

Value Description

external_window Specifies the name of the window in which to open the page
by typing in the name of the window. This creates a new
browser window, unless one already exists with the same
name. If a browser window already exists with the same
name, it opens the page in that window. external_window is
the default.

_blank Specifies to always open the page in a new browser window
and leave the current window in its current state.

_self Specifies to open the page in the same browser window as
the link tag.

_parent Specifies to open the page in the immediate parent window
of the link tag. This option is only useful for very specialized
cases and is quite uncommon.

_top Specifies to open the page in the full body of the same
browser window as the link tag. Specify this value to break
out of a frame all the way to the top of a window.

None Specifies to open the page within the same browser window.
However, unlike _self, the settings of the browser may
control this action.

External URL Target
Specifies how links to external URLs display in your output. The values for this setting are defined
as follows:
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Value Description

external_window Specifies the name of the window in which to open the page
by typing in the name of the window. This creates a new
browser window, unless one already exists with the same
name. If a browser window already exists with the same
name, it opens the page in that window. external_window is
the default.

_blank Specifies to always open the page in a new browser window
and leave the current window in its current state.

_self Specifies to open the page in the same browser window as
the link tag.

_parent Specifies to open the page in the immediate parent window
of the link tag. This option is only useful for very specialized
cases and is quite uncommon.

_top Specifies to open the page in the full body of the same
browser window as the link tag. Specify this value to break
out of a frame all the way to the top of a window.

None Specifies to open the page within the same browser window.
However, unlike _self, the settings of the browser may
control this action.

Preserve Unknown File Links
If enabled, links to files that are not part of the generation will be preserved in the generated output.
Normally, it is not desired to have unknown file links preserved because this can lead to file not
found errors in the end-user experience. If this setting is enabled, make sure that the link has a
target when it is finally deployed.
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Links Report Settings
These settings are not supported for the PDF output format. The settings in this category are defined as
follows:

Baggage file
Specifies the notification to receive if ePublisher does not successfully bring over baggage files to
the baggage files area of your output folder. A baggage file is any file that your source document
references but is not contained in the ePublisher project, such as a .jpeg , .avi , .swf , .gif ,
or.png  file or Microsoft Word, Adobe FrameMaker, or XML file.

External URLs
Specifies the notification to receive when ePublisher detects a hyperlink in your source document
that refers to an external web site or email address.

Generate links report
Specifies whether to generate Links reports.

Unresolved link to destination in other documents
Specifies the notification to receive when ePublisher finds a document, such as a Microsoft
Word, Adobe FrameMaker, or XML document, referenced by a link in your source document, but
ePublisher cannot find the anchor or location within the document that your link references.

Unresolved link to missing document
Specifies the notification to receive when ePublisher cannot resolve a link between Microsoft
Word, Adobe FrameMaker, or XML source documents because ePublisher cannot find the source
documents in the ePublisher project or in any location on the local computer.

Unresolved link to missing file
Specifies the notification to receive when ePublisher cannot resolve a link between a source
document and a file, such as a .jpeg , .gif , .avi , .swf , or .pdf  file.

Unresolved link within document
Specifies the notification to receive when ePublisher cannot find a location referenced by a link in a
source document. Typically, this occurs when ePublisher cannot find the anchor or cross-reference
that the link references.

Unsupported baggage files
Specifies the notification to receive when the output format specified for the target does not support
baggage files. A baggage file is any file that your source document references but is not contained
in the ePublisher project, such as a.jpeg , .avi , .swf , .gif , or.png  file or Microsoft Word,
Adobe FrameMaker, or XML file.

Unsupported external URLs
Specifies the notification to receive when the output format specified for the target does not support
links to external locations outside of the help system.

Unsupported group to group links
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Specifies the notification to receive when the output format specified for the target does not support
group to group linking. Group to group linking is when you reference a location within another
group in your ePublisher project.
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Locale Settings
The settings in this category are defined as follows:

Encoding
Specifies the character encoding method used to convert bytes into characters in your output. This
setting is not supported in PDF.

Note: In some formats this setting is not available. In these cases, the encoding is fixed to UTF-8 .

Locale
Specifies the language in which your output displays. The values for this setting are defined as
follows:

 

Value Description

en English

fr French

de German

ja Japanese

es Spanish

it Italian

ko Korean

pt Portugese

ru Russian

sv Sweden

zh Simplified Chinese for Mainland China

zh_TW Traditional Chinese for Taiwan
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Menu Settings
Controls certain behaviors for the menu used to display the TOC and/or Index functions of a help output
format.

The settings in this category are defined as follows:

Generate menu
Specifies whether you want a menu to be generated in your output.

Menu initial state
Specifies the initial state of the menu as either Opened or Closed when the help is first opened by
the end-user.

Minimum page width for docked menu
If the device viewing region displaying the help is larger than the value of this setting, then the
Menu will be positioned (docked) next to the content page. If the viewing region is smaller than
this setting value, the Menu will be displayed on top of the content page, potentially obscuring
some of the content.
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Oracle Help Settings
These settings apply only to the Oracle Help  output format. The settings in this category are defined as
follows:

Enable search tab
Specifies whether you want to display the Search tab in your generated Oracle Help output.

Helpsetitle
Specifies the name of the Oracle Help system.

JDK location
Specifies the location of the Java Development Kit (JDK) used by the Oracle Help system.

Oracle Help Location
Specifies the location of the Oracle Help system.
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Page Settings
These settings control behavior specific to the page where content is displayed. The settings in this
category are defined as follows:

Document last modified date setting
Displays the date the source document used to generate this specific page was last modified. If
enabled, this document’s last modified date will be displayed at the bottom of each page generated
from this document.

Dropdown expand/collapse toggle button setting
Enables/disables a button that toggles all paragraph dropdown buttons on the currently displayed
page.

Reverb 2.0 page style setting
Specifies page style setting for Reverb 2.0 output. By default, the page will be generated using the
Default (or [Prototype] if there is no Default style) page style in ePublisher.

Splash page style setting
Specifies splash page style setting for Reverb 2.0 output. By default, the splash page will be
generated using the Default (or [Prototype] if there is no Default style) page style in ePublisher.
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PDF Settings
These settings apply only to the PDF output format. The settings in this category are defined as follows:

Acrobat Distiller - PDF job settings
Specifies the Acrobat Distiller PDF job settings you want ePublisher to use when generating PDF
output. The Acrobat Distiller PDF job settings you specify must be configured on the computer
where ePublisher generates output.

Acrobat Distiller - Use for document extensions
Specifies the document extensions you want to use when generating PDF output using Acrobat
Distiller.

Copy PDFs from Target
Allows users to name the PDF target instead of generating a separate one for the help target. This is
especially helpful if the user wants to specify a PDF based on PDF-XSL FO to be linked from the
help system.

Force download on click
Specifies the download behavior of the PDF button. Normally selecting the button causes the PDF
to load in the browser. Enabling this feature forces the PDF to download to the user’s file system
instead.

Generate a combined PDF per top level group
Specifies whether you want to generate a combined PDF for each top level group in Document
Manager.

Generate a PDF per document
Specifies whether you want to generate a PDF for each source document included in Document
Manager.

PDF job settings
Specifies the PDF job settings you want to use when generating output. When you create PDFs
using Adobe FrameMaker, you can manually set job options to specify the compression for
ePublisher to use when creating PDFs. Adobe FrameMaker provides predefined sets of job options
that you can use to control the quality of the PDFs. This setting applies only when you generate
output from Adobe FrameMaker source documents. The values for this setting are defined as
follows:

 

Value Description

Screen Specifies the appropriate settings if you plan to post PDFS on
a web site. This value is designed for low-resolution, on-screen
display. Because of the low-resolution display quality, the screen
setting allows content to download and display faster when users
access and view PDF on web sites
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Value Description

eBook Specifies the appropriate settings if users view your PDFs on
desktops computers, laptop computers, and eBook reading tools.

Print Specifies the appropriate settings if your PDFs will be printed.
This value produces high-resolution and high image quality PDFs
appropriate for printing. This value is similar to the pre press
setting, but it produces a smaller file size and fewer image details.

Pre Press Specifies the appropriate settings if your PDFs will be printed
using a high-resolution printing method. This value produces
the most detailed image quality. However, because of its high
resolution, the PDFs produced using this value have the largest
file sizes when compared to other PDF job settings.

PDF Target Window
Specifies how links to PDF files will be opened. The values for this setting are defined as follows:

 

Value Description

ww_connect_pdf Specifies the name of the window in which to open the page
by typing in the name of the window. This creates a new
browser window, unless one already exists with the same
name. If a browser window already exists with the same
name, it opens the page in that window. ww_connect_pdf is
the default.

_blank Specifies to always open the page in a new browser window
and leave the current window in its current state.

_self Specifies to open the page in the same browser window as
the link tag.

_parent Specifies to open the page in the immediate parent window
of the link tag. This option is only useful for very specialized
cases and is quite uncommon.

_top Specifies to open the page in the full body of the same
browser window as the link tag. Specify this value to break
out of a frame all the way to the top of a window.

Save As PDF - PDF job settings
Specifies the Acrobat Distiller PDF job settings you want FrameMaker to use when generating
PDF output under the direction of ePublisher. If this setting is empty, then ePublisher will not use
FrameMaker’s “Save as PDF ” method. The Acrobat Distiller PDF job settings you specify must
be configured on the computer where ePublisher generates output.

180 | PDF Sengs



This option is only necessary when using FrameMaker and you have embedded videos in your
content that you want to be published in the PDF output.

Note: If your output generation requires page rotations, then you should not use this target setting.

Save As PDF - Use for document extensions
Specify the FrameMaker file extensions to apply the “Save As PDF” operation to.
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Result Options Settings (PDF - XSL-FO)
These settings apply only to the PDF - XSL-FO output format. The settings in this category are defined as
follows:

Generate bookmarks
Specifies whether or not to generate acrobat bookmarks based on the table of contents settings.

Generate group result
Specifies whether or not a PDF will be generated for an entire group of documents or ditamaps
within an ePublisher project.

Generate per document result
Specifies whether or not a PDF will be generated for each document or ditamap within an
ePublisher project.

Generate project result
Specifies whether or not a PDF will be generated that includes all the documents or ditamaps of all
the groups in an ePublisher project.
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Search Settings
This setting controls behavior for end-user search in the generated output. The settings in this category are
defined as follows:

Minimum character amount to execute search
Specifies the minimum amount of characters needed to execute a search. When users type the
minimum amount of characters specified in this setting, an initial list of search results will
begin to be displayed in the search results area. Reducing the value of this setting will make the
progressive search begin to display sooner with suggested results. However, it will also make the
help download file size larger and potentially slower for your end-users the first time they access
the online help. After the first access of any page in the online help, the end-user’s browser will
start downloading the search files and cache them for use when the user does perform a search. The
cached search files may have the effect of making the download size not an issue depending on
end-user behavior.

Progressive search
This setting allows search result suggestions to begin being displayed before a user completes their
search term input. Specifies whether progressive search is enabled/disabled.

Search result count
Allows end-users to see how many search results there are for a given search term input. Specifies
whether search result count is enabled/disabled.

Search scope filtering
This setting creates a dropdown menu displaying all the groups and sub-groups defined in your
ePublisher project within the Document Manager. This menu is available to your end-users next
to the search input in the toolbar. End-users can then select which group(s) they want to perform
a search within. Search results will not be displayed for groups that are not selected. Specifies
whether search scope filtering is enabled/disabled.
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Social Settings
These settings are specific to the WebWorks Reverb Format for integration with social media. Please refer
to the specific site for further instructions once integrated

Disqus - Allow non-public networks
Enables users to post Disqus comments behind a firewall or non-public website.

Disqus Identifier
Enables support for user comments using the Disqus comment web service

FaceBook Like
Enables users to report “I like this!” in Facebook

LinkedIn Share
Enable users to share individual pages within the LinkedIn community.

Tweet This!
Enable Twitter “Tweet This!” support
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Styles Settings (PDF - XSL-FO)
These settings apply only to the PDF - XSL-FO output format. The settings in this category are defined as
follows:

Content page style
Specifies the ePublisher page style to use for generating all non-TOC and non-Index pages.

Index page style
Specifies the ePublisher page style to use for generating the Index pages.

Index style prefix
Specifies the prefix that will be used for the generated index style names such as: IXGroup, IX1,
IX2, IX3. These styles correspond to paragraph styles that can be created in the ePublisher Style
Designer.

Index title style
Specifies the ePublisher paragraph style to use for the title of the generated index pages.

MiniTOC container style
Specifies the ePublisher paragraph style to use for generating mini-TOC sections.

MiniTOC style
Specifies the ePublisher paragraph style to use for generating mini-TOC paragraphs.

Related Topics Title Style
Specifies the ePublisher paragraph style to use for the title of the generated related topics sections.

TOC page style
Specifies the ePublisher page style to use for generating the TOC pages.

TOC style prefix
Specifies the prefix that will be used for the generated TOC style names such as: TOC1, TOC2,
TOC3, TOC4. These styles correspond to paragraph styles that can be created in the ePublisher
Style Designer.

TOC title style
Specifies the ePublisher paragraph style to use for the title of the generated TOC pages.
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Styles Report Settings
The settings in this category are defined as follows:

Generate styles report
Specifies whether to generate the Styles report.

Non-standard styles
Specifies the notification ePublisher generates if ePublisher detects styles in your source document
that are undefined in the Stationery used by your project.

Style overrides
Specifies the notification ePublisher generates if ePublisher detects style overrides in your source
documents. A style override is any modification made to the original style definition defined in the
Stationery used by your project.
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Table of Contents Settings
The settings in this category are defined as follows:

Collapse table of contents
Specifies how you would like skipped heading levels handled in the table of contents for your
output. For more information, see “Defining the Table of Contents from an Irregular Heading
Hierarchy”. The values for this setting are defined as follows:

 

Value Description

Don’t collapse Inserts empty table of content entries for the skipped levels.

Re-label Inserts labeled entries for the skipped table of contents levels.
When you specify this value, ePublisher displays the heading text
from the table of contents entry below the current entry as the
table of contents label.

Fully collapse Removes all skipped heading levels and table of contents
entries and places all table of contents headings at the same
level, regardless of the table of contents level specified in the
Stationery.

Smart collapse Removes empty table of contents entries and moves the heading
that follows an empty table of content entry up a level to replace
the skipped table of contents level.

Generate table of contents
Specifies whether ePublisher generates a table of contents.

Table of Contents filename
Specifies the file name ePublisher should use when ePublisher generates a table of contents file in
certain output formats.
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Title Page Settings (PDF - XSL-FO)
These settings apply only to the PDF - XSL-FO output format. The settings in this category are defined as
follows:

Generate Publish Date on Title Page
Specifies whether or not to generate a publication date on the title page.

Generate Title Page
Specifies whether or not to generate a title page.

Title Page Style
Specifies the ePublisher page style to use for generating the title page.

Title Page title
Specifies how the text of the title page title will be calculated. The following choices are available
with the current installation of ePublisher:

 

Value Description

$Title; This value is set via the ePublisher merge setting title of the
given group or project. Merge setting titles are configured under
the Merge Settings dialog. In the case of a PDF for a single
document or ditamap, then this value is the top-level heading.

None No title will be generated.

Title Page Title style
Specifies the ePublisher paragraph style to use for generating the title page’s title.

Title Page Sub-title
Specifies how the text of the title page sub-title will be calculated. The following choices are
available with the current installation of ePublisher:

Value Description

$Title; This value is set via the ePublisher merge setting title of the
given group or project. Merge setting titles are configured under
the Merge Settings dialog. In the case of a PDF for a single
document or ditamap, then this value is the top-level heading.
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Value Description

None No sub-title will be generated.

Title Page Sub-title style
Specifies the ePublisher paragraph style to use for generating the title page’s sub-title.
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Toolbar Settings
The settings in this category are defined as follows:

Google Translate Button
Enables support for the Google Translate web service. Requires your output to be deployed on a
public-facing web server.

Home setting
Specifies whether you want to display the linked home button in your toolbar.

Linked toolbar logo
Specifies whether you want your toolbar logo to be linked to the home (splash or first page) page or
the Company webpage.

Toolbar logo
Specifies whether you want to display a logo in your toolbar. Toolbar logo can inherit from
Company name or Company logo image.

Toolbar logo link address
Specifies the logo link address.

Toolbar logo override
Specifies which image to use as the toolbar logo. Store the image file in the Files  folder within
your project.
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Topics Report Settings
These settings are not supported for the Dynamic HTML, XML+XSL, PDF - XSL-FO, and PDF output
formats. The settings in this category are defined as follows:

Generate topics report
Specifies whether to generate the Topics report.

Topic links
Specifies the notification ePublisher generates if ePublisher detects that ePublisher did not create
a context-sensitive help topic file for each context-sensitive help topic ID you specified using the
TopicAlias marker.

Duplicate topic aliases
Specifies whether or not there are two or more TopicAlias markers with the same marker text
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WebWorks Help Settings
These settings apply only to the WebWorks Help output format. These settings are defined as follows:

Automatically synchronize the TOC
Specifies whether you want to allow users to locate the topic they are viewing in the table of
contents. When you enable this setting, when a user clicks the “Show in Contents” button located
to the left of the navigation button, WebWorks Help highlights the entry in the Contents tab that
corresponds to the currently displayed topic.

Cookie expiration in days
Specifies the number of days before cookies expire.

Cookie id
Specifies the cookie ID.

Show bookmark toolbar button
Specifies whether you want to display the bookmark toolbar button in your output.

Show favorites tab
Specifies whether you want to display the Favorites tab in your output.

Show first document instead of splash page
Specifies whether you want to show the first topic in your WebWorks help system instead of the
splash page in your output.

Show PDF button
Specifies whether you want to display the PDF button in your output. If you enable this setting,
WebWorks Help displays a PDF file of the source document from which the currently displayed
topic was generated.

Show previous and next tool bar buttons
Specifies whether you want to display the previous and next tool bar buttons in your output. The
previous button allows users to navigate back to topics that precede the currently displayed topic
in the help. The Next button allows users to navigate forward to topics that follow the currently
displayed topic in the help.

Show print toolbar button
Specifies whether you want to display the print toolbar button in your output.

Show related topics inline button
Specifies whether you want to display related topics links as a list in the topic itself as well as in a
popup window when the user clicks a related topics button.

Show related topics toolbar button
Specifies whether you want to display the related topics toolbar button in your output.

Show search tab
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Specifies whether you want to display the Search tab in your output.

Theme
Specifies the theme you want to use in your output.

Top level filename
Specifies the top-level entry-point file for the generated WebWorks Help output.

Use browser cookies
Specifies whether you want to use browser cookies.

WebWorks Help accessibility
Specifies whether you want to enable WebWorks Help accessibility, or if you want to ask users if
they want to enable WebWorks Help accessibility on first use.
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WebWorks Reverb Settings
Display large images in lightbox

When a thumbnail is used for an image, the full size version of the image can be viewed by
clicking the image which is then displayed in a lightbox. When disabled the image displays in a
separate file.

Enabled Print Icon
Enables/disables the print icon in generated pages

Entry Filename
Specifies the name of the Reverb entry-point file name (default is “index.html”)

Feedback Email
Defines the feedback email address for use in generated pages

Feedback Email Message
Defines the contents of both the subject line and body section of the email message sent when
Feedback Email address is specified. Use $Location  to include the current page’s URL in the
message. Please note that this message is single-line only.

Home
Provides a button in the toolbar that links to the entry point of the Reverb help set. If the splash
page is enabled then it will link to the splash page, otherwise it will link to the first page of actual
content.

Minimum height for non-scrolling toolbar
Specifies the minimum browser window height required for Reverb to fix the toolbar at the top of
the window instead of scrolling out of view.

Minimum page width for sidebar
Specifies the minimum browser window width required for Reverb to display the TOC/Index
sidebar panel next to the content panel. If the width of the window is less than this value, then the
TOC/Index will be displayed in place of the content panel and only when the TOC/Index button has
been selected.

Reverb Page Style
Specifies the page style to use when creating the outer-level HTML file that contains all the Reverb
panels (i.e. TOC, index, search, content).

Search Implementation
Specifies the type of search implementation or engine to use. Currently, there are 2 choices
available:
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Value Description and Deployment Requirements

Client-side Search Provides a stand-alone search capability using javascript that is
executed on the end-user’s browser client. Provides basic search
capabilities.
No additional requirements.

Sidebar Width
Specifies the width of the TOC or Index sidebar panel.

Skin
Specifies an alternate skin plugin to use when generating Reverb Help. Skin plugins allow for a
wide range of look-and-feel differences for Reverb Help. The following choices are available with
the current installation of ePublisher Pro:

 

Skin Types Color Schemes

Classic
Classic - Compact

 

Corporate
Corporate - Compact

Blue
Grey
Red

Metro
Metro - Compact

Blue
Dark Green
Grey
Light Green
Orange
Purple
Red
Tiled

Social
Social - Compact

Blue
Green
Grey
Light Blue
Red

Splash Page Style
Specifies the page style to use when processing the splash page

WebWorks Reverb Sengs | 195



Use first document as splash page
Determines initial page displayed. If set to Enabled then no splash page will be created and instead
the first page will be used.

WebWorks Help API Compatibility
Enables users to use the same help API as used for WebWorks Help 4 and 5 with Reverb Help.
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WebWorks Reverb 2.0 Settings
Browser Tab Icon (favicon)

Allows you to select an icon file from the User Files location in the project. This file will then be
used as the favicon which displays in the browser tab.

Browser Tab Title
Specifies the value used in the title of the internet browser tab. When Page Title is used, the title of
the currently open page in the Reverb 2.0 output will populate the browser tab. When Merge Title
is used, the Merge Title value in the Merge Settings window will populate the browser tab.

Display large images in lightbox
Enable/disable the lightbox setting. Lightbox displays the full size of images that have been made
into thumbnails.

Enabled Print Icon
Enables/disables the print icon in generated pages

Entry Filename
Specifies the name of the Reverb entry-point file name (default is “index.html”)

Feedback Email
Defines the feedback email address for use in generated pages

Feedback Email Message
Defines the contents of the body section of the email message sent when Feedback Email address
is specified. Use $Location  to include the current page’s URL in the message. Please note that this
message is single-line only.

Skin
Specifies an alternate skin plugin to use when not using the default skin: Neo. It is recommended
that you leave this field empty, thus using the default skin: Neo. Neo has been optimized to fully
take advantage of Reverb 2.0 design. You can still customize the look of the skin using SASS.
However, if you prefer, you can select from the alternate skin plugins that have been provided as
a means for mimicking an existing Reverb 1 design. The following choices are available with the
current installation of ePublisher Pro:

 

Skin Types Description

Classic This skin features a larger toolbar, and gradients across the layout
to produce a traditional help look and feel. This skin is great for all
around acceptability and use across any platform and website.

Corporate
 

Modeled after high profile technology websites. The Corporate
skin has a polished look and would suit the needs of a high-profile
technology company’s help set.
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Skin Types Description

Metro
 

The Metro skin represents the latest ideas in computer interface
design and comes straight from the Metro Design Language, now
the heart of interfaces used in all Microsoft desktop, smartphone, and
game box operating platforms.

Neo
 

The default skin for WebWorks Reverb 2.0. Neo is the latest design for
Reverb output and was designed with current web aesthetics in mind.
It features a simplistic layout that looks great across many devices.
This skin is very versatile and well suited for most purposes.

Social
 

The Social skin has been designed to provide a user experience most
similar to that of social networking websites. It provides a familiar
interface that is intuitive and casual enough to maximize your end-user
participation.

 
Use first document as splash page

Determines initial page to be displayed. If set to Enabled, the first page will be used as the splash
page.

WebWorks Help API Compatibility
Enables users to use the WebWorks Help API.
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Style Designer Reference

Advanced Properties
Aural Properties
Background Properties
Body Properties
Body Background Properties (Tables)
Border Properties
Bullet Properties
Font Properties
Footer Properties (Tables)
Footer Background Properties (Tables)
Header Properties (Tables)
Header Background Properties (Tables)
HTML Properties
Margin Properties
Master Page Properties (Pages)
Navigation Properties (Pages)
Padding Properties
Pagination Properties
Table Properties (Tables)
Text Properties
Paragraph Styles Options
Character Styles Options
Table Styles Options
Page Styles Options
Page Styles Options (PDF - XSL-FO)
Graphic Styles Options
Marker Styles Options

The Style Designer allows you to specify the appearance and functionality of online content, including
paragraphs, characters, tables, page layouts, images, table of contents levels, popups, and related topics.
ePublisher Pro builds Stationery based on the settings you specify as properties and/or options.
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Advanced Properties
Available only in the PDF - XSL-FO format.

These properties are for use with output formats that require styling and layout characteristics above and
beyond what is provided by CSS. Links all point to this website

Absolute Position
http://www.w3.org/TR/xsl11/#absolute-position

Alignment Adjust
http://www.w3.org/TR/xsl11/#alignment-adjust

Alignment Baseline
http://www.w3.org/TR/xsl11/#alignment-baseline

Baseline Shift
http://www.w3.org/TR/xsl11/#baseline-shift

Block Progression Dimension
http://www.w3.org/TR/xsl11/#block-progression-dimension

Clear
http://www.w3.org/TR/xsl11/#clear

Display Align
http://www.w3.org/TR/xsl11/#display-align

Dominant Baseline
http://www.w3.org/TR/xsl11/#dominant-baseline

End Indent
http://www.w3.org/TR/xsl11/#end-indent

Float
http://www.w3.org/TR/xsl11/#float

Font Selection Strategy
http://www.w3.org/TR/xsl11/#font-selection-strategy

Font Size Adjust
http://www.w3.org/TR/xsl11/#font-size-adjust

Font Stretch
http://www.w3.org/TR/xsl11/#font-stretch

Glyph Orientation Horizontal
http://www.w3.org/TR/xsl11/#glyph-orientation-horizontal

Glyph Orientation Vertical
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http://www.w3.org/TR/xsl11/#glyph-orientation-vertical

Inline Progression Dimension
http://www.w3.org/TR/xsl11/#inline-progression-dimension

Intrusion Displace
http://www.w3.org/TR/xsl11/#intrustion-displace

Last Line End Indent
http://www.w3.org/TR/xsl11/#last-line-end-indent

Leader Alignment
http://www.w3.org/TR/xsl11/#leader-alignment

Leader Length
http://www.w3.org/TR/xsl11/#leader-alignment

Leader Pattern
http://www.w3.org/TR/xsl11/#leader-pattern

Leader Pattern Width
http://www.w3.org/TR/xsl11/#leader-pattern-width

Line Stacking Strategy
http://www.w3.org/TR/xsl11/#line-stacking-strategy

Linefeed Treatment
http://www.w3.org/TR/xsl11/#linefeed-treatment

Maximum Height
http://www.w3.org/TR/xsl11/#max-height

Maximum Width
http://www.w3.org/TR/xsl11/#max-width

Provisional Distance Between Stars
http://www.w3.org/TR/xsl11/#provisional-distance-between-starts

Provisional Label Separation
http://www.w3.org/TR/xsl11/#provisional-label-separation

Reference Orientation
http://www.w3.org/TR/xsl11/#reference-orientation

Relative Align
http://www.w3.org/TR/xsl11/#relative-align

Relative Position
http://www.w3.org/TR/xsl11/#relative-position

Role
http://www.w3.org/TR/xsl11/#role
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Rule Style
http://www.w3.org/TR/xsl11/#rule-style

Rule Thickness
http://www.w3.org/TR/xsl11/#rule-thickness

Score Spaces
http://www.w3.org/TR/xsl11/#score-spaces

Source Document
http://www.w3.org/TR/xsl11/#source-document

Space After
http://www.w3.org/TR/xsl11/#space-after

Space Before
http://www.w3.org/TR/xsl11/#space-before

Space End
http://www.w3.org/TR/xsl11/#space-end

Space Start
http://www.w3.org/TR/xsl11/#space-start

Span
http://www.w3.org/TR/xsl11/#span

Start Indent
http://www.w3.org/TR/xsl11/#start-indent

Suppress at Line Break
http://www.w3.org/TR/xsl11/#suppress-at-line-break

Text Align
http://www.w3.org/TR/xsl11/#text-align

Text Align Last
http://www.w3.org/TR/xsl11/#text-align-last

Text Altitude
http://www.w3.org/TR/xsl11/#text-altitude

Text Depth
http://www.w3.org/TR/xsl11/#text-depth

Text Shadow Blur Radius
http://www.w3.org/TR/xsl11/#text-shadow-blur-radius

Text Shadow Color
http://www.w3.org/TR/xsl11/#text-shadow-color

Text Shadow Vertical Offset
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http://www.w3.org/TR/xsl11/#text-shadow-vertical-offset

Treat as Word Space
http://www.w3.org/TR/xsl11/#treat-as-word-space

White Space Collapse
http://www.w3.org/TR/xsl11/#white-space-collapse

White Space Treatment
http://www.w3.org/TR/xsl11/#white-space-treatment

Wrap Option
http://www.w3.org/TR/xsl11/#wrap-option
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Aural Properties
Available only in the PDF - XSL-FO format.

These properties are for use with output formats that require aural property characteristics.

Azimuth
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-azimuth

Cue After
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-cue-after

Cue Before
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-cue-before

Elevation
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-elevation

Pause After
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-pause-after

Pause Before
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-pause-before

Pitch
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-pitch

Pitch Range
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-pitch-range

Play During
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-play-during

Richness
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-richness

Speak
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-speak

Speak Header
http://www.w3.org/TR/REC-CSS2/tables.html#propdef-speak-header

Speak Numeral
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-speak-numeral

Speak Punctuation
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-speak-numeral

Speech Rate
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http://www.w3.org/TR/REC-CSS2/aural.html#propdef-speech-rate

Stress
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-stress

Voice Family
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-voice-family

Volume
http://www.w3.org/TR/REC-CSS2/aural.html#propdef-volume
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Background Properties
In terms of the CSS box model, the background for a style refers to the background of the content and
the padding areas. If you increase the padding for a style, the background color area for that style also
increases.

Color
Specifies the color for the background. Select a color from the list or type the RGB value of the
color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for Red,
Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex #00 )
to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black is
000000  and white is FFFFFF .

Image
Specifies the background image. This field lists only the image files located in the Files  folder
of your project. If this field does not list the background image you want, press F12  and verify
the image is in the Files  folder for your project. Once you copy the image into the Files  folder,
ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling
Specifies whether the background image repeats. The table must be larger than the background
image to see the image repeated in the background. The background image size also determines if
an image repeat shows when set horizontally or vertically. The values for this setting are defined as
follows:

 

Value Description

No repeat Indicates the background image does not repeat.

Repeat Indicates the background image repeats.

Repeat horizontally Indicates the background image repeats horizontally.

Repeat vertically Indicates the background image repeats vertically.

Scrolling
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Specifies whether the background image remains in a fixed location as the user scrolls down the
page. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through the
page contents.

Fixed Keeps the background image in a fixed location as the user
scrolls through the page contents.

Horizontal
Specifies the starting horizontal position of a background image. The values for this setting are
defined as follows:

 

Value Description

Custom The background image aligns based on the custom value entered
and the unit of measure selected. Units of measure you can
select include: percentage (%) of the line height, centimeters
(cm), em unit (em), x-height (ex), inches (in), millimeters (mm),
pica (pc), point sizes (pt), and pixels (px). For example, if
you enter a value of 20 and select the percentage (%) unit of
measure, the top left corner is considered 0 percent and the
bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-width.

Left The left side of the background image aligns with the leftmost side
of the page.

Center The center of the background image aligns with the center of the
page.

Right The right side of the background image aligns with the right of the
page.

Vertical
Specifies the starting vertical position of a background image. The values for this setting are
defined as follows:
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Value Description

Custom The background image aligns based on the custom value entered
and the unit of measure selected. Units of measure you can
select include: percentage (%) of the line height, centimeters
(cm), em unit (em), x-height (ex), inches (in), millimeters (mm),
pica (pc), point sizes (pt), and pixels (px). For example, if
you enter a value of 20 and select the percentage (%) unit of
measure, the top left corner is considered 0 percent and the
bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-height.

Top The top of the background image aligns with the top of the tallest
element on the line

Center The center of the background image aligns with the middle of the
parent element bottom.

Bottom The bottom of the background image aligns with the lowest
element on the line.
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Body Properties
Body rows are the rows of a table that contain the data. Values you define for table body rows establish
the default values for the table, unless you indicate separate header and footer row values.

In Microsoft Word and Adobe FrameMaker, you can define a header row for your table. In FrameMaker,
you can also define a footer row. Body rows are typically all rows in a table not already defined as a
header or footer rows. However, unless you explicitly specify a row as a header row, ePublisher considers
all rows except the footer rows as body rows.

Within body rows, ePublisher lets you specify the table padding. Padding refers to the space between
the body border and the body content. You can change the left, top, right, and bottom padding values
independently or set all properties to have the same padding. Padding values must be positive numbers.

Left
Specifies the left padding for table body rows. Set a custom value by specifying a number and
selecting the unit of measure. Select Auto for ePublisher to automatically set table row padding.

Top
Specifies the top padding for table body rows. Set a custom value by selecting Custom, entering a
value, and selecting the unit of measure. Units of measure you can select include: percentages (%)
of the line height, centimeters (cm), em units (em), x-height (ex), inches (in), millimeters (mm),
picas (pc), point sizes (pt), and pixels (px).Select Auto for ePublisher to automatically set table row
padding.

Right
Specifies the right padding for table body rows. Set a custom value by selecting Custom, entering a
value, and selecting the unit of measure. Units of measure you can select include: percentages (%)
of the line height, centimeters (cm), em units (em), x-height (ex), inches (in), millimeters (mm),
picas (pc), point sizes (pt), and pixels (px). Select Auto for ePublisher to automatically set table
row padding.

Bottom
Specifies the bottom padding for table body rows. Set a custom value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px). Select Auto for ePublisher to
automatically set table row padding.

Vertical
Specifies the vertical alignment for the content in table body rows. Vertical alignment of content is
very important for readability of online information.

If the cells across a table row have differing numbers of content lines, align the content to either the
top or the bottom of the table row so that all of the row cells across the page align. Typically, cells
within the body of a table area are top-aligned and the header cells for the table are bottom-aligned.

Color
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Specifies the border color for table body rows. Select a color from the list or type the RGB value of
the border color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for
Red, Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex
#00 ) to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black
is 000000  and white is FFFFFF .

To select color values for all body row borders, specify the color on the All tab. To set unique
color values for each individual body row border, click the Left, Right, Top or Bottom tab and
separately set each border value.

This field sets the border color for body rows in a table, not the entire table border. To set the
border color for an entire table, select Border from the Table Styles properties.

Style
Specifies a border style in table body rows, such as a dotted, dashed, or solid line.

Not all browsers display border styles the same way. For example, some browsers may not
differentiate dotted lines from solid lines. Various browsers and operating systems often display the
size and spacing of the dots in a dotted line differently.

Width
Specifies the width of a border in table body rows, such as a thick or thin border. Choose a value or
set a custom width by selecting Custom, entering a value, and selecting the unit of measure. Units
of measure you can select include: percentages (%) of the line height, centimeters (cm), em units
(em), x-height (ex), inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
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Body Background Properties (Tables)
Body Background properties let you specify a background color for table body rows, set the background
as transparent, or specify an image to use in the background of body rows. Indicate alternative colors or
background images to alternate the appearance of rows or columns in a table.

To understand how ePublisher modifies table properties, visualize the body rows of a table as sitting on a
layer above the table background. When you modify the background color of the body rows, you actually
apply an opaque color over the color of the entire table background color. To get the desired results, you
may need to alter other body row elements, such as paragraphs. For example, if you cannot make the body
row transparent, make sure you correctly set the background property for all the different Table Styles
properties.

Color
Specifies the background color of table body rows. Select a color from the list or type the RGB
value of the background color, such as FFFFFF . RGB value refers to the web standard hexadecimal
notation for Red, Green, and Blue color values. RGB values can range from the lowest RGB value
of 0  (hex #00 ) to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation
for black is 000000  and white is FFFFFF .

Image (Background Image Area)
Specifies the background image for table body rows. This field lists only the image files located in
the Files  folder of your project. If this field does not list the background image you want, press
F12  and verify the image is in the Files  folder for your project. Once you copy the image into the
Files  folder, ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling (Background Image Area)
Specifies whether the background image repeats in table body rows.The body rows must be
larger than the background image to see the image repeated in the background of the body rows.
The background image size also determines if an image repeat shows when set horizontally or
vertically. The values for this setting are defined as follows:

 

Value Description

No repeat Specifies that the background image does not repeat.

Repeat Specifies that the background image repeats.
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Value Description

Repeat horizontally Specifies that the background image repeats horizontally.

Repeat vertically Specifies that the background image repeats vertically.

Scrolling (Background Image Area)
Specifies whether the specified image remains in one fixed location as the user scrolls through
content. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through content.

Fixed Keeps the background image in a fixed location as the user
scrolls through content.

Horizontal (Background Image Area)
Specifies the horizontal position of the background image for table body rows. The values for this
setting are defined as follows:

 

Value Description

Custom The background image aligns in the table row based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em unit (em), x-height (ex), inches (in),
millimeters (mm), pica (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-width.

Left The left side of the background image aligns with the leftmost side
of the table row.

Center The center of the background image aligns with the center of the
table row.

Right The right side of the background image aligns with the right of the
table row.

Vertical (Background Image Area)
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Specifies the vertical position of the background image of table body rows. The values for this
setting are defined as follows:

 

Value Description

Custom The background image aligns on the table row based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em unit (em), x-height (ex), inches (in),
millimeters (mm), pica (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-height.

Top The top of the background image aligns with the top of the tallest
element on the table row.

Center The center of the background image aligns with the middle of the
parent element bottom on the table row.

Bottom The bottom of the background image aligns with the lowest
element on the table row.

Context
Specifies whether to use alternate colors or images for alternating rows or columns of a table.

Alternate shading of rows or columns is a useful layout to help minimize the number of lines and
amount of information displayed, while organizing the data in a way that users can easily read and
understand.

Default period
Specifies the number of rows or columns that use the default color in the body row. You must first
set the default body row color in the Color field of the Body Background properties for the table
style. Specify a minimum value of 1. If you specify a value of 0, ePublisher does not use alternate
rows or columns and displays entire body row in the default color.

Alternate period
Specifies how many consecutive rows or columns use the alternate color or image. Specify a value
greater than 0. For example, if you set Alternate period to 2, after the first two rows of a table,
the next two rows would use the alternate color or image. Then, there would be two plain rows,
followed by two more using the alternate color or image, and so on.

Alternate Color
Specifies the color to use as the alternate color. Select a color from the list or type the RGB value
for the alternative color, such as 000000 . RGB value refers to the web standard hexadecimal
notation for Red, Green, and Blue color values. RGB values can range from the lowest RGB value
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of 0  (hex #00 ) to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation
for black is 000000  and white is FFFFFF .

Image (Alternate Info, Background Image Area)
Specifies the alternate background image for table body rows. This field lists only the image files
located in the Files  folder of your project. If this field does not list the background image you
want, press F12  and verify the image is in the Files  folder for your project. Once you copy the
image into the Files  folder, ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling (Alternate Info, Background Image Area)
Specifies whether to repeat the alternate background image in table body rows. The table must
be larger than the alternate background image to see the image repeated in alternate table body
rows. The alternate background image size also determines if an image repeat shows when set
horizontally or vertically. The values for this setting are defined as follows:

 

Value Description

No repeat Specifies that the background image does not repeat.

Repeat Specifies that the background image repeats.

Repeat horizontally Specifies that the background image repeats horizontally.

Repeat vertically Specifies that the background image repeats vertically.

Scrolling (Alternate Info, Background Image Area)
Specifies whether the specified alternate background image remains in one fixed location as the
user scrolls through content. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through content.

Fixed Keeps the background image in a fixed location as the user
scrolls through content.
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Horizontal (Alternate Info, Background Image Area)
Specifies the horizontal position for the alternate background image in table body rows. The values
for this setting are defined as follows:

 

Value Description

Custom The alternate background image aligns in the table row based
on the custom value entered and the unit of measure selected.
Units of measure you can select include: percentage (%) of the
line height, centimeters (cm), em unit (em), x-height (ex), inches
(in), millimeters (mm), pica (pc), point sizes (pt), and pixels (px).
For example, if you enter a value of 20 and select the percentage
(%) unit of measure, the top left corner is considered 0 percent
and the bottom right corner is 100 percent. So, ePublisher aligns
the background image in a 20% value of the line-width.

Left The left side of the alternate background image aligns with the
leftmost side of the table row.

Center The center of the alternate background image aligns with the
center of the table row.

Right The right side of the alternate background image aligns with the
right of the table row.

Vertical (Alternate Info, Background Image Area)
Specifies the vertical position for the alternate background image in table body rows. The values
for this setting are defined as follows:

 

Value Description

Custom The alternate background image aligns on the table row based
on the custom value entered and the unit of measure selected.
Units of measure you can select include: percentage (%) of the
line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
For example, if you enter a value of 20 and select the percentage
(%) unit of measure, the top left corner is considered 0 percent
and the bottom right corner is 100 percent. So, ePublisher aligns
the background image in a 20% value of the line-height.

Top The top of the alternate background image aligns with the top of
the tallest element on the table row.

Center The center of the alternate background image aligns with the
middle of the parent element on the table row.
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Value Description

Bottom The bottom of the alternate background image aligns with the
lowest element on the table row.
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Border Properties
Borders are lines that you can draw around any or all of the four sides of a style. In terms of the CSS box
model, increasing the padding for a style increases the space between the content and the border.

Not all browsers display border styles the same way. For example, some browsers may not differentiate
dotted lines from solid lines. Various browsers and operating systems often display the size and spacing of
the dots in a dotted line differently.

Color
Specifies the border color. Select a color from the list or type the RGB value for the border, such
as 000000 . RGB value refers to the web standard hexadecimal notation for Red, Green, and Blue
color values. RGB values can range from the lowest RGB value of 0  (hex #00 ) to the highest
value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black is 000000  and
white is FFFFFF .

This field sets the border color for an entire table, not borders around body rows. To set the border
color for table body rows, select Body in the Table Styles properties and specify the border settings
for body rows.

Style
Specifies a border style, such as a dotted, dashed, or solid line.

Not all browsers display border styles the same way. For example, some browsers may not
differentiate dotted lines from solid lines. Various browsers and operating systems often display the
size and spacing of the dots in a dotted line differently.

Width
Specifies a border width, such as a thick or thin border. Choose a value or set a custom width by
selecting Custom, entering a value, and selecting the unit of measure. Units of measure you can
select include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex),
inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Border Properes | 217



Bullet Properties
By default, ePublisher generates output for bulleted lists based on the properties in the original source
content. Some source applications use the Symbol or Wingdings font for bullets. These fonts may not be
available on all computers, which can cause the bullets in your output to display incorrectly. To avoid this
issue, use an image for bullets. Also, you can create a character style with a font family assigned, such as
sans-serif, and then apply that character style through ePublisher to the characters you choose to define
for bullets.

Note: When inserting text for either the Text or Separator properties described below, make sure
to use unicode characters. You can copy-and-paste unicode characters from another program
such as the Windows accessory program called Character Map, or you can use a Windows
ALT key sequence.

Steps for inserting special characters using the Windows ALT key sequence

1. Position the cursor where you want the special character to appear

2. Make sure that the numeric keypad Num Lock  is on

3. Press and hold the Alt  key and then press the keys on the numeric keypad that represent the
keystroke value of the character you want to input

4. After you finish typing, release the Alt  key
 

Character Name ALT Key Sequence

Round Bullet 0149

En Dash 0150

Em Dash 0160

Text
Specifies a special character for bullets. Enter the special character using the Windows ALT
key code or by copying and pasting a unicode character from another program. Common bullet
characters are round bullet, en dash, and em dash.

Separator
Specifies the type of separator to use between the bullet and the beginning of the first text line, such
as a space or a colon.

Image
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Specifies the image to use for bullets. This field lists only the image files located in the Files
folder of your project. If you do not see the background image you want in this field, press F12  and
verify the image is in the Files  folder for your project. Once you copy the image into the Files
folder, ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Character Style
Specifies a character style for your bullet to ensure the bullet character uses the correct font. Use
any character style available in your project. To associate an existing character style with a custom
bullet, select the character style in this field.
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Font Properties
Family

Specifies a font family. Click the Ellipsis button to open the Font Family Picker window where you
can select from a list of installed fonts, specify a generic font family, or select a custom font family.

Consider specifying a generic font family, such as sans-serif, rather than a specific font. Many
browsers and help systems use only fonts installed on the user’s computer. If you indicate a
specific font, a user who does not have that font installed does not see the help output correctly. By
selecting a generic font family, the user does not have to have the exact font specified, only a font
from that family.

If you specify multiple fonts, separated by commas, the user’s browser displays the first available
font in the list. For example, if you specify Verdana, Arial, Helvetica, sans-serif  and the
user does not have the Verdana font installed, the browser displays in the Arial font for the help
output instead.

Size
Specifies the size of the font. Select a value from the list or select Custom, and then specify a
number and unit of measure for the custom font size. The smaller value sets the font to a smaller
size than the parent element. The larger value sets the font to a larger size than the parent element.

Style
Specifies the font style, such as italic.

Variant
Specifies the font variation, such as small caps.

Weight
Specifies how thick or thin ePublisher displays text characters, such as bold. For a more precise
weight, select from the numeric values, which range from 100 to 900. For example, a weight of 400
is the same as normal and 700 is the same as bold.
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Footer Properties (Tables)
Tables created in Adobe FrameMaker identify the footer rows of tables, so you can quickly specify the
Footer and Footer background properties in the Table Styles properties in Style Designer to modify
footer rows for online delivery.

Tables created in Microsoft Word do not overtly identify footer rows. To control footer rows with
Microsoft Word and ePublisher, set up the table in your source document to reflect the desired
appearance, or use footer paragraph styles in the footer row of the table. Then, ePublisher uses the footer
paragraph styles in your source document and you can use the footer Table Styles properties in Style
Designer to modify the appearance as needed.

You can also specify footer padding properties for tables. Padding refers to the space between the table
footer border and the table footer content. You can change the left, top, right, and bottom padding values
independently or set all properties to have the same padding. Padding values must be positive numbers.

Left
Specifies the left padding for a table footer, or the space between the left table border and where
the content begins in the left of the table cell. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Top
Specifies the top padding for a table footer, or the space between the top table border and where the
content aligns at the top of the table cell. Set a custom padding value by selecting Custom, entering
a value, and selecting the unit of measure. Units of measure you can select include: percentages
(%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in), millimeters
(mm), picas (pc), point sizes (pt), and pixels (px).

Right
Specifies the right padding for a table footer, or the space between the right table border and where
the content ends at the right of the table cell. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Bottom
Specifies the bottom padding for a table footer, or the space between the bottom table border and
where the content ends at the bottom of the table cell. Set a custom padding value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Vertical
Specifies the vertical alignment of the content in a table footer. The values for this setting are
defined as: Top, Middle, and Bottom.
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Color (Borders, Table Styles)
Specifies the border color of a table footer. Select a color from the list or type the RGB value for
the border. RGB value refers to the web standard hexadecimal notation for Red, Green, and Blue
color values. RGB values can range from the lowest RGB value of 0  (hex #00 ) to the highest
value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black is 000000  and
white is FFFFFF .

Style
Specifies a border style for a table footer, such as a dotted, dashed, or solid line.

Not all browsers display border styles the same way. For example, some browsers may not
differentiate dotted lines from solid lines. Various browsers and operating systems often display the
size and spacing of the dots in a dotted line differently.

Width
Specify a width for the border of a table footer, such as a thick or thin border. Choose a value or
set a custom width by selecting Custom, entering a value, and selecting the unit of measure. Units
of measure you can select include: percentages (%) of the line height, centimeters (cm), em units
(em), x-height (ex), inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
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Footer Background Properties (Tables)
To help you visualize how you can modify properties, think of the footer rows of a table as sitting on a
layer above the background of a table. By modifying the color of the footer rows, you are applying an
opaque color over the color of the background color. You may need to modify other elements, such as
paragraphs, that reside within the footer row to get the desired results. For example, if you cannot make
the footer row transparent, make sure the background property is properly set for all the different layers in
the table.

Tables created in Adobe FrameMaker identify the footer rows of tables, so you can quickly specify the
Footer and Footer background properties in the Table Styles properties in Style Designer to modify
footer rows for online delivery.

Tables created in Microsoft Word do not overtly identify footer rows. To control footer rows with
Microsoft Word and ePublisher, set up the table in your source document to reflect the desired
appearance, or use footer paragraph styles in the footer row of the table. Then, ePublisher uses the footer
paragraph styles in your source document and you can use the footer Table Styles properties in Style
Designer to modify the appearance as needed.

Color
Specifies the background color for the table footer row. Select a color from the list or type the RGB
value of the color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for
Red, Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex
#00 ) to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black
is 000000  and white is FFFFFF .

Image (Background Image Area)
Specifies the background image for table footer rows. This field lists only the image files located
in the Files  folder of your project. If this field does not list the background image you want, press
F12  and verify the image is in the Files  folder for your project. Once you copy the image into the
Files  folder, ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling (Background Image Area)
Specifies whether the background image repeats in the table footer row. The table must be larger
than the background image to see the image repeated in the footer. The background image size also
determines if an image repeat shows when set horizontally or vertically. The values for this setting
are defined as follows:
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Value Description

No repeat Specifies that the background image does not repeat.

Repeat Specifies that the background image repeats.

Repeat horizontally Specifies that the background image repeats horizontally.

Repeat vertically Specifies that the background image repeats vertically.

Scrolling (Background Image Area)
Specifies whether the specified image remains in one fixed location as the user scrolls through
content. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through content.

Fixed Keeps the background image in a fixed location as the user
scrolls through content.

Horizontal (Background Image Area)
Specifies the horizontal position for the background image in your table footer row. The values for
this setting are defined as follows:

 

Value Description

Custom The background image aligns in the table footer based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em unit (em), x-height (ex), inches (in),
millimeters (mm), pica (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-width.

Left The left side of the background image aligns with the leftmost side
of the table footer.

Center The center of the background image aligns with the center of the
table footer.
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Value Description

Right The right side of the background image aligns with the right of the
table footer.

Vertical (Background Image Area)
Specifies the vertical position of the background image in your table footer. The values for this
setting are defined as follows:

 

Value Description

Custom The background image aligns in the table footer based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-height.

Top The top of the background image aligns with the top of the tallest
element in the table footer.

Center The center of the background image aligns with the middle of the
parent element in the table footer.

Bottom The bottom of the background image aligns with the lowest
element on the table footer.

Context
Specifies whether to use alternate rows or columns in a table. Alternate shading of rows or columns
is a useful layout to help minimize the number of lines and amount of information displayed, while
organizing the data in a way that users can easily read and understand.

Default period
Specifies the number of rows or columns that use the default color in the table footer row. You
must first set the default table footer row color in the Color field of the Footer background
properties. Specify a minimum value of 1. If you specify a value of 0, ePublisher does not use
alternate rows or columns and displays entire body row in the default color.

Alternate period
Specifies how many consecutive table footer rows or columns use the alternate color. Set this value
to a value greater than 0 (zero).

Alternate Color
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Specifies the alternate color for the table footer row. Select a color from the list or type the RGB
value of the color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for
Red, Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex
#00 ) to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black
is 000000  and white is FFFFFF .

Image (Alternate Info/Background Image Area)
Specifies the alternate background image for table footer rows. This field lists only the image files
located in the Files  folder of your project. If this field does not list the background image you
want, press F12  and verify the image is in the Files  folder for your project. Once you copy the
image into the Files  folder, ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling (Alternate Info/Background Image Area)
Specifies whether to repeat the alternate background image in the table footer rows. The table must
be larger than the background image to see the image repeated in the footer. The background image
size also determines if an image repeat shows when set horizontally or vertically. The values for
this setting are defined as follows:

 

Value Description

No repeat Specifies that the background image does not repeat.

Repeat Specifies that the background image repeats.

Repeat horizontally Specifies that the background image repeats horizontally.

Repeat vertically Specifies that the background image repeats vertically.

Scrolling (Alternate Info/Background Image Area)
Specifies whether the specified image remains in one fixed location as the user scrolls through
content. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through content.
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Value Description

Fixed Keeps the background image in a fixed location as the user
scrolls through content.

Horizontal (Alternate Info/Background Image Area)
Specifies the horizontal position for the alternate background image in table footer rows. The
values for this setting are defined as follows:

 

Value Description

Custom The alternate background image aligns in the table footer based
on the custom value entered and the unit of measure selected.
Units of measure you can select include: percentage (%) of the
line height, centimeters (cm), em unit (em), x-height (ex), inches
(in), millimeters (mm), pica (pc), point sizes (pt), and pixels (px).
For example, if you enter a value of 20 and select the percentage
(%) unit of measure, the top left corner is considered 0 percent
and the bottom right corner is 100 percent. So, ePublisher aligns
the background image in a 20% value of the line-width.

Left The left side of the alternate background image aligns with the
leftmost side of the table footer.

Center The center of the alternate background image aligns with the
center of the table footer.

Right The right side of the alternate background image aligns with the
right of the table footer.

Vertical (Alternate Info/Background Image Area)
Specifies the vertical position of the alternate background image in table footer rows. The values
for this setting are defined as follows:

 

Value Description

Custom The background image aligns in the table footer based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-height.
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Value Description

Top The top of the background image aligns with the top of the tallest
element in the table footer.

Center The center of the background image aligns with the middle of the
parent element in the table footer.

Bottom The bottom of the background image aligns with the lowest
element on the table footer.
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Header Properties (Tables)
Header rows are rows that contain information that identify the content of a particular column. If the table
spans several pages of a print layout, the header row usually repeats itself at the beginning of each new
page.

In Microsoft Word and Adobe FrameMaker, you can define a header row for your table. In FrameMaker,
you can also define a footer row. Body rows are typically all rows in a table not already defined as a
header or footer rows. However, unless you explicitly specify a row as a header row, ePublisher considers
all rows except the footer rows as body rows.

You can also specify footer padding properties for tables. Padding refers to the space between the table
header border and the table header content. You can change the left, top, right, and bottom padding values
independently or set all properties to have the same padding. Padding values must be positive numbers.

Left
Specifies the left padding for a table header, or the space between the left table border and where
the content begins in the left of the table cell. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Top
Specifies the top padding for a table header, or the space between the top table border and where
the content aligns at the top of the table cell. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Right
Specifies the right padding for a table footer, or the space between the right table border and where
the content ends at the right of the table cell. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Bottom
Specifies the bottom padding for a table header, or the space between the bottom table border and
where the content ends at the bottom of the table cell. Set a custom padding value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Vertical
Specifies the vertical alignment of the content in a table footer. The values for this setting are
defined as: Top, Middle, and Bottom.

Color
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Specifies the border color for a table header. Select a color from the list or type the RGB value of
the color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for Red,
Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex #00 )
to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black is
000000  and white is FFFFFF .

Style
Specifies a border style for a table header, such as a dotted, dashed, or solid line. Not all browsers
display border styles the same way. For example, some browsers may not differentiate dotted lines
from solid lines. Various browsers and operating systems often display the size and spacing of the
dots in a dotted line differently.

Width
Specifies a border width, such as a thick or thin border. Choose a value or set a custom width by
selecting Custom, entering a value, and selecting the unit of measure. Units of measure you can
select include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex),
inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
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Header Background Properties (Tables)
To help you visualize how you can modify properties, think of the header rows of a table as sitting on a
layer above the background of a table. By modifying the color of the header rows, you are applying an
opaque color over the color of the background header row to get the desired results. For example, if you
cannot make the header row transparent, make sure the background property is properly set for all the
different layers in the table.

Color
Specifies the background color for a table header. Select a color from the list or type the RGB value
of the color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for Red,
Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex #00 )
to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black is
000000  and white is FFFFFF .

Image (Background Image Area)
Specifies the background image for table header rows. This field lists only the image files located
in the Files  folder of your project. If this field does not list the background image you want, press
F12  and verify the image is in the Files  folder for your project. Once you copy the image into the
Files  folder, ePublisher displays it in the field list.

ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling (Background Image Area)
Specifies whether the background image repeats in table header rows. The table must be larger than
the background image to see the image repeated in the header. The background image size also
determines if an image repeat shows when set horizontally or vertically. The values for this setting
are defined as follows:

 

Value Description

No repeat Specifies that the background image does not repeat.

Repeat Specifies that the background image repeats.

Repeat horizontally Specifies that the background image repeats horizontally.

Repeat vertically Specifies that the background image repeats vertically.
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Scrolling (Background Image Area)
Specifies whether the specified image remains in one fixed location as the user scrolls through
content. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through content.

Fixed Keeps the background image in a fixed location as the user
scrolls through content.

Horizontal (Background Image Area)
Specifies the horizontal position for the background image in your table header row. The values for
this setting are defined as follows:

 

Value Description

Custom The background image aligns in the table header based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em unit (em), x-height (ex), inches (in),
millimeters (mm), pica (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-width.

Left The left side of the background image aligns with the leftmost side
of the table header.

Center The center of the background image aligns with the center of the
table header.

Right The right side of the background image aligns with the right of the
table header.

Vertical (Background Image Area)
Specifies the vertical position of the background image in your table header row. The values for
this setting are defined as follows:
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Value Description

Custom The background image aligns in the table header based on the
custom value entered and the unit of measure selected. Units
of measure you can select include: percentage (%) of the line
height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px). For
example, if you enter a value of 20 and select the percentage (%)
unit of measure, the top left corner is considered 0 percent and
the bottom right corner is 100 percent. So, ePublisher aligns the
background image in a 20% value of the line-height.

Top The top of the background image aligns with the top of the tallest
element in the table header.

Center The center of the background image aligns with the middle of the
parent element in the table header.

Bottom The bottom of the background image aligns with the lowest
element on the table header.

Context
Specifies whether to use alternate rows or columns in a table header. Alternate shading of rows
or columns is a useful layout to help minimize the number of lines and amount of information
displayed, while organizing the data in a way that users can easily read and understand.

Default period
Specifies the number of rows or columns that use the default color in the table header row. You
must first set the default table header row color in the Color field of the Header background
properties. Specify a minimum value of 1. If you specify a value of 0, ePublisher does not use
alternate rows or columns and displays entire table header row in the default color.

Alternate period
Specifies how many consecutive table header rows or columns will use the alternate color. Set this
value to a value greater than 0.

Alternate Color
Specifies the alternate color for the table header row. Select a color from the list or type the RGB
value of the color, such as FFFFFF . RGB value refers to the web standard hexadecimal notation for
Red, Green, and Blue color values. RGB values can range from the lowest RGB value of 0  (hex
#00 ) to the highest value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black
is 000000  and white is FFFFFF .

Image (Alternate Info/Background Image Area)
Specifies the alternate background image you want to use for your table header row. This field
lists only the image files located in the Files  folder of your project. If this field does not list
the background image you want, press F12  and verify the image is in the Files  folder for your
project. Once you copy the image into the Files  folder, ePublisher displays it in the field list.
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ePublisher Pro automatically transforms your source document images during project generation
to an optimized version for online distribution. However, you can manually modify your project
image settings through the Graphic Styles properties in Style Designer. In Graphic Styles, you
can specify the following image settings: border styles and colors; width, height, and positioning;
surrounding space (padding); maximum width or height; size, resolution, and color bit depth; file
format and quality level; and transparency or grayscale appearance.

Tiling (Alternate Info/Background Image Area)
Specifies whether to repeat the alternate background image in table header rows. The table must be
larger than the background image to see the image repeated in the header. The background image
size also determines if an image repeat shows when set horizontally or vertically. The values for
this setting are defined as follows:

 

Value Description

No repeat Specifies that the background image does not repeat.

Repeat Specifies that the background image repeats.

Repeat horizontally Specifies that the background image repeats horizontally.

Repeat vertically Specifies that the background image repeats vertically.

Scrolling (Alternate Info/Background Image Area)
Specifies whether the specified image remains in one fixed location as the user scrolls through
content. The values for this setting are defined as follows:

 

Value Description

Scroll Scrolls the background image as the user scrolls through content.

Fixed Keeps the background image in a fixed location as the user
scrolls through content.

Horizontal (Alternate Info/Background Image Area)
Specifies the horizontal position of the alternate background image in table header rows. The
values for this setting are defined as follows:
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Value Description

Custom The alternate background image aligns in the table header based
on the custom value entered and the unit of measure selected.
Units of measure you can select include: percentage (%) of the
line height, centimeters (cm), em unit (em), x-height (ex), inches
(in), millimeters (mm), pica (pc), point sizes (pt), and pixels (px).
For example, if you enter a value of 20 and select the percentage
(%) unit of measure, the top left corner is considered 0 percent
and the bottom right corner is 100 percent. So, ePublisher aligns
the background image in a 20% value of the line-width.

Left The left side of the alternate background image aligns with the
leftmost side of the table header.

Center The center of the alternate background image aligns with the
center of the table header.

Right The right side of the alternate background image aligns with the
right of the table header.

Vertical (Alternate Info/Background Image Area)
Specifies the vertical position of the alternate background image in table header rows. The values
for this setting are defined as follows:

 

Value Description

Custom The alternate background image aligns in the table header based
on the custom value entered and the unit of measure selected.
Units of measure you can select include: percentage (%) of the
line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
For example, if you enter a value of 20 and select the percentage
(%) unit of measure, the top left corner is considered 0 percent
and the bottom right corner is 100 percent. So, ePublisher aligns
the background image in a 20% value of the line-height.

Top The top of the alternate background image aligns with the top of
the tallest element in the table header.

Center The center of the alternate background image aligns with the
middle of the parent element in the table header.

Bottom The bottom of the alternate background image aligns with the
lowest element on the table header.
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HTML Properties
Part of the power of ePublisher lies in its ability to produce as many different outputs of your information
as you need. This can include everything from print material, to online help files and web content. While
online output formats can vary a great deal from one another, most are based on HTML. By modifying
styles in Style Designer to include HTML coding properties, you can set up your files to take advantage
of web formatting in properties such as paragraphs, characters, tables, images, and page styles. Once you
have added HTML properties to your content styles, you can quickly and easily publish content to the
web or online.

Tag
Specifies the HTML tag to use for the selected item. By default, ePublisher uses a DIV tag for each
paragraph and assigns a class based on the style name. You can change the DIV tags to P tags for
specific styles by specifying a P in this property for those paragraph styles.

Visibility
Specifies whether to show or hide the selected item by default. This property allows you to hide a
paragraph initially, and then provide a method to show the paragraph.

Width
Specifies the fixed width, including a custom value and the unit of measure, for the selected
item. Leave this value blank if you do not want to specify a fixed width for the selected item. For
example, if you want your margin settings to control the width of a paragraph, do not specify a
width value for your paragraph style.

Height
Specifies the fixed height, including a custom value and the unit of measure, for the selected
item. Leave this value blank if you do not want to specify a fixed height for the selected item. For
example, if you want the amount of content in a paragraph to control the height of that paragraph,
do not specify a height value for your paragraph style.

Left (Positioning Area)
Specifies how far the left edge of the item, such as a paragraph or image, is offset to the right of the
left edge of the block that contains the item. Percentages refer to the containing block. This value
works with the value selected for the Type property.

Top (Positioning Area)
Specifies how far the top edge of the item, such as a paragraph or image, is offset below the top
edge of the block that contains the item. Percentages refer to the height of the containing block.
This value works with the value selected for the Type property.

Right (Positioning Area)
Specifies how far the right edge of the item, such as a paragraph or image, is offset to the left of
the right edge of the block that contains the item. Percentages refer to the width of the containing
block. This value works with the value selected for the Type field.

Bottom (Positioning Area)
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Specifies how far the bottom edge of the item, such as a paragraph or image, is offset above the
bottom of the block that contains the item. Percentages refer to the height of the containing block.
This value works with the value selected for the Type field.

Type
Specifies the type of position scheme. This property controls how the browser processes the
positioning values of Left, Top, Right, and Bottom. The values for this setting are defined as
follows:

 

Value Description

Static Places the item, such as a paragraph or image, in the same
location as it would normally occupy in the normal flow. Left and
Top positioning properties do not apply when you select Static.

Relative Offsets the position of the item, such as a paragraph or image,
from its normal position in the normal flow and ignores other
objects positioned outside of the normal flow with the Absolute
property.

Absolute Positions the item, such as a paragraph or image, in a specific
location. The item is not considered as part of the normal flow and
it is not considered in the layout of objects that follow. Absolute
objects do not affect objects that use the Static or Relative value.

Float
Specifies whether to shift the paragraph to the left or right on the current line and allow content to
flow along the side of the paragraph. Use this field to assign images to align on the left or right and
allow the text to flow into the open area next to the image. You can also create pull quotes or other
sidebars using the Float field, as well as create interesting side effects when combined with border
styles.

Use of the Float property may also be prohibited by the Clear property. If the content of the
paragraph stretches across the width of the entire page, you may not see any noticeable change
unless you assign a smaller width for the paragraph using the Width property. The values for this
setting are defined as follows:

 

Value Description

None Does not allow other content in the normal flow to float to the right
or left of this item.

Left Aligns this item to the left and allows content in the normal flow to
be displayed along the right side.
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Value Description

Right Aligns this item to the right and allows content in the normal flow
to be displayed along the left side.

Clear
Specifies which sides of an item, such as a paragraph or image, may not be adjacent to an earlier
floating box. If you set this property on a floating paragraph, it modifies the rules for positioning
the float. The values for this setting are defined as follows:

 

Value Description

None Does not constrain the position with respect to floats.

Left Increases the top margin of the item enough so that the top
border edge is below the bottom outer edge of any left-floating
boxes that resulted from elements earlier in the source document.

Right Increases the top margin of the item enough so that the top
border edge is below the bottom outer edge of any right-floating
boxes that resulted from elements earlier in the source document.

Both Moves the item below all floating boxes of earlier elements in the
source document.

Display
Specifies the Cascading Style Sheet (CSS) box type, or how to generate CSS boxes for the selected
item, such as a paragraph or image. The values for this setting are defined as follows:

 

Value Description

None Does not generate boxes in the formatting structure. When you
select this option, the item does not display and the browser
treats it as though it does not exist.

Block Generates a principal block box.

Inline Uses the layout properties of the previous element.

List item Displays the item that does not ordinarily display as a list item,
such as a bullet or number, as a list item if it is inside a list.

238 | HTML Properes



Z-Index
Specifies an integer that corresponds with the position of the paragraph on the z-axis. Elements
with a lower value, such as 1, are displayed behind other elements with a higher value, such as 2.
You can also specify negative numbers.

Left (Clipping Area)
Specifies the area of the left side of an image that is visible, when the image is larger than the web
element that it sits inside. ePublisher disregards the Clipping area fields when the Overflow field
is set to Visible.

Top Left (Clipping Area)
Specifies the area to the top of an image that is visible, when the image is larger than the web
element that it sits inside. ePublisher disregards the Clipping area fields when the Overflow field
is set to Visible.

Right Left (Clipping Area)
Specifies the area to the right side of an image that is visible, when the image is larger than the web
element that it sits inside. ePublisher disregards the Clipping area fields when the Overflow field
is set to Visible.

Bottom Left (Clipping Area)
Specifies the area to the bottom of an image that is visible, when the image is larger than the web
element that it sits inside. ePublisher disregards the Clipping area fields when the Overflow field
is set to Visible.

Cursor
Specifies the type of cursor to be displayed when pointing on an element in your HTML output.
The values for this setting are defined as follows:

 

Value Description

Default Displays the default cursor.

Auto Specifies that the browser sets the cursor style.

Crosshair Specifies that the browser sets the cursor as a crosshair.

Pointer (Hand) Specifies that the browser sets the cursor as a pointer (hand),
which indicates the cursor is over a link.

Move Specifies that the browser sets the cursor to indicate an element
must be moved.

Resize East Specifies that the browser sets the cursor to indicate an element
must be moved to the right (east).

Resize Northeast Specifies that the browser sets the cursor to indicate an element
must be moved up and to the right (northeast).
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Value Description

Resize Northwest Specifies that the browser sets the cursor to indicate an element
must be moved up and to the left (northwest).

Resize North Specifies that the browser sets the cursor to indicate an element
must be moved up (north).

Resize Southeast Specifies that the browser sets the cursor to indicate an element
must be moved down and to the right (southeast).

Resize Southwest Specifies that the browser sets the cursor to indicate an element
must be moved down and to the left (southwest).

Resize South Specifies that the browser sets the cursor to indicate an element
must be moved down (south).

Resize West Specifies that the browser sets the cursor to indicate an element
must be moved left (west).

Text Specifies that the browser sets the cursor to indicate an element
is text.

Wait Specifies the browser sets the cursor to indicate that the program
is busy (and often displays a watch or an hourglass).

Help Specifies the browser sets the cursor to indicate that help is
available (and often displays a question mark or balloon).

Overflow
Specifies how the output displays if the content of an element overflow its area. If you set the
Overflow field to Visible, any Clipping area properties you set are disregarded. The values for this
setting are defined as follows:

 

Value Description

Auto Indicates the browser displays a scroll bar for viewing content that
overflows its area.

Visible Indicates the browser does not clip the image or content that
overflows its area. Instead, it displays the content outside the
element.

Hidden Indicates the browser clips the content that overflows its area, but
does not display a scroll-bar for viewing the rest of the content.
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Value Description

Scroll Indicates the browser clips the content that overflows its area, but
displays a scroll-bar for viewing the rest of the content.
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Margin Properties
You can alter the white space around a paragraph by adjusting the margin and the padding. In terms of the
CSS box model, modifying the margin properties adjusts the space outside the border area. For example,
if you create a border or background color for a paragraph and you increase the size of the margins around
the paragraph, the border remains the same distance from the text in the paragraph. However, the position
of the paragraph changes because there is more white space between the modified paragraph and the other
elements on the page. You can set margin properties for paragraphs, characters, tables, images, and pages
from Style Designer.

Left
Specifies the amount of space to the left of a border area. Set a custom margin value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px). If you select Auto, ePublisher
automatically sets the margin value based on the settings already indicated in the project.

Top
Specifies the amount of space above a border area. Set a custom margin value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px). If you select Auto, ePublisher
automatically sets the margin value based on the settings already indicated in the project.

Right
Specifies the amount of space to the right of a border area. Set a custom margin value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px). If you select Auto, ePublisher
automatically sets the margin value based on the settings already indicated in the project.

Bottom
Specifies the amount of space below a border area. Set a custom margin value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px). If you select Auto, ePublisher
automatically sets the margin value based on the settings already indicated in the project.
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Master Page Properties (Pages)
You can control the layout of all your generated pages for output formats that require handling of
pagination (i.e. PDF - XSL-FO output format). For detailed information on these master page properties
see: http://www.w3.org/TR/xsl11/#fo_simple-page-master.

Even Master Page
This tab allows you to specify the main layout properties of all even pages in your generated
output. You can modify parameters such as the overall page size, number of columns, size of the
column gap, and the margin with this set of properties.

Even Master Page: After Region
This tab allows you to specify the layout properties for the FO defined region-after  area of all
even pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Even Master Page: Before Region
This tab allows you to specify the layout properties for the FO defined region-before  area of all
even pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Even Master Page: Body Region
This tab allows you to specify the layout properties for the FO defined region-body  area of all
even pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Even Master Page: End Region
This tab allows you to specify the layout properties for the FO defined region-end  area of all
even pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Even Master Page: Start Region
This tab allows you to specify the layout properties for the FO defined region-start  area of all
even pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Odd Master Page
This tab allows you to specify the main layout properties of the first page and all odd pages in your
generated output. You can modify parameters such as the overall page size, number of columns,
size of the column gap, and the margin with this set of properties.

Odd Master Page: After Region
This tab allows you to specify the layout properties for the FO defined region-after  area of all
odd pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Odd Master Page: Before Region
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This tab allows you to specify the layout properties for the FO defined region-before  area of all
odd pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Odd Master Page: Body Region
This tab allows you to specify the layout properties for the FO defined region-body  area of all
odd pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Odd Master Page: End Region
This tab allows you to specify the layout properties for the FO defined region-end  area of all
odd pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.

Odd Master Page: Start Region
This tab allows you to specify the layout properties for the FO defined region-start  area of all
odd pages in your generated output. You can modify parameters such as the background, clipping
region, alignment, extent, overflow behavior, reference orientation, and writing mode.
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Navigation Properties (Pages)
Effective online documentation requires extra navigation features over print documentation. In addition,
online output follows different rules regarding the number of page breaks and includes unique page
layouts for specific information. From Style Designer, you can specify navigation details for content
pages in Page Styles properties.

If you include navigation buttons in your online output, ePublisher lets you specify several options for
where the navigation features display. Keep in mind that not all output formats support navigation links.

You can form a linked path to show users the location of the current topic in your online content. This
clickable path, called breadcrumbs, steps you through the topics that are responsible for getting you to
the topic being viewed. Breadcrumbs can display at the top of the page, at the bottom of the page, or both.
ePublisher sets the breadcrumb trail to the top of the output page by default.

Top (Navigation Alignment)
Specifies how to align the top navigation browse buttons in your online output, such as Left,
Center or Right. To display navigation browse buttons at the top of the page, click the Options tab
and set the Navigation links shown at top of page option to Enabled for this page style. Then, set
the Navigation Properties from the Properties tab in Page Styles.

Bottom (Navigation Alignment)
Specifies how to align the bottom navigation browse buttons in your online output, such as Left,
Center or Right. To display navigation browse buttons at the bottom of the page, click the Options
tab and set the Navigation links shown at top of page option to Enabled for this page style. Then,
set the Navigation Properties from the Properties tab in Page Styles.

Separator
Specifies the separator characters to use between breadcrumb items. The default character is a
colon (:).

Top (Breadcrumb Alignment)
Specifies how to align the breadcrumbs at the top of the page. To display breadcrumbs at the top of
the page, you must also set the Breadcrumbs shown at top of page option on the Options tab to
Enabled for this page style.

Bottom (Breadcrumb Alignment)
Specifies how to align the breadcrumbs at the bottom of the page. To display breadcrumbs at the
bottom of the page, you must also set the Breadcrumbs shown at bottom of page option on the
Options tab to Enabled for this page style.
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Padding Properties
You can adjust the white space around a paragraph by altering the margin and the padding values.
Padding refers to the space between the border and the content. You can change the Left, Top, Right,
and Bottom padding values independently. Padding values must be positive numbers.

In terms of the CSS box model, modifying the padding properties adjusts the space inside the border area.
For example, if you create a border or background color for a paragraph and you increase the size of the
padding, the border moves away from the text in the paragraph.

You can set padding properties for paragraphs, characters, pages, tables, and graphic styles in Style
Designer. Refer to“Table Properties (Tables)” for details on how to set padding properties in a table.

Left
Specifies the left padding, or the space between the left border and the left content margin. Set a
custom padding value by selecting Custom, entering a value, and selecting the unit of measure.
Units of measure you can select include: percentages (%) of the line height, centimeters (cm), em
units (em), x-height (ex), inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
If you select Auto, ePublisher automatically sets the padding value based on the settings already
indicated in the project.

Top
Specifies the top padding, or the space between the top border and where the content aligns at the
top of the page. Set a custom padding value by selecting Custom, entering a value, and selecting
the unit of measure. Units of measure you can select include: percentages (%) of the line height,
centimeters (cm), em units (em), x-height (ex), inches (in), millimeters (mm), picas (pc), point sizes
(pt), and pixels (px). If you select Auto, ePublisher automatically sets the padding value based on
the settings already indicated in the project.

Right
Specifies the right padding, or the space between the right border and the right content margin. Set
a custom padding value by selecting Custom, entering a value, and selecting the unit of measure.
Units of measure you can select include: percentages (%) of the line height, centimeters (cm), em
units (em), x-height (ex), inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).
If you select Auto, ePublisher automatically sets the padding value based on the settings already
indicated in the project.

Bottom
Specifies the bottom padding, or the space between the bottom border and where the content ends
at the bottom of the page. Set a custom padding value by selecting Custom, entering a value, and
selecting the unit of measure. Units of measure you can select include: percentages (%) of the line
height, centimeters (cm), em units (em), x-height (ex), inches (in), millimeters (mm), picas (pc),
point sizes (pt), and pixels (px). If you select Auto, ePublisher automatically sets the padding value
based on the settings already indicated in the project.
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Pagination Properties
Available only in the PDF - XSL-FO format.

These properties are for use with output formats that require print related pagination characteristics.

Force Page Count
Forces the generated pages to end in a certain manner. The values for this property are defined as
follows:

 

Value Description

Auto Force the last page in this page-sequence to be an odd-page if the initial-page-
number of the next page-sequence is even. Force it to be an even-page if the
initial-page-number of the next page-sequence is odd. If there is no next page-
sequence or if the value of its initial-page-number is "auto" do not force any
page.

Even Force an even number of pages in this page-sequence.

Odd Force an odd number of pages in this page-sequence.

End on Even Force the last page in this page-sequence to be an even-page.

End on Odd Force the last page in this page-sequence to be an odd-page.

Do Not Force Do not force either an even or an odd number of pages in this page-sequence.

Inherit Use the value of the parent page style’s page property of the same name.

Initial Page Number
Specifies the initial folio number to be used in this page-sequence. The values for this property are
defined as follows:

 
 

Value Description

Auto The initial folio number shall be set to 1 if no previous page sequence exists in
the document. If a preceding page-sequence exists, the initial folio number will
be one greater than the last number for that sequence.

Next Odd Page A value is determined in the same manner as for Auto. If that value is an even
number 1 is added.
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Value Description

Next Even Page A value is determined in the same manner as for Auto. If that value is an odd
number 1 is added.

n A positive integer.

Page Number Format
Specifies the page numbering style to use for the generated page numbers in the output. For
detailed information on page numbering see: https://www.w3.org/TR/xslt#number. The values for
this property are defined as follows:

 
 
 

Value Description

1 Specify a numbering sequence that starts with this token. If an
implementation does not support a numbering sequence that starts with that
token, it must use a format token of 1.

a Use lowercase alphabetic sequences for the page numbering.

A Use uppercase alphabetic sequences for the page numbering.

i Use lowercase roman numeral page numbering.

I Use uppercase roman numeral page numbering.

Page Number Letter Value
Specifies characteristics for numbering sequences that use letter values. For detailed information on
page numbering see: https://www.w3.org/TR/xslt#number. The values for this property are defined
as follows:

 

Value Description

Auto Use the default behavior of the implementation.

Alphabetic Use letter values based on their alphabetic sequence.

Traditional Use letter values based on what is traditional for the language that is being
generated.
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Table Properties (Tables)
ePublisher gives you the power to adjust padding, spacing, alignment and layout properties for your
content tables. Padding refers to the space between the table cell border and the table cell content. You
can change left, top, right, and bottom padding values independently. Padding values must be positive
numbers.

Left
Specifies the left padding for the entire table. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Top
Specifies the top padding the entire table. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Right
Specifies the right padding for the entire table. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Bottom
Specifies the bottom padding for the entire table. Set a custom padding value by selecting Custom,
entering a value, and selecting the unit of measure. Units of measure you can select include:
percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches (in),
millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Border
Specifies the size of the border for a table. Borders are lines that you can draw around any or all
of the four sides of a table.This field sets the border for the outer edge of the entire table, not the
border of cells within the table. This is an HTML property, so you do not need to specify a unit of
measure. If you do not specify a border attribute, ePublisher displays the table without any borders.

Cell spacing
Specifies the amount of space between cells of a table. Use cell spacing to create a transparent
space, or increase the distance between table cells. This is an HTML property, so you do not need
to specify a unit of measure.

Cell padding
Specifies the amount of space between the cell content and its borders. This is an HTML property,
so you do not need to specify a unit of measure.

Border collapse
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Specifies whether table borders collapse into a single border or remain detached as with standard
HTML. The values for this setting are defined as follows:

 

Value Description

Collapse Collapses borders into a single border.

Separate Keeps borders detached.

Border spacing
Specifies the distance between the borders of adjacent cells. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px). Border spacing values cannot be
negative numbers.

Caption side
Specifies the position of the table caption in relation to the table. The values for this setting are
defined as: Top and Bottom.

Empty cells
Specifies whether to display empty table cells or to hide them. The values for this setting are
defined as follows:

 

Value Description

hide Indicates no borders are drawn around empty table cells.

show Indicates borders are drawn around empty cells.

Table layout
Specifies whether the table layout is automatic or fixed. The values for this setting are defined as
follows:

 

Value Description

Auto Specifies the browser sets the column width of a table by the
contents of the table cells. This setting can slow down browser
display time because the browser must access all table content
before it can determine the final layout.
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Value Description

Fixed Specifies the browser displays the table layout using settings for
table width and the width of columns, not based on the content
in the table cells. By setting a fixed table layout, the browser can
quickly display the table once it receives the first row of table
content.

Horizontal
Specifies the horizontal alignment of the content in a table. The values for this settings are defined
as: Left, Center, Right, and Justify.

Vertical
Specifies the vertical alignment of the content in a table. The values for this setting are defined as:
Top, Middle, and Bottom.
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Text Properties
Color

Specifies the color for the text. Select a color from the list or type the RGB value of the color, such
as FFFFFF . RGB value refers to the web standard hexadecimal notation for Red, Green, and Blue
color values. RGB values can range from the lowest RGB value of 0  (hex #00 ) to the highest
value of 255  (hex #FF ). For example, the RGB hexidecimal notation for black is 000000  and
white is FFFFFF .

Transform
Specifies whether to display the text in a specific way regardless of how the text is in the source
documents. You can transform the text to capitalize the first letter of each word, all upper case
letters, or all lower case letters. To leave the text as it is in the source documents, select None.

White space
Specifies how the browser displays white space, or extra spaces, within text. The values for this
setting are defined as follows:

 

Value Description

Normal Specifies the browser ignores extra white space.

Pre Specifies the browser preserves all white space. This setting
indicates the browser acts as it does with the <pre> tag in HTML.

No wrap Specifies the browser does not wrap text. The browser displays
text on the same line until it encounters a <br> tag.

Word spacing
Specifies the amount of space between words. This field allows you to adjust the kerning between
words and defaults to Normal spacing. Set a custom spacing value by selecting Custom, entering a
value, and selecting the unit of measure. Units of measure you can select include: percentages (%)
of the line height, centimeters (cm), em units (em), x-height (ex), inches (in), millimeters (mm),
picas (pc), point sizes (pt), and pixels (px). You can adjust the spacing within words with the Letter
spacing field.

Letter spacing
Specifies the amount of space between letters within a word. This field allows you to adjust the
kerning within words and defaults to Normal spacing. Set a custom spacing value by selecting
Custom, entering a value, and selecting the unit of measure. Units of measure you can select
include: percentages (%) of the line height, centimeters (cm), em units (em), x-height (ex), inches
(in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px). You can adjust the spacing
between words with the Word spacing field.
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Line height
Specifies the amount of space between each line within a paragraph. This spacing is also known
as lettingor line height. This field defaults to Normal spacing between lines. Set a custom height
value by selecting Custom, entering a value, and selecting the unit of measure. Units of measure
you can select include: percentages (%) of the line height, centimeters (cm), em units (em), x-
height (ex), inches (in), millimeters (mm), picas (pc), point sizes (pt), and pixels (px).

Underline style
Specifies whether to display a line underneath a character or the text of a paragraph. The underline
may go through the bottoms of letters that drop below the main letter line, such as lowercase g, p,
and q, which can make reading the text more difficult.

Underline color
Specifies the color of the line you choose to display underneath a character or the text of a
paragraph. Select a color from the list or type the RGB value of the color, such as FFFFFF . RGB
value refers to the web standard hexadecimal notation for Red, Green, and Blue color values. RGB
values can range from the lowest RGB value of 0  (hex #00 ) to the highest value of 255  (hex
#FF ). For example, the RGB hexidecimal notation for black is 000000  and white is FFFFFF .

Overline style
Specifies whether to display a line above a character or the text of a paragraph.

Line through style
Specifies whether to display a line through the middle of a character or the text of a paragraph, also
called a strike-through line.

Blink
Specifies whether the character or the text of a paragraph blinks or flashes. Keep in mind, blinking
text can be difficult to read and distracting on a page, so use this feature sparingly.

Horizontal
Specifies the horizontal position for the character or the text of a paragraph. The values for this
setting are defined as follows:

 

Value Description

Custom Aligns the character or paragraph based on the custom value
entered and the unit of measure selected. Units of measure you
can select include: percentage (%) of the line height, centimeters
(cm), em unit (em), x-height (ex), inches (in), millimeters (mm),
pica (pc), point sizes (pt), and pixels (px).

Left Aligns the left side of a paragraph with the left margin of the
layout.

Center Aligns the center of a paragraph with the center of the layout.

Right Aligns the right side of the paragraph with the far right margin of
the layout.
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Value Description

Justify Aligns a paragraph of text along both the left and right margins.
In justified text, the spaces between words and letters (kerning)
is stretched or sometimes compressed to make the text align with
the left and right margins.

Vertical
Specifies the vertical alignment for a character or the text of a paragraph. The values for this setting
are defined as follows:

 

Value Description

Baseline Aligns the paragraph or character on the baseline of the text line.

Sub Aligns the paragraph or character as subscript.

Super Aligns the paragraph or character as superscript.

Top Aligns the paragraph or character with the top of the tallest item
on the line.

Text Top Aligns the paragraph or character with the top of the text line.

Middle Aligns the paragraph or character with the middle of text line.

Bottom Aligns the paragraph or character with the bottom of the lowest
item on the line.

Text Bottom Aligns the paragraph or character with the bottom of the text font.

Indent
Specifies a custom indentation value for a paragraph. Enter the indentation value and select the unit
of measure. Units of measure you can select include: percentage (%) of the line height, centimeters
(cm), em unit (em), x-height (ex), inches (in), millimeters (mm), pica (pc), point sizes (pt), and
pixels (px).

Direction
Specifies the direction the text should be read. This field works with the Unicode Bidi field to
ensure the browser correctly displays your content. If unspecified, ePublisher sets the text direction
as left-to-right by default.

If a document contains right-to-left characters, and if the browser can display the language with the
proper character set, the browser must apply the bidirectional algorithm. If you prefer to control the
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handling of a particular phrase, you can apply a character style to that phrase and then define the
character style with the Direction and Unicode Bidi fields.

Unicode Bidi
Specifies the bidrectional aspect to use when there are some characters in the text within a single
paragraph that can be read from left to right, while other text within the paragraph can be read
from right to left. In some documents, such as those written with the Arabic or Hebrew script,
and in some mixed-language contexts, text within a single paragraph may appear with mixed
directionality. This phenomenon is called bidirectionality, or bidi for short.

If a document contains right-to-left characters, and if the browser is able to display the language
with the proper character set, the browser must apply the bidirectional algorithm. The proper
character set means to not display arbitrary substitutes such as a question mark, a hex code, or a
black box for some characters,

This property allows you to display text within a single paragraph with mixed directionality. The
values for this property are defined as follows:

 

Value Description

Normal Allows implicit use of bidirectional.

Embed Allows the Unicode-bidi algorithm to choose when it is appropriate
to use the value specified for the Direction property. Only the
specific text that is read in a different direction will be modified.
The rest of the paragraph remains in its default direction.

Bidi override Forces the characters to be displayed using the value specified
for the Direction property. All text in the paragraph is modified to
reflect a different direction, completely overriding any instructions
to display the text in the default direction.
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Paragraph Styles Options
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. For example, the options define table of contents levels, popup
windows, and related topics, as well as many other features and behaviors.

Additional CSS classes
Specifies an additional class name to include in the output class name for the selected style. This
option is helpful if you are using a custom .css  file. ePublisher supports this option only in output
formats that support cascading style sheets. This option is available all styles except marker styles.

This option lets you specify other classes to add to the class statement in the generated output for
the selected style. For example, if you have a class in your .css  file called Red  that defines the
text color as red, you can specify Red  in the Additional CSS classes option for each style you
want to have red text. ePublisher adds this class to the class name in the generated output, such as
classname=”sourcestylename Red” .

Apply character styles
Specifies whether ePublisher uses the character style formatting within the selected paragraph style.
Character styles specify characteristics like font size and style for one or more characters. When
you set the Apply character styles option to Enabled, ePublisher applies character formatting to
the content within the selected paragraph style in your source documents. This option is available
only for paragraph styles.

Citation
Specifies that ePublisher recognizes and formats the text with this style as quotation content. A
citation is a reference or footnote to a book, article, or other material that specifies the source from
which a quotation was borrowed. The citation for a quote enables users to go to a Web site that
contains more information about the quote.

You must define a Citation paragraph or character format and a Citation marker to specify a URL
citation. The paragraph or character format with this option enabled identifies the quote in the
generated output. The Citation marker defines the URL for the Web site with more information.
When you hover over the quote in the output file, a popup window displays the URL. This option is
available only for paragraph and character styles.

Dropdown
Specifies whether to use the selected paragraph style to define an expand/collapse section, also
called a dropdown hotspot. Some output formats do not support expand/collapse sections.

You can configure the expand/collapse section to initially be hidden or shown. When the user clicks
the dropdown hotspot, the content expands and collapses to allow the user to view more or less
information. The expand/collapse content can include multiple paragraph styles. You can use the
DropDownEnd marker to identify the end of the expand/collapse content. If you have a specific
paragraph style that always serves as the ending point for your expand/collapse content and is
not included in the expand/collapse content, set this option for that paragraph style to Break. By
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default, all paragraph styles are included in the expand/collapse content. The values for this setting
are defined as follows:

 

Value Description

Break Specifies the paragraph style is never included in expand/collapse
content. A paragraph style with this option set to Break ends the
expand/collapse content section.

Continue Specifies the selected paragraph style does not change the expand/
collapse content output. If the selected paragraph style is within
an expand/collapse content section, the Continue value directs
ePublisher to include the content as part of the expand/collapse
content. This value is the default for paragraph styles.

End Allows the content to be inside the dropdown selection but it will
signify the end of the droprdown similar to the behavior of a marker.

Start open Displays the content in the expand/collapse section when the page
is initially displayed. The paragraph with this option set provides the
hotspot where the user can click to show or hide the expand/collapse
content. This paragraph style starts the expand/collapse section.

Start closed Hides the content in the expand/collapse section when the page is
initially displayed. The paragraph with this option set provides the
hotspot where the user can click to show or hide the expand/collapse
content. This paragraph style starts the expand/collapse section.

Element name
Specifies the name of the element that contains the content of the associated style when ePublisher
converts it to XML output. This option is available only for paragraph styles and graphic styles for
the XML+XSL output format.

Generate output
Specifies whether the selected style is included in the generated output. This option is available for
all styles except marker styles. By default. the Generate output option is set to Enabled so that all
content is included in the output. If you select Disabled, the content with the selected style does not
appear in the generated output.

Glossary behavior
Specifies whether ePublisher uses the paragraph style to format glossary terms and definitions
displayed on the Glossary tab in Sun JavaHelp. This option is available only for the Sun JavaHelp
output format.

Keep empty paragraphs
Specifies whether ePublisher generates output for paragraphs with the selected style that do not
have any content. For example, at the end of chapters in Microsoft Word, you may have multiple
blank paragraphs to create the footer on a blank even page. To exclude the empty paragraphs from
your generated content, select the paragraph style of the blank paragraphs in Style Designer and set
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the Keep empty paragraphs option to Disabled. If you leave this option set to its default value of
Enabled, ePublisher can display blank lines in your generated output.

Keep paragraph numbering
Specifies whether ePublisher includes the auto-generated numbers for the selected paragraph style
in your source documents. For example, chapter titles, headings, figure captions, and table captions
may have auto-numbering in your source documents that you do not want to include in your online
content. To exclude the autonumbering, select the paragraph style that contains autonumbering and
set the Keep paragraph numbering option to Disabled.

Keep paragraph numbering in TOC
Specifies whether ePublisher includes the auto-generated numbers for the selected paragraph
style in your source documents that have been defined to have a Table of Contents level by the
Paragraph Style’s Options. To exclude the autonumbering, select the paragraph style that contains
autonumbering and set the Keep paragraph numbering in TOC option to Disabled.

Mini-TOC levels
Specifies whether to include a miniature table of contents (mini-TOC), also known as a partial table
of contents, and what table of contents levels to include in the mini-TOC. A mini-TOC provides
a small-scale look at the topics in the upcoming section. The topic titles are displayed as links
beneath the current topic heading for easier navigation within the section.

ePublisher does not create mini-TOCs by default. To create a mini-TOC following a paragraph
style. set this option to a value other than None. ePublisher generates the mini-TOC on all pages on
which the selected paragraph style occurs. ePublisher creates the mini-TOC for all styles with TOC
level settings in the specified range between the selected paragraph style of the current topic and
the next occurrence of this same style. The values for this setting are defined as follows:

 

Value Description

All Creates a mini-TOC for all TOC levels up to the next occurrence of the current
paragraph style and displays the mini-TOC on all output pages on which this
paragraph style occurs.

None Does not create a mini-TOC.

n Creates a mini-TOC for all TOC levels from 1 through the number specified
(where n equals any numeric value), up to the next occurrence of the current
paragraph style. The mini-TOC is displayed on all output pages on which this
paragraph style occurs. For example, if you specify 1, ePublisher creates
a mini-TOC for all TOC levels 1, up to the next occurrence of the current
paragraph style. If you specify 4, ePublisher creates a mini-TOC for all TOC
levels 1 through 4, up to the next occurrence of the current paragraph style.

For more information, see “Defining TOCs and Mini-TOCs”.

Page break priority
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Specifies how to handle page breaks for the selected paragraph style. This option specifies whether
to create a new page starting with the selected paragraph style and allows you to avoid new pages
with a heading and no content if two headings occur in a row in your source documents. The
default value is Use table of contents level , which only creates a new page when there is a
Table of contents level.

 

Value Description

Use table of contents level Uses the value as determined by this paragraph style’s Table of contents
level value. Keep in mind that if that value is set to Auto-Detect, then this
value will be based on the actual document’s setting.

None Does not create a page break under any condition.

n Creates a page break so long as the previous paragraph has a Page break
priority value that is numerically lower or that is set to None .

This option works with the Page break handling format setting to give you complete control for
how ePublisher handles page breaks. To access the Page break handling format setting, click
Target Settings on the Target menu. With the Page break handling setting value set to Combine ,
to create a new page every time the selected paragraph style exists, select the highest priority level
of 1. To create a new page only if the preceding paragraph did not create a new page, select a lower
priority level of 2 through 5. For more information, see “Defining New Pages (Page Breaks)”.

Pass Through
Specifies whether ePublisher should process the content with the selected paragraph style applied
or insert the content directly into your output without being transformed and coded for your output
format. By default this option is disabled. If you enable this option, ePublisher does not process the
content when generating output. For example, you can use this option to embed HTML code into
your generated output.

Popup
Specifies whether a paragraph style is displayed in a popup window and how the content is
displayed in your generated output. Define a paragraph style for the first paragraph to display in a
popup window. If the popup window contains more than one paragraph of content, create a second
paragraph style and apply it to all subsequent paragraphs that follow the first paragraph in the
popup window. The values for this setting are defined as follows:

 

Value Description

None Does not create a popup window.

Define Specifies the first paragraph of a popup window. The content of the selected
paragraph is also displayed in the generated output file. Select this option
only if you apply the paragraph style to the first paragraph of popup content
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Value Description

and you want the content to be displayed in the topic as well as in a popup
window.

Define with no output Specifies the first paragraph of a popup window. Use this option to display the
text only in a popup window. The content is not included in the topic where the
content is defined. Select this option only if you apply the paragraph style to
the first paragraph of popup content and you want the content to be displayed
only in a popup window.

Append Specifies additional paragraphs to include in a popup window that you already
defined by a paragraph style with the Popup option set to Define.

Append with no output Specifies additional paragraphs to include in a popup window that you already
defined by a paragraph style with the Popup option set to Define with no
output.

For more information, see “Defining Popup Windows”.

Popup page style
Specifies an alternate page style for the popup window associated with the selected paragraph
style. ePublisher creates default popup windows with the same appearance as all other topic pages,
including breadcrumbs and company information. You can define additional page styles to use for
popup windows. To assign a page style other than the default page style to popup windows, you
must first create the new page style in Style Designer. Then, select the paragraph style you use to
designate popup window content and select the new page style in the Popup page style option.

If you are using marker styles to create popups, you cannot use page styles to control the
appearance of popup windows. This method applies only to popup windows created with paragraph
styles.

Related topic
Specifies whether the selected paragraph style provides links to topics that are similar to the
current topic or may be of additional interest to the user. Related topic links are essentially cross-
references to other corresponding topics within your output. Instead of displaying cross-references
directly in your output, you can create a list of Related Topics links. The values for this setting are
defined as follows:

 

Value Description

None Does not include the paragraph style in related topics.

Define Displays the related topics link both within the body of the topic
and when the user clicks the Related Topics button.

260 | Paragraph Styles Opons



Value Description

Define with no output Displays the related topics link only when the user clicks the
Related Topics button.

To create a Related Topics button and have the Related Topics links displayed in the output, create
a paragraph style in the source documents that you apply to each related topic link. Then, create a
list of Related Topics links for each topic. For more information, see “Defining Related Topics”.

Search relevance weight
Reverb allows you to add a Search relevance weight to your Paragraph Styles, giving you the
opportunity to control the order of the Search Results, assigning to every word with that paragraph
style the specified weight and then saved in the index file. The default value is 1.

The predefined values for this setting are defined as follows (but you can define any integer value):
Ignore, 1, 10, 20, 50 and 100. If you choose to Ignore it (which is going to be 0), it means that the
style is not going to be shown in your results.

See Also
Defines See Also link functionality for the selected paragraph or character style. See Also links are
associative links, also called Alinks, that identify other topics that may be of interest to the user of
the current topic. These links use internal identifiers to define links and the browser builds the list
dynamically based on the topics available when the user displays the links.

To create a See Also link as inline text without a button, create a unique character style and select
the See Also option for that style.

To use a button to display See Also links, create a unique paragraph style, select the See Also
option for that style, and type the See Also text on that paragraph. The paragraph style properties
selected in Style Designer affect the text of the See Also button.

You must also define SeeAlsoLink and SeeAlsoKeyword markers. HTML Help also supports the
SeeAlsoLinkDisplayType and SeeAlsoLinkWindowType markers. These markers allow you to
change how the See Also links are displayed in HTML Help. See Also links are not supported by
all output formats, such Dynamic HTML. For more information, see “Defining See Also Links”.

Table of contents level
Specifies the level of the table of contents (TOC) entry for the selected paragraph style. For
example, setting this option to 1 specifies that all the paragraphs with the selected style appear in
the TOC at the first level in the TOC hierarchy. Setting this option to 2 specifies that all paragraphs
with the selected style appear in the table of contents at the second level. The Table of contents
level option works in conjunction with the Page break priority option.

The Auto-Detect  option takes the source file’s information and will automatically assign values
for the paragraph. From Adobe FrameMaker, this will be taken from the Bookmarks tab in the PDF
Setup from the Print Document dialog box. From Microsoft Word, ePublisher uses the Heading
levels (usually from Heading 1-Heading 9). From DITA, the map hierarchy becomes the TOC.
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Value Description

Auto-Detect Uses the value as determined by the original content’s TOC setting.

None Does not create a TOC entry under any condition.

n Creates a TOC entry in the online help system with this explicit value.

The value you specify for each of your paragraph styles determines the structure of the online
version of your table of contents. These values also define the structure of mini-TOCs. ePublisher
defaults this value to Auto-Detect , which typically results in your online table of contents looking
the same as your document’s table of contents. This option is available only for paragraph styles.
For more information, see “Defining TOCs and Mini-TOCs” S.

Variable
Specifies the name for a variable that ePublisher creates. ePublisher sets the value of the variable to
the contents of the selected paragraph or character style. You can then use this variable in your page
layout override Page.asp  file.

For example, if you want to include a section name in a banner area at the top of each topic in
that section, you can assign a variable for the paragraph style of the section name. Then, you can
modify the override Page.asp  file to include this variable value in the page layout where you want
it. Each topic in a section use the section name for that section, until the next section name defined
by the paragraph style changes the value for the next section of topics. To insert a variable in the
override Page.asp  file, insert the following code in the file, where variable is the name of the
variable you specify in this option:

<div wwpage:content="wwvars:variable">replaced variable value</div>

After processing the Page.asp  file for a topic where the variable value is User Information ,
ePublisher replaces this code with the following code in the output file:

<div>User Information</div>

‘What is this’ marker
Available only in the Microsoft HTML Help 1.x format. This option specifies whether the selected
paragraph style should define What’s This help content for field-level context-sensitive help. When
the user right-clicks on a field in the user interface and then clicks What’s This on the right-click
menu, the application displays this type of content. This content does not support formatting and is
not supported in all output formats. The values for this setting are defined as follows:

 

Value Description

None Does not include the content in What’s This help content.
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Value Description

Define Displays the content both in What’s This help and in the
topic where the content is defined, such as in a glossary or a
terminology list.

Define with no output Displays the content only as What’s This help. The content is
not included in the topic where the content is defined.

Paragraph Styles Opons | 263



Character Styles Options
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. For example, the options define table of contents levels, popup
windows, and related topics, as well as many other features and behaviors.

Abbreviation
Specifies that ePublisher provides alternate or expansion text for all abbreviations with the selected
character format in your online output. This option is available only for character styles.

You must define an Abbreviation character format and an AbbreviationTitle marker to specify
alternate text for abbreviations. The character format with this option enabled identifies the
abbreviation in the generated output. The AbbreviationTitle marker defines the alternate text for the
abbreviation. ePublisher adds the abbreviation alternate text you specify to the title attribute of the
abbr tag in the output. When you hover over the abbreviation in the output file, a popup window
displays the alternate or expansion text for the abbreviation.

Acronym
Specifies that ePublisher provides alternate or definition text for all acronyms with the selected
character format in your online output. This option is available only for character styles.

You must define an Acronym character format and an Acronym marker to specify alternate text for
acronyms. The character format with this option enabled identifies the acronym in the generated
output. The Acronym marker defines the alternate text for the acronym. ePublisher adds the
acronym alternate text you specify to the title attribute of the acronym tag in the output. When you
hover over the acronym in the output file, a popup window displays the alternate or definition text
for the acronym.

Additional CSS classes
Specifies an additional class name to include in the output class name for the selected style. This
option is helpful if you are using a custom .css  file. ePublisher supports this option only in output
formats that support cascading style sheets. This option is available all styles except marker styles.

This option lets you specify other classes to add to the class statement in the generated output for
the selected style. For example, if you have a class in your .css  file called Red  that defines the
text color as red, you can specify Red  in the Additional CSS classes option for each style you
want to have red text. ePublisher adds this class to the class name in the generated output, such as
classname=”sourcestylename Red” .

Citation
Specifies that ePublisher recognizes and formats the text with this style as quotation content. A
citation is a reference or footnote to a book, article, or other material that specifies the source from
which a quotation was borrowed. The citation for a quote enables users to go to a Web site that
contains more information about the quote.

You must define a Citation paragraph or character format and a Citation marker to specify a URL
citation. The paragraph or character format with this option enabled identifies the quote in the
generated output. The Citation marker defines the URL for the Web site with more information.
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When you hover over the quote in the output file, a popup window displays the URL. This option is
available only for paragraph and character styles.

Generate output
Specifies whether the selected style is included in the generated output. This option is available for
all styles except marker styles. By default. the Generate output option is set to Enabled so that all
content is included in the output. If you select Disabled, the content with the selected style does not
appear in the generated output.

Pass Through
Specifies whether ePublisher should process the content with the selected character style applied
or insert the content directly into your output without being transformed and coded for your output
format. By default this option is disabled. If you enable this option, ePublisher does not process the
content when generating output. For example, you can use this option to embed HTML code into
your generated output.

See Also
Defines See Also link functionality for the selected paragraph or character style. See Also links are
associative links, also called Alinks, that identify other topics that may be of interest to the user of
the current topic. These links use internal identifiers to define links and the browser builds the list
dynamically based on the topics available when the user displays the links.

To create a See Also link as inline text without a button, create a unique character style and select
the See Also option for that style.

To use a button to display See Also links, create a unique paragraph style, select the See Also
option for that style, and type the See Also text on that paragraph. The paragraph style properties
selected in Style Designer affect the text of the See Also button.

You must also define SeeAlsoLink and SeeAlsoKeyword markers. HTML Help also supports the
SeeAlsoLinkDisplayType and SeeAlsoLinkWindowType markers. These markers allow you to
change how the See Also links are displayed in HTML Help. See Also links are not supported by
all output formats, such Dynamic HTML.

Variable
Specifies the name for a variable that ePublisher creates. ePublisher sets the value of the variable to
the contents of the selected paragraph or character style. You can then use this variable in your page
layout override Page.asp  file.

For example, if you want to include a section name in a banner area at the top of each topic in
that section, you can assign a variable for the paragraph style of the section name. Then, you can
modify the override Page.asp  file to include this variable value in the page layout where you want
it. Each topic in a section use the section name for that section, until the next section name defined
by the paragraph style changes the value for the next section of topics. To insert a variable in the
override Page.asp  file, insert the following code in the file, where variable is the name of the
variable you specify in this option:

<div wwpage:content="wwvars:variable">replaced variable value</div>

After processing the Page.asp  file for a topic where the variable value is User Information ,
ePublisher replaces this code with the following code in the output file:
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<div>User Information</div>
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Table Styles Options
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. For example, the options define table of contents levels, popup
windows, and related topics, as well as many other features and behaviors.

Additional CSS classes
Specifies an additional class name to include in the output class name for the selected style. This
option is helpful if you are using a custom .css  file. ePublisher supports this option only in output
formats that support cascading style sheets. This option is available all styles except marker styles.

This option lets you specify other classes to add to the class statement in the generated output for
the selected style. For example, if you have a class in your .css  file called Red  that defines the
text color as red, you can specify Red  in the Additional CSS classes option for each style you
want to have red text. ePublisher adds this class to the class name in the generated output, such as
classname=”sourcestylename Red” .

Dropdown
Specifies whether to use the selected table style to define an expand/collapse section, also called a
dropdown hotspot. Some output formats do not support expand/collapse sections.

You can configure the expand/collapse section to initially be hidden or shown. When the user clicks
the dropdown hotspot, the content expands and collapses to allow the user to view more or less
information. The expand/collapse content can include multiple paragraph and table styles. You can
use the DropDownEnd marker to identify the end of the expand/collapse content. If you have a
specific table style that always serves as the ending point for your expand/collapse content and is
not included in the expand/collapse content, set this option for that table style to Break. By default,
all table styles are included in the expand/collapse content. The values for this setting are defined as
follows:

 

Value Description

Break Specifies the table style is never included in expand/collapse content.
A table style with this option set to Break ends the expand/collapse
content section.

Continue Specifies the selected table style does not change the expand/
collapse content output. If the selected paragraph style is within
an expand/collapse content section, the Continue value directs
ePublisher to include the content as part of the expand/collapse
content. This value is the default for table styles.

End Allows the content to be inside the dropdown selection but it will
signify the end of the droprdown similar to the behavior of a marker.

Start open Displays the content in the expand/collapse section when the page is
initially displayed. The table with this option set provides the hotspot
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Value Description

where the user can click to show or hide the expand/collapse content.
This table style starts the expand/collapse section.

Start closed Hides the content in the expand/collapse section when the page is
initially displayed. The table with this option set provides the hotspot
where the user can click to show or hide the expand/collapse content.
This table style starts the expand/collapse section.

Emit table markup
Specifies whether the selected style includes all generated markup in the output.

First Table Cell Width
Specifies the width of the first cell of the table. Useful when working with tables where you only
need to specify the width of the first column while allowing the other columns to flow naturally in
the output. Typically this means that you would also disable the Use document cell widths option
when enabling this option.

Generate output
Specifies whether the selected style is included in the generated output. This option is available for
all styles except marker styles. By default. the Generate output option is set to Enabled so that all
content is included in the output. If you select Disabled, the content with the selected style does not
appear in the generated output.

Last Table Cell Width
Specifies the width of the last cell of the table. Useful when working with tables where you only
need to specify the width of the last column while allowing the other columns to flow naturally in
the output. Typically this means that you would also disable the Use document cell widths option
when enabling this option.

Page break priority
Specifies how to handle page breaks for the selected paragraph style. This option specifies whether
to create a new page starting with the selected paragraph style and allows you to avoid new pages
with a heading and no content if two headings occur in a row in your source documents. The
default value is None, which does not create a new page.

This option works with the Page break handling format setting to give you complete control for
how ePublisher handles page breaks. To access the Page break handling format setting, click
Target Settings on the Target menu. With the default Page break handling format setting, to
create a new page every time the selected paragraph style exists, select the highest priority level of
1. To create a new page only if the preceding paragraph did not create a new page, select a lower
priority level of 2 through 5. For more information, see “Defining New Pages (Page Breaks)”.

Use % table cell widths
This option works similar to the Use document cell widths, except that it converts the specific
dimensions into relative percentages thus overcoming the problem of changing the font size of the
generated output.

Use document cell widths
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Specifies whether ePublisher sets all cell widths for tables of the selected table style to the same
values as defined in the source document. If you set this option to Disabled, ePublisher sets table
cell widths based on the size of the viewer window.

If the font size for your online table text differs from your source documents, enabling the Use
document cell widths option may not give you the desired results. For example, if fonts for online
tables are larger than in your source documents, some of the table text may wrap in the cells in the
generated output.
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Page Styles Options
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. For example, the options define table of contents levels, popup
windows, and related topics, as well as many other features and behaviors.

Additional CSS classes
Specifies an additional class name to include in the output class name for the selected style. This
option is helpful if you are using a custom .css  file. ePublisher supports this option only in output
formats that support cascading style sheets. This option is available all styles except marker styles.

This option lets you specify other classes to add to the class statement in the generated output for
the selected style. For example, if you have a class in your .css  file called Red  that defines the
text color as red, you can specify Red  in the Additional CSS classes option for each style you
want to have red text. ePublisher adds this class to the class name in the generated output, such as
classname=”sourcestylename Red” .

Breadcrumbs shown at bottom of page
Specifies whether to include breadcrumbs at the bottom of each page for the selected page style.
Breadcrumbs form a linked path to show users the hierarchical location of the current topic in
your online content. This clickable path steps you through the topics at the higher levels in the
online organization of topics. This option is not available in some output types.

You can include breadcrumbs at the top of the page, at the bottom of the page, or both. The
breadcrumb trail at the top of the output page is enabled by default.

Breadcrumbs shown at top of page
Specifies whether to include breadcrumbs at the top of each page for the selected page style.
Breadcrumbs form a linked path to show users the hierarchical location of the current topic in
your online content. This clickable path steps you through the topics at the higher levels in the
online organization of topics. This option is not available in some output types.

You can include breadcrumbs at the top of the page, at the bottom of the page, or both. The
breadcrumb trail at the top of the output page is enabled by default.

Company info bottom alignment
Specifies the alignment of the company information displayed at the bottom of each page for the
selected page style. For example, you can align the company information to the left or to the right.
To display the company information at the bottom, set the Company info displayed at bottom
option to Enabled. This option is not available in some output types.

Company info displayed at bottom
Specifies whether to display the company information at the bottom of pages with the selected
page style. If you set this option to Enabled, ePublisher displays the information specified in the
company-related format settings at the bottom of these pages. This option is not available in some
output types.
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Use the Company info bottom alignment option to adjust how ePublisher displays the company
information. ePublisher does not display the company information in the Preview pane.

If you add a logo image to your project, ePublisher displays the logo next to your company contact
information on the top or the bottom of your output pages.To include a company logo, you must
first store the image file in the Files  folder of your project.

Company info displayed at top
Specifies whether to display the company information at the top of pages with the selected page
style. If you set this option to Enabled, ePublisher displays the information specified in the
company-related format settings at the top of these pages. This option is not available in some
output types.

Use the Company info top alignment option to adjust how ePublisher displays the company
information. ePublisher does not display the company information in the Preview pane.

If you add a logo image to your project, ePublisher displays the logo next to your company contact
information on the top or the bottom of your output pages.To include a company logo, you must
first store the image file in the Files  folder of your project.

Company info top alignment
Specifies the alignment of the company information displayed at the top of each page for the
selected page style. For example, you can align the company information to the left or to the right.
To display the company information at the top, set the Company info displayed at top option to
Enabled. This option is not available in some output types.

Custom document css file
Specifies the name of the custom .css  file to include in each generated output file. You can use a
custom .css  file to modify the appearance of your content instead of using the Style Designer, or
to augment the Style Designer settings. When you specify the name of the custom .css  file in this
option, ePublisher inserts the link tag within all HTML pages and links to the .css  file specified.
This option is available only for page styles.

You must store the custom .css  file in the Files  folder of your project for it to be recognized by
ePublisher. If you use a subfolder within the Files  folder for your .css  file, click the Browse
button next to the Custom document css file option to navigate to the subfolder. ePublisher
populates this option with the correct path to the custom .css  file.

Generate output
Specifies whether the selected style is included in the generated output. This option is available for
all styles except marker styles. By default. the Generate output option is set to Enabled so that all
content is included in the output. If you select Disabled, the content with the selected style does not
appear in the generated output.

Navigation links shown at bottom of page
Specifies whether to display navigation links, also known as browse buttons, at the bottom of each
page for the selected page style. The Navigation Alignment property for the page controls whether
the navigation links are aligned to the left or right. To set the Navigation Alignment property, on
the Properties tab, click Navigation. This option is not available in some output types.

Navigation links shown at top of page
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Specifies whether to display navigation links, also known as browse buttons, at the top of each
page for the selected page style. The Navigation Alignment property for the page controls whether
the navigation links are aligned to the left or right. To set the Navigation Alignment property, on
the Properties tab, click Navigation. This option is not available in some output types.

Output file extension
Specifies the file extension to use for output files. If you select a page style, specify a value such as
.htm or .html for your output files. If you select a graphic style, specify a value that corresponds to
the graphic file format you selected for the Format option, such as .jpg, .gif, or .png. This option
is available only for graphic and page styles.

272 | Page Styles Opons



Page Styles Options (PDF - XSL-FO)
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. The Page Styles Options can be used to customize your PDF-
XSL-FO output. Selected styles will be applied to the text in that region.

Even page footer style
Specifies a Paragraph Style to be applied to the footer text on even pages.

Even page footer text
Specifies whether to display the first heading’s text of each even page as the text in the footer.

Even page header style
Specifies a Paragraph Style to be applied to the header text on even pages.

Even page header text
Specifies whether to display the first heading’s text of the page as the text on even header pages.

First Master Page
Select whether to enable or disable the first master page. By default, the First Master Page option
is set to Disabled.

First page footer style
Specifies a Paragraph Style to be applied to the footer text of the first page.

First page footer text
Specifies whether to display the first heading style of the page as the text in the first page footer.

First page header style
Specifies a Paragraph Style to be applied to the header text of the first page.

First page header text
Specifies whether to display the first heading style of the page as the text in the first page header.

Generate output
Specifies whether the selected style is included in the generated output. This option is available for
all styles except marker styles. By default. the Generate output option is set to Enabled so that all
content is included in the output. If you select Disabled, the content with the selected style does not
appear in the generated output.

Last Master Page
Select whether to enable or disable the last master page. By default, the Last Master Page option
is set to Disabled.

Last page footer style
Specifies a Paragraph Style to be applied to the footer text of the last page.

Last page footer text
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Specifies whether to display the first heading style of the page as the text in the last page footer.

Last page header style
Specifies a Paragraph Style to be applied to the header text of the last page.

Last page header text
Specifies whether to display the first heading style of the page as the text in the last page header.

Odd page footer style
Specifies a Paragraph Style to be applied to the footer text on odd pages.

Odd page footer text
Specifies whether to display the first heading style of the page as the text in each odd page footer.

Odd page header style
Specifies a Paragraph Style to be applied to the header text on odd pages.

Odd page header text
Specifies whether to display the first heading style of the page as the text in each odd page header.

Output file extension
Specifies the file extension to use for output files. If you select a page style, specify a value such as
.htm or .html for your output files. If you select a graphic style, specify a value that corresponds to
the graphic file format you selected for the Format option, such as .jpg, .gif, or .png. This option
is available only for graphic and page styles.
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Graphic Styles Options
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. For example, the options define the size and quality of the
images in the generated output, as well as many other features and behaviors. For more information, see
“Defining the Appearance of Images”

Additional CSS classes
Specifies an additional class name to include in the output class name for the selected style. This
option is helpful if you are using a custom .css  file. ePublisher supports this option only in output
formats that support cascading style sheets. This option is available all styles except marker styles.

This option lets you specify other classes to add to the class statement in the generated output for
the selected style. For example, if you have a class in your .css  file called Red  that defines the
text color as red, you can specify Red  in the Additional CSS classes option for each style you
want to have red text. ePublisher adds this class to the class name in the generated output, such as
classname=”sourcestylename Red” .

Allow by-reference vector images (SVG)
Allows vector image .svg  files to be imported by-reference in the source documents. ePublisher
includes these images in the generated output files. This option is available only for graphic styles.

By reference graphics
Allows images to be imported in source documents by reference. ePublisher preserves the original
image file names that are imported by reference and does not assign file names to these images.
This option is available only for graphic styles.

By reference graphics use document dimensions
Resizes all images imported by reference in the source documents to use the size defined within the
source documents. Enabling this option can reduce the clarity of images by causing ePublisher to
rasterize the images to achieve the size defined in the source documents. ePublisher preserves the
original image file names that are imported by reference and does not assign file names to these
images. This option is available only for graphic styles.

Color bit depth
Specifies the number of bits of data carrying the color information in your images. The range
of colors available through digital computer images is usually expressed in terms of bit depth.
Common bit depth levels for images include 8-bit and 24-bit color. In general, more bits of data
make more colors available. This option applies only to .gif  and .png  images. .jpg  images are
32-bit images. This option is available only for graphic styles.

Format
Specifies the output format for images with the selected graphic style. By default, ePublisher
transfers all images in your source documents, regardless of their file format, to Web-ready .jpg
images. You may want to use other image formats for online delivery. For example, .gif  images
can produce similar quality images as .jpg , but the file size is smaller. The .gif  format can also
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support transparent colors. You can also create .png  images, which combine some of the best
qualities of both .jpg  and .gif  files.

If you use the same format and size as your source document images, you can avoid the
rasterization process and improve the clarity of your images in your generated output. For more
information, see “Defining the Appearance of Images”.

This option works with the Output file extension and JPG Quality options. If you select JPG,
set Output file extension to .jpg and set JPG Quality to the appropriate value to transform your
images with the quality level you need. This option is available only for graphic styles. For more
information, see “Choosing an Image File Format and Quality Level”.

Generate output
Specifies whether the selected style is included in the generated output. This option is available for
all styles except marker styles. By default. the Generate output option is set to Enabled so that all
content is included in the output. If you select Disabled, the content with the selected style does not
appear in the generated output.

Grayscale
Specifies whether to transform your original color images into grayscale versions in your generated
content. If you set the Grayscale option to Enabled, ePublisher removes the color saturation of the
original images when those images are transformed with your content. If the original source images
are grayscale, this option has no effect. This option is available only for graphic styles.

Interlaced
Specifies whether to transform images as interlaced images. Interlaced images initially load more
quickly in browsers and become more clear as the browser displays additional detail. This option is
available only for graphic styles.

JPG Quality
Specifies the quality of the .jpg  image files ePublisher creates from the images in your source
documents with the selected graphic style. This value is a percentage of the original source
document quality. For example, set this option to 100 to have ePublisher duplicate the quality of
your original images. The default value is 75.

Once you select JPG in the Format option for a graphic style, set the JPG Quality option. The
quality level impacts both the visual aspects of your images and the size of the generated files.
Higher-quality images require larger files, which require more time to download and display. This
option does not affect .gif  or .png  images. This option is available only for graphic styles.

Maximum image height (px)
Specifies the maximum height, in pixels, for images with the selected graphic style. During
conversion, ePublisher resizes source document images taller than this value and maintains
the original aspect ratio of each image. This option works with the Render DPI, Scale %, and
Maximum image width options to make sure your images are correctly sized for online delivery.
This option is available only for graphic styles.

ePublisher automatically converts images in your source document into Web-ready formats.
However, the size of your print image may not be appropriate for online delivery. ePublisher
provides several ways to modify the size of your images for online delivery without affecting
the original images. While you can specify a fixed image width and height for all images using
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a specific graphic style, it is often most efficient to define the maximum height and width for an
image.

Maximum image width (px)
Specifies the maximum width, in pixels, for images with the selected graphic style. During
conversion, ePublisher resizes source document images wider than this value and maintains
the original aspect ratio of each image. This option works with the Render DPI, Scale %, and
Maximum image height options to make sure your images are correctly sized for online delivery.
This option is available only for graphic styles.

ePublisher automatically converts images in your source document into Web-ready formats.
However, the size of your print image may not be appropriate for online delivery. ePublisher
provides several ways to modify the size of your images for online delivery without affecting
the original images. While you can specify a fixed image width and height for all images using
a specific graphic style, it is often most efficient to define the maximum height and width for an
image.

Maximum thumbnail height (px)
Specifies the maximum height, in pixels, for thumbnails of images with the selected graphic
style. A thumbnail is a small copy of an image displayed in place of the original image online to
conserve space and download time. This option is available only for graphic styles.

When you enter a value in this option, ePublisher automatically creates thumbnails for any image
that exceeds the maximum thumbnail height specified. When the user clicks the thumbnail in the
generated output, the full-size image is displayed. Use the Thumbnail page style option to alter
the appearance of the window in which ePublisher displays the full-size images. If you do not want
thumbnail images used in your online output, leave this option value blank.

Maximum thumbnail width (px)
Specifies the maximum width, in pixels, for thumbnails of images with the selected graphic
style. A thumbnail is a small copy of an image displayed in place of the original image online to
conserve space and download time. This option is available only for graphic styles.

When you enter a value in this option, ePublisher automatically creates thumbnails for any image
that exceeds the maximum thumbnail width specified. When the user clicks the thumbnail in the
generated output, the full-size image is displayed. Use the Thumbnail page style option to alter
the appearance of the window in which ePublisher displays the full-size images. If you do not want
thumbnail images used in your online output, leave this option value blank.

Output file extension
Specifies the file extension to use for output files. If you select a page style, specify a value such as
.htm or .html for your output files. If you select a graphic style, specify a value that corresponds to
the graphic file format you selected for the Format option, such as .jpg, .gif, or .png. This option
is available only for graphic and page styles.

Render DPI
Specifies the dots per inch (DPI) to use for images with the selected graphic style. ePublisher
defaults this value to 96. If you specify a DPI that differs from the DPI of your source images,
ePublisher rasterizes the image to create the new image for online delivery. If your source
documents images have settings for a print-level resolution, such as 300 DPI or higher, you can
reduce the image resolution for online delivery. Higher DPI images create larger files that require
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more time to download. In addition, most monitors display a resolution of 96 DPI, so higher
resolutions do not increase the quality of the image displayed online. This option is available only
for graphic styles.

Although transforming an image from 300 DPI to 96 DPI helps optimize your images for online
delivery, it also affects the width and height of your images. Because a resolution of 300 DPI
contains more dots per inch than a resolution of 96 DPI, the image ePublisher transforms will be
roughly 68% smaller than the original image. For example, a 300 DPI image that is 100 x 100
pixels will be 32 x 32 pixels when transformed to a 96 DPI image.

To counter this effect, use the Scale % option in conjunction with the Render DPI option to
control the size of your images. In the example of transforming a 300 DPI image to 96 DPI, set
the Scale % option to 312, which generates an image that has roughly the same dimensions as
the original source image. You can also use the Scale % and Render DPI options together with
the Maximum image height and Maximum image width options to make sure your images are
correctly sized for online delivery.

Responsive image sizing
When enabled, generated output will resize the images based on the available screen area of the
device. The image will never be larger than its generated size, however, if the available screen size
is less than the size of the image, the image will be scaled down in size so that it fits withing the
viewable area.

Scale %
Specifies the percentage ePublisher resizes all images with the selected graphic style. For example,
if you specify 50, ePublisher reduces each image with the selected graphic style to half its original
size. When the actual width and height of an image is not important, you can specify a scaling
percentage to apply to all images with the selected graphic style. This option allows you to modify
the size of all images associated with the graphic style in relation to their original sizes. Modifying
images in this way retains the original aspect ratio of each image.

This option works with the Render DPI, Maximum image height, and Maximum image width
options to make sure your images are correctly sized for online delivery. This option is available
only for graphic styles. For more information, see “Defining the Appearance of Images”.

Thumbnail page style
Specifies the name of the page style that ePublisher uses when displaying full-size images in a
separate window after a user clicks a thumbnail image within the generated output. You can create
a custom page style and then select the name of the custom page style to use for full-size image
windows displayed from thumbnail images. If you leave the Thumbnail page style option blank,
ePublisher uses the page style of the main content for the full-size image windows displayed from
thumbnail images. This option is available only for graphic styles.

You must enter a value in the Maximum thumbnail height and Maximum thumbnail width
options for ePublisher to recognize and use the Thumbnail page style option.

Transparency
Specifies whether to transform all white regions in .gif  or .png  images with the selected graphic
style to transparent areas. In some images, you may want to set a color to transparent. For example,
if your source document has a white background, images with a white background display as
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though they do not have a background. However, if your online content has a different color
background, the background of these images appear as white areas.

Select the graphic style and enable the Transparency option in ePublisher to transform the white
background into a transparent one. Only .gif  and .png  images support transparent colors. This
option is available only for graphic styles.
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Marker Styles Options
ePublisher provides many options to allow you to customize your content transformation process and
implement the online features you need. For example, the options define table of contents levels, popup
windows, and related topics, as well as many other features and behaviors.

Marker type
Specifies the function associated with the selected marker style. ePublisher defines default names
for the marker styles to support selected features. For example, if you have a marker style named
Filename, ePublisher sets this option to allow that marker to define file names for output files.
These default associations automate ePublisher configuration. You can specify your own marker
styles and assign the function for each marker style. This option is available only for marker styles.
For more information, see “Defining Marker Types”.

Navigation title
Specifies whether the selected marker type supports the Navigation title function. If you enable
this option for a marker type, you can use the marker to specify alternate text to display in the table
of contents for a topic. For example, if you have a topic that does not have a heading, such as a
topic that contains just a table or chart, you can add a marker with this option enabled to that topic
and specify the text you want to be displayed in the table of contents for that topic.

Search relevance weight
Reverb allows you to add a Search relevance weight to your Marker Styles, giving you the
opportunity to control the order of the Search Results, assigning to every word with that marker
style the specified weight and then saved in the index file. The default value is 1.

The predefined values for this option are defined as follows (but you can define any integer value):
Ignore, 1, 10, 20, 50 and 100. If you choose to Ignore it (which is going to be 0), it means that the
style is not going to be shown in your results.

Variable
Specifies the name for a variable that ePublisher creates. ePublisher sets the value of the variable to
the contents of the selected marker, paragraph or character style. You can then use this variable in
your page layout override Page.asp  file.

For example, if you want to include a section name in a banner area at the top of each topic in
that section, you can assign a variable for the paragraph style of the section name. Then, you can
modify the override Page.asp  file to include this variable value in the page layout where you want
it. Each topic in a section use the section name for that section, until the next section name defined
by the paragraph style changes the value for the next section of topics. To insert a variable in the
override Page.asp  file, insert the following code in the file, where variable is the name of the
variable you specify in this option:

<div wwpage:content="wwvars:variable">replaced variable value</div>

After processing the Page.asp  file for a topic where the variable value is User Information ,
ePublisher replaces this code with the following code in the output file:
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<div>User Information</div>
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Customizing WebWorks Reverb
2.0

Changing the Appearance of WebWorks Reverb 2.0
Target Settings for WebWorks Reverb 2.0
Customizing the Top-Level Entry File
Customizing TOC Menu Item Display
Customizing the Splash Page in WebWorks Reverb 2.0
Using Context-Sensitive Help in WebWorks Reverb 2.0
Configuring Client-Side Search for Reverb 2.0
Searching WebWorks Reverb 2.0 - URL Method
Incorporating Google Analytics for Your Reverb 2.0 Files
Configuring Commenting and End-User Feedback for Reverb 2.0
Customizing Icons in Your Reverb 2.0 Output Using Font Awesome
Incorporating Web Fonts in Your Reverb 2.0 Output
‘Was This Helpful?’ Buttons
Dropdown Collapse/Expand All Toggle Button
Document Last Modified Date/Publish Date
Customizing Related Topics

WebWorks Reverb 2.0 uses SASS technology to build a robust and responsive layout. Using ePublisher’s
implementation of this technology, the user can customize any aspect of the visual layout.

282 | Customizing WebWorks Reverb 2.0



Changing the Appearance of WebWorks Reverb 2.0
Most customizations to WebWorks Reverb 2.0 rely upon changing one of three file types:

Page Templates - Found in the Pages folder and have the extension .asp. Users may create
overrides for these files in their project to change overall layouts.

SASS Files - Found in the Pages\sass folder. Users may change the color, icons, and other layout
specific behaviors of the skin with these files. Changes to these files will not have an effect on the
content pages if styles have been defined within the source documents or in the Style Designer.

Images - Found in the Pages\images folder. These files are injected into the layout via Connect.asp
and can be replaced with another image.

For easy reference, see the below table for a list of template files.
 

Page Template Use

Connect.asp Entry point to the Reverb 2.0 run-time. This file
controls the placement of the toolbar buttons, menu
(table of contents/index), page, and footer.

Header.asp Defines the layout and appearance of the Header.

Footer.asp Defines the layout and appearance of the Footer.

Index.asp Data file for each Reverb parcel’s Index information.

Page.asp Defines the layout and appearance of generated
pages.

Parcel.asp Data file for each Reverb parcel (help set).

Search.asp Search integration page.

Splash.asp Defines the layout and appearance of the Reverb
2.0 splash page.

Unsupported_Browser.asp Defines the layout and appearance of the message
that displays when a user visits a Reverb 2.0 help
set with an unsupported browser.
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Using SASS To Customize WebWorks Reverb 2.0
WebWorks Reverb 2.0 makes use of SASS to produce a responsive HTML5 layout. These files are found
in the Pages/sass folder of the Format. SASS file names end with the .scss extension. There are many files
in this folder and all of the files have a specific purpose.

Of these files, they fall into two categories:

Template Files - These are identified by their filename. A Template File’s name will always begin
with the underscore character. These files contain variables that hold values that can be changed by
the user to affect areas of the layout without changing the implementation of the layout itself.

Layout Files - These files have filenames that do not begin with the underscore character. These
files contain the implementations of the variables defined in template files.

For reference, refer to the below table for a summary of what each SASS file pertains to.
 

SASS Filename Pertains To

_borders.scss Contains variables for border values to be applied
across the layout.

_colors.scss Contains variables for color values to be applied
across the layout.

_fonts.scss Contains variables for font values to be applied
across the layout.

_functions.scss Contains definitions of custom SASS functions
created by WebWorks for use in the layout.

_icons.scss Contains variables for icon values to be applied
across the layout.

_sizes.scss Contains variables for size values to be applied
across the layout.

connect.scss Contains the implementation for top-level structure
and core behavior for the layout.

menu_initial_closed.scss Contains the menu configuration for when the menu
is set to be closed upon first visit of the help set.

menu_initial_open.scss Contains the menu configuration for when the menu
is set to be open upon first visit of the help set.

print.scss Contains style information for the presentation when
a page is to be printed.
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SASS Filename Pertains To

search.scss Contains style information for the presentation of the
search page.

skin.scss Contains the aesthetic implementation for
the layout. This file is where colors, fonts,
borders, icons, and other visual style settings are
implemented. This file also contains the various
implementations for individual skins.

social.scss Contains style information for the social buttons in
the page toolbar.

webworks.scss Contains default style information for tables, the
Mini-TOC, and other various small items in the
layout. This file is implemented last and works well
for custom implementations as well.
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SASS Variables In WebWorks Reverb 2.0
WebWorks Reverb 2.0 contains an implementation of SASS variables that has been constructed with
efficiency and user-friendliness in mind. In each Template File, there are many variables that contain
values that are implemented in the layout. Each variable has been given a name that describes the use of
the value it holds. Variables are named in a procedural manner, each name starting with the section of the
layout that it resides, and with every consecutive word defining more specifically what it pertains to.

As a reference, these graphics provide a visualization of the regions of the layout. The graphics can
provide a starting point for finding the variable for the item that needs to be customized. The regions in
the graphics have been color coded and numbered from 1 to 7. These numbers can be matched with a
variable prefix that matches with a collection of variables that affect that region.
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Number Variable Prefix

1 $toolbar_*

2 $menu_*

3 $page_*

4 $mini_toc_*

5 $footer_*

6 $search_*
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Number Variable Prefix

7 $back_to_top_*
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Migrating SASS Overrides To Newer Format Versions
Upon installation of the latest version of ePublisher, it is recommended that a migration of overrides
is performed on any project that contains overridden files that match to a prior format version. The
migration procedure works for all file types in an ePublisher project, but is highlighted for SASS because
of it’s interconnected nature between the files. Sometimes, when a project is updated to the latest Format
Version, users will get an error like this one when generating:

[Error] Traceback (most recent call last):

  File "C:\Program Files (x86)\WebWorks\ePublisher\2018.2\Helpers\python\WebWorks
\compile_sass.py", line 25, in &lt;module&gt;

    compile_sass(input_file, output_file)

  File "C:\Program Files (x86)\WebWorks\ePublisher\2018.2\Helpers\python\WebWorks
\compile_sass.py", line 13, in compile_sass

    _cssoutput = sass.compile(string=data)

  File "C:\Program Files (x86)\WebWorks\ePublisher\2018.2\Helpers\python\lib\site-
packages\sass.py", line 640, in compile

    raise CompileError(v)

sass.CompileError: Error: Undefined variable: "$related-topics-title-background-
color".

        on line 143 of stdin

&gt;&gt;   background: $related_topics_title_background_color;

   --------------^

This error happens most commonly when a newer version of one of the SASS files has a reference to
a variable that should be inside an older, overridden SASS file. The solution for this is to migrate the
overridden file to the latest version, comparing the overridden version to the latest version in a diff tool,
and copying your local changes to the latest version of the same file.

Refer to this article for a comprehensive list of free and paid diff tools available for Windows:

https://www.git-tower.com/blog/diff-tools-windows
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Layout Colors In WebWorks Reverb 2.0 Skins
In the file _colors.scss, a convention has been created to allow for ease of use and user friendliness.
The file makes use of Layout Colors that are defined at the top of the page. Every other color value in the
layout inherits from these layout colors, so with this logic, you could change the color value of one layout
color, and this value would be applied to many aspects of the layout. For the best results, the designer
should take a top-down approach, first changing the values of colors at the top level, and then changing
individual values for items that need minor adjustments.

For reference, we have created a table for each skin that details every variable that inherits from a certain
layout color. These tables may seem like a lot, but just remember, the fact that one Layout Color affects so
many values means that for the designer, the workload in the end is greatly reduced.

Neo

Layout Color Inherited By

$_layout_color_1 $back_to_top_background_color, $footer_link_color,
$header_link_color, $link_default_color,
$menu_nav_buttons_background_color_hover,
$menu_toc_item_current_highlight_color,
$mini_toc_entry_background_color_hover,
$page_breadcrumbs_link_color, $page_breadcrumbs_link_color_hover,
$page_helpful_button_icon_color_selected,
$related_topics_entry_text_color,
$related_topics_title_background_color,
$toolbar_background_color, $toolbar_button_background_color,
$toolbar_button_home_background_color,
$toolbar_button_menu_background_color,
$toolbar_button_next_background_color,
$toolbar_button_previous_background_color,
$toolbar_button_search_background_color,
$toolbar_button_translate_background_color,
$toolbar_logo_section_background_color,
$toolbar_search_section_background_color,
$toolbar_tab_background_color,
$toolbar_tabs_container_background_color,
$unsupported_browser_heading_text_color

$_layout_color_2 $back_to_top_caret_color, $menu_index_link_color,
$menu_index_text_color, $menu_index_title_color,
$menu_nav_buttons_current_icon_color,
$menu_nav_buttons_current_icon_color_click,
$menu_nav_buttons_current_icon_color_hover,
$menu_nav_buttons_icon_color, $menu_nav_buttons_icon_color_hover,
$menu_text_color, $menu_toc_item_icon_color,
$menu_toc_item_text_color, $menu_toc_title_text_color,
$mini_toc_entry_text_color, $mini_toc_entry_text_color_visited,
$page_dropdown_arrow_color, $page_helpful_button_icon_color,
$page_helpful_message_text_color,
$page_toolbar_icon_divider_color,
$page_toolbar_social_icon_color,
$page_toolbar_social_icon_facebook_color,
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Layout Color Inherited By

$page_toolbar_social_icon_linkedin_color,
$page_toolbar_social_icon_twitter_color,
$page_toolbar_tool_icon_color,
$related_topics_dropdown_toggle_icon_color,
$related_topics_entry_icon_color,
$related_topics_title_text_color,
$search_filter_message_text_color, $search_plain_text_color,
$search_result_count_message_text_color,
$search_result_icon_color,
$search_result_summary_highlight_text_color,
$search_result_summary_text_color, $search_title_text_color,
$toolbar_button_home_icon_color, $toolbar_button_icon_color,
$toolbar_button_menu_icon_color, $toolbar_button_next_icon_color,
$toolbar_button_previous_icon_color,
$toolbar_button_search_icon_color,
$toolbar_button_translate_icon_color, $toolbar_icon_color,
$toolbar_logo_link_text_color, $toolbar_logo_text_color,
$toolbar_search_scope_option_text_color,
$toolbar_search_scope_options_text_color,
$toolbar_search_scope_selector_icon_color,
$toolbar_search_scope_selector_text_color,
$toolbar_tab_current_text_color,
$toolbar_tab_current_text_color_hover, $toolbar_tab_text_color,
$toolbar_text_color, $unsupported_browser_message_text_color

$_layout_color_3 $disqus_background_color, $footer_text_color, $header_text_color,
$menu_background_color, $menu_index_background_color,
$menu_nav_buttons_current_background_color,
$menu_toc_background_color, $menu_toc_item_background_color,
$mini_toc_background_color,
$toolbar_search_scope_option_background_color,
$toolbar_search_scope_options_background_color,
$toolbar_search_scope_selector_background_color

$_layout_color_4 $lightbox_button_close_icon_color,
$mini_toc_entry_text_color_hover,
$mini_toc_entry_text_color_visited_hover,
$no_javascript_text_color, $page_breadcrumbs_text_color

$_layout_color_5 $footer_background_color, $header_background_color,
$page_breadcrumbs_background_color

$_layout_color_6 $page_background_color, $search_background_color,
$search_result_background_color

Classic

Layout Color Inherited By

$_layout_color_1 $footer_link_color, $header_link_color,
$link_default_color, $mini_toc_entry_background_color_hover,
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Layout Color Inherited By

$page_helpful_button_icon_color_selected,
$related_topics_entry_text_color,
$toolbar_button_home_icon_color_click,
$toolbar_button_home_icon_color_hover,
$toolbar_button_menu_icon_color_click,
$toolbar_button_menu_icon_color_hover,
$toolbar_button_next_icon_color_click,
$toolbar_button_next_icon_color_hover,
$toolbar_button_previous_icon_color_click,
$toolbar_button_previous_icon_color_hover,
$toolbar_button_search_icon_color_click,
$toolbar_button_search_icon_color_hover,
$toolbar_button_translate_icon_color_click,
$toolbar_button_translate_icon_color_hover,
$toolbar_tab_current_background_color,
$unsupported_browser_heading_text_color

$_layout_color_2 $back_to_top_caret_color, $menu_nav_buttons_current_icon_color,
$menu_nav_buttons_current_icon_color_click,
$menu_nav_buttons_current_icon_color_hover,
$menu_nav_buttons_icon_color, $menu_text_color,
$menu_toc_item_icon_color, $menu_toc_title_text_color,
$mini_toc_entry_text_color, $mini_toc_entry_text_color_visited,
$page_dropdown_arrow_color, $page_helpful_button_icon_color,
$page_toolbar_icon_divider_color,
$page_toolbar_social_icon_color,
$page_toolbar_social_icon_facebook_color,
$page_toolbar_social_icon_linkedin_color,
$page_toolbar_social_icon_twitter_color,
$page_toolbar_tool_icon_color,
$related_topics_dropdown_toggle_icon_color,
$related_topics_entry_icon_color,
$related_topics_title_text_color,
$search_filter_message_text_color, $search_plain_text_color,
$search_result_count_message_text_color,
$search_result_icon_color,
$search_result_summary_highlight_text_color,
$search_result_summary_text_color, $search_title_text_color,
$toolbar_button_home_icon_color, $toolbar_button_icon_color,
$toolbar_button_menu_icon_color, $toolbar_button_next_icon_color,
$toolbar_button_previous_icon_color,
$toolbar_button_search_icon_color,
$toolbar_button_translate_icon_color, $toolbar_icon_color,
$toolbar_logo_link_text_color, $toolbar_logo_text_color,
$toolbar_search_scope_option_text_color,
$toolbar_search_scope_options_text_color,
$toolbar_search_scope_selector_icon_color,
$toolbar_search_scope_selector_text_color,
$toolbar_tab_text_color, $toolbar_text_color,
$unsupported_browser_message_text_color

$_layout_color_3 $disqus_background_color, $footer_text_color, $header_text_color,
$menu_background_color, $menu_index_background_color,
$menu_nav_buttons_current_background_color,
$menu_toc_background_color, $menu_toc_item_background_color,
$mini_toc_background_color,
$toolbar_search_scope_option_background_color,
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Layout Color Inherited By

$toolbar_search_scope_options_background_color,
$toolbar_search_scope_selector_background_color,
$toolbar_tab_background_color

$_layout_color_4 $lightbox_button_close_icon_color,
$menu_nav_buttons_icon_color_click,
$menu_nav_buttons_icon_color_hover,
$menu_toc_item_current_icon_color,
$menu_toc_item_current_icon_color_click,
$menu_toc_item_current_icon_color_hover,
$menu_toc_item_current_text_color,
$menu_toc_item_current_text_color_click,
$menu_toc_item_current_text_color_hover,
$menu_toc_item_icon_color_click, $menu_toc_item_icon_color_hover,
$menu_toc_item_text_color_click, $menu_toc_item_text_color_hover,
$mini_toc_entry_text_color_hover,
$mini_toc_entry_text_color_visited_hover,
$no_javascript_text_color, $page_breadcrumbs_link_color,
$page_breadcrumbs_link_color_hover,
$page_breadcrumbs_link_color_visited,
$page_breadcrumbs_link_color_visited_hover,
$page_breadcrumbs_text_color,
$toolbar_search_scope_option_text_color_hover,
$toolbar_search_scope_selector_icon_color_hover,
$toolbar_search_scope_selector_text_color_hover,
$toolbar_tab_current_text_color,
$toolbar_tab_current_text_color_hover,
$toolbar_tab_text_color_hover

$_layout_color_5 $footer_background_color, $footer_copyright_message_text_color,
$footer_hr_color, $footer_publish_date_text_color,
$header_background_color, $page_breadcrumbs_background_color

$_layout_color_6 $page_background_color, $search_background_color,
$search_result_background_color

$_layout_color_7 $back_to_top_background_color,
$back_to_top_background_color_hover,
$menu_toc_item_current_highlight_color,
$related_topics_title_background_color,
$toolbar_background_color, $toolbar_button_background_color,
$toolbar_button_home_background_color,
$toolbar_button_home_background_color_click,
$toolbar_button_home_background_color_hover,
$toolbar_button_menu_background_color,
$toolbar_button_menu_background_color_click,
$toolbar_button_menu_background_color_hover,
$toolbar_button_next_background_color,
$toolbar_button_next_background_color_click,
$toolbar_button_next_background_color_hover,
$toolbar_button_previous_background_color,
$toolbar_button_previous_background_color_click,
$toolbar_button_previous_background_color_hover,
$toolbar_button_search_background_color,
$toolbar_button_search_background_color_click,
$toolbar_button_search_background_color_hover,
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$toolbar_button_translate_background_color,
$toolbar_button_translate_background_color_click,
$toolbar_button_translate_background_color_hover,
$toolbar_logo_section_background_color,
$toolbar_search_section_background_color

$_layout_color_8 $menu_toc_item_current_background_color,
$menu_toc_item_current_background_color_click,
$menu_toc_item_current_background_color_hover

$_layout_color_9 $menu_nav_buttons_background_color_click,
$menu_nav_buttons_background_color_hover,
$menu_toc_item_background_color_click,
$menu_toc_item_background_color_hover,
$toolbar_search_scope_option_background_color_hover,
$toolbar_search_scope_selector_background_color_hover

$_layout_color_10$menu_index_link_color, $menu_index_text_color,
$menu_index_title_color, $menu_toc_item_text_color,
$page_helpful_message_text_color

Corporate

Layout Color Inherited By

$_layout_color_1 $mini_toc_entry_background_color_hover,
$page_breadcrumbs_link_color, $page_breadcrumbs_link_color_hover,
$page_breadcrumbs_link_color_visited,
$page_breadcrumbs_link_color_visited_hover,
$related_topics_entry_text_color,
$unsupported_browser_heading_text_color

$_layout_color_2 $back_to_top_caret_color, $menu_nav_buttons_icon_color_click,
$menu_nav_buttons_icon_color_hover,
$page_helpful_button_icon_color,
$page_toolbar_icon_divider_color,
$page_toolbar_social_icon_color,
$page_toolbar_social_icon_facebook_color,
$page_toolbar_social_icon_linkedin_color,
$page_toolbar_social_icon_twitter_color,
$page_toolbar_tool_icon_color,
$related_topics_dropdown_toggle_icon_color,
$related_topics_entry_icon_color,
$related_topics_title_text_color,
$toolbar_button_home_icon_color,
$toolbar_button_home_icon_color_click,
$toolbar_button_home_icon_color_hover,
$toolbar_button_icon_color, $toolbar_button_menu_icon_color,
$toolbar_button_menu_icon_color_click,
$toolbar_button_menu_icon_color_hover,
$toolbar_button_next_icon_color,
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$toolbar_button_next_icon_color_click,
$toolbar_button_next_icon_color_hover,
$toolbar_button_previous_icon_color,
$toolbar_button_previous_icon_color_click,
$toolbar_button_previous_icon_color_hover,
$toolbar_button_search_icon_color,
$toolbar_button_search_icon_color_click,
$toolbar_button_search_icon_color_hover,
$toolbar_button_translate_icon_color,
$toolbar_button_translate_icon_color_click,
$toolbar_button_translate_icon_color_hover, $toolbar_icon_color,
$toolbar_logo_link_text_color, $toolbar_logo_text_color,
$toolbar_tab_text_color, $toolbar_text_color

$_layout_color_3 $disqus_background_color, $footer_text_color, $header_text_color

$_layout_color_4 $menu_index_link_color, $menu_index_text_color,
$menu_index_title_color, $menu_toc_title_text_color,
$mini_toc_entry_text_color, $mini_toc_entry_text_color_visited,
$no_javascript_text_color, $page_breadcrumbs_text_color,
$page_dropdown_arrow_color, $page_helpful_message_text_color,
$search_filter_message_text_color, $search_plain_text_color,
$search_result_count_message_text_color,
$search_result_icon_color,
$search_result_summary_highlight_text_color,
$search_result_summary_text_color, $search_title_text_color,
$toolbar_search_scope_option_text_color,
$toolbar_search_scope_option_text_color_hover,
$toolbar_search_scope_options_text_color,
$toolbar_search_scope_selector_icon_color,
$toolbar_search_scope_selector_icon_color_hover,
$toolbar_search_scope_selector_text_color,
$toolbar_search_scope_selector_text_color_hover,
$unsupported_browser_message_text_color

$_layout_color_5 $toolbar_button_home_background_color_hover,
$toolbar_button_menu_background_color_hover,
$toolbar_button_next_background_color_hover,
$toolbar_button_previous_background_color_hover,
$toolbar_button_translate_background_color_hover,
$toolbar_search_section_background_color_hover

$_layout_color_6 $menu_background_color, $menu_index_background_color,
$menu_nav_buttons_current_background_color,
$menu_toc_background_color, $menu_toc_item_background_color,
$mini_toc_background_color, $page_background_color,
$page_breadcrumbs_background_color,
$search_background_color, $search_result_background_color,
$toolbar_search_scope_option_background_color,
$toolbar_search_scope_options_background_color,
$toolbar_search_scope_selector_background_color

$_layout_color_7 $back_to_top_background_color,
$back_to_top_background_color_hover,
$menu_toc_item_current_highlight_color,
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$related_topics_title_background_color,
$toolbar_background_color, $toolbar_button_background_color,
$toolbar_button_home_background_color,
$toolbar_button_menu_background_color,
$toolbar_button_next_background_color,
$toolbar_button_previous_background_color,
$toolbar_button_search_background_color,
$toolbar_button_search_background_color_click,
$toolbar_button_search_background_color_hover,
$toolbar_button_translate_background_color,
$toolbar_logo_section_background_color,
$toolbar_search_section_background_color

$_layout_color_8 $toolbar_button_home_background_color_click,
$toolbar_button_menu_background_color_click,
$toolbar_button_next_background_color_click,
$toolbar_button_previous_background_color_click,
$toolbar_button_translate_background_color_click

$_layout_color_9 $menu_nav_buttons_background_color_click,
$menu_nav_buttons_background_color_hover

$_layout_color_10$lightbox_button_close_icon_color,
$mini_toc_entry_text_color_hover,
$mini_toc_entry_text_color_visited_hover,
$toolbar_tab_current_text_color,
$toolbar_tab_current_text_color_hover,
$toolbar_tab_text_color_hover

$_layout_color_11$menu_nav_buttons_current_icon_color,
$menu_nav_buttons_current_icon_color_click,
$menu_nav_buttons_current_icon_color_hover,
$menu_nav_buttons_icon_color, $menu_text_color,
$menu_toc_item_current_icon_color,
$menu_toc_item_current_icon_color_click,
$menu_toc_item_current_icon_color_hover,
$menu_toc_item_current_text_color,
$menu_toc_item_current_text_color_click,
$menu_toc_item_current_text_color_hover,
$menu_toc_item_icon_color, $menu_toc_item_icon_color_click,
$menu_toc_item_icon_color_hover, $menu_toc_item_text_color,
$menu_toc_item_text_color_click, $menu_toc_item_text_color_hover

$_layout_color_12$footer_background_color, $header_background_color,
$toolbar_tab_background_color,
$toolbar_tab_current_background_color,
$toolbar_tabs_container_background_color

Metro
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$_layout_color_1 $back_to_top_background_color, $footer_link_color,
$header_link_color, $link_default_color,
$mini_toc_entry_background_color_hover,
$page_breadcrumbs_link_color, $page_breadcrumbs_link_color_hover,
$page_helpful_button_icon_color_selected,
$related_topics_entry_text_color,
$related_topics_title_background_color,
$toolbar_tab_background_color,
$unsupported_browser_heading_text_color

$_layout_color_2 $back_to_top_caret_color, $menu_toc_item_current_text_color,
$menu_toc_item_current_text_color_click,
$menu_toc_item_current_text_color_hover,
$menu_toc_item_text_color_click, $menu_toc_item_text_color_hover,
$mini_toc_entry_text_color, $mini_toc_entry_text_color_visited,
$page_dropdown_arrow_color, $page_helpful_button_icon_color,
$page_helpful_message_text_color,
$page_toolbar_icon_divider_color,
$page_toolbar_social_icon_color,
$page_toolbar_social_icon_facebook_color,
$page_toolbar_social_icon_linkedin_color,
$page_toolbar_social_icon_twitter_color,
$page_toolbar_tool_icon_color,
$related_topics_dropdown_toggle_icon_color,
$related_topics_entry_icon_color,
$related_topics_title_text_color,
$search_filter_message_text_color, $search_plain_text_color,
$search_result_count_message_text_color,
$search_result_icon_color,
$search_result_summary_highlight_text_color,
$search_result_summary_text_color, $search_title_text_color,
$toolbar_logo_link_text_color, $toolbar_logo_text_color,
$toolbar_search_scope_option_text_color,
$toolbar_search_scope_options_text_color,
$toolbar_search_scope_selector_icon_color,
$toolbar_search_scope_selector_text_color,
$toolbar_tab_current_text_color,
$toolbar_tab_current_text_color_hover, $toolbar_text_color,
$unsupported_browser_message_text_color

$_layout_color_3 $disqus_background_color, $footer_text_color,
$header_text_color, $menu_index_link_color,
$menu_index_text_color, $menu_index_title_color,
$menu_nav_buttons_background_color_click,
$menu_nav_buttons_current_icon_color,
$menu_nav_buttons_current_icon_color_click,
$menu_nav_buttons_current_icon_color_hover,
$menu_nav_buttons_icon_color_hover,
$menu_text_color, $menu_toc_item_current_icon_color,
$menu_toc_item_current_icon_color_click,
$menu_toc_item_current_icon_color_hover,
$menu_toc_item_icon_color_click,
$menu_toc_item_icon_color_hover, $menu_toc_item_text_color,
$menu_toc_title_text_color, $mini_toc_background_color,
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$toolbar_button_home_background_color_click,
$toolbar_button_menu_background_color_click,
$toolbar_button_next_background_color_click,
$toolbar_button_previous_background_color_click,
$toolbar_button_translate_background_color_click,
$toolbar_search_scope_option_background_color,
$toolbar_search_scope_options_background_color,
$toolbar_search_scope_selector_background_color

$_layout_color_4 $lightbox_button_close_icon_color,
$mini_toc_entry_text_color_hover,
$mini_toc_entry_text_color_visited_hover,
$no_javascript_text_color, $page_breadcrumbs_text_color,
$toolbar_button_home_icon_color,
$toolbar_button_home_icon_color_hover,
$toolbar_button_icon_color, $toolbar_button_menu_icon_color,
$toolbar_button_menu_icon_color_hover,
$toolbar_button_next_icon_color,
$toolbar_button_next_icon_color_hover,
$toolbar_button_previous_icon_color,
$toolbar_button_previous_icon_color_hover,
$toolbar_button_search_icon_color,
$toolbar_button_search_icon_color_hover,
$toolbar_button_translate_icon_color,
$toolbar_button_translate_icon_color_hover, $toolbar_icon_color,
$toolbar_tab_text_color, $toolbar_tab_text_color_hover

$_layout_color_5 $footer_background_color, $header_background_color,
$menu_toc_item_current_highlight_color,
$page_breadcrumbs_background_color, $toolbar_background_color,
$toolbar_tabs_container_background_color

$_layout_color_6 $page_background_color, $search_background_color,
$search_result_background_color

$_layout_color_7 $menu_background_color, $menu_index_background_color,
$menu_nav_buttons_background_color,
$menu_nav_buttons_background_color_hover,
$menu_nav_buttons_current_background_color,
$menu_toc_background_color, $menu_toc_item_background_color,
$toolbar_button_background_color,
$toolbar_button_home_background_color,
$toolbar_button_home_background_color_hover,
$toolbar_button_menu_background_color,
$toolbar_button_menu_background_color_hover,
$toolbar_button_next_background_color,
$toolbar_button_next_background_color_hover,
$toolbar_button_previous_background_color,
$toolbar_button_previous_background_color_hover,
$toolbar_button_translate_background_color,
$toolbar_button_translate_background_color_hover,
$toolbar_logo_section_background_color,
$toolbar_search_section_background_color
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$_layout_color_8 $menu_toc_item_background_color_click,
$menu_toc_item_background_color_hover

$_layout_color_9 $menu_toc_item_current_background_color,
$menu_toc_item_current_background_color_click,
$menu_toc_item_current_background_color_hover,
$toolbar_tab_current_background_color

Social

Layout Color Inherited By

$_layout_color_1 $back_to_top_background_color, $footer_link_color,
$header_link_color, $link_default_color,
$menu_nav_buttons_background_color_hover,
$menu_toc_item_current_highlight_color,
$mini_toc_entry_background_color_hover,
$page_breadcrumbs_link_color, $page_breadcrumbs_link_color_hover,
$page_helpful_button_icon_color,
$page_helpful_button_icon_color_selected,
$related_topics_entry_text_color,
$related_topics_title_background_color,
$toolbar_background_color, $toolbar_button_background_color,
$toolbar_button_home_background_color,
$toolbar_button_menu_background_color,
$toolbar_button_next_background_color,
$toolbar_button_previous_background_color,
$toolbar_button_search_background_color,
$toolbar_button_translate_background_color,
$toolbar_logo_section_background_color,
$toolbar_search_section_background_color,
$toolbar_tab_background_color,
$toolbar_tabs_container_background_color,
$unsupported_browser_heading_text_color

$_layout_color_2 $back_to_top_caret_color, $menu_index_link_color,
$menu_index_text_color, $menu_index_title_color,
$menu_nav_buttons_current_icon_color,
$menu_nav_buttons_current_icon_color_click,
$menu_nav_buttons_current_icon_color_hover,
$menu_nav_buttons_icon_color, $menu_text_color,
$menu_toc_item_icon_color, $menu_toc_item_text_color,
$menu_toc_title_text_color, $mini_toc_entry_text_color,
$mini_toc_entry_text_color_visited, $page_breadcrumbs_text_color,
$page_dropdown_arrow_color, $page_helpful_message_text_color,
$page_toolbar_icon_divider_color,
$page_toolbar_social_icon_color,
$page_toolbar_social_icon_facebook_color,
$page_toolbar_social_icon_linkedin_color,
$page_toolbar_social_icon_twitter_color,
$page_toolbar_tool_icon_color, $related_topics_entry_icon_color,
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$search_filter_message_text_color, $search_plain_text_color,
$search_result_count_message_text_color,
$search_result_icon_color,
$search_result_summary_highlight_text_color,
$search_result_summary_text_color, $search_title_text_color,
$toolbar_search_scope_option_text_color,
$toolbar_search_scope_options_text_color,
$toolbar_search_scope_selector_icon_color,
$toolbar_search_scope_selector_text_color,
$unsupported_browser_message_text_color

$_layout_color_3 $disqus_background_color, $footer_text_color, $header_text_color,
$menu_background_color, $menu_index_background_color,
$menu_nav_buttons_current_background_color,
$menu_toc_background_color, $menu_toc_item_background_color,
$mini_toc_background_color,
$toolbar_search_scope_option_background_color,
$toolbar_search_scope_options_background_color,
$toolbar_search_scope_selector_background_color

$_layout_color_4 $lightbox_button_close_icon_color,
$menu_nav_buttons_icon_color_hover,
$mini_toc_entry_text_color_hover,
$mini_toc_entry_text_color_visited_hover,
$no_javascript_text_color,
$related_topics_dropdown_toggle_icon_color,
$related_topics_title_text_color,
$toolbar_button_home_icon_color,
$toolbar_button_home_icon_color_click,
$toolbar_button_home_icon_color_hover,
$toolbar_button_icon_color, $toolbar_button_menu_icon_color,
$toolbar_button_menu_icon_color_click,
$toolbar_button_menu_icon_color_hover,
$toolbar_button_next_icon_color,
$toolbar_button_next_icon_color_click,
$toolbar_button_next_icon_color_hover,
$toolbar_button_previous_icon_color,
$toolbar_button_previous_icon_color_click,
$toolbar_button_previous_icon_color_hover,
$toolbar_button_search_icon_color,
$toolbar_button_search_icon_color_click,
$toolbar_button_search_icon_color_hover,
$toolbar_button_translate_icon_color,
$toolbar_button_translate_icon_color_click,
$toolbar_button_translate_icon_color_hover,
$toolbar_icon_color, $toolbar_logo_link_text_color,
$toolbar_logo_text_color, $toolbar_tab_current_text_color,
$toolbar_tab_current_text_color_hover, $toolbar_tab_text_color,
$toolbar_tab_text_color_hover, $toolbar_text_color

$_layout_color_5 $footer_background_color, $header_background_color

$_layout_color_6 $page_background_color, $page_breadcrumbs_background_color,
$search_background_color, $search_result_background_color
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$_layout_color_7 $toolbar_button_icon_color_disabled,
$toolbar_button_menu_icon_color_disabled
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Target Settings for WebWorks Reverb 2.0
WebWorks Reverb defines several format specific settings.
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WebWorks Reverb 2.0 Target Settings
The complete reference of WebWorks Reverb 2.0 Settings.
 

Format Setting Use

Browser Tab Icon (favicon) Specifies a .png .ico or .jpg file to use as the
Browser Tab Icon (favicon) for the Reverb 2.0 help
set.

Display large images in lightbox When a thumbnail is used for an image, the full size
version of the image can be viewed by clicking the
image which is then displayed in a lightbox. When
disabled the image displays in a separate file.

Enable Print Icon Enables/disables the print icon in generated pages

Entry Filename Specifies the name of the Reverb entry-point file
name (default is “index.html”)

Feedback Email Defines the feedback email address for use in
generated pages

Feedback Email Message Defines the contents of the feedback email subject
line and body section. Use $Location; to insert the
URL of the current page

Skin Specifies an alternate plugin file to use for changing
the look-and-feel of the Reverb skin.

Use first document as splash
page

Determines initial page displayed

WebWorks Help API
Compatibility

Enables/disables compatability with the WebWorks
Help API allowing Reverb to replace existing
implementations of WebWorks Help while using the
same API.
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WebWorks Reverb 2.0 Toolbar Target Settings
The complete reference of WebWorks Reverb 2.0 Target Settings that affect the toolbar.
 

Format Setting Use

Google Translate Button Enables/disables Google Translate on content
pages. The Reverb 2.0 output must be hosted on a
server in order for the button to render in the toolbar.

Home Enables/disables the home navigation button which
navigates users to the first page in the browse
sequence

Linked Toolbar Logo Enables or Disables linking of the Toolbar Logo. If
this setting is Enabled, the user must also set an
address in the Toolbar Logo Link Address setting.

Toolbar Logo Determines what Company Info item should be
used, if any. Users can select None, Company
name, or Company logo image.

Toolbar Logo Link Address Determines an address the Linked Toolbar Logo
directs to when a user clicks on the Toolbar Logo.

Toolbar Logo Override Allows the user to set a custom image for the
Toolbar Logo. As the name suggests, this setting will
override any setting selected in the Toolbar Logo
setting.
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WebWorks Reverb 2.0 Analytics Target Settings
The complete reference of WebWorks Reverb 2.0 Target Settings that pertain to analytics.
 

Format Setting Use

Google Tracking ID Sets the Tracking ID associated with a view on your
Google Analytics account. Setting a value in this
field enables analytics.

Page “Was This Helpful?”
Buttons

Enables a set of buttons on content pages that
provides the user with a pair of icon buttons that
reports to analytics whether a page was helpful or
not.

Search “Was This Helpful?”
Buttons

Enables a set of buttons the search results page
that provides the user with a pair of icon buttons that
reports to analytics whether a set of search results
was helpful or not.
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WebWorks Reverb 2.0 Menu Target Settings
The complete reference of WebWorks Reverb 2.0 Target Settings that affect the menu.
 

Format Setting Use

Generate Menu Determines whether the menu is generated or not.

Menu Initial State Determines whether the menu is visible or hidden to
users when they first visit the help set.

Minimum Page Width for Docked
Menu

Sets the minimum width that the viewport must be
to allow the menu to use docked behavior. If the
viewport is less wide than this value, the user will be
presented with the mobile view.
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WebWorks Reverb 2.0 Page Target Settings
The complete reference of WebWorks Reverb 2.0 Target Settings that affect the page.
 

Format Setting Use

Document Last Modified Date When enabled, this setting will display the date that
the source document a content page is generated
from was last modified. The date will be added to
the content page in the output after source content.

Dropdown Expand/Collapse
Toggle Button

This setting will render a button in the page toolbar
that, when clicked, will simultaneously toggle
all available dropdowns on a content page to
an expanded or collapsed state. This button is
only rendered on a content page if there are also
dropdowns present on that page.

Publish Date When enabled, this setting will display the date that
the output was generated from ePublisher. The date
will be added to the content page in the output after
source content.

Related Topic Dropdown Icon
Position

This setting determines whether the icon that
handles the expand/collapse behavior for Related
Topics is positioned to the Left or Right of the title of
the Related Topics.

Related Topic Dropdown Start
Behavior

This setting determines whether a set of Related
Topics will be expanded or collapsed upon first visit
of a content page.

Reverb 2.0 Page Style Specifies the page style to use when processing the
Reverb entry-point file that encapsulates the TOC,
Index, Search, and content panels.

Splash Page Style Specifies the page style to use when processing the
splash page (move)

Use Dropdown for Related Topics When enabled, this setting applies dropdown
behavior to Related Topics, allowing it to be
expanded or collapsed with the click of a button.
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WebWorks Reverb 2.0 Footer Target Settings
The complete reference of WebWorks Reverb 2.0 Target Settings that affect the footer.
 

Format Setting Use

Footer Location Determines where the footer is generated. If End
of Layout is selected, the footer will be generated
underneath both the menu and the page content.
If End of Page is selected, the footer will be
generated next to the menu and underneath the
page content.

Footer Logo Determines what Company Info item should be
used, if any. Users can select None, Company
name, or Company logo image.

Footer Logo Link Address Determines an address the Linked Footer Logo
directs to when a user clicks on the Footer Logo.

Footer Logo Override Allows the user to set a custom image for the
Footer Logo. As the name suggests, this setting will
override any setting selected in the Footer Logo
setting.

Generate Footer Determines whether the footer is generated or not.

Linked Footer Logo Enables or Disables linking of the Footer Logo. If
this setting is Enabled, the user must also set an
address in the Footer Logo Link Address setting.

Publish Date When enabled, this setting will display the date that
the output was generated from ePublisher. The date
will be added to the footer in the same area that the
copyright information is displayed by default.
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Social Target Settings
The complete reference of Social Media Settings.
 

Format Setting Use

Disqus Identifier Enables support for user comments using the
Disqus comment web service

Disqus - Allow non-public
networks

Enable users to post Disqus comments behind a
firewall or non-public website

FaceBook Like Enables users to report “I like this!” in Facebook

Google +1 Button Enables users to recommend the current page to
their Google +1 social networks

LinkedIn Share Enables users to share the current page to their
LinkedIn community as well as increment the
counter that shows how many times the link has
been shared.

Tweet This! Enable Twitter “Tweet This!” support
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Selecting an Alternate Skin for WebWorks Reverb 2.0
In WebWorks Reverb 2.0, you can select among several alternate skins to define the appearance of your
help. When you specify an alternate skin, the underlying ASP and CSS files will be automatically updated
to reflect the differences in that skin.

To choose an alternate skin for WebWorks Reverb

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. In the WebWorks Reverb 2.0 category, select the right column of the Skin entry to display the file
picker button.

4. Click the file picker button to bring up an Open file dialog which will display a list of skin plugin
files. Each skin plugin file is identifiable by a .weplugin  extension.

5. Browse to the plugin file that you wish to use and double-click it to set the skin to that value.

Once you have set an alternate skin, you can later change it again using the same procedure.

Warning:If you have customized any files using the Advanced menu to create a Target override, then
you will need to remove that customization and then re-implement it again after you change
the skin setting. For more information on implementing and managing Target overrides see
“Creating Target Overrides”.

Note: If you are going to customize an alternative Reverb 2.0 skin, first set the skin type in the
Target Settings then create a Target Customization override for the file(s) that you want to
customize.
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Customizing the Top-Level Entry File

Specifying the Entry Page Name
When you generate output for your project, a top-level entry file is created. This file defines the frameset
for the help and gives the user a file to open that displays the complete help. By default, the top-level
entry file is named index.html , but you can specify any name you need for the top-level entry file as
long as you specify an .html  or .htm  extension.

To rename the top-level file

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. In Entry filename, type the name you want to use for the top-level entry file.

4. Click OK.

5. Regenerate the project and review the results.
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Specifying the Entry Page Style
WebWorks Reverb 2.0 allows users to leverage ePublisher’s Style Designer to set color and layout
properties of the generated entry page. Users can specify a page style to use under the WebWorks Reverb
2.0 section of the Target Settings dialog.
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Customizing TOC Menu Item Display

Specifying TOC Item CSS Class
WebWorks Reverb 2.0 allows users to be able to customize the style of each individual entry in the Table
of Contents. Users can specify an entry style by simply editing the TOCEntryStyle marker to contain the
name of the CSS class.
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Customizing the Splash Page in WebWorks Reverb 2.0
You can modify or remove the splash page that is displayed while your WebWorks Reverb 2.0 opens. You
can customize the splash page in the Stationery, and then writers can override this customization in each
project, as needed.
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Specifying the Splash Page Style
WebWorks Reverb 2.0 allows users to leverage ePublisher’s Style Designer to set color and layout
properties of the generated splash page. Users can specify a page style to use under the WebWorks Reverb
2.0 section of the Target Settings dialog.
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Replacing the Splash Image
The splash page is the first page that displays in the topic pane when the help set launches initially. By
default, WebWorks Reverb 2.0 systems display the WebWorks Reverb 2.0 splash image. You can replace
the default splash image with a custom image.

To replace the splash page image

1. Identify the theme in use for your WebWorks Reverb 2.0 target that you want to modify.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the image for all WebWorks Reverb 2.0 targets, create the
Formats\WebWorks Reverb 2.0\Pages\images  folder in your projectname folder, where
projectname is the name of your ePublisher project.

4. If you want to override the image for one WebWorks Reverb 2.0 target, create the
Targets\<Target Name>\Pages\images  folder in your projectname folder, where projectname
is the name of your ePublisher project and Target Name is the name of the specific target that will
use this splash page image.

5. Copy the splash.png  file from the following folder to the images  override folder you created
within your project folder:

Program Files\WebWorks\ePublisher Pro\Formats\WebWorks Reverb 2.0\ Pages\images

6. Open the splash.png  file you copied to your project override folder and modify it to be the splash
page image you want.

7. Save and close the splash.png  file.

8. Regenerate your project to review the changes.
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Modifying the Splash Page
Users may also create an override for the splash page template, Splash.asp. This allows users to change
every aspect of a splash page’s appearance.
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Removing the Splash Page
When WebWorks Reverb 2.0 opens, it displays the splash page. However, instead of displaying the splash
page, you can configure WebWorks Reverb 2.0 to display the first topic in the help.

To remove the splash page

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Set Use first document as splash page to Enabled.

4. Click OK.

5. Regenerate the project and review the results.

318 | Removing the Splash Page



Using Context-Sensitive Help in WebWorks Reverb 2.0
Context-sensitive help links provide content based on the context of what the user is doing. In many
cases, this help content is based on the window that is open and active. For example, the Help button on a
window in a software product can open a specific help topic that provides important information about the
window and links to related topics.

WebWorks Reverb 2.0 allows you to use a TopicAlias marker to define an internal identifier for each
topic. The benefit of using an internal identifier is that it allows file names to change without impacting
the links from the product. The writer inserts this marker in a topic and specifies a unique value for that
topic. ePublisher creates a mapping file to identify each topic associated with a unique value. Then,
WebWorks Reverb 2.0 uses this internal identifier and the mapping file to display the correct topic.
Before you can reference topics in WebWorks Reverb 2.0 using topic aliases, you must enable TopicAlias
markers in your Stationery. For more information, see “Defining Filename Markers for Context-Sensitive
Help Links”.
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Mapping Files in WebWorks Reverb 2.0
WebWorks Reverb 2.0 does not generate a mapping file. However, you can see a list of defined contexts
and topics in the parcel file. You can also use the Topics Report to verify that context-sensitive help topics
have been created for each topic ID specified in your source document. The Topics Report lists the topic
ID and the topic file created for each topic ID.Topic aliases report. For more information about the topics
report, see “Topics Reports”.
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Opening Context-Sensitive Help in WebWorks Reverb 2.0 using Standard
URLs
You can open WebWorks Reverb 2.0 from the application using standard URLs.

To open a specific topic in WebWorks Reverb 2.0, use the following URL:

helplocation/index.html#context/topic_alias

or with the now optional group_context  parameter:

helplocation/index.html#context/group_context/topic_alias

The variable parts of this URL are defined as follows:

helplocation
Specifies the location of the desired WebWorks Reverb 2.0 help set. If the help is on a Web server,
specify the location using the http  protocol and the Web site path to the root of the help, such as
http://www.webworks.com/help .

group_context
Now optional, but useful when you have the same topic alias value used in more than one group.

Specifies the group context value for the top-level group in which the topic resides in Document
Manager. This group context is specified in merge settings for each top-level group.

topic_alias
Specifies the value of the TopicAlias marker in the topic to open.
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URL Commands Support by WebWorks Reverb 2.0
WebWorks Reverb 2.0 supports additional commands in addition to context-sensitive help.

 

Command Related Action

index.html# context / group_context / topic_aliasDisplay specified context-sensitive help topic

index.html# page / child_page_pathDisplays define child page

index.html# search / search
words

Initiates search for specific terms

index.html# search / search
words #scope / group_name

Initiates search for specific terms using only the
specified groups

index.html# toc / Display the table of contents panel

index.html# index / Display the index panel

index.html# parcels /
group_name

Loads the help set with only the specified groups
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Opening Context-Sensitive Help in WebWorks Reverb 2.0 using JavaScript
You can use JavaScript to open your context-sensitive help links when working with web applications
or websites designed with HTML and JavaScript. For complete details of using WebWorks Reverb with
web applications and websites, see http://wiki.webworks.com/DevCenter/Projects/Reverb/For Web
Applications.
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Opening Context-Sensitive Help in WebWorks Reverb 2.0 using the
WebWorks Help API
In addition to using simple URLs for opening context-sensitive help, you can alternatively use an API
that is incorporated into your application. Using an API makes it easier to enable help buttons in your
application so that the load the correct page in your Reverb 2.0 output.

WebWorks Reverb 2.0 uses the same API as WebWorks Help 4 and 5.

Steps for Enabling the Context-Sensitive Help API for use with WebWorks Reverb 2.0

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. In the WebWorks Reverb 2.0 category, set WebWorksHelpAPICompatibility to Enabled.

4. Click OK to save the target settings.

5. Have your application developers download the WebWorks Help SDK located at: http://
wiki.webworks.com/DevCenter/Projects/WebWorksHelp/WebWorksHelpSDK. Depending on the
technologies your application uses, your developers will be able to incorporate the API and then
make context-sensitive API calls to your published Reverb 2.0 output.
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Configuring Client-Side Search for Reverb 2.0
This is the default search configuration for WebWorks Reverb 2.0 in the Target Settings. This search
implementation requires no additional setup or configuration. The search implementation supports both
wildcard (*) and phrase searching.
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Configuring Synonyms
By defining a list of synonyms, you can increase the effectiveness of a search by grouping similar words
together as a single result. You can define as synonyms words that are not in your source documents, but
the main word does need to be in a source file. For example, if you define video  and avi  as synonyms
of movie  (main word), then when a user searches for video , a match will be scored showing the source
files where the word itself is in, but also where the main word movie  is as well. Please note that the
inverse is not true, meaning that if a user searches instead for movie , files where the word video  is will
not be scored because of the synonym entry.

To add these definitions, you’ll need to perform an override on a file called locales.xml , located by
default in the ePublisher Designer installation directory here:

  \Formats\WebWorks Reverb 2.0\Shared\common\locale

Once the file is copied to the correct location in your project directory, open it in any text- or XML-
editing application (e.g., NotePad), and add entries to the <Synonyms>  section. For example, your
synonyms might look like this:

  <Synonyms>

   <Word value="movie">

    <Synonym value="avi" />

    <Synonym value="video" />

   </Word>

   <Word value="designer">

    <Synonym value="pro" />

    <Synonym value="publisher" />

   </Word>

  </Synonyms>

Please note that the Synonyms feature does not recognize multiple word values or synonyms. And, it
ignores words (and synonyms) shorter in length than the specified value for MinimumWordLength defined
in the same file. Synonyms are not case sensitive.
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Searching WebWorks Reverb 2.0 - URL Method
When viewing the URL for your help, you can use a search term after the URL, for example you can go
to the link here: https://www.webworks.com/Documentation/Reverb/index.html#search/ePublisher

When clicked, the link above searches for the term “ePublisher” this can be changed to any search term,
which will produce results accordingly.
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Incorporating Google Analytics for Your Reverb 2.0 Files
WebWorks Reverb 2.0 is not only a fully functional help system for your content, it’s also a collection
of distinct web page files that can be viewed individually on a website. In fact, you can very easily share
URLs of individual page files from your Reverb 2.0 help system. These URLs will load just like a single
web page within a browser. While this is very nice from an end-user perspective, because the load times
are very minimal, it is even better from a publisher perspective. Simply put, you can now easily track the
usage patterns and frequencies of all your Reverb 2.0 help pages, which is where the value of Google
Analytics comes in; all you have to do is either determine the appropriate Google Analytics Account ID
that your website is currently using (if Google Analytics has already been setup for your website), or
create a Google Analytics Account which will then provide a unique identifier for your website or website
path.

Once you have obtained the appropriate Google Analytics Account ID, then you simply set your
ePublisher project’s target setting located at: Analytics > Google Tracking ID.
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Configuring Commenting and End-User Feedback for
Reverb 2.0
WebWorks Reverb 2.0 uses the Disqus commenting platform for enabling a very powerful and cost-
effective commenting and discussion system. The integration with WebWorks Reverb 2.0 is not only
transparent, it is optimized to ensure fast downloads. To enable this feature, all you need to do is set up
a Disqus account and then create a Disqus Site for your Reverb 2.0 help volume(s). Once you create a
Disqus Site, you will then use the site’s Disqus Site Shortname as the setting value for your ePublisher
project’s target setting located at: Social > Disqus Identifier. The Disqus Site can then be used to track
and manage all the threads used within your deployed Reverb 2.0 help volume(s). For the reports, you can
use the Disqus engagement features: https://disqus.com/.

For more information regarding the API, refer to the documentation: https://disqus.com/api
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Customizing Icons in Your Reverb 2.0 Output Using Font
Awesome
In WebWorks Reverb 2.0, all icons in the output can be configured to use another icon that is a part of
Font Awesome's 5.15.4 package. In Reverb 2.0, all icons are injected to the output by using a unique
character code defined by Font Awesome.

The icons can be found in the file _icons.scss .

Steps to customize a font awesome icon:

1. Create a format or target override for the file _icons.scss .

2. Open _icons.scss in a text editor.

3. Open the Font Awesome cheatsheet. You can use the cheatsheet found on the web.

Cheatsheet web location:

https://fontawesome.com/v5/cheatsheet/free

4. Find the 4-character code for the icon that is to be used.

Note: The web cheatsheet's character codes look like: f2bb. You only need the 4 characters starting
at 'f'.

5. Find the variable for the icon that is to be changed.

6. Change the value of the variable to the new character code, wrapped in quotes with a leading
backslash, ex: \f2bb.

7. Save the file and generate a new Reverb 2.0 output.
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Incorporating Web Fonts in Your Reverb 2.0 Output
In WebWorks Reverb 2.0, you can select from many of the built-in fonts in the Font Family Picker
window. However, it is possible to incorporate web fonts in to your Reverb 2.0 output.

Steps for integrating web fonts

1. Save the font file in the Files folder of your project. For the example below, mycustomfont.ttf
would be placed into this folder.

2. Add the following to your webworks.scss  file, just below the @import statements at the top of the
file.

@font-face {

  font-family: 'Custom Font';

  src: url('../mycustomfont.ttf') format('truetype');

}

Note: The URL contains the path to the location where the font is saved. The path must be entered
correctly for the font to be located and used by the browser. By default, ePublisher copies
any file inside the files folder of your project to the appropriate location of your output. The
URL in the example above is a relative path from the output CSS file to the font file.

3. In the WebWorks Reverb 2.0 Font Family Picker window, enter the name of your custom font in
the Custom font family input. Press the right arrow button to add the custom font to your selected
fonts.
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4. Click OK to save the target settings.

Steps for integrating Google Fonts

1. Copy the @import statement for the selected Google font (Do not copy the style tags).

Example:

@import url('https://fonts.googleapis.com/css?family=Rubik');

2. Paste the @import statement in to your webworks.scss file, just below the other @import statements
at the top of the file.

3. Add the following code just below the @import statement, replacing the font-family in the example
with the the font-family of the selected font.

     @font-face {

  font-family: 'Rubik', sans-serif;

}

4. In the WebWorks Reverb 2.0 Font Family Picker window, enter the name of your selected
Google font in the Custom font family input. Press the right arrow button to add the custom font
to your selected fonts

5. Click OK to save the target settings.
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Steps to Create Your First Disqus Site
1. Visit the URL: https://disqus.com/. Then select the Sign Up button. You will then be taken through

a few simple forms which will create your Disqus Login as well as your initial Disqus Site.

2. In the field Site URL , specify the URL that best describes where your Reverb volume(s) will exist
on your website.

Note: You can use a single Disqus site for all your Reverb deployments that exist on the same
website or you can use separate Disqus sites for each separately deployed Reverb volume.
Disqus provides a wide range of solutions for managing and moderating threads so choosing
either strategy will be effective and depends more on how your organization’s process will
be handled.

3. In the field Site Name , specify a unique, human readable name that best describes the site.
Then check the Site Shortname  text box field and correct it to suit your preference. The Site
Shortname will not only be used by ePublisher, but will also become the sub-domain used on
Disqus. So if your Site Shortname is epub , then the URL used for this site’s threads will be
http://epub.disqus.com .

4. On the same page, specify the information for the Primary Moderator, other moderators can be
added later. Then select the Continue button.

5. On the Settings page, specify your language and any optional features that you wish to also use.
Then select the Continue button. You now have a Disqus Login as well as your first Disqus Site.
No additional steps are required to begin using your new site
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‘Was This Helpful?’ Buttons
The Was This Helpful? buttons feature allows you to provide your end-uses with the ability to give
anonymous feedback about their experience. The Was This Helpful? buttons feature can be used to
record feedback on the current page or search results being viewed. A Google Tracking ID is required for
these buttons to record analytic events.
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Dropdown Collapse/Expand All Toggle Button
Enables/disables a button that toggles all paragraph dropdown on the currently displayed page. This
applies to all paragraphs with dropdown behavior, as well as Related Topics with dropdown behavior
enabled. This feature is made available by enabling the Dropdown Expand/Collapse Toggle Button
Target Setting.
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Document Last Modified Date/Publish Date
ePublisher can add a time stamp to Reverb 2.0 output that displays the date of the most recent generation,
as well as the last time a source document was modified. The last modified date can be displayed in the
page content area just after the content by default, and the publish date is available in the same area as
the last modified date, as well as near the copyright information in the footer. These features are made
available by enabling the Document Last Modified Date and Publish Date Target Settings.

If you would like to change the date format, it can be done with an override to the locales.xml file.

Copy locales.xml from:

C:\Program Files\WebWorks\ePublisher\2023.1\Formats\Shared\common\locale\locales.xml

To:

<Project Folder>\Formats\Shared\common\locale\locales.xml

In the locales.xml file, locate the element with the name PublishDateFormat. The value inside this
element can be changed to match the desired date format. For more information on how to write proper
format values in this element, refer to Microsoft's documentation on Custom date and time format strings
at: https://docs.microsoft.com/en-us/dotnet/standard/base-types/custom-date-and-time-format-strings.
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Customizing Related Topics
In Reverb 2.0, Related Topics have been given a generous set of customization options related to sizing,
color, and an assignable icon for each topic entry.
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Customizing Related Topic Styling/Appearance
The appearance of Related Topics can customized by making SASS changes to the file webworks.scss.
In this file, all CSS declarations for items with a class name that contains .Related_Topics can be
modified to change the appearance of Related Topics.
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Enabling/Disabling Related Topic Dropdown Behavior
Related Topics can be given dropdown behavior by enabling the Use Dropdown for Related
Topics Target Setting. This will add an icon to the title bar, and enable collapsing and expanding of the
Related Topic list when the title bar is clicked. This feature also works with the Dropdown Toggle Button
feature.

Enabling/Disabling Related Topic Dropdown Behavior | 339



Customizing PDF - XSL-FO

Custom Header and Footers
Document Last Modified Date/Publish Date
Page Template Customizations

The PDF - XSL-FO output format is used by ePublisher to generate PDF files from the documents that
ePublisher is generating. All of the styling and layout is controlled using the user interface of ePublisher
Designer, however some customizations require specific knowledge. This section covers common
customizations.
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Custom Header and Footers
One of the advantages of selecting this format over the traditional PDF format is the ability to customize
the footer and header depending on the Page Styles in the Style Designer. Please keep in mind that this
will only be available per ePublisher Pro as the Style Designer is not available in ePublisher Express.

To customize the Header or Footer

1. In ePublisher Pro, go to the Style Designer -> Page Styles

2. Select the Page Style that you have defined and click the Options tab

3. Depending on where you would like to have your information you can enter in information for
Even or Odd pages

4. Chose to Enable or Disable Header and Footer text under the Generate Output option

5. Chose from the following Variables to customize the content

$Title; This variable expands to the title of the PDF. For the document-level PDF, this
value is the title of the document or the value of the first paragraph. For the
group-level PDF, this value is the name of the Group. For the project-level
PDF, this value is the name of the Target

$PageNumber; This variable expands to the current page number

$RunningTitle; This variable expands to the text of the last paragraph in the flow of the
document which generated a TOC entry

$ChapterTitle; This variable expands to the text of the top-most TOC entry of the document.
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Document Last Modified Date/Publish Date
ePublisher can add a time stamp to PDF XSL-FO Title Page that displays the date of the most recent
generation. This feature is made available by enabling the Generate Publish Date on Title Page Target
Setting.

If you would like to change the date format, it can be done with an override to the locales.xml file.

Copy locales.xml from:

C:\Program Files\WebWorks\ePublisher\2023.1\Formats\Shared\common\locale\locales.xml

To:

<Project Folder>\Formats\Shared\common\locale\locales.xml

In the locales.xml file, locate the element with the name PublishDateFormat. The value inside this
element can be changed to match the desired date format. For more information on how to write proper
format values in this element, refer to Microsoft's documentation on Custom date and time format strings.
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Page Template Customizations
To customize your PDF-XSL-FO output, you can edit the following files:

Note: Page.asp  in PDF-XSL-FO output is not the same as the Page.asp  file in Reverb and
Reverb 2.0 outputs. It is used to layout the other .asp  files.

Page.asp
It is recommended that you do not make edits to this file.

Body.asp
Edit this file if you would like to make customizations to the body pages of your output.

Index.asp
Edit this file if you would like to make customizations to the index pages of your output.

Title.asp
Edit this file if you would like to make customizations to the title page of your output.

TOC.asp
Edit this file if you would like to make customizations to the table of contents of your output.
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Customizing Dynamic HTML

Using SASS to change the Appearance of Dynamic HTML
Modifying the Appearance of the Table of Contents in Dynamic HTML
Modifying the Appearance of the Index in Dynamic HTML
Other Changes to Text in the TOC and Index in Dynamic HTML
Document Last Modified Date/Publish Date

You can customize the appearance of Dynamic HTML in several ways. For example, you can customize
the appearance of the table of contents and the index entries. The following sections describe these
Dynamic HTML-specific customizations.

344 | Customizing Dynamic HTML



Using SASS to change the Appearance of Dynamic
HTML
To facilitate more advanced CSS handling you can enable a Target Setting in the group Files called Use
SASS to compile CSS. If this setting is Enabled webworks.css  will be generated from the SASS file
called webworks.scss . This file is located in the css  folder next to the webworks.css  file.
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Modifying the Appearance of the Table of Contents in
Dynamic HTML
ePublisher stores CSS settings that control the appearance of table of contents entries in the
webworks.css  file. You can create an override file to modify these settings for specific levels of the table
of contents. For example, you can define a different font size and margin for each level in the table of
contents.

To modify the appearance of the table of contents

1. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

2. If you want to override the CSS settings for all Dynamic HTML targets in the project, create the
Formats\Dynamic HTML\Pages\css  folder in your project folder.

3. If you want to override the CSS settings for a specific target, create the Targets
\targetname\Pages\css  folder in your project folder, where targetname is the name of the
target you want to override.

4. Copy the webworks.css  file from the following folder to the override folder you created within
your project folder:

Program Files\WebWorks\ePublisher Pro\Formats\Dynamic HTML\Pages\css

5. Open the webworks.css  file you copied to your project override folder.

6. Find the code for div.WebWorks_TOC_Levelx, where x is the level number you want to modify.
Then, specify the values within the braces to modify the font or margin:

To modify the font of all table of contents entries for the specified level, specify the name of
the font you want, such as font-family: Arial; .

To modify the font size of all table of contents entries for the specified level, specify the size
of the font you want, such as font-size: 14pt; .

To modify the left margin indent of all table of contents entries for the specified level,
specify the indent you want, such as margin-left: 10px; .

7. Save the webworks.css  file.

8. Regenerate your project to review the changes.

For example, the following figure illustrates how you could customize your table of contents entries.

div.WebWorks_TOC_Level1

{ font-size: 14pt;

  font-family: Arial;

  margin-left: 12px;
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}

div.WebWorks_TOC_Level2

{ font-size: 12pt;

  font-family: Arial;

  margin-left: 24px;

}
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Modifying the Appearance of the Index in Dynamic HTML
ePublisher stores CSS settings that control the appearance of index entries in the webworks.css  file. You
can create an override file to modify these settings for specific index entry levels. For example, you can
define a different font size and margin for each level in the index.

To modify the appearance of the index

1. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

2. If you want to override the CSS settings for all Dynamic HTML targets in the project, create the
Formats\Dynamic HTML\Pages\css  folder in your project folder.

3. If you want to override the CSS settings for a specific target, create the Targets
\targetname\Pages\css  folder in your project folder, where targetname is the name of the
target you want to override.

4. Copy the webworks.css  file from the following folder to the override folder you created within
your project folder:

Program Files\WebWorks\ePublisher Pro\Formats\Dynamic HTML\Pages\css

5. Open the webworks.css  file you copied to your project override folder.

6. Find the code for div.WebWorks_Index_Levelx, where x is the level number you want to modify.
Then, specify the values within the braces to modify the font or margin:

To modify the font of all index entries for the specified level, specify the name of the font
you want, such as font-family: Arial; .

To modify the font size of all index entries for the specified level, specify the size of the font
you want, such as font-size: 14pt; .

To modify the left margin indent of all index entries for the specified level, specify the indent
you want, such as margin-left: 10px; .

7. Save the webworks.css  file.

8. Regenerate your project to review the changes.

For example, the following figure illustrates how you could customize your index entries.

div.WebWorks_Index_Level1

{ font-size: 14pt;

  font-family: Arial;

  margin-left: 12px;

}

div.WebWorks_Index_Level2

{ font-size: 12pt;
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  font-family: Arial;

  margin-left: 24px;

}
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Other Changes to Text in the TOC and Index in Dynamic
HTML
You can change the text in the table of contents and the index by adding the proper CSS coding between
the braces for the appropriate style and class. Put the value after a colon, and put a semicolon at the end of
the added coding. The following table summarizes the CSS coding for some common modifications.
 

Markup Possible Values Explanation

font-style: normal | italic | oblique Specifies whether the font should use
the normal, also known as upright or
roman, italic, or oblique faces within a
font family.

font-weight: normal | bold | bolder |
lighter | 100 | 200 | 300 |
400 | 500 | 600 | 700 | 800
| 900

Specifies the thickness of the font.
The value normal  is equal to 400 ,
and the value bold  is equal to 700 .

text-transform: capitalize | uppercase |
lowercase | none

Specifies whether to transform the
case of the text.

text-align: left | right | center |
justify

Specifies how to align the text on the
page.
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Document Last Modified Date/Publish Date
ePublisher can add a time stamp to Dynamic HTML output that displays the date of the most recent
generation. The publish date can be displayed in the page content area just after the content by default.
This feature is made available by enabling the Page Style Option Publish Date shown at bottom of
page.

If you would like to change the date format, it can be done with an override to the locales.xml file.

Copy locales.xml from:

C:\Program Files\WebWorks\ePublisher\2023.1\Formats\Shared\common\locale\locales.xml

To:

<Project Folder>\Formats\Shared\common\locale\locales.xml

In the locales.xml file, locate the element with the name PublishDateFormat. The value inside this
element can be changed to match the desired date format. For more information on how to write proper
format values in this element, refer to Microsoft's documentation on Custom date and time format strings.
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Customizing Eclipse Help

Using Markers to Specify Context Plug-ins in Eclipse Help
Using Markers to Specify Topic Descriptions for Context-Sensitive Help Topics in Eclipse Help

You can customize the appearance and behavior of Eclipse Help in several ways. For example, you can
specify context plug-in IDs for your Eclipse Help system. You can also specify topic descriptions for
context-sensitive help topics.
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Using Markers to Specify Context Plug-ins in Eclipse
Help
You can specify Eclipse Help context plug-ins by using Context Plugin markers in your source
documents. Obtain the context plug-in IDs you need to specify for your source document groups from
your development team. ePublisher places the context plug-ins you specify in your source documents in
the plugin.xml  file generated for each source document group you have in your project. The Eclipse
developers use the context plug-ins defined in plugin.xml files to call your Eclipse Help system as
appropriate from Eclipse plug-ins.

To enable specifying context plug-ins for Eclipse Help systems, you need to enable the Context Plugin
marker. By default, ePublisher sets the Marker type option for a marker named Context Plugin to
Context Plugin. You can create a marker with a different name and set the Marker type option for that
marker to Context Plugin.

Then, writers can use this marker in the source documents to define context plug-in IDs for each of the
source document groups in their project. Context plug-in IDs must follow these guidelines:

Must be unique

May specify only one context plug-in ID in each Context Plugin marker

May contain alphanumeric characters

Should not contain special characters or spaces, with the exception of underscore (_) characters

To assign context plug-in behavior to context plug-in markers

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In the Marker Styles, select the marker style you want to modify.

4. On the Options tab, set Marker type to Context Plugins.

Using Markers to Specify Context Plug-ins in Eclipse Help | 353



Using Markers to Specify Topic Descriptions for Context-
Sensitive Help Topics in Eclipse Help
In Eclipse Help, you can specify the topic description you want to display for each context-sensitive link.
When you use a TopicAlias marker to create context-sensitive links, Eclipse creates a contexts.xml
file that lists all of the context IDs for the Eclipse Help system you created using TopicAlias markers. In
the context.xml  file, Eclipse also provides a description of the context-sensitive link. By default, the
description Eclipse provides for the context-sensitive link is the text of the first paragraph of the topic.
However, if you want to specify a different description for the context-sensitive link, you can do this by
using the TopicDescription marker.

To enable specifying topic descriptions for context-sensitive help topics in Eclipse Help, you need to
enable the TopicDescription marker. By default, ePublisher sets the Marker type option for a marker
named TopicDescription to TopicDescription. You can create a marker with a different name and set the
Marker type option for that marker to TopicDescription. Then, writers can use this marker in the source
documents to specify topic descriptions for each of context-sensitive help topics in their project.

To assign topic description behavior to topic description markers

1. Open your Stationery design project.

2. On the View menu, click Style Designer.

3. In the Marker Styles, select the marker style you want to modify.

4. On the Options tab, set Marker type to TopicDescription.
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Customizing Oracle Help and Sun
JavaHelp

Defining the Navigation Pane in Oracle Help
Using Custom Windows in Oracle Help
Defining the Navigation Pane in Sun JavaHelp
Using Context-Sensitive Help in Oracle Help and Sun JavaHelp

You can customize the appearance and behavior of Oracle Help and Sun JavaHelp in several ways. For
example, you can customize which buttons are included in the toolbar pane. The following sections
describe these Oracle Help and Sun JavaHelp-specific customizations.
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Defining the Navigation Pane in Oracle Help
You can specify whether to include the Search tab in your Oracle Help output.

To specify whether to include the Search tab in your Oracle Help

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. In the Oracle Help category, set Enable Search tab to Enabled or Disabled.

4. Click OK to save the target settings.

356 | Defining the Navigaon Pane in Oracle Help



Using Custom Windows in Oracle Help
By default, Oracle Help uses the standard Oracle Help viewer. You can modify the size, position, and
other characteristics of the Oracle Help windows. You can also define and use custom windows in your
Oracle Help project. To define custom windows, you need to override the template.hs  file, which is
used to create your helpset .hs  file.

Once you have defined custom windows in a project, you can assign topics to them by adding the
WindowType marker in specific topics in your source documents. When you assign a topic to a custom
window, the topic is displayed in that window whenever users view the topic.

To override the template.hs file in Oracle Help

1. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

2. If you want to override the default settings for all Oracle Help targets in the project, create the
Formats\Oracle Help\Pages  folder in your project folder.

3. If you want to override the default settings for a specific target, create the Targets
\targetname\Pages  folder in your project folder, where targetname is the name of the target you
want to override.

4. Copy the template.hs  file from the following folder to the override folder you created within
your project folder:

Program Files\WebWorks\ePublisher Pro\Formats\Oracle Help\Pages

5. Open the template.hs  file you copied to your project override folder.

6. Modify the template.hs  file as needed. For more information about this file, see the Oracle Help
documentation.

7. Save and close the template.hs  file.

8. Regenerate your output and review the results.
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Defining the Navigation Pane in Sun JavaHelp
By default, the navigation pane includes the Contents, Index, Search, and Favorites tabs. You can select
whether to include the Favorites, Glossary, and Search tabs in your output. You can also define your own
views in Sun JavaHelp by overriding the template.hs  file. For example, you can create an alternate list
of topics and provide that list as a separate view.

To specify which tabs to include in your Sun JavaHelp

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. In the Java Help category, set each tab you want to include to Enabled.

4. Click OK to save the target settings.

358 | Defining the Navigaon Pane in Sun JavaHelp



Using Context-Sensitive Help in Oracle Help and Sun
JavaHelp
Context-sensitive help links allow you to open a specific help topic. For example, the Help button on a
window in a software product can open a specific help topic that describes the window and provides links
to related topics.

You can reference topics in Oracle Help and Sun JavaHelp using the file name or an internal identifier
called a topic ID or topic alias. To use file names, use a Filename marker to assign a file name to a topic.
Then, you can open that specific topic with that file name. However, if your file naming changes, you
need to change the link to the topic. To use an internal identifier, use a TopicAlias marker to define the
identifier for each topic. The benefit of using this approach is that it allows file names to change without
impacting the links from the product. The writer inserts this marker in a topic and specifies a unique value
for that topic. Then, Oracle Help and Sun JavaHelp use a mapping file that defines these topic aliases.

To simplify the coding of your source documents, you can use the same marker to define both the name
and the topic alias for each topic file. In Style Designer, set the Marker type option for the marker you
want to use to Filename and topic alias. However, if you change the value of this marker, you need to
change the application that uses this value.

To use context-sensitive help in Oracle Help and Sun JavaHelp

1. Meet with your application developers and define the topic ID for each context-sensitive help topic.
Also discuss how ePublisher generates the mapping file.

2. In your source documents, use TopicAlias markers to identify the topic ID for each topic.

3. Generate output from your project and test your context-sensitive help links.
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Mapping Files in Oracle Help and Sun JavaHelp
Implementing context-sensitive help requires cooperation between the help author and the developer of
the application that displays the context-sensitive help topics. You both need a mapping .jhm  file that
associates topic IDs with the target URL. When an application calls a context-sensitive help topic, it uses
the topic ID to display the correct topic. Therefore, both the help and the application must use the same
mapping file. If the topic IDs and target URLs do not match, the application displays either the wrong
topic or no topic.

The mapping .jhm  file lists topic IDs and target URLs. This mapping file is also referred to as a header
file. For Oracle Help and Sun JavaHelp, the mapping file is similar to the following sample file:

<mapID target="ch1_htm_999374" url="ch1.htm#999374">

<mapID target="ch2_htm_999640" url="ch2.htm#999640">

<mapID target="ch9_htm_999786" url="ch9.htm#999786">

In this example, ch1_htm_99374  is a topic ID, and ch1.htm#99374  is the target URL for this particular
topic ID. The marker in the appropriate topic has the ch1_htm_999374  value.

When you implement context-sensitive help, you need to work with your application developers to decide
how to choose the topic ID for each context-sensitive help topic. You can choose a set of topic IDs and
embed them in your source documents using TopicAlias markers. When you generate output, ePublisher
generates a mapping file using those topic IDs and assigns the target URL to each topic ID based on your
source documents. You can provide the generated mapping file to your application developers, who can
embed the topic IDs in the application code. ePublisher generates an updated file each time you generate
the help. Remember to give the updated file to your application developers each time.

Note: Once you choose a set of topic IDs, embed them in your source documents
using TopicAlias markers and do not change them.
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Testing Context-Sensitive Oracle Help and Sun JavaHelp
The best way to verify that your context-sensitive help topics function correctly is to test the help system
with the application that displays the help topics. This testing process ensures the whole implementation
works correctly.
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Customizing WebWorks Help

Renaming the Top-Level Entry File
Selecting a Theme
Customizing the Splash Page in WebWorks Help
Customizing the Toolbar in WebWorks Help
Customizing the Navigation Pane in WebWorks Help

You can customize the appearance and behavior of WebWorks Help in several ways. For example, you
can customize the colors and images, and toolbar buttons displayed in the browser. You can also define
which buttons are included in the toolbar pane. The following sections describe these WebWorks Help-
specific customizations.
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Renaming the Top-Level Entry File
When you generate output for your project, a top-level entry file is created. This file defines the frameset
for the help and gives the user a file to open that displays the complete help. By default, the top-level
entry file is named index.html , but you can specify any name you need for the top-level entry file as
long as you specify an .html  or .htm  extension.

To rename the top-level file

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. In Top level filename, type the name you want to use for the top-level entry file.

4. Click OK.

5. Regenerate the project and review the results.
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Selecting a Theme
In WebWorks Help, you can select a theme (skin) to define the appearance of your help. ePublisher
provides many different WebWorks Help themes. Each theme provides a custom skin, which defines the
toolbar color, button images, navigation pane, tabs, and splash image.

To choose a theme for WebWorks Help

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Click on the WebWorks Help setting to reveal its contents.

4. In Theme, select the appropriate value.

5. Click OK.

6. Regenerate the project and review the results.

You can further customize your theme to deliver the specific appearance you want. For example, you can
override images in your selected theme.
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Customizing the Splash Page in WebWorks Help
You can replace or remove the splash page that is displayed while your WebWorks Help opens. You can
customize the splash page in the Stationery, and then writers can override this customization in each
project, as needed.
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Replacing the Splash Image
The splash page is the first page that displays in the topic pane when the help set launches initially. By
default, WebWorks Help systems display the WebWorks splash image. You can replace the default splash
image with a custom image.

To replace the splash page image

1. Identify the theme in use for your WebWorks Help target that you want to modify. For more
information, see “Selecting a Theme”.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the image for all WebWorks Help targets, create the
Formats\WebWorks Help 5.0\Pages\images  folder in your projectname folder, where
projectname is the name of your ePublisher project.

4. If you want to override the image for one WebWorks Help target, create the
Targets\WebWorks Help 5.0\Pages\images  folder in your projectname folder, where
projectname is the name of your ePublisher project.

5. Copy the splash.jpg  file from the following folder to the images  override folder you created
within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Pages
\images

6. Open the splash.jpg  file you copied to your project override folder and modify it to be the splash
page image you want.

7. Save and close the splash.jpg  file.

8. Regenerate your project to review the changes.
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Removing the Splash Page
When WebWorks Help opens, it displays the splash page. However, instead of displaying the splash page,
you can configure WebWorks Help to display the first topic in the help.

To remove the splash page

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Set Show first document instead of splash page to Enabled.

4. Click OK.

5. Regenerate the project and review the results.
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Customizing the Toolbar in WebWorks Help
You can customize the toolbar pane in WebWorks help to provide the buttons and options you need. You
can add, remove, and replace toolbar buttons. You can also customize the appearance of the toolbar pane.
For more information about the toolbar pane, see “Toolbar Pane in WebWorks Help”.
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Adding and Removing Toolbar Buttons in WebWorks Help
You can add and remove toolbar buttons from the toolbar pane in WebWorks Help. To add a button, set
the format setting for that button to Enabled for your WebWorks Help target. To remove a button, set the
format setting for that button to Disabled for your WebWorks Help target.

To add or remove one or more toolbar buttons from the toolbar pane

1. On the Project menu, select the Active Target you want to specify settings for.

2. On the Target menu, click Target Settings.

3. Set the following target settings to Enabled or Disabled to define whether a button is displayed in
the toolbar pane:

 

Button Format Setting to Modify

Show in Contents Automatically synchronize in TOC

Bookmark Show bookmark toolbar button

PDF Show PDF button

Previous and Next browse buttons Show previous & next toolbar buttons

Print Show print toolbar button

Related Topics Show related topics toolbar button

4. Click OK.
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Replacing the Toolbar Buttons in WebWorks Help
WebWorks Help provides several default buttons. These buttons allow the user to navigate through the
help, and they provide additional features, such as printing a page from the help or emailing a link to
a topic page. The toolbar buttons are .gif  images for which you can provide override files. You can
replace these standard buttons with other .gif  images.

To replace one or more toolbar buttons in WebWorks Help

1. Identify the theme in use for your WebWorks Help target that you want to modify. For more
information, see “Selecting a Theme”.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the images for all WebWorks Help targets, create the
WebWorks Help 5.0\Skins\theme\Files\wwhelp\wwhimpl\common\images  folder in your
projectname\Formats folder, where theme is the name of the WebWorks Help theme you want
to override, such as Lobby_Blue , and projectname is the name of your ePublisher project. If the
theme name is two words, include an underscore instead of a space between the words.

4. If you want to override the images for one WebWorks Help target, create the
WebWorks Help 5.0\Skins\theme\Files\wwhelp\wwhimpl\common\images  folder in your
projectname\Targets folder, where theme is the name of the WebWorks Help theme you want
to override, such as Lobby_Blue , and projectname is the name of your ePublisher project. If the
theme name is two words, include an underscore instead of a space between the words.

5. Paste the .gif  files you want to use with names identical to those you want to replace in the
images  folder you created. The following table lists several default button images and their
file names. For a complete list of image file names, see the appropriate folder in the ePublisher
installation folder within Program Files . You can copy the files from the installation folder and
then modify them in your project.

 

Button File Name Description

Show in Contents sync.gif Highlights the currently displayed topic in the
table of contents.

Show in Contents
(not available)

syncx.gif Displayed when a topic is not currently
displayed in the topic pane.

Previous prev.gif Displays the previous topic in the help.

Previous (not available) prevx.gif Displayed when there is no previous HTML
document available.

Next next.gif Displays the next topic in the help.
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Button File Name Description

Next (not available) nextx.gif Displayed when there is no next HTML
document available.

6. Regenerate your project to review the changes.
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Changing the Background Color of the Toolbar
The toolbar in WebWorks Help is composed of a single repeating .gif  image. This image is located in
the images folder of your WebWorks Help theme. To modify the background color of the toolbar, you can
override the toolsbg.gif  file.

To change the background color of the toolbar

1. Identify the theme in use for your WebWorks Help target that you want to modify. For more
information, see “Selecting a Theme”.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the image for all WebWorks Help targets, create the
WebWorks Help 5.0\Skins\theme\Files\wwhelp\wwhimpl\common\images  folder in your
projectname\Formats folder, where theme is the name of the WebWorks Help theme you want
to override, such as Lobby_Blue , and projectname is the name of your ePublisher project. If the
theme name is two words, include an underscore instead of a space between the words.

4. If you want to override the image for one WebWorks Help target, create the
WebWorks Help 5.0\Skins\theme\Files\wwhelp\wwhimpl\common\images  folder in your
projectname\Targets folder, where theme is the name of the WebWorks Help theme you want
to override, such as Lobby_Blue , and projectname is the name of your ePublisher project. If the
theme name is two words, include an underscore instead of a space between the words.

5. Copy the toolsbg.gif  file from the following folder to the images  override folder you created
within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Skins
\theme\Files\wwhelp\wwhimpl\common\images

6. Open the toolsbg.gif  file you copied to your project override folder and modify it to be the
background image of the toolbar pane.

7. Save and close the toolsbg.gif  file.

8. Regenerate your project to review the changes.
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Customizing the Navigation Pane in WebWorks Help
You can customize the navigation pane in several ways. For more information about the navigation pane,
see “Navigation Pane in WebWorks Help”.
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Setting the Initial Width of the WebWorks Help Navigation Pane
The navigation pane provides the Contents, Index, Search, and Favorites tabs. When the WebWorks Help
opens, the initial width of the navigation pane is 300 pixels by default. You can override the wwhelp.htm
file to define the initial width of the navigation pane.

To set the initial width of the navigation pane

1. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

2. If you want to override the initial width for all WebWorks Help targets, create the Formats
\WebWorks Help 5.0\Files\wwhelp\wwhimpl\js\html  folder in your projectname folder,
where projectname is the name of your ePublisher project.

3. If you want to override the initial width for one WebWorks Help target, create the Targets
\WebWorks Help 5.0\Files\wwhelp\wwhimpl\js\html  folder in your projectname folder,
where projectname is the name of your ePublisher project.

4. Copy the wwhelp.htm  file from the following folder to the html  override folder you created
within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Files
\wwhelp\wwhimpl\js\html

5. Open the wwhelp.htm  file you copied to your project override folder.

6. Find the following line of code and modify the 300  to be the number of pixels wide you want the
navigation pane to use as its initial width.

<frameset cols="300,*" onLoad ...

7. Save and close the wwhelp.htm  file.

8. Regenerate your project to review the changes.
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Controlling the Navigation Pane Hover Text Appearance
Hover text refers to the popup window that WebWorks Help displays when you mouseover (hover over) a
link on the Contents tab, as shown in the following figure.

You can adjust the appearance of the hover text by overriding the wwhelp_settings.xml  file. This file
allows you to modify the font, font color, background color, and border color of the hover text and its
popup window. You can also disable the hover text.

To change the navigation pane hover text appearance

1. Identify the theme in use for your WebWorks Help target that you want to modify. For more
information, see “Selecting a Theme”.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the hover text settings for all WebWorks Help targets, create the Formats
\WebWorks Help 5.0\Skins\theme folder in your projectname folder, where theme is the name
of the WebWorks Help theme you want to override, such as Lobby_Blue , and projectname is the
name of your ePublisher project. If the theme name is two words, include an underscore instead of
a space between the words.

4. If you want to override the hover text settings for one WebWorks Help target, create the Targets
\WebWorks Help 5.0\Skins\theme folder in your projectname folder, where theme is the name
of the WebWorks Help theme you want to override, such as Lobby_Blue , and projectname is the
name of your ePublisher project. If the theme name is two words, include an underscore instead of
a space between the words.

5. Copy the wwhelp_settings.xml  file from the following folder to the theme override folder you
created within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Skins
\theme

6. Open the wwhelp_settings.xml  file you copied to your project override folder.

7. Find the following block of code:

<HoverText enable="true">
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...

</HoverText>

8. If you want to disable the hover text, replace <HoverText enable="true"> with <HoverText
enable="false">.

9. If you want to change the font family of the hover text, replace font-family: Verdana, Arial,
Helvetica, sans-serif with the names of the font family you want to use for the text. Make sure
you specify fonts that are installed by default.

10. If you want to change the font size of the hover text, replace font-size: 8pt with the size of the
font you want to use for the text, such as font-size: 10pt.

11. If you want to change the font color of the hover text, replace the color defined by
foreground="#000000" with the RGB color value you want to use for the text.

12. If you want to change the background color of the popup window, replace the color defined by
background="#FFFFCC" with the RGB color value you want to use for the background.

13. If you want to change the border color of the popup window, replace the color defined by
border="#999999" with the RGB color value you want to use for the border.

14. Save and close the wwhelp_settings.xml  file.

15. Regenerate your project to review the changes.
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Changing the Font Color on the Navigation Pane Tabs in WebWorks Help
The tabs in the navigation pane all share the same font and text style properties. These style properties are
specified in the wwhelp_settings.xml  file.

To change the font color on all the tabs in the navigation pane

1. Identify the theme in use for your WebWorks Help target that you want to modify. For more
information, see “Selecting a Theme”.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the tab font color for all WebWorks Help targets, create the Formats
\WebWorks Help 5.0\Skins\theme folder in your projectname folder, where theme is the name
of the WebWorks Help theme you want to override, such as Lobby_Blue , and projectname is the
name of your ePublisher project. If the theme name is two words, include an underscore instead of
a space between the words.

4. If you want to override the tab font color for one WebWorks Help target, create the Targets
\WebWorks Help 5.0\Skins\theme folder in your projectname folder, where theme is the name
of the WebWorks Help theme you want to override, such as Lobby_Blue , and projectname is the
name of your ePublisher project. If the theme name is two words, include an underscore instead of
a space between the words.

5. Copy the wwhelp_settings.xml  file from the following folder to the theme override folder you
created within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Skins
\theme

6. Open the wwhelp_settings.xml  file you copied to your project override folder.

7. Find the following block of code:

<Tabs>

  <DefaultColors foreground="#666666" />

  <SelectedColors foreground="#FFFFFF" />

</Tabs>

8. If you want to change the color of the text on the unselected tabs, replace #666666  with the RGB
color value you want to use for the text on those tabs.

9. If you want to change the color of the text on the selected tab, replace #FFFFFF  with the RGB
color value you want to use for the text on that tab.

10. Save and close the wwhelp_settings.xml  file.

11. Regenerate your project to review the changes.
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Using Custom Icons on the Contents Tab in WebWorks Help
When you navigate through the table of contents on the Contents tab, you can see two types of icons
for entries that have subentries. The open book icons (fo.gif ) represent expanded table of contents
levels, and the closed book icons (fc.gif ) represent unexpanded table of contents levels, as shown in the
following figure.

These icons are .gif  images stored in the WebWorks Help theme folder. You can create override files
for the fo.gif  and fc.gif  files to replace these files and use your own custom table of content icons
instead.

To replace the book icons used on the Contents tab

1. Identify the theme in use for your WebWorks Help target that you want to modify. For more
information, see “Selecting a Theme”.

2. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

3. If you want to override the images for all WebWorks Help targets, create the
WebWorks Help 5.0\Skins\theme\Files\wwhelp\wwhimpl\common\images  folder in your
projectname\Formats folder, where theme is the name of the WebWorks Help theme you want
to override, such as Lobby_Blue , and projectname is the name of your ePublisher project. If the
theme name is two words, include an underscore instead of a space between the words.

4. If you want to override the images for one WebWorks Help target, create the
WebWorks Help 5.0\Skins\theme\Files\wwhelp\wwhimpl\common\images  folder in your
projectname\Targets folder, where theme is the name of the WebWorks Help theme you want
to override, such as Lobby_Blue , and projectname is the name of your ePublisher project. If the
theme name is two words, include an underscore instead of a space between the words.

5. Copy the fo.gif  and fc.gif  files from the following folder to the images  override folder you
created within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Skins
\theme\Files\wwhelp\wwhimpl\common\images

6. Open the fo.gif  and fc.gif  files you copied to your project override folder and modify these
files to be the book icons you want to use.
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7. Save and close the fo.gif  and fc.gif  files.

8. Regenerate your project to review the changes.
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Modifying the Appearance of the Search Message in WebWorks Help
In WebWorks Help, when users click on the Search tab, the message “Type in the word(s) to search for:”
is displayed. Once the user types in a word to search for and clicks Go, the “(Searching)” message is
briefly displayed in the search results box. The appearance of these messages is controlled by the h2  and
h3  HTML tags, and these tags are located in the search.js  file. To modify the appearance of the search
message, you need to specify the style properties for h2  and h3  tags in a separate .css  file.

Note: If you customize the appearance of the search message by modifying
the search.js file, you will be responsible for maintaining your customizations
as needed each time you update your Stationery to work with a new version
of ePublisher.

For more information about override files and locations, see “Stationery, Projects, and Overrides”.

To change the appearance of the “Type in the word(s) to search for” message, create a style definition for
the h2 tag. To modify the appearance of the “(Searching)” message, create a style definition for the h3 tag.
After you specify the font properties in a .css  file for the h2 and h3  tags, reference the .css  file in the
search.js  file.

Note: The messages.xml  file in the Formats\WebWorks Help 5.0\Files\wwhelp  folder
controls the message text used throughout WebWorks Help for multiple
languages. You can override this file to provide customized messages for your
specific needs.

To modify the appearance of the search messages

1. If you want to override the message appearance for all WebWorks Help targets, complete the
following steps:

a. In your Stationery design project, on the View menu, click Format Override Directory.

b. Create the following folder in your projectname folder, where projectname is the name of
your ePublisher project:

Formats\WebWorks Help 5.0\Files\wwhelp\wwhimpl\js\scripts

2. If you want to override the message appearance for one WebWorks Help target, complete the
following steps:

a. In your Stationery design project, on the View menu, click Target Override Directory.

b. Create the following folder in your projectname folder, where projectname is the name of
your ePublisher project:

Targets\WebWorks Help 5.0\Files\wwhelp\wwhimpl\js\scripts

3. Copy the search.js  file from the following folder to the scripts  override folder you created
within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Files
\wwhelp\wwhimpl\js\scripts
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4. Open the search.js  file you copied to your project override folder.

5. Find the following block of code:

// Display initializing message

//

HTML.fAppend("<h2>" + WWHFrame.WWHJavaScript.mMessage.mInitializingMessage + "</

h2>\n");

6. Replace that block of code with the following code:

// Display searching message

//

HTML.fAppend("<h2 style=\"color:#FF00FF; text-decoration: underline; font-size:

12pt;\">" + WWHFrame.WWHJavaScript.mMessages.mSearchSearchingMessage + "</h2>

\n");

7. Find both instances of the following block of code:

// Display searching message

//

HTML.fAppend("<h2>" + WWHFrame.WWHJavaScript.mMessages.mSearchSearchingMessage +

"</h2>\n");

8. Replace each instance of that block of code with the following code:

// Display searching message

//

HTML.fAppend("<h2 style=\"color:#FF00FF; text-decoration: underline; font-size:

12pt;\">" + WWHFrame.WWHJavaScript.mMessages.mSearchSearchingMessage + "</h2>

\n");

9. Find the following block of code:

// Display search message and/or prepare results for display

//

if (this.mSavedSearchWords.length == 0)

}

HTML.fAppend("<h3>" + WWHFrame.WWHJavaScript.mMessages.mSearchDefaultMessage +

"</h3>\n");

10. Replace that block of code with the following code:

// Display search message and/or prepare results for display
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//

if (this.mSavedSearchWords.length == 0)

{

HTML.fAppend("<h3 style=\" color:#FF00FF; text-decoration: none; font-size: 14pt;

\">" + WWHFrame.WWHJavaScript.mMessages.mSearchDefaultMessage + "</h3>\n");

11. Save and close the search.js  file.

12. Regenerate your project to review the changes.
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Modifying the Search Ranking
The search results are displayed in the Search tab when a user types a word to search for and clicks
Go. The search results are sorted by the relevancy ranking, which is calculated based on the scoring
preference defined for the HTML tags in the wwhelp_files.xml  file. By default, WebWorks Help
assigns relevancy rankings based on where in a topic a particular item is found.

For example, if you set the scoring preference, or weight, for Heading 1 to 25 and you set the weight for
Heading 2 to 15, then any search term found in a Heading 1 returns a higher relevancy ranking than if the
search term is found in a Heading 2.

The following scenario illustrates how the relevancy ranking is calculated:

If you search for the word popup, and that word appears in both a Heading 1 and a Heading 2 on one
page, and in a Heading 1 on another page, the search returns two results sorted by the relevancy ranking.

To get the relevancy ranking, WebWorks Help takes the score of each search result and divides it by the
highest score found. To get the score of each search result, the scoring preference for each HTML tag is
used.

For example, Heading 1 has a scoring preference of 25 and Heading 2 has a scoring preference of 15. If
the word “popup” appears in a Heading 1 and a Heading 2 on a topic page, then the score for that word on
that page is 25+15=40. If the word “popup” appears in a Heading 1 on another topic page, then the score
for that word on that page is 25. Therefore, if 40 is the highest score that a search for “popup” returns,
the relevancy ranking of the first search result is 100%=40/40x100%, and the relevancy ranking for the
second search result is 38%=15/40x100%.

To modify the relevancy ranking for search results

1. In your Stationery design project, on the View menu, click Project Directory. For more
information about override files and locations, see “Stationery, Projects, and Overrides”.

2. If you want to override the message appearance for all WebWorks Help targets, create
the Formats\WebWorks Help 5.0\Transforms  folder in your projectname folder, where
projectname is the name of your ePublisher project.

3. If you want to override the message appearance for one WebWorks Help target, create
the Targets\WebWorks Help 5.0\Transforms  folder in your projectname folder, where
projectname is the name of your ePublisher project.

4. Copy the wwhelp_files.xml  file from the following folder to the Transforms  override folder you
created within your project folder:

Program Files\WebWorks\ePublisher Designer\Formats\WebWorks Help 5.0\ Transforms

5. Open the wwhelp_files.xml  file you copied to your project override folder.

6. Find the following block of code:

<ScoringPrefs>

  <meta name="keywords" weight="100"/>
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  <meta name="description" weight="50"/>

  <meta name="summary" weight="50"/>

  <title weight="20"/>

  <h1 weight="15"/>

  <h2 weight="10"/>

  <caption weight="10"/>

  <h3 weight="7"/>

  <th weight="5"/>

  <h4 weight="5"/>

  <h5 weight="4"/>

  <h6 weight="3"/>

  <h7 weight="2"/>

</ScoringPrefs>

7. Modify the weight attributes for any tags, such as h1  and h2 , you want to change.

8. Save and close the wwhelp_files.xml  file.

9. Regenerate your project to review the changes.
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Modifying the Search Highlighting
You can control search highlighting with an override:

  Formats\WebWorks Help 5.0\Skins\[skin name]\wwhelp_settings.xml

For more information regarding overrides, See “Creating Format Overrides”.

The following markup controls the behavior:

  <Search enable="true">

  <Results showrank="true" />

   <Highlighting enable="true">

    <Colors foreground="#FFFFFF" background="#333399" />

   </Highlighting>

  </Search>

Using an HTML value for the color will help you control the search highlighting color for the text and for
the background of the word that is being searched in the output page.

Note: This browser behavior is limited to Internet Explorer.
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Synonyms
By defining a list of synonyms, you can increase the effectiveness of a search by grouping similar words
together as a single result. For example, you define movie, video, and avi as synonyms. If a user searches
for one of those terms, a match will be scored if any of the three are found in a document.

To add these definitions, you’ll need to perform an override on a file called synonyms.xml, located by
default in the ePublisher Designer installation directory here:

  \Formats\WebWorks Help 5.0\Files\wwhdata\common

Once the file is copied to the correct location in your project directory, open it in any text- or XML-
editing application (e.g., NotePad), and add entries to the <WebWorksSynonyms>  section. For example,
your synonyms might look like this:

  <WebWorksSynonyms>

   <Word value="movie">

    <Synonym value="avi" />

    <Synonym value="video" />

   </Word>

   <Word value="picture">

    <Synonym value="image" />

    <Synonym value="graphic" />

    <Synonym value="photo" />

   </Word>

  </WebWorksSynonyms>

Please note that the Synonyms feature does not recognize multiple word values or synonyms. And, it
ignores words (and synonyms) of 2 letters or less. Also, its search logic is quite literal. That is, it finds
only what you type, and only if the exact form is in the text. For example, it does not find plurals or
phrases, and it even includes punctuation.
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Minimum word length & common words
When performing a text search, the WebWorks Help 5.0 search engine follows a couple of guidelines
designed to make the search more efficient and the results more helpful. By default, the minimum length
of a word in the search results is 3 letters. ePublisher Designer also comes with a list of terms which
appear commonly in many types of documents, and are therefore left out of search results. You can
modify both the minimum length and the list of common words by performaing a target override on a file
called locales.xml, located by default in the ePublisher Designer installation directory, here:

2023.1\Formats\Shared\common\locale

Because this file is in the Shared formats directory, your project folder hierarchy should look like this:

MyProject\Targets\MyWWHelpTarget\Shared\common\locale

To change the minimum number of letters in a WebWorks Help 5.0 search result:

1. Open locales.xml in an XML- or text-editing application (e.g., NotePad).

2. Find the Locale used by your project (default English is “en”).

3. Under the <Search> section, change the MinimumWordLength value to the desired number of
characters in the shortest word the search should return.

To change the list of words which will not be returned in a WebWorks Help 5.0 search:

1. Open locales.xml in an XML- or text-editing application (e.g., NotePad).

2. Find the Locale used by your project (default English is “en”).

3. Under the <Search> section, modify the <StopWords> values to reflect the list of words which
should not appear in your project’s search results.

Minimum word length & common words | 387



Using Context-Sensitive Help in WebWorks Help
Context-sensitive help links provide content based on the context of what the user is doing. In many
cases, this help content is based on the window that is open and active. For example, the Help button on a
window in a software product can open a specific help topic that provides important information about the
window and links to related topics.

WebWorks Help allows you to use a TopicAlias marker to define an internal identifier for each topic.
The benefit of using an internal identifier is that it allows file names to change without impacting the
links from the product. The writer inserts this marker in a topic and specifies a unique value for that
topic. ePublisher creates a mapping file to identify each topic associated with a unique value. Then,
WebWorks Help uses this internal identifier and the mapping file to display the correct topic. Before you
can reference topics in WebWorks Help using topic aliases, you must enable TopicAlias markers in your
Stationery. For more information, see “Defining Filename Markers for Context-Sensitive Help Links”.
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Mapping Files in WebWorks Help
WebWorks Help does not generate a mapping file. However, you can see a list of defined contexts and
topics in the wwdata/xml/files.xml  file. You can also use the Topics Report to verify that context-
sensitive help topics have been created for each topic ID specified in your source document. The Topics
Report lists the topic ID and the topic file created for each topic ID.Topic aliases report. For more
information about the topics report, see “Topics Reports”.
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Opening Context-Sensitive Help in WebWorks Help using Standard URLs
You can open WebWorks Help from the application using standard URLs or the WebWorks Help API. For
more information about the API, see “Opening Context-Sensitive Help with the WebWorks Help API”.

Note: If you have WebWorks Help installed on the local computer, Internet Explorer
7 ignores the query string attached to a URL when it reloads a page. For
example, after displaying a security warning or other message, Internet
Explorer reloads the page. Without the query string, the browser cannot open
the specific topic, since the group name and topic alias are not available. To
avoid this issue with Internet Explorer 7, you can use the WebWorks Help API
to open a topic in locally installed WebWorks Help.

To open the complete WebWorks Help output to the default help topic, open the index.htm  or
index.html  file in the root of the folder where the WebWorks Help is stored. This file defines the help
frameset and loads the individual components, such as the table of contents, index, and topic content.

To open a specific topic in WebWorks Help, use the following URL:

helplocation/wwhelp/wwhimpl/api.htm?context=groupname&topic=alias

The variable parts of this URL are defined as follows:

helplocation
Specifies the location where the WebWorks Help is installed. If the help is on a Web server, specify
the location using the http  protocol and the Web site path to the root of the help, such as http://
www.webworks.com/help . If the help is installed on the local computer, specify the location
using the file protocol and the path to the root of the help, such as file:///C:/Program Files/
YourApplication/help .

groupname
Specifies the group context value for the top-level group in which the topic resides in Document
Manager. This group context is specified in merge settings for each top-level group.

alias
Specifies the value of the TopicAlias marker in the topic to open.
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Opening Context-Sensitive Help with the WebWorks Help API
WebWorks Help provides an API that you can use to call context-sensitive topics in WebWorks Help.
Using the API instead of simple URLs gives you increased flexibility and enhanced control. For example,
the following list highlights some of the benefits of using the API:

The API automatically determines the default browser and opens it to display the correct help topic.

The API reduces the amount of code developers must write to integrate context-sensitive help.
Without the API, developers must code their own COM interface to communicate with the browser
on the Windows platform. This code is provided as part of the WebWorks Help API.

Using the API can significantly reduce the time required to load an individual topic if the help
system is already open in the browser. If your application calls a topic using a URL instead of
the API, the entire frameset, including the WebWorks Help applet, is loaded each time the user
opens help. If the application calls a topic using the API, and the correct help is already loaded
in the browser, neither the frameset nor the applet is reloaded. Instead, the currently open topic
pane displays the correct help topic, which delivers a significant performance improvement for
WebWorks Help users.

The API allows you to avoid the issue that exists with standard URLs in Internet Explorer 7. In
Internet Explorer 7, if you have WebWorks Help installed on the local computer, Internet Explorer
7 ignores the query string attached to a URL when it reloads a page. For example, after displaying a
security warning or other message, Internet Explorer reloads the page. Without the query string, the
browser cannot open the specific topic, since the group name and topic alias are not available.

You can use the C/C++ API, which is available as a .dll  or a COM object. This API supports WebWorks
Help 4.0 and 5.0. WebWorks Help 5.0, does not include the Java navigation. Therefore, do not use
the Java navigation options with WebWorks Help 5.0. For more information about this API and
the software development kit, see http://wiki.webworks.com/DevCenter/Projects/WebWorksHelp/
WebWorksHelpSDK.

Opening Context-Sensive Help with the WebWorks Help API | 391

http://wiki.webworks.com/DevCenter/Projects/WebWorksHelp/WebWorksHelpSDK
http://wiki.webworks.com/DevCenter/Projects/WebWorksHelp/WebWorksHelpSDK


Opening Context-Sensitive Help with the Javascript API
Similar to using the WebWorks Help API, you can use the Javascript API when working with web
applications designed to run on websites using standard HTML and Javascript. For complete details of
the WebWorks Help Javascript API, see http://wiki.webworks.com/DevCenter/Projects/WebWorksHelp/
JavascriptAPI.
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