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What changed in Font Awesome
version 5.15.4 from 4.7.x that impacts
Reverb 2.0?
The Font Awesome library included with ePublisher and used in the WebWorks
Reverb 2.0 format was upgraded the 2021.1 version of ePublisher.

Most of the icons and glyphs used by WebWorks Reverb 2.0 look and function
the same, however there are some differences to be aware of that may impact your
own advanced customizations.

Three new classes were introduced: fas
 far fab

• fas , which replaces fa  is typically used to get the solid version of an icon.
fa  is backward compatible with fas  and may not need to be changed in pre-
existing implementations.

• far  is typically used to get the regular version of an icon, and is thinner and
lighter than the fas  version.

• fab  is used for icons that represent a brand, for example the Twitter icon.

Font Awesome Cheatsheet
Free to use icons can be found at: https://fontawesome.com/v5/cheatsheet/free
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How do I disable automatic Preview
generation in Designer?
In ePublisher Designer's Document Manager, to disable the automatic generation
of Preview tabs each time a document is added, do the following:

1. Open the Preferences dialog using menu: Edit > Preferences.

2. Uncheck Automatically display preview for newly imported
documents.

3. Select OK

In addition, you can disable generation of Preview tabs when double-clicking
documents in the Document Manager by also unchecking:

Display preview on document double-click
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How do I capture source file meta data
in the published HTML output?
You can capture location specific meta data within your source content and then use
it in your generated HTML pages.

The most common way to use this kind of data is through the Page.asp  template
file.

For example, a marker called ReviewDate  in your source content could contain the
date this section of the file was reviewed. Then using an advanced customization of
Page.asp , the following would conditionally emit its value on the generated HTML
page.

<div wwpage:content="wwmarker:ReviewDate"
 wwpage:condition="wwmarker:ReviewDate">

  October 20, 2021

</div>
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How do I use a Project Variable's value
in the published output?
If your ePublisher project configures a specific variable to a non-empty value, then
that value can be captured in your generated output even if the variable is not used
in the source content.

Project variables can be captured using attributes in the Page.asp  template file.

For example, if a project variable called ProductVersion  has been configured in
ePublisher to a non-empty value such as: 1.0 , then it can be published in your
generated output as follows:

<div

  wwpage:content="projvars:ProductVersion"

  wwpage:condition="projvars:ProductVersion">

  x.x

</div>
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How do I upgrade an existing
WebWorks Reverb 2.0 project to a
newer version?
The following video walks through all of the steps that may be required to upgrade
an existing WebWorks Reverb 2.0 project.

Watch on youtube to access the video's quick links.

See video on Reverb 2.0 Typical Customization Tasks.
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How to add an image icon and stylize
your DITA Hazard statement elements?
Specify an image file to use for your Hazard Caution Label  paragraph style in the
Style Designer.

It will show up to the left of your content's Hazard statement.

For example:

ePublisher Designer Display Preview

For each type of Hazard statement, there are a set of Designer styles as follows:

• Paragraph

◦ Hazard <Type>
◦ Hazard <Type>  Consequence
◦ Hazard <Type>  HowToAvoid
◦ Hazard <Type>  HowToAvoid End
◦ Hazard <Type>  Label
◦ Hazard <Type>  Type

• Table

◦ Hazard <Type>

Note:

There is a placeholder style used that is shared by all Hazard statements for the
empty regions of the table. It does not need to be styled.

• Paragraph

◦ Hazard Empty
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How to supplement or replace Reverb
Toolbar Group Tabs
Create an Advanced Customization of the file Connect.asp  to add to or replace
the Reverb Toolbar group tabs.

For example:

Reverb 2.0 Toolbar with Additional Tab

Steps

1. Create Advanced Target Customization for Connect.asp .

2. Locate HTML code for tabs by searching for toolbar-tabs  in Connect.asp .

3. Copy existing <li wwpage:replace="toolbar-tabs">..</li>  element with
sub-content to use as starting point for each new tab to create.

4. Remove attribute wwpage:replace="toolbar-tabs"  from your newly pasted
elements. This attribute is only used to inject a list of the ePublisher project's
group tabs into the output.

◦ Note: If you want to remove the group tabs from the toolbar, remove
the wwpage:replace="toolbar-tabs"  from all tab <li>  elements.

5. Specify desired href  destination, usually a context specifier with Topic Alias
ID, such as: #context/<TOPIC ALIAS ID> .

6. Specify desired title  attribute to produce fly over text for your tab.

7. Specify the text to appear on the tab itself.
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8. Optionally, add a target attribute to open page in a new window, which is
required for destinations outside of the help set.

◦ For example: <a target="_blank" href="#context/LandingPage2"
 title="Landing Page 2">

Example Reverb Toolbar Tab Code

<ul class="ww_skin_toolbar_tab_group">

  <li wwpage:replace="toolbar-tabs">

    <div class="ww_skin_toolbar_tab">

      <a href="connect/splash.html" title="Home">

        Home

      </a>

    </div>

  </li>

  <li>

    <div class="ww_skin_toolbar_tab">

      <a href="#context/LandingPage2" title="Another Tab">

        Another Tab

      </a>

    </div>

  </li>

</ul>
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Invalid File Path Characters Filtered
from Generated File Names
When working with file systems and browsers, certain file path characters are
either forbidden or problematic. With ePublisher, you can use target settings and/or
Filename  markers to influence the file names generated in your published output.
However, there are some characters that are considered invalid and ePublisher will
not use them when creating output file names.

You don't need to worry or track the invalid characters, because ePublisher will
automatically eliminate them from the output. In addition, any time an invalid
character is attempted to be used to generate a file name, ePublisher will replace
that character with a single '_' (underscore) character as a placeholder.

For example, if you had a heading paragraph that is attempting to generate a file
name such as: Document (%25).html . The actual generated file name will be:
Document (_25).html  because the %  character is a problematic character.

Aside: In URLs the %  is a special character that is used to encode other characters,
making it problematic to use this character as itself in URL paths.

Invalid File Path Characters
"#$%&*+,/:;<=>?[\]|

Each occurrence of one of these characters will be replaced by a single _
(underscore) character.
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How to enable 'WebWorks
Menu' (Transit) Add-in for Microsoft
Word
If you have WebWorks ePublisher component installed on your system and when
running Microsoft Word you do not see a WebWorks menu, then this article will
explain how to enable the Add-in called Transit.dotm .

WebWorks Menu Add-in for Microsoft Word

Steps to Enable

Note: There are several ways to make the transit.dotm  add-in available in the
Word toolbar (ribbon). The ePublisher Express installer will normally install the
add-in file to the prescribed location for your version of Microsoft Word. However,
sometimes the computer system will block the installer from copying the add-in
to this location. Find the location below for your version of Word and make sure
the file has been copied there. If it is not there, you can manually copy it from the
ePublisher installation folder, usually at the following.
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C:\Program Files (x86)\WebWorks\ePublisher\2022.1\Transit

1. Location of transit.dotm  based on the version of Microsoft Word.

◦ Word 2016 (64-bit) or later versions, possible locations:

C:\Program Files\Microsoft Office\office16\Startup\

C:\Program Files\Microsoft Office\root\office16\Startup\

◦ Word 2013 (64-bit), possible locations:

C:\Program Files\Microsoft Office\office15\Startup\

C:\Program Files\Microsoft Office\root\office15\Startup\

◦ Word 2016 (32-bit) or later versions, possible locations:

C:\Program Files (x86)\Microsoft Office\office16\Startup\

C:\Program Files (x86)\Microsoft Office\root
\office16\Startup\

◦ Word 2013 (32-bit), possible locations:

C:\Program Files\Microsoft Office\office15\Startup\

C:\Program Files\Microsoft Office\root\office15\Startup\

2. On Microsoft Word Ribbon, click File > Options > Trust Center > Trusted
Locations.

◦ Click the Add New Location button
◦ Add the directory path noted above for transit.dotm .
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How do I set image horizontal
alignment in ePublisher?
In ePublisher version 2022.1 and above, you can control the image alignment of
a Graphic Style using the Style Designer to modify that style's property: HTML >
Text > (Alignment) Horizontal.

Possible Horizontal Property Values

• Left
• Center
• Right

Note: If your authoring environment supports assigning horizontal alignment,
then that property will be inherited by the Graphic Style, which means the same
alignment will be used in the generated output without having to explicitly set it in
ePublisher's Style Designer.

Floating Image to Left or Right of Paragraph

To float an image style to the left or right of the paragraph that contains it, use the
Style Designer to modify the graphic style properties as follows.

Graphic Style Property Value
HTML > Display Block
HTML > Float Left or Right
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Why is the PDF format skipping
Markdown files?
When generating the Output Format PDF using Markdown source documents, this
message will appear in the generation log:

[Warning] Skipping file ... PDF Format is only available for Word and
 FrameMaker documents. Use PDF - XSL-FO Format instead.

To publish PDF output using Markdown files, use the format PDF - XSL-FO, which is
available for all source document types.

The legacy format called: PDF was created only for publishing Adobe FrameMaker
and Microsoft Word source documents, and thus is not available for publishing
Markdown source content. If you do attempt to publish a markdown file using the
PDF format, you will get a warning message in your ePublisher generation log.
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How can a markdown file include
another?
Using Markdown++ you can include the contents of one markdown file in another,
similar to the following:

<!--include:../Topics/MyTopic.md-->

In the above statement, a filename from the parent folder's Topics folder is being
included in markdown file.

To include markdown files in other folders, be sure to use a path that is relative to
the file that contains the include statement. Absolute paths will work as well, but
might not be as portable if you move your content from one location to another.
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How can you insert an Index Marker
into a Markdown file?
In your markdown file, you can insert an IndexMarker using the following syntax:

<!--markers:{"IndexMarker": "term1 term2"}-->

Paragraph to be used for the index terms: term1 and term2.
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How to use alternate DITA-OT
installation with ePublisher
Set the DITA_HOME  environment variable and ePublisher will use that installation
of the DITA Open Toolkit instead of the toolkits that it maintains in its installed
location.

ePublisher doesn't require anything unique for its use of the DITA-OT, however, you
may have your own custom plugins, in which case, this may be an easier way to
maintain and use the DITA-OT with ePublisher.

Steps

1. Set the environment variable DITA_HOME  to the installation location of the
DITA-OT that you are using. For example: C:\dita-ot-4.0 .

2. Make sure that your ePublisher project is configured to use the same version
number (or closest) using the menu: Project > Project Settings.... Locate
the the setting: Input Configurations > DITA Open Toolkit version.
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How do I embed HTML within DITA
source content?
It is often necessary to embed HTML within your DITA source content for supporting
the display of media such as youtube videos.

The two most common ways to embed HTML are through the use of a <foreign>
element or a paragraph with a custom outputclass  assigned to it.

An example for each is as follows.

Using the <foreign>  element

Note: Embedding a link to a local file, still requires that file to exist at the specified
link location. In other words, ePublisher will not handle it as a Baggage File.

<foreign audience="web">

 <![CDATA[

  <iframe width="800" height="500" src="_animation/
AC_41_Rackwinkel_1.html" frameborder="0" allowfullscreen="true">

  </iframe>

 ]]>

</foreign>

Using @outputclass  to enable Pass Through behavior

<p outputclass="PassThrough" audience="web">

 <![CDATA[

  <iframe 

   width="660"

   height="375"

   src="https://www.youtube.com/embed/D4QoQWboM-U?rel=0"
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   frameborder="0"

   allow="accelerometer; autoplay; encrypted-media; gyroscope;
 picture-in-picture"

   allowfullscreen>

  </iframe>

 ]]>

</p>

Steps in ePublisher Designer
By default ePublisher disables HTML code within the source content, so you will
need to enable the appropriate paragraph style's Pass Through option in the Style
Designer.

1. In ePublisher Designer, open the Style Designer and select the name of the
paragraph style assigned with the @outputclass  attribute or if you used
<foreign> , then the style name will be foreign .

2. Select the Options tab and then set the option: Pass Through to Enabled.

3. The ePublisher project will now generate the embedded HTML correctly and
you can deploy an updated Stationery for use in other Express projects.
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How to use Context Links in Reverb 2.0
If you are generating online help it may be more robust to use a context link to a
topic alias identifier instead of a traditional hyperlink to a filename and anchor.

Link Structure

#context/<TopicAlias Identifier>

#context/<Context>/<TopicAlias Identifier>

With a Reverb context link you are creating a link to a location. This is different
from a traditional hyperlink which points to a specific filename.
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What happens if a Reverb link is no
longer valid?
When end-users access an invalid link in your published Reverb 2.0 online help
a standard page will be displayed in the same locale as the online help files. The
default text for this page is as follows:

404
File Not Found
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How do I know what baggage files are
in my Reverb 2.0 output?
If you are linking to non-source files from within your source content, ePublisher
will treat them as Baggage Files and make them available as part of your
generated help set.

In Reverb 2.0, the generated file url_maps.xml  (default filename) contains a
complete list of all the baggage files in your help set. The baggage file entries will
look similar to the following:

<BaggageMap>

  <Baggage

   basename="download_kit.zip"

   path="UserGuide\baggage\download_kit.zip"

   groupID="0jQCq1sTUkc"

  />

  .

  .

  .

</BaggageMap>
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What user interactions can Reverb
track in Google Analytics?
When using the WebWorks Reverb 2.0 output format, you can enable the target
setting for Google Analytics and capture end-user interactions with the online help
content.

The users interactions that are tracked are as follows:

• Content page view
• Content page click
• Content page scroll
• Content page PDF button click
• Content page Print button click
• Content page "Back to top" button click
• Content page "Was this helpful - Yes" button click
• Content page "Was this helpful - No" button click
• Search query
• Search result page view
• Search result page "Was this helpful - Yes" button click
• Search result page "Was this helpful - No" button click
• Toolbar menu button click
• Toolbar search button click
• Toolbar previous button click
• Toolbar next button click
• Toolbar home button click
• Toolbar translate button click
• Menu TOC button click
• Menu Index button click
• "Context Sensitive Help" access
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How can I modify the Reverb search
result summary?
The search result summaries use Description marker values when available in the
source content.

The marker must occur somewhere within the content that makes up the generated
output HTML page. Markers in other locations will not affect the search result
summary.

If a Description marker is not found, then the summary will be calculated from the
first paragraph(s) within the generated HTML page.
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How to add Keywords meta data to
generated HTML pages
When generating HTML-based output such as the WebWorks Reverb 2.0 or
Dynamic HTML formats, you can use a Keywords marker to set the Keywords
meta data for the generated HTML page.

In some search engines, setting the Keywords meta data can make sure that your
audience knows that those keywords are important in the HTML file, even if those
keywords are not actually present in the file.

In the WebWorks Reverb 2.0" format, the Keywords marker can make those
words show up higher in priority in the search results when they are queried.

For example, in the following markdown source content, the keyword "WidgetXYZ"
will cause generated HTML page to show up with high priority in the search results.

<!--markers:{"Keywords": "WidgetXYZ"}-->

# The Widget Company

We make all kinds of widgets.
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Why does HTML content within my
source file not publish to PDF?
PDF output does not support pass-through HTML. This includes even HTML content
within Markdown source files.

When ePublisher generates PDF output from content that contains HTML, the HTML
content is ignored since PDF viewers do not understand HTML.

[]: # "See how to disable the automatic preview"
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