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Exploring ePublisher

Understanding the ePublisher Workflow
Exploring the ePublisher User Interfaces
Customizing Your ePublisher Workspace
Specifying General ePublisher Preferences

This section helps you understand the ePublisher workflow, from the tasks that the Stationery designer
performs, such as preparing source document templates and creating Stationery, through the tasks that
writers perform, such as preparing their source documents for output generation, generating output, and
validating their generated output.

This section also provides an overview of each ePublisher user interface and, through the use of sample
Exploring ePublisher source documents, projects, and Stationery, helps you understand how you can
quickly and easily produce online content that meets required styles and standards
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Understanding the ePublisher Workflow
ePublisher allows your organization to quickly and easily produce online content that meets your
organization’s styles and standards. With ePublisher, you use the following workflow to quickly and
easily generate online content:

Stationery designers create new or modify existing source document templates and then
use ePublisher Designer to create Stationery for writers to use to generate output. For more
information, see “Stationery Designers and ePublisher Designer”.

Writers use ePublisher Express and the Stationery created by a Stationery designer to generate and
validate online content. For more information, see “Writers and ePublisher Express”.

ePublisher AutoMap can automatically generate and deploy online content using the Stationery
created by a Stationery designer and source documents created by writers. For more information,
see “Automating Output Generation with ePublisher AutoMap”.
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Stationery Designers and ePublisher Designer
If you are a Stationery designer, your first step when you work with ePublisher will be to identify which
input formats will be used to author source documents, which types of output need to be generated, and
which online features should be included in generated output.

After you identify your input and output formats and the features you want to include in your online
content, your next step is to either create source document templates or prepare your existing source
document templates for output generation. Stationery designers use source document templates to
configure settings and create Stationery for writers to use when generating output. Writers use the source
document templates to create content and prepare source documents for output generation. If writers
already use source document templates, Stationery designers can simply prepare the existing source
document templates for output generation. If writers are not currently using source document templates,
the Stationery designer creates a source document template for each content authoring tool used by the
authors in the organization. Writers then use the styles and standards defined in the template to prepare
their source files for output generation.

For example, if all writers use Adobe FrameMaker and Adobe FrameMaker templates when authoring
content, the Stationery designer can take the existing Adobe FrameMaker templates, modify the templates
as needed to support online content, and then use the existing templates to create Stationery. If writers use
both Adobe FrameMaker and Microsoft Word but are not yet consistently using templates, the Stationery
designer creates a new standard set of both Adobe FrameMaker and Microsoft Word templates for writers
to use when authoring content.

After the Stationery designer prepares source document templates for the content authoring tools writers
use, the Stationery designer uses ePublisher Designer to perform the following tasks:

Create a Stationery design project using the source document templates.

Configure settings and options in the Stationery design project that define the look, feel, and
behavior for each output target.

For example, the Stationery designer can specify if ePublisher should use the existing styles and
formatting in the source documents when generating output to ensure the source documents and
online content share the same look and feel. The Stationery designer can also specify that online
content have a completely different look and feel than the source documents based on online output
design goals and business needs.

Create Stationery using the settings defined in the Stationery design project. The Stationery defines
the style and behavior of generated output, and writers use the settings in the Stationery when they
generate output from their source documents.

After the Stationery designer creates the Stationery, the Stationery designer places the ePublisher
Stationery and source document template files on a shared network folder for writers to use as they author
their content, prepare their source documents for output generation, and generate output.
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Writers and ePublisher Express
With ePublisher, writers use their preferred content authoring tool and the source document templates
provided by the Stationery designer to create content and prepare their source documents for output
generation. Writers can use Markdown++, Microsoft Word, structured or unstructured Adobe
FrameMaker, and DITA-XML content authoring tools to author content. Writers format, or tag, their
source documents by applying styles and formats, and then ePublisher uses this information to generate
the appropriate output based on the settings the Stationery designer specified in the Stationery. Writers do
not need to worry about output design. Instead, writers can focus on creating the content users need.

When writers are ready to generate online content, writers use ePublisher Express to perform the
following tasks:

Create an ePublisher Express project based on Stationery created by a Stationery designer.

Add the source documents they want to use to generate output to the ePublisher Express project.

Generate output. The output that writers generate adheres to the styles and standards defined by the
Stationery designer in the Stationery. Writers can generate output on demand. ePublisher can also
automatically generate output based on a schedule if ePublisher AutoMap is implemented.

Deploy generated output. Writers can deploy their generation to a Web site or to a central location
from which a product build can obtain the files. ePublisher can automatically deploy output if
ePublisher AutoMap is implemented.

Check the generated output into a version control system or copy the generated output to a central
archive location.

Although writers typically use the Stationery provided by the Stationery designer without modification,
writers can use ePublisher Express to perform some customizations of output target settings if they have
target setting modification permissions. For example, writers can customize company information such
as company name, phone number, and Web site information in their generated output if they have target
setting modification permissions. If writers need to customize any target or project settings, they should
first ensure they have appropriate target setting modification permissions. After they make any target
setting customizations, they regenerate their output and verify their target setting customizations before
deploying their final output.

Most writers prefer to use ePublisher Express to perform an initial output generation early in their project
cycle. This allows writers to quickly and easily verify that they are formatting their source documents
correctly and also confirm that their generated output has the appearance and features they want. After
an initial verification of the generated output early in the project cycle, writers continue to add content
to their source documents, then regenerate output on a periodic basis, such as once a week, as the project
progresses.

If ePublisher AutoMap is implemented, ePublisher AutoMap can be configured to automatically generate
output for writers on a regular schedule. For example, ePublisher AutoMap can be configured to
automatically generate output for a project every night. When writers arrive at work the next day, writers
can quickly and easily verify that the latest content they added to their source documents is formatted
correctly and displays appropriately in their generated output. Periodic output generation using the latest
version of source documents and Stationery provides the following benefits:
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Allows writers to quickly and easily confirm that they are formatting their source documents
correctly and feel confident that their generated output always conforms to the standards and styles
defined in their project Stationery by the Stationery designer

Reduces the amount of time writers spend doing a quality assurance review for their generated
output at the end of a project cycle

Helps eliminate post-generation editing and processing, which save organizations time and money

Ensures that the end of the project cycle is smooth and hassle-free

ePublisher allows writers to quickly and easily produce high-quality output according to specifications
each time they generate output.
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Automating Output Generation with ePublisher AutoMap
If you implement ePublisher AutoMap, you can configure ePublisher AutoMap to automate your output
generation using Stationery created by a Stationery designer and source documents created by writers.
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Exploring the ePublisher User Interfaces
The WebWorks ePublisher Platform provides the following user interfaces:

ePublisher Express user interface, which writers use when generating output

ePublisher Designer user interface, which Stationery designers use when creating and updating
Stationery

ePublisher AutoMap user interface, used to automate output generation and integrate the output
generation process with source control systems and product build systems

This section provides an overview of each of these ePublisher user interfaces.
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Exploring the ePublisher Express User Interface
The ePublisher Express user interface includes the following windows:

Start page. For more information, see “Understanding the Start Page”.

Document Manager. For more information, see “Understanding Document Manager”.

Output Explorer. For more information, see “Understanding Output Explorer”.

Log Window. For more information, see “Understanding the Log Window”.

The following figure shows the ePublisher Express user interface.
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Exploring the ePublisher Designer User Interface
The ePublisher Designer user interface includes the following windows:

Start page. For more information, see “Understanding the Start Page”.

Document Manager. For more information, see “Understanding Document Manager”.

Output Explorer. For more information, see “Understanding Output Explorer”.

Log Window. For more information, see “Understanding the Log Window”.

Style Designer. For more information, see “Understanding Style Designer”.

Preview window. For more information, see “Understanding the Preview Window”.

The following figure shows the ePublisher Designer user interface.
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Understanding the Start Page
The Start page is available in both ePublisher Express and ePublisher Designer. The Start page lists the
most recently opened ePublisher projects. You click on a project name on the Start page to open the
associated project file. You can also specify the number of projects you want to display on the Start page.
For more information about specifying the number of projects you want to display on the Start page, see
“Specifying General ePublisher Preferences”.

The following figure shows the Start page.
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Understanding Document Manager
Document Manager is available in both ePublisher Express and ePublisher Designer. Document Manager
allows you to organize the source documents in your project. Within Document Manager, you can add,
remove, and rearrange the groups and source documents in your project. The following figure shows
Document Manager.
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Including or Excluding Files
ePublisher allows you to include/exclude documents from processing on a target by target basis. This
capability is available to all ePublisher users, regardless of their source authoring format. Users working
with Adobe FrameMaker book files will see that ePublisher scans default include/exclude values from
their source documents.

To include or exclude a document from processing, right-click on any file or book. The context menu
will appear with the Include/Exclude option. Clicking this item will reveal three choices: Include,
Exclude and Use Document Value. Clicking Exclude will create a red dotted line around the file that will
indicated that this source file will not be created in the output file. Clicking include will show as normal
and if it is not changed in the FM source, will be included. The Use Document Value will take whatever
is set in FrameMaker and if already set to Exclude in the source will show the dotted red lines around the
source documents.

Note: Include/exclude settings are configured on a per Target. For example in this
project’s WebWorks Help target, ecology.book  (along with all child files) is
excluded:

In the same project’s WebWorks Reverb target, ecology.book  book is included for processing
while Exploring ePublisher.book  (and child files) is excluded.
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Understanding Output Explorer
Output Explorer is available in both ePublisher Express and ePublisher Designer. Output Explorer
displays all of the files generated by ePublisher.

The following figure shows Output Explorer.

 

The output files displayed in the Output Explorer depend on the item you select in Document Manger.
Output Explorer displays items as follows:

If you have a source document selected in Document Manager, ePublisher displays the source
document group in Output Explorer. The source document group displayed in Output Explorer
contains the Files group, which lists all of the generated topic files, the Images group, which lists
all of the generated images for your output, and the Reports group, which lists Styles, Links,
Accessibility, Filenames, and Topics reports.

If you have a top-level group selected in Document Manager, ePublisher displays the top-
level group in Output Explorer. The top-level group displayed in Output Explorer contains the
Navigation group, which lists the entry-point file for the generated output based on the active target
selected in the project, and the Reports group, which lists Styles, Links, Accessibility, Filenames,
and Topics reports.

If you have a subgroup selected in Document Manager, ePublisher displays the subgroup in
Output Explorer. The subgroup contains the entry-point file for the generated output.

If you have more than one top-level group in Document Manager, in addition to displaying the
top-level group you select in Document Manager in Output Explorer, ePublisher also displays
a Merge Output group in Output Explorer. The Merge Output group displays the merged entry-
point file created from each top-level group entry point file. You can use the merged entry-point
file ePublisher automatically creates when you have more than one top-level group in Document
Manager to created merged help systems.

For more information about merged help systems, see “Merging Top-level Groups (Multivolume
Help)”.
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Understanding the Log Window
The Log Window is available in both ePublisher Express and ePublisher Designer. The Log Window
displays the log ePublisher creates when generating output. When ePublisher creates a log during output
generation, you can see the status of the output generation process and any errors generated. You can also
quickly and easily see which pipelines ePublisher processed, which settings ePublisher applied, and which
files ePublisher parsed. For more information about viewing or working with logs, see the “Working with
Output Log Files”.The following figure shows the Log Window.
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Understanding Style Designer
Style Designer is available in only ePublisher Designer. ePublisher intelligently discovers the styles in the
source documents and presents a list of these styles in Style Designer. Stationery designers then define
how output should be generated by specifying properties and options for each style. Stationery designers
use Style Designer to define how paragraphs, characters, tables, and images display in generated output,
including the color or font of a paragraph style, the style of a table border, the layout of a page, and the
file format of converted images. Stationery designers can also specify other aspects of generated output,
such as page layout and when topic pages are created.

ePublisher uses the styles in source documents along with the settings the Stationery designer defines in
the Stationery to generate output. Using styles in source documents and Stationery settings allows precise
control over the appearance and behavior of generated output.

The following figure shows Style Designer.
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Understanding the Preview Window
The Preview window is available in only ePublisher Designer. When designing Stationery, Stationery
designers can use the Preview window to quickly see how modifications made to styles and project
settings affect the appearance of generated output. You can generate a preview of output from a source
file in ePublisher Designer when you select a source document in Document Manager. However, some
online content features, such as popup windows, links, and conditions, are not displayed or active in the
Preview window.

The following figure shows the Preview window.

For more information about using the preview window in ePublisher Designer when designing Stationery,
see “Previewing the Output from a Source File”.
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Exploring the ePublisher AutoMap User Interface
The ePublisher AutoMap user interface allows you to create, edit, and schedule ePublisher AutoMap jobs.
The following figure shows the ePublisher AutoMap user interface.

For more information about using ePublisher AutoMap, see “Scheduling and Integrating Processes with
AutoMap”.
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Customizing Your ePublisher Workspace
By default, the ePublisher user interface comes preset with certain toolbar icons and window settings.
ePublisher gives you extensive control over the appearance of the user interface by allowing you to
customize the display of windows and toolbars.

When you open ePublisher for the first time, Document Manager and Output Explorer are docked and
the Log Window is undocked. When a window is undocked, it displays as a tab in the sidebar, and it will
auto-hide unless you hover over the tab in the sidebar. When you hover over an undocked window, the
window displays.

You can customize the display of windows in the user interface to suit your needs. In ePublisher, you can
move Document Manager, Output Explorer, and the Log Window to different locations within the user
interface or make them into floating windows. When you dock a window, it becomes stationary within the
user interface and is always visible.

You can rearrange docked windows by moving the window to a new location within the user interface.
For example, you can move the Output Explorer into a new window pane next to the Start page. However,
the Start page cannot be moved. The Start page serves as the central point from which all the windows
are arranged. To move a docked window within the user interface, click on the title bar of the window
and then drag the window to a new location. To undock a window, click on the pin icon in the upper right
corner of the window.

In addition to rearranging docked windows, you can add, remove, customize, or create buttons on tool
bars. You can also create your own custom toolbars. By customizing your toolbars and buttons, you can
create a workspace that fits your preferences and work style.

Whenever you make changes to the user interface by moving windows, changing window dock settings,
or customizing toolbars, the changes take effect for each subsequent project you create or open. For
example, if you dock Document Manager, Output Explorer, and the Log Window and add customized
buttons to the toolbar, these settings will become the default settings for each project you open.

Customizing Your ePublisher Workspace | 25



Specifying General ePublisher Preferences
You use the General tab of the Preferences window to specify ePublisher preferences, such as the number
of recent projects to display on the Start page, whether to automatically scan source documents when
you add them to Document Manager, and where to store user-created formats. You can also reset the user
interface toolbar and window dock positions.

To specify general ePublisher preferences

1. On the Edit menu, click Preferences.

2. Specify preferences for each setting. For more information about settings and options, click Help.
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Miscellaneous ePublisher
Windows

Add New Target Window
Conditions Window
Cross Reference Rules Window
Deployment Configuration (Name) Window
Deployment Editor Window
Documents Window
Edit Target Window
File Mapping Editor Window
Folder Deployment Editor Window
Target Settings Window
Job Info Window
License Information Window

Main ePublisher AutoMap Window

Main ePublisher Window
Manage Targets Window
Merge Settings Window
New ePublisher AutoMap Job Window
New Project Wizard
Preferences Window
Project Settings Window
Save As Stationery Window
Script Editor Window
Target Configuration Window
Target Selection Window
User Information Window
Variables Window
WebWorks ePublisher Preferences Window
WebWorks Licensing Info Window

The topics in this section identify the windows in ePublisher Express, ePublisher Designer, and ePublisher
AutoMap. Each topic provides information about a window or tab and the related fields.
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Add New Target Window
This window allows you to create a new target in your project. A target is based on an output format,
such as WebWorks Reverb 2.0, PDF - XSL-FO, Microsoft HTML Help, or Sun JavaHelp. Each target also
has target settings to customize that target. A project can have multiple targets based on the same output
format, such as WebWorks Reverb 2.0. You may add multiple targets in projects that generate multiple
versions of the online content based on OEM partner agreements or multiple versions of the product.
Each target can have different variable values and conditions set to generate unique output. The fields are
defined as follows:

Target Name
Specifies the name for the target. You can specify a target name that is different from the output
format name. For example, you can name a target OnlineHelp , to identify the purpose of the
generated output. You can also name a target to match the output format name, such as WebWorks
Help , as long as you have only one target in the project using that output format.

Format Type
Specifies the output format for the target, such as WebWorks Reverb 2.0, PDF - XSL-FO, or Sun
JavaHelp 2.0.

28 | Add New Target Window



Conditions Window
This window allows you to specify conditions to use when generating output. Conditions allow you to
show or hide information in your generated output. Conditional text is any content that has a condition
applied to it.

You apply conditions to the content in your source documents, and then you define the visibility for those
conditions in your output. Your project lists the conditions in your source documents and allows you to
specify whether to show or hide each condition. You can also use the condition settings specified in your
source documents. By default, ePublisher uses the condition settings specified in your source documents.
You can modify the settings for the conditions for each target in your project. This window provides the
following tabs:

“Classic Tab”

“Expressions Tab (FrameMaker Only)”

Condions Window | 29



Classic Tab
This tab allows you to specify the visibility of conditions in your output. The columns are defined as
follows:

Name
Specifies the name of the condition.

Visibility
Specifies whether the content with the condition applied to it is included in your output. The values
for this setting are defined as follows:

 

Value Description

Visible Displays the content in your output.

Hidden Excludes the content from your output.

Use document value Uses the state of the condition specified in your source
documents to determine whether the content is displayed in your
output.

Pass Through
Puts the content directly in your output without processing or transforming the output. This setting
allows you to put HTML code in your source documents and have that code put directly in your
output. The content with this type of condition applied is not transformed, so the special characters
in HTML coding remain unchanged. For example, the <  is not transformed to &lt;  and the >  is
not transformed to &gt; .
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Expressions Tab (FrameMaker Only)
This window allows you to manage the expressions related to conditions in source documents authored
in FrameMaker version 8.0 or higher. In these later versions of FrameMaker, FrameMaker allows
you to define logical expressions to use when applying visibility settings to conditional text in a
FrameMaker source document. Using FrameMaker conditional settings, you can create conditional tags
and build complex Boolean expressions for defining output filters when authoring in both structured and
unstructured modes. For more information about conditional expressions in FrameMaker, refer to the
FrameMaker documentation.

Note: The use of Expressions is limited to FrameMaker input.
The fields are defined as follows:

Use Document Value
Specifies whether to use the value specified in your source documents to determine whether the
content is included in your generated output.
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Cross Reference Rules Window
This window allows you to add, edit, and delete cross-reference formats for your project. A cross-
reference format is a combination of text and code that defines how ePublisher displays cross-references
in your generated output.

Cross-references help users navigate through your content. ePublisher automatically converts cross-
references to links in the online content. However, you often want cross-references in your online content
to use a different format from your printed content. For example, you usually include page numbers only
in your printed content. ePublisher enables you to add, edit, and delete cross-reference formats for your
online output.

The columns are defined as follows:

Document Type
Specifies the content type of the source document that contains the cross-reference formats to
modify.

Name
Specifies the name of the cross-reference format. ePublisher obtains the cross-reference formats
displayed in this column from your source documents. The Name column shows either the cross-
references formats used or a set of default cross-reference formats depending on the type of source
document you are converting. These formats are hidden building blocks or codes that come directly
from your source document. If you would like to find out how to interpret them, see the Help
documentation for the application that was used to create the source document.

Use Document Value
Specifies whether to use the value specified in your source documents instead of the specified value
in the ePublisher project.

Value
Specifies the replacement content and building block code that ePublisher uses when generating
your output. For example, a FrameMaker cross reference format may be <$paratext>  to provide
the text of the linked heading paragraph as the cross reference. For more information about the
building block of text and code that defines your cross-reference format, see the documentation for
the authoring tool you used when you created your source documents. For example, if you created
your source documents in Adobe FrameMaker, see the Adobe FrameMaker documentation.

To edit the cross-reference format, double-click the value to edit, and then edit the cross-reference
format in the Replacement field in the Edit Cross Reference window. The Value column shows the
corresponding online cross-reference formats. The first time you open this window for a project,
the formats in the Value column match the formats in the Name column so that ePublisher matches
the content of your generated output to your source documents.
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Deployment Configuration (Name) Window
This window allows you to specify a name for an output destination when you configure an output
destination for a target.

The fields are defined as follows:

Name
Specifies the name for the output destination. Ensure you specify a descriptive name for the output
destination. When you work with output destination, you can only see the name of the output
destination. You will not be able to see the actual path you specified to the output destination.
Type a descriptive name for the output destination that allows you to easily identify each output
destination you specify.
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Deployment Editor Window
This window allows you to specify deployment locations for your generated output. A deployment
location is a folder where you deploy generated output files. A deployment location can be a folder on
your local computer or on a network share.

The columns are defined as follows:

Name
Specifies the name of the deployment location.

Deployment Type
Specifies the type of container to which the generated output files are deployed. ePublisher
currently supports only folders as deployment locations.
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Documents Window
This window allows you to specify the source documents the ePublisher AutoMap job uses when
generating output create groups and to create groups for source documents. This window also allows you
to specify a script to use when obtaining source documents for a group. For example, to obtain source
documents from a version control or content management system, you can specify a script that obtains
and prepares source documents based on the parameters you define in the script.

You must create a top-level group before you can add source documents to the ePublisher AutoMap job.
A top-level group is the primary container for source documents, subgroups, and the entry-point file for
the output. After you create a top-level group, you can add source documents to the job, and you can also
create subgroups and add source documents to subgroups as needed.

The fields are defined as follows:

Script to retrieve documents
Specifies the script to run to retrieve source documents.Type or paste the script to use to retrieve
source documents into the text field or click Edit Script to use the Script Editor window to write
your script. The script you specify runs before the ePublisher AutoMap job generates output,
which ensures that the ePublisher AutoMap job always uses the most current version of the source
documents.
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Edit Target Window
This window allows you to edit the name of a target. A target is the specific type of output you want
to produce using your source files and project settings, and targets are based on an output format, such
as WebWorks Reverb 2.0, PDF - XSL-FO, or JavaHelp. Targets include all of the project settings you
specify for each output format included in your project when you configure your project.

Target Name
Specifies the name of the target. You can specify a target name that is different from the output
format name. For example, you can name a target based on the WebWorks Reverb 2.0 output
format OnlineHelpFormat , or you can name a target based on the WebWorks Reverb 2.0 output
format WebWorks Reverb 2.0 format .

Format Type
Displays the output format for the target. For example, the format type may be WebWorks Reverb
2, PDF - XSL-FO, or WebWorks Help.
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File Mapping Editor Window
This window allows you to create a file mapping. A file mapping is an association between a file
extension and an ePublisher adapter. An ePublisher adapter is an ePublisher component that bridges
the gap between the application in which the source document was created and ePublisher. ePublisher
currently provides adapters for Helper (Markdown++), Microsoft Word, Adobe FrameMaker, and XML.

The columns are defined as follows:

File extension
Specifies the file extension to associate with an ePublisher adapter.

Adapter
Specifies the ePublisher adapter to use for the file extension.
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Folder Deployment Editor Window
This window allows you to edit deployment locations. A deployment location is a folder where
ePublisher deploys output files from a project. A deployment location can be a folder on your local
computer or on a network share.

The fields are defined as follows:

Name
Specifies the name you of the deployment location.

Directory
Specifies the folder where to deploy your output files.
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Target Settings Window
This window allows you to specify the settings to use for a selected output target. You can reach this
window by selecting the menu: Target > Target Settings.

The target settings are grouped according to function.
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Generated output location
Specifies the location where ePublisher saves the generated output for the selected target.

Note: We do not recommend changing the generated output location as it creates issues with
maintaining project in the future.
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Deploy to
Specifies the name of the deployment location where ePublisher deploys the output generated for
the target if you have created and selected a deployment location. Specify a deployment location by
selecting a deployment location you created from the list.
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List of Target Settings
The main component of the Target Settings Window is the list of available target settings that can
be configured for a given target in your project. See “Target Settings Reference” for a complete list
of available settings.
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Job Info Window
This window allows you to specify information about an ePublisher AutoMap job. You can also specify if
any scripts run before or after the job runs and generates output.

The fields are defined as follows:

Job name
Specifies the name of the job.

Choose ePublisher project or stationery
Specifies the ePublisher project or Stationery for the job. You specified the ePublisher Designer
project or Stationery when you created the job. To change the ePublisher project or Stationery
specified for the job, type a path to the new ePublisher project or Stationery for the job or click the
Folder icon to browse to and select the new ePublisher project or Stationery for the job.

Pre-build
Specifies the pre-build script to run before ePublisher AutoMap generates output. Type or paste the
pre-build script into the text field or click Edit Script to use the Script Editor window to write your
script.

Post-build
Specifies the post-build script to run before ePublisher AutoMap generates output.Type or paste
the post-build script into the text field or click Edit Script to use the Script Editor window to write
your script.
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License Information Window
This window allows you to view the adapters for which you are licensed. Adapter licensing information
is specified in your Contract ID. ePublisher uses adapter license keys, or activation codes, to enable
ePublisher functionality, and ePublisher automatically retrieves and enables these codes based on your
Contract ID. ePublisher licenses, or activation codes, do not display in the ePublisher user interface.
ePublisher components automatically communicate with the ePublisher licensing server periodically to
refresh and update ePublisher activation codes as needed.

If you have a valid Contract ID for one version of the ePublisher product, when a new version of
ePublisher releases, you can continue to use your same Contract ID when you upgrade to the new version
of the product. You can also continue to use your same Contract ID if you have to uninstall and then re-
install a version of ePublisher.

The fields are defined as follows:

Product
Specifies the name of the ePublisher adapters for which you are licensed. Your Contract ID
specifies the ePublisher adapters for which you are licensed.

Expires
Specifies the license expiration date for the licensed ePublisher adapters. ePublisher components
automatically communicate with the ePublisher licensing server to renew activation codes as
needed before they expire based on the terms of your current contract.

“Working with Contract IDs”

“Viewing Licensing and Contract ID Information”

“Obtaining Contract IDs”

“Entering Contract IDs”

“Managing Licensing in Environments without Internet Connectivity”

“Updating Licensing”

“Deactivating Licensing”

“Problems with FrameMaker or Microsoft Word”
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Main ePublisher AutoMap Window
This window allows you to view information about ePublisher AutoMap jobs.

The columns are defined as follows:

Name
Specifies the name of the ePublisher AutoMap job.

Last Result
Specifies the results from the last time the job ran. You can see if the job completed successfully, or
if any errors occurred the last time the job ran.

Status
Specifies the current state of the job, such as whether the job is currently running or ready to be
run.

Last Run
Specifies the date and time the job last ran.

Next Run
Specifies the date and time the job is scheduled to run again.

Scheduled
Specifies whether the job is currently scheduled to run.
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Main ePublisher Window
The WebWorks ePublisher Platform (ePublisher) is a powerful, comprehensive solution that delivers cost-
effective processes for efficiently publishing and maintaining online and print information. ePublisher
gives you the flexibility to deliver content from multiple types of source documents, such as Adobe
FrameMaker, Microsoft Word, and DITA, in virtually any output format you need. The open, standards-
based architecture provides a powerful engine that does not lock your content in a proprietary format that
can become outdated as tools and standards change.

The main ePublisher window connects you to the many powerful features found in ePublisher. This
window includes the following subwindows:

“Document Manager”

“Output Explorer”

“Start Page”

“Log Window”

“Style Designer”

“Document Designer”
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Document Manager
This window allows you to view and organize source documents in your ePublisher project. From
the Document Manager window, you can add, remove, and rearrange groups, subgroups, and source
documents.

In Document Manager, you can create an organizational structure for your source documents that
includes groups and subgroups. A group is the highest level of organization of generated material.
The group indicates how ePublisher outputs source documents. Each primary-level group created in
Document Manager generates a separate Help system output. Subgroups organize your help project
source documents into a logical and helpful system.

You can include multiple source documents of differing file types within Document Manager. Each file
type has a unique and identifiable icon in the Document Manager window.
 

File Type Icon File Type Description

ePublisher Project file

Adobe FrameMaker file

DITA 1.0 or DITA 1.1 file

Microsoft Word 98 to Microsoft Word 2007 file

“Understanding Document Manager”
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Output Explorer
This window allows you to view and open generated output files from ePublisher Designer. The Output
Explorer window displays output files based on whether you select a source document or the project file
in the Document Manager window. If you select the project file, Output Explorer displays the project file
along with its navigation information and any project reports. If you select a source document, Output
Explorer displays the individual files, images, and reports for the document.
 

File Type Icon File Type Description

ePublisher project directory

Output files directory

Images directory

Output file that has been deleted

Navigation directory

Reports directory

Single report

Printable report

“Understanding Output Explorer”

“Understanding Document Manager”
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Reports
Once you have generated output or generated a report from ePublisher, you can double click each of the
types of report to bring up a tab to the right of the Document Manager and Output Explorer that will list
the various occurrences of filename markers, topic alias markers, and other components of your source
document.

Note: If you do not have anything to report, the tab will be blank. For example, if
you do not have any topic aliases, there will be nothing in the topics report.
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Reports - printable
Provides an xml list of the reports that are generated with the output.
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Start Page
This window lists all recently opened ePublisher projects. Click any of the project names listed to open
the project file. Click New Project to create a new project from this window. Click Open Project to
navigate and open an existing project not already listed on the Start Page.

To specify the maximum number of projects that ePublisher shows in Start Page or clear the currently
displayed projects, select Preferences on the Edit menu. Enter the number of projects to display in the
Recent projects to remember field. Click Clear List to remove the current list of projects shown on
Start Page.
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Log Window
This window shows the status of project and report generation. The Log window identifies where errors
occur when generating output files or reports and displays a detailed error message description. Links in
this window are highlighted in blue and if clicked they will open that URL in the default browser.

When you generate output, ePublisher converts a source document to a target by breaking the process into
a series of steps, also known as stages. Each stage performs a specific action in the process. ePublisher
groups these steps into pipelines of related stages.

Each time you generate output or reports, ePublisher Designer creates an external log file, generate.log
in the Logs  directory of the selected project file. Send this log file to the ePublisher support team if you
submit a support request. Click Save As in the Log window to save the current log contents as a text file
in another directory.

The Log window automatically displays when you open the main ePublisher Designer window. If you
close the Log window and need to reopen it, select Log Window on the View menu.
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Preview Window
This window shows a preview of how a source document will display when you generate output. You can
modify output formatting in the Preview window from Document Designer. Document Designer allows
you to make modifications only at the paragraph or table level, which means each modification you make
applies only to the selected paragraph or table.

Note: The Preview window gives you an idea of how your project settings affect
the appearance of generated output. However, this window does not display
some output features or shows them as inactive, such as popups, links, and
conditions.

After you modify properties in Document Designer, click Refresh at the top of the Preview window to
view an updated preview. If you modify your original source documents, you must scan the document
again to see changes in the Preview window

“Understanding the Preview Window”

“Customizing Your ePublisher Workspace”
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Document Designer
This window allows you to override the appearance of a paragraph or table in generated output. If there is
an issue in the output and the designer does not have time to make the change in the Stationery, or if you
did not set all the styles needed in the source documents and you do not have time to fix it, use Document
Designer to put style overrides in place for specific paragraphs or tables. Select the Allow user style
overrides project setting to allow style overrides.

Note: ePublisher does not keep changes made through Document Designer if you
save a project as Stationery.

Document Designer works in conjunction with the Preview window. To preview a document, select a
single document in the Document Manager, and then select Generate Preview from the Project menu.
Select a paragraph or table in the Preview window and make modifications in Document Designer.
Document Designer fields appear inactive until you open the Preview window and select text in the
source document.

After modifying the selected content in Document Designer, click refresh in the Preview window to see
how modifications look in the generated output.

Note: Changes made using Document Designer override any others modifications
in ePublisher. For example, if you alter a paragraph in Document Designer
to have a red background, but you later decide to change the style the
paragraph uses in Style Designer to have a blue background, the Document
Designer modifications take precedence.

To clear changes made in Document Designer, select Clear Document Style Overrides on the Edit
menu.

Style type
Indicates what style was applied to the paragraph or table selected in the Preview window.
ePublisher populates this field with style name specified in your source document.

Apply style
Allows you to select a different style to apply to the paragraph or table selected in the Preview
window. ePublisher imports all styles in your original source document when you generate project
files.
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Style Designer
This window allows you to specify the appearance and functionality of online content, including
paragraphs, characters, tables, page layouts, images, table of contents levels, popups, and related topics.
ePublisher Designer builds Stationery based on the settings you specify in Style Designer.
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Font Family Picker Window
This window allows you to assign a font or font family to a paragraph style in your project. From Style
Designer, select the paragraph style to assign a font or font family and click the Ellipses button in the
Family field. Select an installed font, a font family, or a custom font and click the Arrow button to move
the font or font family to the Selected field. To remove a font or font family from the Selected field,
select the font in that field and click “X” at the top of the window.

Consider specifying a generic font family, such as sans-serif, rather than a specific font. Many browsers
and help systems use only fonts installed on the user’s computer. If you indicate a specific font, a user
who does not have that specified font installed does not see the help output correctly. By selecting a
generic font family, the user does not have to have the exact font specified, only a font from that family.

If you specify multiple fonts, separated by commas, the user’s browser displays the first available font in
the list. For example, if you specify Verdana, Arial, Helvetica, sans-serif  and the user does not
have the Verdana font installed, the browser displays in the Arial font for the help output instead.
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Manage Targets Window
This window allows you to create and manage targets in your project. A target is based on an output
format, such as WebWorks Reverb 2.0, PDF - XSL-FO, or Sun JavaHelp. Each target also has target
settings to customize that target. A project can have multiple targets based on the same output format,
such as Microsoft HTML Help. You may add multiple targets in projects that generate multiple versions
of the online content based on OEM partner agreements or multiple versions of the product. Each target
can have different variable values and conditions set to generate unique output. The columns are defined
as follows:

Target Name
Specifies the name for the target. You can specify a target name that is different from the output
format name. For example, you can name a target OnlineHelp , to identify the purpose of the
generated output. You can also name a target to match the output format name, such as WebWorks
Reverb 2.0 , as long as you have only one target in the project using that output format.

Format Type
Specifies the output format for the target, such as WebWorks Reverb 2.0, PDF - XSL-FO, or Sun
JavaHelp 2.0.

Manage Targets Window | 57



Merge Settings Window
This window allows you to specify custom settings for merged, or multivolume help. ePublisher only
enables this window if you are working with an output format that supports merged, or multivolume help
systems. Not all output formats support merged, or multivolume help. WebWorks Reverb 1 and 2, Eclipse
Help, Microsoft HTML Help, and WebWorks Help are the output formats that currently support merged,
or multivolume help systems. If you are working with an output format that does not support merged, or
multivolume help, this window is disabled.

The fields are defined as follows:

Merge Title
Specifies the name displayed in the title bar of the help.

Hierarchy
Lists all the top-level groups in your project. This group hierarchy is used to define the hierarchy
displayed in the table of contents for your multivolume help system. To reposition any of your top-
level groups in the table of contents hierarchy, select the group to move and drag the group to a
new location in the hierarchy.

Table of contents title
Specifies the name displayed for the selected top-level group when that group is displayed in
the table of contents for your merged, or multivolume help system. The group name specified in
Document Manager defines the name of the folder that contains the generated output files in that
group. Change the name displayed for the top-level group in your merged, or multivolume help
system by selecting a top-level group and then typing a new name in this field. By default, the
name displayed in the table of contents is the name of the top-level group specified in Document
Manager.

Group context
Specifies the help context to use when generating merged, or multivolume help that includes
context-sensitive help. In WebWorks Help, you need to include this context and the TopicAlias
value in the help call to display the correct help topic.

Note: The group context must be unique so that when topic IDs are duplicated in
different help sets, the context sensitive reference will refer to the correct
help location. For more information, see “Opening Context-Sensitive Help in
WebWorks Help using Standard URLs”.
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New ePublisher AutoMap Job Window
This window allows you to create a new ePublisher AutoMap job. A job is a task that ePublisher
AutoMap schedules that generates output based on an existing ePublisher project or existing ePublisher
Stationery. Once you create an ePublisher AutoMap job, you can run the job immediately, or schedule the
job to run at a later point in time.

The fields are defined as follows:

ePublisher project
Creates a new ePublisher AutoMap job based on an existing ePublisher project.

ePublisher stationery
Creates a new ePublisher AutoMap job based on existing ePublisher Stationery.

Choose ePublisher project or stationery
Specifies the location of the project or Stationery that ePublisher AutoMap should use to generate
output.
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New Project Wizard
This wizard allows you to create a new ePublisher project in ePublisher Express or ePublisher Designer.
A project is all the necessary files and components needed to generate output from source documents.
This wizard provides several windows:

“New Project Window (New Project Wizard)”

“Browse For Folder Window (New Project Wizard)”

“Source Documents Window (New Project Wizard)”
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New Project Window (New Project Wizard)
This window allows you to specify a name for a new project and where to save the new project you are
creating. If you are using ePublisher Express, this window allows you to specify the Stationery to use
when creating your new project. If you are using ePublisher Designer, this window allows you to specify
the output format for your Stationery design project.

The fields are defined as follows:

Project name
Specifies the name to use for your project.

Location
Specifies the folder in which to save your new project. Click Browse to open the Browse For
Folder window where you can select the folder in which to save your new project.

Format
Specifies the output format to use for your project. You must specify at least one output format
when you create the project. You can also specify additional output formats for the project after you
create the project.
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Browse For Folder Window (New Project Wizard)
This window allows you to specify the folder where you want to save the new project. Navigate to and
select the folder where you want to save the project, or click Make New Folder to create a new folder in
which to save the project.

62 | Browse For Folder Window (New Project Wizard)



Source Documents Window (New Project Wizard)
This window allows you to specify the source documents to use in your project. To add source documents
to your project, click Add, select the files to add, and then click Open. To remove a source document
from the list, select the source document and then click Remove. You can also add and remove source
documents after you have created the project.

When the Source Documents field lists all the source documents you want to initially add to the project,
click Finish.
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Preferences Window
This window allows you to customize ePublisher AutoMap behavior for your specific needs. These
preferences affect the behavior of the application, such as the language displayed in the console.

This window provides the following tabs:

“General Tab (Preferences Window)”
 

“File Mappings Tab (Preferences Window)”
 

“Notification Tab (Preferences Window)”
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General Tab (Preferences Window)
This window allows you to specify a job folder, staging folder, and user formats folder for ePublisher
AutoMap jobs. You can also specify the user interface language ePublisher AutoMap uses, whether you
want ePublisher AutoMap jobs to always scan for variables and conditions, and if you want ePublisher
AutoMap jobs to delete temporary files created in the staging folder after generating output.

The fields are defined as follows:

Job folder
Specifies the folder where ePublisher AutoMap stores job files and log files.

A job file is a file that uses a proprietary XML format. ePublisher AutoMap stores all information
that describes an ePublisher AutoMap job in the job file. ePublisher AutoMap uses the name of
the job as the job file name, and ePublisher AutoMap uses WebWorks AutoMap Job (.waj ) as the
extension for the job file. ePublisher AutoMap creates the job file based on information you specify
using the ePublisher AutoMap user interface. Do not edit the job file directly. If you edit the job file
outside of the ePublisher AutoMap user interface, ePublisher AutoMap may no longer be able to
read the job file.

A log file is a file that contains information about events that occurred the last time the ePublisher
AutoMap job generated output. The log file is a plain text file that you can view using any text
editor. Log files use the .txt extension. ePublisher AutoMap does not create and store a log file
in the job folder until the job runs and generates output.

By default, ePublisher AutoMap creates the job folder in the following location: \Documents and
Settings\UserName\My Documents\WebWorks Automap\Jobs , where UserName  is the name of
the user account under which the job runs.

Staging folder
Specifies the folder where ePublisher AutoMap stores the job information an ePublisher AutoMap
job needs to generate output. The staging folder servers as a working folder for the job. Information
such as automatically generated ePublisher projects, intermediate data files, and output files are
stored in the stating folder.

By default, ePublisher AutoMap creates the staging folder in the following location: \Documents
and Settings\UserName\My Documents\WebWorks Automap\Staging , where UserName  is the
name of the user account under which the job runs.

ePublisher AutoMap creates the staging folder contents based on information you specify using the
ePublisher AutoMap user interface and uses this information to generate output. Do not edit files
in the staging folder directly. If you edit files in the staging folder directly, the ePublisher AutoMap
job may no longer be able to run.

Always scan for variables and conditions
Specifies whether ePublisher AutoMap always scans for new variables and conditions when adding
a document to the Document Manager.

Delete temporary files after generating
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Specifies whether ePublisher AutoMap jobs delete the temporary files the job created in the staging
folder after generating output. This option is disabled in ePublisher AutoMap by default so you
can examine the actual project and intermediate files created and stored in the staging folder
when the ePublisher AutoMap job generated output. Enable this option to reduce the amount of
computer disk space ePublisher AutoMap uses and if you do not want to examine the actual project
and intermediate files created and stored in the staging folder when the ePublisher AutoMap job
generated output.

User interface language
Specifies the language the ePublisher AutoMap user interface uses. ePublisher is currently
available in English, French, German and Japanese. If you change the user interface language to
use, you must close and then reopen the user interface before the language change you specified
takes effect.
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File Mappings Tab (Preferences Window)
This window allows you to specify file mappings. A file mapping is an association between a file
extension and an ePublisher adapter. An ePublisher adapter is an ePublisher component that bridges
the gap between the application in which the source document was created and ePublisher. ePublisher
currently provides adapters for Markdown++ (helper), Microsoft Word, Adobe FrameMaker, and XML.

The columns are defined as follows:

File Extension
Specifies the name of the file extension.

Adapter
Specifies the ePublisher adapter associated with the file extension.
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Notification Tab (Preferences Window)
This window allows you to specify email notification options if you want ePublisher AutoMap to send an
email notification after an ePublisher AutoMap job completes. You can configure ePublisher AutoMap to
send an email notification that contains information about if the job completed successfully or if the job
generated errors. You can also specify to include the log file generated by the ePublisher AutoMap job as
an email text file (.txt ) attachment.

The fields are defined as follows:

Enable email notification
Specifies whether ePublisher AutoMap sends out an email notification when a job completes.

To address
Specifies the email addresses to which ePublisher AutoMap sends email notifications. Enter an
email address for each person to send an ePublisher AutoMap email notification to when a job
completes. To enter multiple email addresses, separate email addresses using a comma (,) character.
You can also send email notifications to group email aliases. To create a group email alias to send
ePublisher AutoMap email notification to, contact your system administrator at your company.
After your system administrator creates the appropriate group email aliases you want to use, enter
the group alias in the field.

From address
Specifies the email address from which the email notification is sent. If someone replies to an
ePublisher AutoMap email notification, this is the email address to which the reply will be sent.

SMTP server
Specifies the name of the SMTP server ePublisher AutoMap uses to send email notifications.
ePublisher AutoMap email notifications require an SMTP email server in order to send emails.
Contact your system administrator at your company to obtain the name of an SMTP email server
ePublisher AutoMap can use to send email notifications.

Username
Specifies the name of a user account with permissions to send emails using the SMTP server.
Contact your system administrator at your company to obtain the user name and password for a
user with permissions to send ePublisher AutoMap notifications using the SMTP server.

Password
Specifies the password for the user account with permissions to send email using the SMTP server.
Contact your system administrator at your company to obtain the user name and password for a
user with permissions to send ePublisher AutoMap email notifications using the SMTP server.
ePublisher encrypts and stores the password you specify.

Always attach log to email
Specifies whether you want to include the log file generated by the job as an email text file (.txt )
attachment in the ePublisher AutoMap email notification.
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Project Settings Window
This window allows you to specify file mappings for your project. If you are using ePublisher Designer,
this window also allows you to specify if you want to allow user style overrides in document previews
for the project and input configurations. Depending on which ePublisher component you are using, this
window can provide the following tabs:

“File Mappings Tab (Project Settings Window)”

“Input Configurations Tab (Project Settings Window)”
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File Mappings Tab (Project Settings Window)
This window allows you to specify file mappings for your project. A file mapping is an association
between a file extension and an ePublisher adapter. An ePublisher adapter is an ePublisher component
that bridges the gap between the application in which the source document was created and ePublisher.
ePublisher currently provides adapters for Microsoft Word, Adobe FrameMaker, and XML.

The columns are defined as follows:

File Extension
Specifies the name of the file extension.

Adapter
Specifies the name of the ePublisher adapter associated with the file extension.
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General Tab (Project Settings Window)
If you are using ePublisher Designer, this window allows you to specify if the project allows user style
overrides in document previews by default. A style override is a change made with Document Designer
to the preview of a single document. Overrides can be applied to a paragraph or a table, and an override
supersedes any values or properties set in either the source document or in Style Designer. Overrides
appear only in output. The do not display in or affect the source document. Overrides cannot be saved to
Stationery.

The fields are defined as follows:

Allow user style overrides in document previews (ePublisher Designer only)
Specifies whether to allow user style overrides. When you add overrides to the output in your
project, ePublisher adds bookmarks to your source documents. These bookmarks contain unique
IDs that store override information and allow ePublisher Designer to keep track of your overrides.
These IDs are invisible and do not affect the functionality of your source documents.

If you clear this option, you cannot add overrides to your output, and you cannot use Document
Designer. If you do not want ePublisher to add these unique ID bookmarks to your source
documents, clear the check box.

If all paragraphs in your Microsoft Word documents use a style other than Normal and you do not
plan on adding any overrides to your documents, you may want to clear this option.

Compatibility Configuration
The Base format version determines which Format library will be used when generating output.
You can select any ePublisher version back to 9.2.2. This option is available to ensure ease of use
when upgrading should user contain XSL overrides which may be incompatible with newer format
libraries. Any plugin used in the project will be updated to match format version.

Users will see a log message such as the following when a project is configured to operate in
compatibility mode:

[Warning] Project configured to use legacy format version '2009.2'.

Keep in mind that a project in running in compatiblity mode can only use formats defined for
that version. You will be able to use the latest format versions once you have upgraded your
customizations to be compatible with the newer release.
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Input Configurations Tab (Project Settings Window)
This window allows you to specify settings for ePublisher input formats, also known as ePublisher
adapters.

The fields are defined as follows:

Preserve condition colors in PDF
Specifies whether you want to preserve any colors assigned to conditions in your Adobe
FrameMaker source documents when you generate output.

Preserve condition styles in PDF
Specifies whether you want to preserve any condition styles assigned to conditions in your Adobe
FrameMaker source documents when you generate output.

Version used for generation
Specifies the version of Adobe FrameMaker to use when generating output. Use this setting if you
have more than one version of Adobe FrameMaker installed on the computer used to generate
output and you want ePublisher to use a specific version of Adobe FrameMaker when generating
output.

Preserve change bars in PDF
This allows the change bar feature in Microsoft Word to be added to the PDF output.

Preserve Index
By default, ePublisher does not use the Index generated within Microsoft Word. In cases (usually
when generating PDFs) where you want to preserve the Index generated by Microsoft Word, you
can enable this feature.

Preserve Table of Contents
By default, ePublisher does not use the table of contents generated within Microsoft Word. In cases
(usually when generating PDFs) where you want to preserve the table of contents generated by
Microsoft Word, you can enable this feature.

Preserve Table of Figures
By default, ePublisher does not use the table of figures generated within Microsoft Word. In cases
(usually when generating PDFs) where you want to preserve the table of figures generated by
Microsoft Word, you can enable this feature.

RD field behavior
Specifies how you want Referenced Document (RD) field code behavior used when you generate
output using Microsoft Word source documents that contain RD field codes that reference other
source documents. The values for this setting are defined as follows:
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Value Description

Indicates Book
document

Processes source documents that contain RD field codes as book
files. ePublisher processes all the source documents identified by
RD field codes.

Ignore Ignores all the source documents identified by RD field codes.
ePublisher processes only the source documents included directly
in the project.

Auto-Detect Processes source documents that contain RD field codes based
on the contents of the source document. ePublisher analyzes the
contents of each source document to determine if the file should
be processed as a book file, front matter, table of contents, or
index. This analysis is based on the presence of RD field codes
combined with the presence or absence of a TOC or INDEX field
code, which indicate whether the document contains a table of
contents, index, or table of figures..

All DITA topics must exist
Specifies whether or not to generate an error instead of a warning whenever a missing topic is
found during the processing of a ditamap.

Combine DITA character styles
Starting with version 2014.1, ePublisher will use combined character styles to allow nested
elements to be styled more precisely in the generated output. For new projects this setting will
default to enabled, otherwise it will be disabled for backward compatibility.

Convert notes to tables
Enable this setting to convert DITA <note>  elements into simple tables with ePublisher paragraph
styles for better control of the generated output.

DITA Abbreviated Form Scope
Specifies what scope to use when controlling when an abbreviation should be used instead of the
long form. The values for this setting are defined as follows:

 

Value Description

Map Use the long form once for the entire ditamap. All other instances
after the first usage will use the abbreviated form.

Part If you organize multiple chapters into a part, then only the first
instance will use the long form within the part.

Chapter Use the long form once per chapter.
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Value Description

Topic Use the long form once per topic.This is the default configuration.

DITA Open Toolkit version
Specifies the version of the DITA Open Toolkit you want to use when generating output using
DITA source documents.

Emit draft comments
Enable this setting when working with DITA and you want to emit draft comments.

Ignore print attribute
Disable this setting if you want ePublisher to process the print attribute for DITA content. In the
DITA 1.3 specification, the @print  attribute was deprecated and a new attribute that obeys DITA
filtering rules, @deliveryTarget , was introduced.
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Save As Stationery Window
This window allows you to create Stationery from an ePublisher Designer Stationery design project
by creating and saving a Stationery file. Stationery contains all project configurations, including style
information, target settings, variables, conditions, cross-reference definitions, target overrides, user files,
merge settings, and output format information.

The fields and columns are defined as follows:

Name
Specifies the name of the Stationery file.

Directory
Specifies the location where ePublisher saves the Stationery.

Target Name
Specifies the names of the targets included in the Stationery.

Format Type
Specifies the output format of the each target.
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Script Editor Window
This window allows you to write ePublisher AutoMap job scripts using a simple script editor. The
ePublisher AutoMap script editor provides a text area where you can paste or write a script and a list of
useful ePublisher AutoMap variables you can use in your scripts or pass to other scripts and applications.

ePublisher AutoMap only recognizes text-based scripts. If you paste a script into the script editor, any
formatting or additional information available in a third-party script editor is lost when you paste the
script into the ePublisher AutoMap script window.

The columns are defined as follows:

Name
Specifies the name of the ePublisher AutoMap variable.

Description
Specifies a description for the ePublisher AutoMap variable.
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Target Configuration Window
This window allows you to specify output generation parameters for each output target in ePublisher
AutoMap. Depending on which output target you select in the Target Name column, this window can
provide the following tabs:

“Info Tab (Target Configuration Window)”

“Conditions Tab (Target Configuration Window)”

“Variables Tab (Target Configuration Window)”

“Target Settings Tab (Target Configuration Window)”

“Merge Settings Tab (Target Configuration Window)”

For example, if you select an output target that uses the Dynamic HTML output format, the Target
Configuration window displays the Info, Conditions, Variables, and Target Settings tabs, but does not
display the Merge Settings tab, because merge settings is not supported for the Dynamic HTML output
format. However, if you select an output target that uses the Microsoft HTML Help output format, the
Target Configuration window displays the Info, Conditions, Variables, Target Settings, and Merge
Settings tab.
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Info Tab (Target Configuration Window)
This window allows you to specify output target settings for the selected output target, such as where to
deploy the output after generating the output, if you want ePublisher AutoMap to delete any files in the
output location before generating output, and if you want to run a pre-build or post-build script before or
after generating output for each output target.

The fields are defined as follows:

Deploy to
Specifies the deployment location. The deployment locations listed are deployment location
configured in the ePublisher Stationery or ePublisher project associated with the ePublisher
AutoMap job. Click Add deploy target to add an output deployment location to the list.

Delete files in output location before deployment
Specifies whether ePublisher AutoMap deletes any existing files in the deployment location before
ePublisher AutoMap places new files in the deployment location.

Pre-build
Specifies the pre-build script to run before ePublisher AutoMap generates output. Type or paste the
pre-build script into the text field or click Edit Script to use the Script Editor window to write your
script.

Post-build
Specifies the post-build script to run before ePublisher AutoMap generates output. Type or paste
the pre-build script into the text field or click Edit Script to use the Script Editor window to write
your script.
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Conditions Tab (Target Configuration Window)
This window allows you to specify the visibility of conditions in your output. The columns are defined as
follows:

Name
Specifies the name of the condition.

Value
Specifies whether the content with the condition applied to it is included in your output. The values
for this setting are defined as follows:

 

Value Description

Visible Displays the content in your output.

Hidden Excludes the content from your output.

Use document value Uses the state of the condition specified in your source
documents to determine whether the content is displayed in your
output.

Passthrough
Places the content directly in your output without processing or transforming the output. This
setting allows you to put HTML code in your source documents and have that code put directly
in your output. The content with this type of condition applied is not transformed, so the special
characters in HTML coding remain unchanged. For example, the <  is not transformed to &lt;  and
the >  is not transformed to &gt; .
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Variables Tab (Target Configuration Window)
This window allows you to specify the variables to use when generating output.

The columns are defined as follows:

Name
Specifies the name of the variable.

Use document value
Specifies whether you want to use the variable value specified in your source documents when
generating output.

Value
Specifies the value of the variable that will be used in your output. The default ePublisher behavior
is to use variable value specified in the source document in your project. However, you can change
the value of the variable in your project by clicking in the Value field for the variable to change and
then typing in a new value for the variable.
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Target Settings Tab (Target Configuration Window)
This window allows you to specify the settings to use for the selected output target. The target settings
displayed in ePublisher AutoMap are the target settings specified in ePublisher projects and Stationery.
Typically, the target settings are configured and managed by the Stationery Designer in ePublisher
Designer. However, you can override the target settings specified in ePublisher projects and Stationery
using ePublisher AutoMap for each output target in an ePublisher AutoMap job if needed.

The columns are defined as follows:

Setting
Specifies the settings available for the selected target.

Value
Specifies the value of the setting.
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Merge Settings Tab (Target Configuration Window)
This window allows you to specify custom settings for merged, or multivolume help. ePublisher only
enables this window if you are working with an output format that supports merged, or multivolume help
systems. Not all output formats support merged, or multivolume help. Eclipse Help, Microsoft HTML
Help, and WebWorks Help are the output formats that currently support merged, or multivolume help
systems. If you are working with an output format that does not support merged, or multivolume help, this
tab is not displayed.

The fields are defined as follows:

Merge Title
Specifies the name displayed in the title bar of the help system when the multivolume help system
opens.

For example, if you have two or more groups, the Merge Title will reflect the title bar of the meged
helpset and the top-level group.

Hierarchy
Specifies all of the top-level groups in your project in a hierarchy. This group hierarchy is used
to define the hierarchy displayed in the table of contents for your multivolume help system. To
reposition any of your top-level groups in the table of contents hierarchy, select the group to move
and drag the group to a new location in the hierarchy.

Table of contents title
Specifies the name displayed for the top-level group when the top-level group is displayed in the
table of contents for your merged, or multivolume help system. Change the name displayed for the
top-level group in your merged, or multivolume help system by selecting a top-level group and
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then typing a new name in the field. By default, the name displayed is the name of the top-level
group in your project.

Group context
Specifies the name to use as the topic context when you generate merged, or multivolume help that
includes context-sensitive help.
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Target Selection Window
This window allows you to specify the targets the ePublisher AutoMap job generates. A target is based
on an output format, such as WebWorks Help, Microsoft HTML Help, or Sun JavaHelp, but targets also
contain project-specific settings. Targets define how your output looks, and are based on output formats
and settings specified in the ePublisher Stationery or ePublisher project associated with the ePublisher
AutoMap job. An ePublisher AutoMap job can generate output for one or multiple targets.

The columns are defined as follows:

Target Name
Specifies the list of targets in the ePublisher Stationery or ePublisher project associated with the
ePublisher AutoMap job.

Format
Specifies the type of output format associated with the target.

Build
Specifies whether the target will be included in the ePublisher AutoMap job. Select this check box
for the target to include the target in the ePublisher AutoMap job. Clear this check box if you do
not want to include the target in the ePublisher AutoMap job.
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User Information Window
This window allows you to specify authentication information to schedule an ePublisher AutoMap job
using Windows Task Scheduler. Windows Task Scheduler is a free tool that is included in Microsoft
Windows operating systems.

With ePublisher AutoMap, you can specify when ePublisher AutoMap jobs run using Windows Task
Scheduler. When you configure an ePublisher AutoMap job to run on a schedule, you must specify a user
account and password for Windows Task Scheduler to use when running the job. When the ePublisher
AutoMap job you scheduled using Windows Task Scheduler runs, Windows Task Scheduler executes the
job using the security context of the credentials you specified when you created the job.

For more information about Windows Task Scheduler, refer to the Microsoft Windows operating system
help.

The fields are defined as follows:

User name
Specifies the user account name for Windows Task Scheduler to use when running the job. Enter
your Windows user account name. Include the name of the domain to which the user account
belongs to use the credentials of a user account that is a member of a Windows domain to run the
job.

For example, type DomainName\UserAccountName, where DomainName is the name of the
domain to which the user account belongs, and UserAccountName is the name of the Windows user
account.

Password
Specifies the password for the user account name. Type the password for the Windows user account
you specified in the User name field.
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Variables Window
This window allows you to specify the values to use for variables when generating output. The columns
are defined as follows:

Name
Specifies the name of the variable.

Use document value
Specifies whether you want to use the variable value specified in your source documents when
generating output.

Value
Specifies the value of the variable that will be used in your output. The default ePublisher behavior
is to use variable value specified in the source document in your project. However, you can change
the value of the variable in your project by clicking in the Value field for the variable to change and
then typing in a new value for the variable.
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WebWorks ePublisher Preferences Window
This window allows you to customize ePublisher Designer and ePublisher Express behavior for your
specific needs. These preferences affect the behavior of the application, such as the language displayed in
the console.

This window provides the following tabs:

“General Tab (WebWorks ePublisher Preferences Window)”

“File Mappings Tab (WebWorks ePublisher Preferences Window)”
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General Tab (WebWorks ePublisher Preferences Window)
This window allows you to specify the number of projects listed on the Start Page, the user interface
language ePublisher Express or ePublisher Designer uses, and source document scan options. You can
also use this window to reset the toolbar, reset dock positions, and clear the Do not ask again option.

The fields are defined as follows:

Scan added documents
Specifies when to scan source documents you add to a project. The scanning option you select will
become the default selection for all existing projects, as well as all new projects you create. The
default scan option is Always. When ePublisher scans source documents, it reads the style and
formatting information, conditions, variables, and markers in your source documents. The values
for this setting are defined as follows:

Value Description

Ask Specifies that ePublisher prompt you to scan source documents
when you add them to a project.

Always Specifies that ePublisher always scans source documents
when you add them to a project. When you select this option,
ePublisher automatically scans your source documents for style
and formatting information when you add new source documents
to your project.

Never Specifies that ePublisher does not scan source documents when
you add them to a project. If you select this option, ePublisher will
never scan your source documents unless you manually scan
your source documents using one of the scanning commands on
the Project menu.

Preview Options (ePublisher Designer)
Specifies when to create preview tabs of source documents added to the project or selected in the
Document Manager.

Automatically display preview for newly imported documents

Checking this option causes ePublisher Designer to generate a new preview
tab whenever a source document or file is added to the Document Manager.

Display preview on document double-click

Checking this option causes ePublisher Designer to generate a new preview
tab whenever a source document or file in the Document Manager is double-
clicked.

Recent projects to remember
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Specifies the number of projects to list on the Start Page. Click Clear List to clear the list of
projects displayed on the Start Page.

Language
Specifies the language the ePublisher Express or ePublisher Designer user interface uses from
the drop-down list. If you change the user interface language ePublisher Express or ePublisher
Designer uses, you must close and then reopen the user interface before the language change you
specified takes effect. The values for this setting are defined as follows:

 

Value Description

English Specifies English as the user interface language.

Deutsch Specifies German as the user interface language.

Francais Specifies French as the user interface language.

Miscellaneous

Reset Toolbar

Reset toolbar interface to default position.

Reset Dock Positions

Reset user interface dock positions to default.

Clear “Do not ask again”

Reset automatic prompt settings to their default.

Reset Evaluation Materials

Reset the trial projects and sample materials to their original state.
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File Mappings Tab (WebWorks ePublisher Preferences Window)
This window allows you to specify file mappings. A file mapping is an association between a file
extension and an ePublisher adapter. An ePublisher adapter is an ePublisher component that bridges
the gap between the application in which the source document was created and ePublisher. ePublisher
currently provides adapters for Microsoft Word, Adobe FrameMaker, and XML.

The columns are defined as follows:

File Extension
Specifies the name of the file extension.

Adapter
Specifies the name of the ePublisher adapter associated with the file extension.

90 | File Mappings Tab (WebWorks ePublisher Preferences Window)



Editor Preferences Tab (WebWorks ePublisher Preferences Window)
This window allows you to specify both a Text Editor as well as an Image Editor for use when modifying
overridden files. The overridden files can be viewed and easily accessed from the Advanced menu.
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Diff Preferences Tab (WebWorks ePublisher Preferences Window)
This window allows you to specify the path to your preferred Diff Program. A Diff program allows
you to manage your custom changes to overridden files. Overridden files can be easily accessed from the
Advanced menu.
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Log Window Tab (WebWorks ePublisher Preferences Window)
This window allows you to edit the Log Window display settings. You can change the foreground,
background, warning message, and error message colors. You can also set the font, and enable word wrap.
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WebWorks Licensing Info Window
This window allows you to specify your Contract ID. A Contract ID is a unique identifier that identifies
the number of users and type of functionality enabled for your ePublisher installation. WebWorks
generates an appropriate Contract ID for your ePublisher installation when you purchase ePublisher or
request an evaluation copy of ePublisher.

You must enter your Contract ID, email address, and computer name before you can use ePublisher
components. The Contract ID enables the ePublisher product components and ePublisher input formats
for which you are licensed.

The fields are defined as follows:

Contract
Specifies your Contract ID. Enter the Contract ID you received from WebWorks when you
purchased ePublisher or requested an evaluation copy of ePublisher.

Email
Specifies your email address. If you have an email address that you use as your WebWorks support
login, enter that email address.

Computer
Specifies the name of the computer where ePublisher is installed.

“Working with Contract IDs”

“Viewing Licensing and Contract ID Information”

“Obtaining Contract IDs”

“Entering Contract IDs”

“Managing Licensing in Environments without Internet Connectivity”

“Updating Licensing”

“Deactivating Licensing”

“Problems with FrameMaker or Microsoft Word”
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Producing Output from Stationery

What Makes an ePublisher Project
Source Documents
Targets
Stationery
Creating Projects Based on Stationery
Working with Source Documents
Working with Targets
Working with Projects
Generating and Regenerating Output
Viewing Output
Validating Output Using Reports
Merging Top-level Groups (Multivolume Help)
Deploying Output
Working with Target Settings
Setting Variables in Projects
Setting Conditions in Projects
Setting Cross-References in Projects
File Mappings for Source Documents

This section explains how writers can use their source documents and ePublisher projects and Stationery
to produce output.
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What Makes an ePublisher Project
This section explains what a project is and the folder structure projects use.
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ePublisher Projects
An ePublisher project consists of all the necessary pieces needed to convert your source documents
into online output. It contains your source documents, images, project Stationery, and any settings or
preferences you specify. After you create a project, you can modify your project settings and preferences,
generate reports, and produce output.

ePublisher provides powerful single-sourcing capabilities that allow you to generate online output in
multiple formats using a single project and a single set of source documents. For example, you can
generate WebWorks Help, Microsoft HTML Help, Oracle Help, Dynamic HTML Help, and Sun JavaHelp
using one project and one set of source files.
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Project Folder Structure
The following figure shows a sample project folder.

To view all of the files for your project, on the View menu, click Project Directory.

The project folder contains the following subfolders:

Files
Contains any custom files you want your project to use. Typically, the Files  folder contains logo
images, custom.css  files, custom bullet images, and custom background images. To view the files
in the Files  folder for your project, on the View menu, click User Files.

You can also place a Files  directory in a target’s override folder or within the target’s format
override folder.

Formats\<format name>\Files

Targets\<target name>\Files

These files will be copied for each target’s sub-directory but will not be visible in the user interface
to select, e.g. the company logo image in the Target Settings dialog.

Formats
Contains output format overrides and all of the files required to generate output for an output
format. Any time you want to override an output format file, place the override in the Formats
folder. For example, if you want to override the standard table of contents icons for topics in
WebWorks Help by specifying custom table of contents icons, place the custom table of contents
icons you want to use in an images  folder in the Formats  folder. For more information about
format overrides, see “Creating Format Overrides”. To view the files in the Formats  folder for
your project, on the View menu, click Format Override Directory.

Logs
Contains the generate.log  file. The generate.log  file contains information about the actions
ePublisher performed when generating output, along with any warning or errors that occurred
during output generation.

Output
Contains the files ePublisher creates when generating output and provides a structure for generated
output files. ePublisher creates a folder for each target in the project in the Output  folder, and each
target folder contains all topic pages, generated images, entry-point files, and merged help files
generated for the target. The entry-point file is the file that opens the help system.
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By default, ePublisher creates the Output  folder in the following location:

If you use ePublisher Express, by default ePublisher creates the Output  folder in the My
Documents\ePublisher Express Projects\ProjectName folder, where ProjectName  is
the name of the project.

If you use ePublisher Designer, by default ePublisher creates the Output  folder in the My
Documents\ePublisher Designer Projects\ProjectName folder, where ProjectName  is
the name of the project.

You can view output files in the Output  folder using Output Explorer or by clicking on and
opening output files in the Output  folder. To view the files in the Output  folder for your project,
on the View menu, click Output Directory. For more information about viewing output, see
“Viewing Output in Output Explorer” and “Viewing Output in the Output Folder”.

Reports
Contains all of your configured reports in an XML format that ePublisher can display.

Targets
Contains target overrides. Any time you want to override a file in a target, place the override in the
Targets  folder. ePublisher looks for overrides in the Targets  folder before it looks for overrides
in the Formats  folder. The Targets  folder only appears in your project folder if your Stationery
is configured to use target overrides. For more information about target overrides, see “Creating
Target Overrides”. To view the files in the Targets  folder for the selected target in your project, on
the View menu, click Target Override Directory.

Your project also uses a Data  folder. The Data  folder contains information about how files in your
project have been processed. The .wif  files, which are located in the Data  folder, contain style and
content information from your source documents. ePublisher creates the Data folder in the following
temporary folder location:

Documents and Settings\UserName\Local Settings\Temp\WebWorks\ePublisherComponent\Data

where UserName is the name of the ePublisher user, and ePublisherComponent is the name of the
ePublisher component used to generate output, such as ePublisher Express or ePublisher Designer.

To view the files in the Data  folder for your project, on the View menu, click Data Directory.

Project Folder Structure | 99



Source Documents
Source documents are documents you create your content in using a content authoring tool such as
Notepad++, Microsoft Word, Adobe FrameMaker, or an authoring environment that supports DITA
authoring. After you prepare your source documents, you use your source documents to generate output.
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Targets
A target is the specific type of output you want to produce using your source files and project settings.
Targets are based the output formats you specify for your project, and include all of the project settings
you specify for each output format included in your project when you configure your project.

For example, assume that you are a writer working at CompanyA, and you have the requirement to
create a web-based help system using your source documents. In this scenario, you create a project using
stationery that supports WebWorks Help output and then create a target called CompanyA WebWorks
Help.

Next, assume that your documentation requirements change, and in addition to creating WebWorks Help
for CompanyA, you must now also produce Microsoft HTML Help and PDF files for CompanyA using
your same source documents. In this scenario, you update your project to now include the following
targets:

CompanyA WebWorks Help

CompanyA Microsoft HTML Help

CompanyA PDF Files

Finally, assume your documentation requirements change again, and now, based on an Original
Equipment Manufacturer (OEM) agreement your company signed, in addition to creating WebWorks
Help, Microsoft HTML Help, and PDF files for CompanyA, you must use your same set of source
documents to create WebWorks Help, Microsoft HTML Help, and PDF files for CompanyB, using
company information and variables and conditions specific to CompanyB. In this scenario, you update
your project to now include the following targets:

CompanyA WebWorks Help

CompanyA Microsoft HTML Help

CompanyA PDF Files

CompanyB WebWorks Help

CompanyB Microsoft HTML Help

CompanyB PDF Files

When you have multiple targets included in a project, you choose an active target and then specify project
settings for the active target. The active target is the target currently selected in your project. When you
want to modify project settings for an target, if you have multiple targets included in your project, ensure
you have the correct target selected in the project when you modify project settings. For more information
about specifying an active target, see “Specifying Active Targets”.
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Stationery
The Stationery designer creates Stationery with ePublisher Designer using a Stationery design project.
Stationery specifies the settings ePublisher uses to generate output. Stationery designers create Stationery
by creating a Stationery design project in ePublisher Designer and then saving the processing rules, styles,
and other information specified in the Stationery design project as Stationery. ePublisher Express and
ePublisher AutoMap can then use the Stationery to generate output.

When the Stationery designer creates a project in ePublisher Designer and then saves a project using
the Save As Stationery option, ePublisher Designer creates a Stationery file. A Stationery file is a file
with the .wxsp  file extension that contains formatting, project settings, project overrides, and style
information. Source documents and document-specific information, such as Document Manager groups,
are not saved in Stationery. After the Stationery designer creates the Stationery, writers use the Stationery
provided by the Stationery designer when they create an ePublisher Express project. Writers use their
ePublisher Express project and Stationery to generate output.

When the Stationery designer saves the Stationery, ePublisher creates the following folders:

StationeryName\Formats\OutputFormat

StationeryName\Formats\OutputFormat.base

where StationeryName is the name the Stationery designer specified for the Stationery, and
OutputFormat is the type of output format the Stationery Designer specified for a target in the Stationery.

The StationeryName\Formats\OutputFormat folder contains any customizations or overrides the
Stationery designer specified when designing the Stationery. ePublisher Express synchronizes with the
files in the OutputFormat folder and uses the information about customizations and overrides contained
in files in the OutputFormat folder to generate output.

Note: The Stationery may have one or more OutputFormat folders, based on the
settings the Stationery designer specified.

The StationeryName\Formats\OutputFormat.base  folder contains copies of all the files located in the
\Program Files\WebWorks\ePublisher\2023.1\Formats\OutputFormat folder. These files define the
default output format and transforms and are installed by default when you install ePublisher.

Stationery designers can do a compare, or diff, between the files located in these folders to quickly see
any customizations or overrides specified for the Stationery. Stationery designers can use this information
to help them reapply customizations and overrides as needed when designing a newer version of the
Stationery in ePublisher Designer.

When the styles or features used in the generated output need to change, the Stationery designer uses the
ePublisher Designer Stationery design project to update the styles and features specified in the Stationery,
and then the Stationery designer saves the changes, creates updated Stationery, and deploys the Stationery.
Once the new Stationery is available, writers synchronize their ePublisher Express project with the
updated Stationery file and use the updated Stationery the next time they generate output.

Note: When you synchronize your project with Stationery, the synchronization
process overwrites any target setting customizations you configured for the
project.
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For more information about synchronizing Stationery, see “Synchronizing Projects with Stationery”.
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Creating Projects Based on Stationery
Writers use ePublisher Express and Stationery created by a Stationery designer to generate output. When
you use ePublisher Express to create a project based on Stationery, you specify the Stationery you want
the project to use and the source documents you want to include in the project. The Stationery file uses
a .wxsp file extension and contains information and settings for the project to use, such as style or
format information, variable values, condition settings, cross-reference definitions, and more. The source
documents contain the content for which you want to generate output. The project uses the settings
specified in the Stationery file and the content and formatting in the source documents to generate output.
A project file created with ePublisher Express uses the .wrp file extension.

Note: You cannot create a project based on Stationery using ePublisher Designer.
You can only create projects based on Stationery using ePublisher Express.
Stationery designers use ePublisher Designer to create Stationery using
Stationery design projects.

To create a project based on Stationery

1. In ePublisher Express, on the File menu, click New Project.

2. In the Project Name field, type a name for your project.

3. In the Location field, specify the location where you want to save your ePublisher project by
clicking on the folder icon and browsing to the location where you want to save your project.

Note: Ensure you consider the length of the full path you specify for the project name and location.
If you specify long names and paths for project, Windows may not be able to support the
length of the full path.

By default, ePublisher stores projects in the My Documents\ePublisher Express Projects
folder.

4. In the Standalone stationery field, specify the Stationery you want to use to create your project by
clicking on the folder icon and browsing to the location of the Stationery file.

5. Select a Stationery file (.wxsp  file), and then click Open.

6. Click Next.

7. Click Add.

8. Browse to the location of the source documents you want to include in your project, select the
source documents, and then click Open.

Note: You can add source documents when you create your project or you can add source
documents after you create your project. For more information about adding source
documents to projects, see “Adding Source Documents to Projects”.
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9. Click Finish to create the project. ePublisher creates the project and gathers information about the
structure of your source documents.

After you create your project, add targets to your projects as needed and then generate output. For more
information, see “Adding Targets to Projects Based on Stationery” and “Generating Output”.
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Working with Source Documents
This section explains how to work with source documents in Document Manger.
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Adding Source Documents to Projects
You can add source documents to your project when you create a project. You can also add source
documents to your project after you create a project. When you add source documents to your project,
ePublisher automatically adds the source documents to your project and creates a top-level group in
Document Manager that contains your source document. For more information about top-level groups,
see “Source Documents Groups”.

To add a source document to your project

1. On the Project menu, click Add Document.

2. Browse to the folder that contains the source document you want to add to your project.

3. Select the source document you want to add to your project, and then click Open.

4. If you configured ePublisher to scan source documents when you add source documents to
projects, ePublisher adds the source documents to Document Manager and scans the source
documents. For more information about scanning source documents and setting scanning options,
see “Scanning Source Documents” and “Setting Scanning Options”.

5. If you did not configure ePublisher to scan source documents when you add source documents
to projects, ePublisher adds the source documents to Document Manager but does not scan your
documents. After ePublisher adds your source documents to Document Manager, scan your source
documents. For more information about scanning source documents and setting scanning options,
see “Scanning Source Documents” and “Setting Scanning Options”.

6. If you are adding a FrameMaker book file to your project, ePublisher adds the FrameMaker
book file (.bk  or .book  files) and the source documents the FrameMaker book file contains (.fm
files) to your project. Consider the following points when you add a FrameMaker book file to your
project:

When you add a FrameMaker book to your project, by default ePublisher creates a group
for the FrameMaker book in Document Manager, and any FrameMaker source documents
contained within the FrameMaker book are always contained within the group in your
project.

When you make changes to a FrameMaker book, such as adding or removing source
documents from a FrameMaker book file, when you scan the FrameMaker book, ePublisher
updates the project with the changes you made to the FrameMaker book file. If you add
or remove FrameMaker source documents in a FrameMaker book, ensure you scan the
FrameMaker book before you generate output. For more information about scanning source
documents and setting scanning options, see “Scanning Source Documents” and “Setting
Scanning Options”.

If your FrameMaker book contains front matter files, table of contents files, or index files,
consider the following points:

If you are generating output for a target that uses any output format other than
PDF, by default ePublisher generates output for source document front matter files
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included in a book, but does not generate output using the table of contents files and
index files included in the FrameMaker book. ePublisher instead uses the headings
and index entries in the source documents to generate a table of contents and an index
for your online output.

If you are generating output for a target that uses PDF as the output format, by
default ePublisher generates the PDF using the front matter, index, and table of
contents files included in the FrameMaker book.

The Stationery designer may modify these default file processing settings when designing
Stationery. If you have target setting modification permissions, you can also customize these
settings as needed. For more information about target setting customization permissions and
customizing file processing settings, see “Working with Target Settings” and “Specifying
File Processing Behavior for Front Matter, Index, and Table of Contents Files”. If you do
not have target setting customization permissions, instead of adding an Adobe FrameMaker
.book  file that contains front matter, table of contents, and index files, you can instead add
the individual Adobe FrameMaker chapter .fm  files, and then use the individual chapter
files to generate output.

After you add source documents to your ePublisher project, ePublisher displays your source documents
in Document Manager. You can organize your source documents in Document Manager and perform the
following tasks:

Open and edit source documents from within Document Manager. For more information, see
“Opening Source Documents from Document Manager”.

Relink source documents. For more information, see “Relinking Source Documents”

Remove source documents from your project. For more information, see “Removing Source
Documents from Projects”.

Create an organizational structure for your online output using groups. For more information, see
“Source Documents Groups” and “Organizing Source Documents Using Groups”.

Rearrange the source document order in Document Manager. For more information, see
“Rearranging Source Documents in Groups”.
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Opening Source Documents from Document Manager
If you want to edit the content of your source documents while working with a project, you can open the
source documents from Document Manager.

To open a source document from Document Manager

1. In Document Manager, double-click the source document you want to open. ePublisher opens the
source document using the content authoring tool you used to create the source document.

2. If you want to edit the content in your source document, edit the content using the content
authoring tool you used to create the source document.

3. Save the source document.
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Scanning Source Documents
This section explains how scanning works, how to scan source documents, and source document scanning
options.
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Scanning and Scanning Options
When ePublisher scans your source documents, it reads the style and formatting information, variables,
conditions, and marker types in your source documents and then imports this information into your
ePublisher project. Once ePublisher imports this information into your project, you can generate
output. You can also modify target settings if you have permissions to modify target settings. For more
information, see “Generating and Regenerating Output” and “Working with Target Settings”.

The scanning process can be time-consuming. You can reduce the amount of time it takes ePublisher to
scan your documents by scanning only the source documents you select. Scan your source documents
when you have made any of the following changes to your source documents:

Added new content

Added new style information

Modified any existing styles

Added new markers, variables, or conditions

Modified existing markers, variables, or conditions

ePublisher provides the following options for scanning source documents in Document Manager:

Scan Selected
Scans only the selected source document in Document Manager.

Scan All Documents
Scans all of the source documents that you added to your project and that are displayed in
Document Manager.
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Setting Scanning Options
By default, ePublisher will automatically scan your documents, thus making sure any new styles,
conditions, variables, etc. are added to your project.

If you set this option to Ask, then adding a source document a dialog box will appear:

This indicates that files such as FrameMaker .book files will scan for additional .fm files linked from this
source. Clicking Yes will scan the individual documents so that the document set styles, for example can
be added to the Style Designer (the same goes for most of the document set customizations.)

However, you can specify that you want ePublisher to scan source documents when you add them to
your project. For example, you can choose to have ePublisher prompt you to scan the source documents
when you add source documents to your project, or you can choose to always have ePublisher scan source
documents when you add them to a project. The scanning option you specify will become the default
selection for all existing and subsequent projects.

If you choose to never have ePublisher scan source documents, when you add them to a project, you must
remember to scan your source documents before you generate output.

To set scanning options

1. On the Edit menu, click Preferences.

2. On the General tab, in the Scan options area, select the scan setting you want to specify. For more
information about scanning options, click Help.

3. Click OK.
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Scanning Selected Documents
Sometimes you may make a change to content in a single source document. You can scan only the source
document you changed. Scanning the selected document updates your project with the new information
you specified in the selected source document.

To scan a selected source document

1. In Document Manager, select the source document you want to scan.

2. On the Project menu, click Scan Selected. ePublisher scans the document you selected in
Document Manager.
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Scanning All Documents
If you have made multiple changes to content in your source documents, you can scan all of the source
documents included in your project at once. Scanning all source documents ensures that ePublisher
includes any changes you made to any of the source documents in your project.

To scan all source documents in a project

On the Project menu, click Scan All Documents. ePublisher scans all of the source documents displayed
in Document Manager.
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Relinking Source Documents
Sometimes the link between Document Manager and the source document may become broken. For
example, moving the source document to another folder location or deleting the source document from a
folder may break the link between Document Manager and the source document. When ePublisher detects
a broken link between Document Manager and the source document, ePublisher displays a Broken Link
icon, or red question mark, next to the source document in Document Manager.

To relink a source document

1. In Document Manager, double-click the Broken Link icon next to the name of the source
document.

2. Browse to the location of the source document.

3. Select the source document, and then click Open. ePublisher recreates the link between the source
document and Document Manager.
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Removing Source Documents from Projects
You can remove source documents from an ePublisher project. Remove source documents from your
project when you no longer want to include the content in the source document in your project or in your
generated output.

If you are a Stationery designer using ePublisher Designer to design Stationery, when you remove
source documents from an ePublisher project, any styles or formats associated with the source document
remain in Style Designer. For example, assume that the UserManualTitle style is a style that is specific
to only one source document in your project. If you remove the source document that contains the
UserManualTitle style from your project, ePublisher retains the UserManualTitle style name and style
information in Style Designer. If you want to remove this style from Style Designer, you must manually
delete it.

To remove a source document from a project

1. In Document Manager, click the source document you want to remove from your project.

2. On the Edit menu, click Remove.

3. If you want to remove an Adobe FrameMaker source document (.fm  file) that is a part of an
Adobe FrameMaker book (.book  or .bk  file) you have added to a project, you cannot remove
the Adobe FrameMaker source document from the project using ePublisher. You must remove
the Adobe FrameMaker source document from the Adobe FrameMaker book file and then scan
the Adobe FrameMaker book file to remove the Adobe FrameMaker source document from
your project. For more information about scanning source documents, see “Scanning Source
Documents”.

4. Click Yes to confirm that you want to remove the source document from your project.
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Source Documents Groups
Groups are containers in Document Manager that hold your source documents and allow you to create an
organizational structure for your output. When you first create a new project, ePublisher automatically
creates a new group in Document Manager using the project name. You can use ePublisher to create the
following types of groups in Document Manager:

Top-level groups
Contains source documents and subgroups. ePublisher creates an entry-point file for each top-level
group in Document Manager. The entry-point file is the file that opens the generated output. All
projects must contain at least one top-level group. You can create additional top-level groups to
further organize your source documents in Document Manager or if you want to create merged,
or multivolume, help. For more information about merged help systems, see “Merging Top-level
Groups (Multivolume Help)”.

Subgroups
Used to organize source documents within top-level groups. Subgroups do not create entry-point
files and do not represent an actual volume in a merged help system.

The following figure shows top-level groups and subgroups in Document Manager.
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Organizing Source Documents Using Groups
You can perform the following actions with source documents and groups in ePublisher:

Create top-level groups. For more information, see “Creating Top-Level Groups”.

Create subgroups. For more information, see “Creating Subgroups”.

Rename groups. For more information, see “Renaming Groups”.

Rearrange source documents in groups. For more information, see “Rearranging Source Documents
in Groups”.

Remove groups. For more information, see “Removing Groups”.
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Creating Top-Level Groups
By default, ePublisher creates a top-level group based on the name of the project when you add your first
source document to your project. There must always be at least one top-level group in Document Manager
in order to add source documents to a project. You can create additional top-level groups if you want to
further organize your source documents or create merged help systems, or multivolume help. For more
information about creating merged help systems, see “Merging Top-level Groups (Multivolume Help)”.

To create a top-level group

1. On the Project menu, click New Group. ePublisher creates and displays a new top-level group in
Document Manager.

2. Type a name for the new group.

3. Drag the new top-level group to its appropriate position above, below, or between an existing top-
level group in Document Manager.
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Creating Subgroups
You can create subgroups in Document Manager to organize the source documents in a group. By
organizing your source documents into subgroups, you can organize how you want to display your source
documents in Document Manager and how you want content to display in your generated output.

To create a subgroup

1. In Document Manager, select the group to which you want to add a subgroup. You can add a
subgroup to a top-level group or to an existing subgroup.

2. On the Project menu, click New Group. ePublisher displays the new group in Document Manager.

3. Type a name for the new group.
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Renaming Groups
You can rename existing top-level groups and subgroups in Document Manager. For example, when you
create a new project, by default ePublisher creates a new group based on the project name. However, you
can change the default name of the group in Document Manager.

To rename a group in Document Manager

1. In Document Manager, click twice on the group you want to rename.

2. Type a new name for the group.

3. Press ENTER or click outside of the typing area to change the name.
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Rearranging Source Documents in Groups
Once you have added source documents to your project and placed your source documents into groups
within Document Manager, you can rearrange source documents by moving the source documents within
the same group or by moving source documents to a new location in a new group.

If you have a FrameMaker book (.bk  or .book  file) in a group, you can move the FrameMaker book to
a different group, but you cannot move an individual FrameMaker document (.fm  file) to a group if it
is included in the .book  file. .fm  files that belong to a .book  file must remain in the same group as the
.book  file. If you want to move a .fm  file to a different group than the .book  file is in, first remove the
.fm  file from the book, scan the book, and add the .fm  file, which is no longer part of the book, to the
appropriate book.

To rearrange source documents in groups

1. If you want to change the order of source documents within a group, complete the following
steps:

a. In Document Manager, click the source document you want to move.

b. Drag the source document to the desired location within the group.

2. If you want to move a source document to a different group, complete the following steps:

a. In Document Manager, click the document you want to move.

b. Drag the source document to the desired location within the new group.
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Removing Groups
If you no longer want to use a group, you can remove the group from Document Manager. When you
remove a group from Document Manager, ePublisher removes any source documents associated with the
group from your project.

Note: ePublisher does not delete the source documents from your computer.
ePublisher only removes the source documents from the project.

To remove a group

1. In Document Manager, select the group you want to remove.

2. On the Edit menu, click Remove.
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Working with Targets
This section explains how to work with targets. For more information about what targets are, see
“Targets”.
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Specifying Active Targets
Within a project, you can have multiple targets. The active target is the target currently selected in the
project. ePublisher uses the active target when you make modifications to your target settings or generate
output.

To specify the active target

On the Project menu, select the target next to Active Target.
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Adding Targets to Projects Based on Stationery
Every project must contain at least one target. Add targets to projects when you need to produce different
kinds of output using the same source documents. Each target is associated with one output format, such
as WebWorks Help, Microsoft HTML Help, or PDF. If you are generating output based on Stationery
using ePublisher Express, the Stationery you use for your project defines the type of output formats you
can specify for a target when you add a target to your project. You can only use output formats defined
in the Stationery by the Stationery designer when you create targets. If you need to create a target for an
output format not included in the Stationery, talk to the Stationery designer about updating the Stationery
to include the output format.

For example, assume that you are a writer working at CompanyA, and you need to create web-based
help. You have Stationery from a Stationery designer configured to support WebWorks Help, Microsoft
HTML Help, and PDF output. In this scenario, you create an ePublisher project based on Stationery from
the Stationery designer, and then you create a target called CompanyA WebWorks Help that specifies
WebWorks Help as the output format for the target.

Next, assume that your documentation requirements change, and in addition to creating WebWorks Help
for CompanyA, you must now also produce Microsoft HTML Help and PDF files for CompanyA using
your same source documents. In this scenario, you update your project by adding Microsoft HTML Help
and PDF as targets, and you project now contains the following targets:

CompanyA WebWorks Help

CompanyA Microsoft HTML Help

CompanyA PDF Files

To add a target to a project based on Stationery

1. On the Project menu, click Manage Targets.

2. Click Add.

3. In the Format Type field, select the output format you want to use for the format target.

4. In the Target Name field, type a name for the format target.

5. Click OK.
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Renaming Targets
You can rename targets. By default, the target name is the same as the output format in ePublisher.
However, in some situations, you may want specify a different name for the target. For example, assume
that you are a writer working at CompanyA, and you have the requirement to create a web-based help
system using your documentation source files. In this scenario, you create an ePublisher project that
specifies WebWorks help as your help system and you configure your project settings to use information
and branding for CompanyA to create an target called WebWorks Help.

Next, assume that your requirements change, and now, based on an OEM agreement your company
signed, in addition to creating WebWorks Help for CompanyA, you must use your source files to
create WebWorks Help for CompanyB. In this scenario you create a new target in your project called
CompanyB WebWorks Help and configure settings for this target. However, after configuring settings for
the CompanyB WebWorks Help target, you now want to go back and rename your original WebWorks
Help output format, and change the name of this output format to CompanyA WebWorks Help.

To rename a target

1. On the Project menu, click Manage Targets.

2. In the Target Name field, click the name of the output format you want to rename.

3. Click Edit.

4. In the Target Name field, type the new name you want to specify.

5. Click OK.
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Deleting Targets
You can delete targets from a project if you no longer need to produce output for the target.

To delete a target

1. On the Project menu, click Manage Targets.

2. In the Target Name field, click the name of the output format you want to delete.

3. Click Delete.

4. Click OK.
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Working with Projects
This section explains how to work with projects.
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Saving Projects
You should periodically save your project to ensure that you do not lose any changes you have made. By
saving your project, you ensure that ePublisher stores the information in your project in the project files
and all of your project information will be available the next time you open your project.

To save a project

On the File menu, click Save. ePublisher automatically saves your ePublisher project in a file in the
location you specified when you first created the project.

If you are saving an ePublisher Express project, by default ePublisher saves the project file in the
My Documents\ePublisher Express Projects\ ProjectName  folder, where ProjectName  is the
name of the project.

If you are saving an ePublisher Designer project, by default ePublisher saves the project file in
the My Documents\ePublisher Designer Projects\ProjectName folder, where ProjectName
is the name of the project.
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Opening Existing Projects
You can open an existing project using one of the following methods:

Open the project from within the ePublisher Express or ePublisher Designer user interface.

Open the project from Windows Explorer by double-clicking the project file in the folder where
you saved the project.

By default ePublisher saves project files in the following locations:

ePublisher saves ePublisher Express project files in the My Documents\ePublisher Express
Projects\ ProjectName  folder, where ProjectName  is the name of the project. ePublisher
Express project files use the .wrp  file extension.

ePublisher saves ePublisher Designer project files in the My Documents\ePublisher Designer
Projects\ProjectName folder, where UserName  is the name of the user account running
ePublisher Express and ProjectName  is the name of the project. ePublisher Designer project files
use the .wep  file extension.

When you open an existing project, ePublisher opens a separate instance of the ePublisher for each
project, and each project has its own window. For example, if you have ProjectA open, and then you
decide to open a project called ProjectB, ePublisher opens up a new instance of ePublisher for the new
project and you have two ePublisher instances with ProjectA and ProjectB open concurrently on your
computer.

To open an existing project

1. If you want to open an existing project from within ePublisher Express or ePublisher Designer,
complete the following actions:

a. In ePublisher, on the File menu, click Open.

b. Browse to the location of the project file you want to open.

c. Select the project file you want to open, and then click Open.

2. If you want to open an existing project using Windows Explorer, complete the following steps:

a. In Windows Explorer, browse to the location of the ePublisher project file you want to open.

b. Double-click the ePublisher project file.
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Closing Projects
When you finish working with a project, you can close it. When you close the project, ePublisher prompts
you to save any changes to your project that you have not already saved.

To close a project

On the File menu, click Exit.
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Synchronizing Projects with Stationery
ePublisher Express projects use Stationery designed in ePublisher Designer by the Stationery designer.
From time to time, the Stationery designer may update the Stationery used by your ePublisher Express
project. When the Stationery designer updates the Stationery, you must synchronize your ePublisher
Express project with the Stationery associated with the project in order to obtain the updates made by the
Stationery designer. For more information about Stationery, see “Stationery”.

When the Stationery designer updates the Stationery an ePublisher Express project uses, ePublisher
detects the change the next time you open a project that uses the Stationery, notifies you that the
Stationery used by the project has been modified, and prompts you to synchronize your project with the
updated Stationery. ePublisher Express prompts you to synchronize your project with its Stationery file
under the following conditions:

ePublisher detects differences between the project manifest file and the Stationery manifest file.

ePublisher detects modifications to the Stationery file used by the project.

When you synchronize your project with Stationery, you update your project file so that the information
in your project file matches the information in the Stationery file and in the Stationery manifest file.
Synchronizing the project file with the Stationery file and the manifest file ensures all of the settings and
information in the project file match all of the settings and information in the Stationery file. For more
information about the Stationery file and the Stationery manifest file, see “Manifest Files” and “Stationery
Files”.

Based on your ePublisher implementation, after you create an ePublisher Express project using Stationery,
you can customize target settings for the targets available in your project if you have appropriate
permissions. You can only customize target settings in your ePublisher Express project if you have target
setting modification permissions. Any customizations you make to target settings will be overwritten the
next time you synchronize your ePublisher Express project with Stationery. For more information, see
“Working with Target Settings”.

ePublisher Express allows you to synchronize your project with its associated Stationery using one of the
following methods:

Automatically synchronize projects with Stationery. For more information, see “Automatically
Synchronizing ePublisher Express Projects with Stationery”.

Manually synchronize projects with Stationery. For more information, see “Manually
Synchronizing ePublisher Express Projects with Stationery”.
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Manifest Files
When you create a project based on Stationery in ePublisher Express, ePublisher copies the manifest file
used by the Stationery you specify for the project and places a copy of the Stationery manifest file in
the project folder for the new ePublisher Express project. The manifest file is a record of all of the files
associated with the Stationery file, including all of the files listed in the following project folders:

Formats  folder

Targets  folder

Files  folder

For more information about project folders, see “Project Folder Structure”.

Any time the Stationery designer performs one of the following actions in the Stationery Formats ,
Targets , or Files  folder, ePublisher updates the Stationery manifest file:

Modifies a file in a folder

Adds a file to a folder

Removes a file from a folder

When you open an existing ePublisher Express project, ePublisher compares the ePublisher Express
project manifest file to manifest file of the Stationery associated with the ePublisher Express project and
determines if there are differences between the manifest file.

If the Stationery designer has updated, removed, or added any files to the Formats , Targets , and Files
folder in the Stationery since the last time you opened your ePublisher Express project, ePublisher detects
these differences and prompts you to synchronize your ePublisher Express project with the Stationery
file. When you synchronize your ePublisher Express project with the Stationery file, ePublisher copies
the Stationery’s updated manifest file over to your ePublisher Express project file and adds, removes, and
updates files in the Formats , Targets , and Files  folders for your project as appropriate.

For example, assume that the Stationery designer updated the Stationery you use for one of your projects
by adding a new Page.asp  file. When the Stationery designer makes this change, ePublisher updates
the Stationery manifest file with the change. After the Stationery designer makes this change, the next
time you open up your ePublisher Express project that uses the changed Stationery, ePublisher Express
recognizes that the ePublisher Express project manifest file is different than the Stationery project file
and prompts you to synchronize your project to your Stationery file. When you synchronize your project,
ePublisher adds the new Page.asp  file to your project folders.
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Stationery Files
When you open an existing ePublisher Express project, ePublisher Express determines if the Stationery
used by the project has been modified by examining the checksum of the Stationery file. A checksum is a
value that depends on the contents of a file. ePublisher uses the checksum to determine if a Stationery the
file has changed. If the checksum of the Stationery file is different than the checksum of the project file,
ePublisher Express prompts you to synchronize your project with the Stationery file associated with your
project. Any changes to the following settings within the Stationery file will affect the checksum:

Style and format information

Conditions

Variables

Cross-reference definitions

Target settings
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When to Synchronize
All ePublisher Express projects should be synchronized with Stationery any time the Stationery designer
modifies the Stationery. ePublisher Express projects must be synchronized with the Stationery in
order for ePublisher to include the changes made by the Stationery designer to the Stationery file in
an ePublisher Express project. When you synchronize an ePublisher Express project (.wrp file) with
Stationery (.wxsp  file), ePublisher updates the information in the ePublisher Express project to match
the information in the Stationery file. If you choose not to synchronize, your project will retain its old
settings and the information in the project file will not match the information in the Stationery file until
you synchronize.
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Automatically Synchronizing ePublisher Express Projects with Stationery
When you open an existing project, ePublisher Express automatically detects whether any modifications
have been made to the Stationery file. If any changes have been made to the Stationery, ePublisher
Express displays a window notifying you that the Stationery has been modified. When this window
displays, you can choose to synchronize your project to the modified Stationery file. You can also choose
to synchronize your project to new Stationery.

To automatically synchronize an ePublisher Express project with Stationery

1. Open ePublisher Express. If the Stationery designer has modified the Stationery linked to your
ePublisher Express project, ePublisher Express displays a window that tells you that the Stationery
the ePublisher Express project is linked to has been modified. The window ePublisher displays
should be similar to the following window.

2. If you want to synchronize your ePublisher Express project with the specified Stationery, click
Yes.

3. If you want to synchronize your ePublisher Express project with different Stationery, complete
the following steps:

a. Click the folder icon, and then browse to the location of the Stationery with which you want
to synchronize your ePublisher Express project.

b. Select the Stationery (.wxsp  file), and then click Open.

c. Click OK again.

4. If you do not want to synchronize your ePublisher Express project with Stationery, click Cancel.
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Manually Synchronizing ePublisher Express Projects with Stationery
You can manually synchronize your project file with Stationery at any time. When you manually
synchronize your project file with Stationery, ePublisher Express prompts you to specify the Stationery
with which you want to synchronize your ePublisher Express project. You can synchronize your
ePublisher Express project with the Stationery currently associated with your ePublisher Express project,
or you can specify that you want your ePublisher Express project to synchronize with different Stationery.

To manually synchronize an ePublisher Express project with Stationery

1. In ePublisher Express, on the File menu, click Synchronize with Stationery.

Note: You can only synchronize ePublisher Express projects with Stationery. You cannot
synchronize ePublisher Designer projects with Stationery, because ePublisher Designer
projects are not based on Stationery. ePublisher Designer projects are used to design
Stationery.

2. Browse to the location of the Stationery to which you want to synchronize your ePublisher Express
project. By default, ePublisher saves Stationery to the following folder:

My Documents\ePublisher Stationery\ProjectName, where ProjectName  is the name of the
project used to create the Stationery.

3. Select the Stationery (.wxsp  file), and then click Open. ePublisher synchronizes the ePublisher
Express project with the specified Stationery.
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Project Information that is not Synchronized
Most items are synchronized with Stationary but the following are not:

Merge Settings

All settings in the Document Manager Pane

Preferences
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Deleting Projects
Delete a project when you no longer want to use the project to generate output.

To delete a project

1. Open Windows Explorer.

2. Browse to the location of the project folder for the project you want to delete.

By default ePublisher saves ePublisher Express project files in the My Documents
\ePublisher Express Projects\ ProjectName  folder, where ProjectName  is the name
of the project. ePublisher Express project files use the .wrp  file extension

By default ePublisher saves the ePublisher Designer project files in the My Documents
\ePublisher Designer Projects\ProjectName folder, where ProjectName  is the name
of the project. ePublisher Designer project files use the .wep  file extension.

3. Delete the project folder.

When you delete a project, ePublisher continues to display the project on the Start Page until you close
and then reopen the ePublisher user interface.
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Generating and Regenerating Output
When you generate output in ePublisher, ePublisher creates all of the files specified for the target.
ePublisher uses the information in the project source documents and project settings to generate output
files. Output files include the following types of files:

Individual topic page .html  files

Image files, such as .jpg , .gif , and .png files

The entry-point file, which is used to open the generated output

All files required by the help system if you are generating output for a help system
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Output Generation and Regeneration
In ePublisher, you generate output using either the generate or regenerate option. The generate and
regenerate option both create output from your project. However, there are some important differences
between the options.

As you make changes to your source documents and your project settings, you need to generate output
files in order to see any changes made to the following items:

Content changes in your source documents

Changes to project settings

Changes in the Stationery associated with your ePublisher project

When you generate output for a target for the first time, ePublisher creates the output files for the first
time. After you generate output files for a target the first time, if you generate output for your target again,
you update your output files with the changes you made in your source documents and the changes you
made to your project settings. Generating, or updating, your output creates output files more quickly than
regenerating your output files.

Use the generate option when you have made changes to the following project settings:

Condition settings

Variable values

Cross-reference definitions

Merge settings

Target settings

Project preferences

When you regenerate output, ePublisher deletes the Data  folder from the project folder, creates a new
Data  folder, and creates new output files each time. Regenerate your output any time you add new
information to your source documents that is not content. Non-content modifications to source documents
include adding, removing, or modifying following items:

Paragraph, character and table styles and formats

Marker types

Cross-reference definitions

Variable values in the source documents

Condition settings in the source documents
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Generating Output
In ePublisher, you can generate output for the following items:

The entire project, which generates output for all the groups and source documents in your project

A single group within your project

An individual source document within your project

Generate output for all of the groups in your project when you are generating the final, completed output
or help system, when you are merging output or help systems, or when you are deploying your output.

Generate output for a single group if you have already generated output for the other groups in your
project, but you have made some slight modifications to one of the groups. Using ePublisher to generate
output for a single group reduces the amount of time it takes ePublisher to generate output for your
project. When you generate output for a single group, ePublisher generates output for all of the source
documents within the group. If you select a top-level group or a group that contains subgroups, ePublisher
generates output for all of the source documents in the group and its subgroups.

Generate output for an individual source document if you have made some slight modifications to a
source document and want to preview what your generated output will look like. Selecting an individual
source document instead of generating output for the entire group or project reduces the amount of time it
takes ePublisher to generate output.

To generate output

1. On the Project menu, select the target next to Active Target for which you want to generate
output.

2. If you want to generate output for an entire project, on the Project menu, click Generate All.

3. If you want to generate output for a group in your project, complete the following steps:

a. In Document Manager, select the group for which you want to generate output.

b. On the Project menu, click Generate Selected.

4. If you want to generate output for an individual source document in your project, complete the
following steps:

a. In Document Manager, select the document for which you want to generate output.

b. On the Project menu, click Generate Selected.

Note: Some formats, such as WebWorks Reverb (1 &2), must be deployed to a
server for observing full functionality. WebWorks Reverb (1 & 2) does provide
a convenience web server that can be used for quick, non-production preview
purposes. Refer to Deploying Output to Output Destinations for further
information.
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Regenerating Output
When you regenerate output, ePublisher deletes the Data  folder from the project folder, creates a new
Data  folder, and generates new output files.

Regenerate your source document any time you have added new information to your source document
that is not content, including adding, removing, or modifying the following items:

Character styles

Paragraph styles

Table styles

Cross-reference definitions

Variable values within source documents

Conditions settings within source documents

To regenerate output

1. On the Project menu, select the target next to Active Target for which you want to regenerate
output.

2. On the Project menu, click Regenerate All.
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Generating Output from FrameMaker or Microsoft Word
ePublisher provides the ability to generate output and reports from both FrameMaker and Word using
a custom menu, often referred to as WebWorks Transit or WebWorks Menu. Output and reports
generated via this menu are short-lived. They disappear once the project window is closed. Long lived
projects should be created with the classic Express interface.

In your Source Document

1. Go to the WebWorks menu

2. Select ePublisher Express -> Generate Output

3. Select the Stationery file on which you want the project to be based

4. Click OK once you have selected the Stationery and the Target you want to use. Now click Finish
to generate output. ePublisher provides you a window to view the Output Explorer as well as the
generated output
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Modifying Help System Title Bars
The title bar in your generated help system displays the title you assigned to your project. If you want
to specify a different title in the title bar for your generated help system, you can do this in the Merge
Settings window if you are generating output for the following help systems:

Dynamic HTML

Eclipse Help

Microsoft HTML Help

WebWorks Help

WebWorks Reverb

You cannot use merge settings to modify help system title bars for other output formats.

To modify the title bar of a help system

1. On the Project menu, select the target next to Active Target for which you want to modify the title
bar of a help system.

2. On the Target menu, click Merge Settings.

3. In the Merge Title field, type the title you want to display in the title bar for your generated help
system, and then click OK.
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4. On the File menu, click Save.

5. Regenerate your output. For more information, see “Regenerating Output”
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Viewing Output
After you specify project and target settings, generate output for your target to review your changes and
verify that the generated output displays and functions properly. You can generate output for all of the
source documents and groups in your project, or you can generate output for a single group or source
document. You can view your generated output files in one of the following ways:

View output by automatically opening the generated output. For more information, see “Viewing
Output by Automatically Opening Generated Output”.

View output in Output Explorer. For more information, see “Viewing Output in Output Explorer”.

View output in the Output  folder. For more information, see “Viewing Output in the Output
Folder”.
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Viewing Output by Automatically Opening Generated Output
When you generate or regenerate output for a target, after ePublisher generates output, ePublisher prompts
you to view the generated output by displaying the following window:

To view output by automatically opening the output

1. Generate or regenerate output. For more information, see “Generating Output” or “Regenerating
Output”.

2. When ePublisher displays a window asking if you would like to view the generated output, perform
one of the following actions:

If you want to view the generated output, click Yes.

If you do not want to view the generated output, click No.

If you want ePublisher to automatically open the output each time you generate output
and you do not want ePublisher to ask you each time if you want to view the generated
output, select the Don’t ask me about this again check box, and then click Yes.

If you do not want ePublisher to automatically open the output each time you generate
output and you do not want ePublisher to ask you each time if you want to view the
generated output, select the Don’t ask me about this again check box, and then click No.

If you select the Don’t ask me about this again check box and specify that you always want ePublisher
to display the generated output or that you never want ePublisher to display the generated output,
ePublisher uses the options you specify as the default behavior for automatically displaying output when
you generate or regenerate output. If you later want to change the default behavior, you can clear your
preferences in the WebWorks ePublisher Preferences window, and then set new preferences the next time
you generate or regenerate output.
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Viewing Output in Output Explorer
Output Explorer allows you to view output files from within the ePublisher user interface. Each time
you generate output for a group of source documents or for an individual source document, ePublisher
displays the generated output files in Output Explorer. The list of files ePublisher displays in Output
Explorer is based on if you have a group of source documents selected or if you have an individual source
document selected.

If you select a top-level group in Document Manager, ePublisher displays a group folder with the same
name as the top-level group in Output Explorer that contains the following items:

Navigation group. The Navigation group displays the generated entry-point file and printable
reports. The entry-point file is the file that opens the generated output.

Reports group. The Reports group displays any reports associated with the target that ePublisher
generated.

If you select a source document in Document Manager, ePublisher displays the source document group
with the same name as the source document selected in Document Manager that contains the following
items:

Files group. The Files group contains all of the generated content files and printable reports.

Images group. The Images group contains images associated with the source document.

Reports group. The Reports group displays any reports associated with the generated output for the
target.

If you select a subgroup in Document Manager, ePublisher does not display any information in the
Navigation and Reports groups in Output Explorer, because subgroups do not create a generated entry-
point file and do not represent an actual table of contents group in generated output. The entry-point file is
the file that opens the generated output.

If you have two or more top-level groups in Document Manager and your output format supports
merged help systems, ePublisher creates a Merge Output group in Output Explorer. The Merge Output
group contains the entry-point file for the merged help system. For more information about merged help
systems, see“Merging Top-level Groups (Multivolume Help)”.

To view output in Output Explorer

1. If Output Explorer is not displayed in the ePublisher user interface, on the View menu, click
Output Explorer.

2. On the Project menu, select the target next to Active Target for which you want to view output.

3. If you want to view output by opening the entry-point file, complete the following steps:

a. In Output Explorer, select a top-level group.

b. Click on the plus sign next to the top-level group to expand the group.

c. Click on the plus sign next to the Navigation group to expand the group.
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d. Double-click on the entry-point file to open the generated output.

Output Type Generated Default Entry-Point File to Double-Click to Open

WebWorks Reverb index.html

Dynamic HTML toc.html

WebWorks Help index.html

Eclipse Help View Eclipse Help

Microsoft HTML Help name.chm

Oracle Help name.jar

Sun JavaHelp name.jar

4. If you generated output for an HTML-based output format and you want to view the individual
HTML files generated for a specific document, complete the following steps:

Note: By default, ePublisher produces individual HTML files for HTML-based output formats
based on the page breaks settings you specify for your project. For more information about
specifying page break settings, see “Specifying Page Breaks Settings”.

a. In Document Manager, select a source document.

b. In the Output Explorer, click on the plus sign next to the document to expand the group.

c. Click on the plus sign next to the Files group to expand the group.

d. Double-click on the generated output file to open the file.

5. If your output format supports merged help systems and you want to view the entry-point file for
a merged help system, complete the following steps:

a. In Output Explorer, click on the plus sign next to the Merged Output group in the Output
Explorer to expand the group.

b. Double-click on the entry-point file to open the generated output.
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Viewing Output in the Output Folder
ePublisher stores generated output pages and images in the Output  folder. By default, ePublisher creates
an Output  folder in the following location:

If you are creating a project using ePublisher Express, by default ePublisher creates the Output
folder in the My Documents\ePublisher Express Projects\ProjectName folder, where
ProjectName  is the name of the project.

If you are creating a project using ePublisher Designer, by default ePublisher creates the Output
folder in the My Documents\ePublisher Designer Projects\ProjectName folder, where
ProjectName is the name of the project.

The Output  folder contains individual output folders for each one of your targets. For example, if your
project contains targets for WebWorks Help, Microsoft HTML Help, and Dynamic HTML, then there will
be three folders, one for each of these targets, in the Output  folder.

You can view output files for all output formats by opening them directly from the Output  folder.

You can also view output files for all output formats by opening them from the ePublisher user interface.
When you open output files from the ePublisher user interface, ePublisher opens the Output  folder for
the active target you are currently working with in ePublisher. For more information about specifying an
active target and working with targets, see “Specifying Active Targets” and “Working with Targets”.

To view output in the Output Folder

1. On the Project menu, select the target next to Active Target for which you want to view output.

Note: You must generate output before you can view output in the Output  folder. For more
information about generating output, see “Generating Output”.

2. On the View menu, click Output Directory. ePublisher opens Windows Explorer and displays a
folder based on the name of your target. This Output  folder contains the output files ePublisher
generated for the active target.
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Changing the Location of the Output Folder
When you generate output, ePublisher places the output files into the Output folder. You can modify the
location where ePublisher stores your output files.

Note: We do not recommend doing this, it makes the project non-portable

To change the default location of the Output folder

1. On the Project menu, select the target next to Active Target for which you want to view output.

2. On the Target menu, click Target Settings.

3. In the Generated output location field, type the path to the folder where you want ePublisher to
place the generated output, or click the folder icon to browse to and select a folder.

4. Click OK.
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Working with Output Log Files
Each time you generate output for a target,ePublisher creates a log file named generate.log  and writes
the following information to the log file:

Time when output generation began

Actions and commands ePublisher performed, such as processing, creating and copying files

Pipelines processed by ePublisher

Any messages, warnings, or errors generated by ePublisher when ePublisher generated output for
the target

Time when output generation ended

Total amount of time it took ePublisher to generate the output

To work with output log files for a target

1. If you want to view the log file for a target from within the ePublisher user interface, complete the
following steps:

a. On the Project menu, select the target next to Active Target for which you want to view log
files.

b. On the View menu, click Log Window.

2. If you want to save the log file as a .txt  file, complete the following steps:

a. Click the Save button, located in the upper-right corner of the Log Window.

b. Specify a name for the log file and the location where you want to save the log file, and then
click Save.

3. If you want to view the log file for a target using Windows Explorer, in Windows Explorer browse
to one of the following locations:

If you are using ePublisher Express, browse to the ProjectName\Logs\TargetName folder,
where ProjectName  is the name of the project and TargetName  is the name of the target
for which you generated output. By default ePublisher saves project files for ePublisher
Express projects in the My Documents\ePublisher Express Projects\ ProjectName

folder, where ProjectName  is the name of the project.

If you are using ePublisher Designer, browse to the ProjectName\Logs\TargetName
folder, where ProjectName  is the name of the project and TargetName  is the name of
the target for which you generated output. By default ePublisher saves project files for
ePublisher Designer projects in the My Documents\ePublisher Designer Projects
\ ProjectName  folder, where ProjectName  is the name of the project.
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Validating Output Using Reports
After you generate output, you can validate your output using ePublisher reports. ePublisher reports
contain information about how ePublisher processed items in your source documents when ePublisher
generated output. Reports also allow you to identify any problems that occurred when ePublisher
generated output. If reports display notifications, such as messages, warnings, or errors, you can correct
the items in your source documents that caused the error. You can then generate output again and then
review the reports again to verify that any issues have been addressed as needed.

ePublisher provides the following types of reports:

Accessibility reports. For more information, see “Accessibility Reports”.

Baggage Files reports. For more informations, see “Baggage Files Reports”.

Conditions reports. For more information, see “Conditions Reports”.

Filenames reports. For more information, see “Filenames Reports”.

Links reports. For more information, see “Links Reports”.

Styles reports. For more information, see “Styles Reports”.

Topics reports. For more information, see “Topics Reports”.

Images reports. For more information, see “Images Reports”.

Printable reports. For more information, see “Printable Reports”.

For more information about configuring and generating reports, see “Configuring Reports” and
“Generating Reports”.
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Accessibility Reports
You can use markers in your source documents to create accessible online content.

You can use Accessibility reports to validate that the online content you generate using ePublisher meets
your accessibility requirements. Accessibility reports provide notifications on the following items when
ePublisher generates output:

Images without alternative text

Image maps without alternative text

Images without long descriptions

Tables without summaries

Configure the notifications you want ePublisher to generate for Accessibility report settings before you
generate Accessibility reports. For more information about configuring Accessibility report settings, see
“Configuring Reports”. For more information about generating Accessibility reports, see “Generating
Reports”.
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Baggage Files Reports
You can generate baggage files by adding links to HTML or PDF files in your file system, in your source
documents. For more information about baggage files, see “Targets” and “Specifying Baggage Files
Settings”.

You can use Baggage Files reports to obtain information about how the baggage files are going to be
shown in your Search Results. Baggage Files reports provide notifications on the following items when
ePublisher generates output:

Baggage files without summary

Baggage files without title

Configure the notifications you want ePublisher to generate for Baggage Files report settings before you
generate Baggage Files reports. For more information about configuring Baggage Files report settings, see
“Configuring Reports”. For more information about generating Baggage Files reports, see “Generating
Reports”.
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Conditions Reports
If you add new conditions after ePublisher already scanned the document, those new conditions won’t
be picked up by ePublisher. To warn you about that, ePublisher has a Conditions Report where you can
see all those details, and re-scan the document so the new conditions can be picked up or add it manually
yourself using the UI:
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Filenames Reports
You can specify names for output files using Filename markers.

You can use Filenames reports to validate that ePublisher named your output files correctly using the
Filename markers you inserted in your source documents. The Filenames report displays the name of
the Filename marker you inserted into your source document and the name of the output file ePublisher
generated based on the Filename marker. The Filenames report also provides notifications on the
following items when ePublisher generates output:

The files ePublisher created that correspond to the Filename markers you inserted into your source
documents

If ePublisher ignored a Filename marker when generating output

If duplicate Filename markers exist in the source documents used by your project to generate
output

Configure the notifications you want ePublisher to generate for Filenames report settings before you
generate Filenames reports. For more information about configuring Filename report settings, see
“Configuring Reports”. For more information about generating Filename reports, see “Generating
Reports”.
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Links Reports
You can use Links reports to verify that the links you specify to items in your source documents resolve
and that ePublisher processed links in your source documents to the item referenced by the link correctly.
Links reports provide notifications on the following items:

Baggage files

External URLs

Unresolved links to items in other documents

Unresolved links to missing source document

Unresolved links to missing files

Unresolved link within source documents document

Unsupported baggage files

Unsupported external URLs

Unsupported group to group links

For the definition of a baggage file see “Targets”.

Configure the notification you want ePublisher to generate for Links report settings before you generate
Links reports. For more information about configuring Links report settings, see “Configuring Reports”.
For more information about generating Links reports, see “Generating Reports”.
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Styles Reports
Styles reports allow you to verify that your source documents conform to the styles and formatting
defined in the Stationery by the Stationery designer. The Styles report notifies you about the following
items when ePublisher generates reports:

Any non-standard styles used in your source documents

Any style overrides used in your source documents

A non-standard style is any style that exists in your source document but is not defined in the
stationery file used by your project. For example, if you add a new style to your source document
called BodyIndent 4 , but your stationery designer has not updated the stationery file to include the
BodyIndent 4  style, the Styles report notifies you that there is a non-standard style used in the source
document.

A style override is any modification you made to the original style definition for a particular instance
of a style. For example, if you have applied the Body  paragraph style to a paragraph in your source
document, and you then apply the Bold  character style to the paragraph, the Body  paragraph style has a
style override.

If your source document contains any non-standard styles or style overrides, ePublisher will process your
source documents when you generate output using the non-standard styles and style overrides you applied
in your source documents.

Configure the notifications you want ePublisher to generate for Styles report settings before you generate
Styles reports. For more information about configuring Styles report settings, see “Configuring Reports”.
For more information about generating Styles reports, see “Generating Reports”.
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Topics Reports
Context-sensitive help topics require that you have TopicAlias markers inserted in your source
documents. ePublisher generates context-sensitive help topics based on the topic IDs you specify for
each TopicAlias marker you insert in your source documents. Each time ePublisher detects a TopicAlias
marker in a source document, ePublisher generates a context-sensitive help topic based on the topic ID.

You can use the Topics Report to verify that context-sensitive help topics have been created for each topic
ID specified in your source document. The Topics Report lists the topic ID and the topic file created for
each topic ID.

Configure the notifications you want ePublisher to generate for Topics report settings before you generate
Topics reports. For more information about configuring Topics report settings, see “Configuring Reports”.
For more information about generating Topics reports, see “Generating Reports”.
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Images Reports
Image reports enable you to verify the integrity and appearance of ePublisher manage images. Users are
notified any time a source image is missing or when an image occurs in a problematic structure, such a
images within tables in the ePUB format.
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Printable Reports
With the new ePublisher you can see your reports in two different ways: from the UI and in your browser
(Printable Reports). You can find them right after your usual reports.
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Configuring Reports
When you use reports to validate your output, you must specify the type of notification that you want to
display when ePublisher detects issues or performs actions while generating output using your source
documents. When ePublisher generates output, ePublisher generates notifications under the following
conditions:

When ePublisher cannot properly process elements

When ePublisher encounters missing information

For example, ePublisher can generate a notification when it detects a potential error in your source
documents when you generate output, such as an unresolved cross reference. ePublisher can also generate
a notification when it performs a specific action using elements contained in your source documents, such
as when ePublisher generates an output file using a filename you specified using a Filename marker.

You can specify the following values for report options when you generate output:

Ignore
Specify this value if you do not want ePublisher to report any issues it identifies in the report. For
example, specify this value you do not want the Styles report to report any style overrides.

Message
Specify this value if you want to receive a message when ePublisher completes or fails to complete
an action. For example, if you are not concerned if your source document uses non-standard styles,
but you would like to see where non-standard styles are used in your source documents, specify
this value.

Warning
Specify this value if you want to receive a warning when ePublisher completes or files to complete
an action. For example, if you want to be warned when ePublisher detects non-standard styles in
your source documents, specify this value.

Error
Specify this value if you want the report to display an error when ePublisher completes or files
to complete an action. For example, if you want to receive an error notification when ePublisher
detects unresolved cross-references in your source documents, specify this value.

To configure report notification settings

1. On the Project menu, select the target next to Active Target for which you want to configure report
notification settings.

2. On the Target menu, click Target Settings.

3. If you want to specify Accessibility report notification settings, in the Accessibility Report area,
specify a value for each Accessibility report notification setting you want to configure. For more
information about each setting, click Help.
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4. If you want to specify Baggage Files report notification settings, in the Baggage Files Report
area, specify a value for each Baggage File report notification setting you want to configure. For
more information about each setting, click Help.

5. If you want to specify Conditions report notification settings, in the Conditions Report area,
specify a value for each Condition report notification setting you want to configure. For more
information about each setting, click Help.

6. If you want to specify Filenames report notification settings, in the Filenames Report area,
specify a value for each Filename report notification setting you want to configure. For more
information about each setting, click Help.

7. If you want to specify Links report notification settings, in the Links Report area, specify a value
for each Link report notification setting you want to configure. For more information about each
setting, click Help.

8. If you want to specify Styles report notification settings, in the Styles Report area, specify a value
for each Style report notification setting you want to configure. For more information about each
setting, click Help.

9. If you want to specify Topics report notification settings, in the Topics Report area, specify a
value for each Topic report notification setting you want to configure. For more information about
each setting, click Help.

10. If you want to specify Images report notification settings, in the Images Report area, specify a
value for each Image report notification setting you want to configure. For more information about
each setting, click Help.
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Generating Reports
You can generate reports for source documents and baggage files by selecting the group or source
document that you want to generate reports for in Document Manager. Before you generate reports,
configure notification settings for each report you want to generate. For more information about
configuring report notification settings, see “Configuring Reports”.

To generate a report

1. In Document Manager, select the group or source document for which you want to generate a
report.

1. If you want to generate all reports for the selected item, on the Project menu, click Generate
Reports > All.

2. If you want to generate Accessibility reports for the selected item, on the Project menu, click
Generate Reports > Accessibility Report.

3. If you want to generate Baggage Files reports for the selected item, on the Project menu, click
Generate Reports > Baggage Files Report.

4. If you want to generate Conditions reports for the selected item, on the Project menu, click
Generate Reports > Conditions Report.

5. If you want to generate Filename reports for the selected item, on the Project menu, click
Generate Reports > Filenames Report.

6. If you want to generate Links reports for the selected item, on the Project menu, click Generate
Reports > Links Report.

7. If you want to generate Styles reports for the selected item, on the Project menu, click Generate
Reports > Styles Report.

8. If you want to generate Topics reports for the selected item, on the Project menu, click Generate
Reports > Topics Report.

9. If you want to generate Images reports for the selected item, on the Project menu, click Generate
Reports > Images Report.
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Report Messages
The following tables provide descriptions for report messages.
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Accessibility Report Messages
The following table lists messages in Accessibility reports.

Message Definition

Table is missing a table summary. The table does not contain a table summary. Insert a table summary marker
within the table.

Image link '{0}' is missing alternate
text.

The hotspot does not have alternate text. Insert an image area alternate text
marker in a text frame within the image.

Image is missing alternate text. The image does not have alternate text. Insert an image alternate text marker
in a text frame within the image.

Image is missing a long description The image does not have a long description. Insert an image long description
marker in a text frame within the image.
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Baggage Files Report Messages
The following table lists messages in Baggage Files reports.

Message Definition

Title missing for '{0}'. The baggage file doesn’t have a title defined.
If it’s an HTML  baggage file insert a <title>  tag in the <head>  tag of the
HTML . Or add the @title  attribute to that file entry in your baggage list info
file.
If it’s a PDF  baggage file add the @title  attribute to that file entry in your
baggage list info file.

Summary missing for '{0}'. The baggage file doesn’t have a summary defined.
If it’s an HTML  baggage file you can do one of these:

insert a <meta>  tag in the <head>  tag of the HTML  with
@name=’summary’  and @content  with the summary you want to
define,
create any kind of tag inside the <body>  tag that accepts the attribute
@class  with @class=’summary’  and then place your summary as
the content of the element,
insert a <meta>  tag in the <head>  tag of the HTML  with
@name=’description’  and @content  with the summary you want
to define.

Or add the @summary  attribute to that file entry in your baggage list info file.
If it’s a PDF  baggage file add the @summary  attribute to that file entry in
your baggage list info file.

170 | Baggage Files Report Messages



Filename Report Messages
The following table lists messages in Filename reports.

Message Definition

File '[NAME]' has been processed
as a baggage file.

Any files not contained within your project are processed as baggage files.

Filename marker '[NAME]' has
been used for generated file '[FILE
PATH]'.

A file has been generated using a filename marker. This alerts you that the
name of the file has been changed.

Filename marker '[NAME]' has
been ignored.

The filename marker has been ignored because it is either uses a duplicate
name or it has not been inserted at a heading that splits.

Filename marker '[NAME]' has
been processed as '[NAME]' for
generated file '[NAME]'.

The filename marker has not been used; instead, the file has been renamed
to the filename indicated.
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Links Report Messages
The following table list messages in Links reports.

Message Definition

Unresolved link to target ‘[NAME]’
in document ‘[NAME]’.

There is an unresolved cross-reference in the document. The destination
target either does not exist or cannot be found.

Unresolved link from document
‘[NAME]’ to target ‘[NAME]’ in
document ‘[NAME]’.

There is an unresolved cross-reference from a document to a location in
another document. The destination target cannot be found.

Unresolved link from document
'[NAME]' to document '[NAME]'.

There is an unresolved link from one document to another document. It
cannot find the referenced document.

Unresolved link from document
'[NAME]' to missing file '[NAME]'.

There is an unresolved link from a document to an external file. A file refers to
any file that is not part of the ePublisher project or is not of the same type as
your source document (for example, .jpeg, .gif, .tif )

Unresolved link from document
'[NAME]' to document '[NAME]'.
Output format does not support
group to group linking.

There is an unresolved cross-reference from one document to another
document because the output format your project is using does not support
linking from one top-level group to another.

Unresolved link from document
'[NAME]' to file '[NAME]'. Output
format does not support baggage
files.

There is an unresolved cross-reference from the document to a file because
the output format your project is using does not support baggage files. Files
refer to any file that is not part of the project.

External URL link '[NAME]' is not
supported.

The output format does not support external links.

Styles Report Messages
The following table lists messages in Styles reports.

Message Definition

Encountered [STYLE TYPE] style
name '[NAME]' in your source file
that is not defined in ePublisher.

The style name is not defined in ePublisher.

Encountered text with [STYLE
TYPE] style name '[NAME]' that
has modified style properties in
your source file.

There is a style override. Style overrides refer to attributes that are defined
within the style.
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Message Definition

Encountered style properties not
associated with a named style in
your source file.

There is a style override. For example, the character style bold has been
modified in one instance of its use.
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Topics Report Messages
The following table lists messages in Topics reports.

Message Definition

Topic '[NAME]' resolves to the file
'[FILE PATH]'.

A topic page has been created for the topic alias marker.

Topic ‘[NAME]’ is duplicated in the
file ‘[FILENAME]’

A duplicate topic alias has been created in that file.
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Images Report Messages
The following table lists messages in Images reports.

Message Definition

Missing by-reference source files An image referenced by the source document is missing.

Images in table cells Image occurs inside a table cell (problematic for certain ePUB readers)
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Merging Top-level Groups (Multivolume Help)
Merged help, which is sometimes also referred to as multivolume help, is a help system with a single set
of files created from output from multiple top-level groups from within a project. Merged help takes the
table of contents, index, and search data from each top-level group entry-point file and combines this
information to create a single, consolidated help system. You can use ePublisher to create merged help
systems for the following output formats:

WebWorks Reverb (1.0 and 2.0)

WebWorks Help

Eclipse Help

Microsoft HTML Help

If you have created several top-level groups in Document Manager for your project, by default ePublisher
generates its own help system with its own entry-point file when you generate output for your project.
The entry-point file is the file that opens the help system. ePublisher places the merged help system in the
Merged Output group in Output Explorer.

You must have at least two top-level groups in Document Manager to create merged help. By default,
ePublisher uses the organizational structure specified in Document Manager to create the merged, or
multivolume help system. If you want to organize and group your top-level groups using a different name
than the group name specified in the Document Manager, or if you want to use a different hierarchy in
your merged help system than the hierarchy you currently have specified for your project in Document
Manager, you can do this using merge settings. The following figure shows the Merge Settings window.

ePublisher names the merged help system based on the name of your target. For example, if you generate
output for a target named CompanyA WebWorks Help, ePublisher creates an entry-point file for the
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merged help system named CompanyA WebWorks Help and displays this name in the title bar when users
open the merged help system.

ePublisher also creates individual help systems for each top-level group in Document Manager and
names these individual help systems based on the names of the top-level groups in Document Manager.
For example, if you have three top-level groups in Document Manager named FeatureA, FeatureB, and
FeatureC and you are generating output for a target called CompanyA WebWorks Help, ePublisher creates
FeatureA, FeatureB, and FeatureC help systems as well as a merged help system named CompanyA
WebWorks Help that merges the table of contents, index, and search data from each top-level group into
a single, consolidated help system. These top-level groups also display in the table of contents in your
merged help system.

You can use ePublisher merge settings to perform the following actions:

Specify a different name than the target name for the title displayed in the title bar of the merged
help system

Specify a different name for subgroups in your generated output than the names used in Document
Manager

Organize and group your top-level groups in a merged help system into a different hierarchy than
the hierarchy used in Document Manager.

To merge help systems

1. Create the top-level groups you want to use in your merged help system in Document Manager. For
more information about creating top-level groups, see “Creating Top-Level Groups”.

2. On the Project menu, select the target next to Active Target for which you want to create a merged
help system.

3. On the Target menu, click Merge Settings.

4. If you want to specify a name other than your target name for the merged help system, in the
Merge Title field, type in the name you would like to display in the title bar of your merged help
system.

5. If you want to specify a different name for each top-level group in the table of contents for your
generated output, complete the following steps for each top-level group you want to rename in
your generated output:

a. In the Hierarchy area, select the name of the top-level group for which you want to specify
a different name in the generated output.

b. In the Table of contents title field, type the name you want to display for the group in the
generated output.

6. If you want to reorganize the table of contents in your merged help system, select and then drag
and drop any of the top-level groups to a new position.

7. If you want to create a new custom group for your merged help system that includes some of
your existing top-level groups from Document Manager, complete the following steps:
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a. Click the Add button. The Add button in the Merge Settings window is an icon of a blue
page with a plus (+) character ePublisher adds a new group called Untitled Topic  to your
table of contents hierarchy.

b. Click on the Untitled Topic group in the Merge Settings window and rename it.

c. Select and then drag and drop the top-level groups you want to include in the new group into
the new group.

8. If you want to delete a custom group you previously created that contains top-level groups,
complete the following steps:

Note: You can only remove groups that you have manually added to your merged help system
hierarchy. You cannot remove groups ePublisher creates by default based on the top-level
groups in Document Manager.

a. Select the group you want to remove.

b. Click the Delete button.

9. If you are generating merged, or multivolume WebWorks Help or WebWorks Reverb that
includes context-sensitive help, in the Group context field, specify the help context for each top-
level group to use.

Note: In WebWorks Reverb, you can optionally include the context as a parameter when you have
more than one instance of the same TopicAlias value in a multivolume help set.

10. Click OK.

11. Generate you output. For more information, see “Generating Output”.

12. Open the merged help system by completing one of the following steps:

Note: ePublisher creates the entry-point file using the name of the selected target. If you want to
change the name of the entry-point file for the merged help system, rename your target. For
more information about renaming your target, see “Renaming Targets”.

a. On the View menu, click Output Explorer.

b. Under the Merge Output group in the Output Explorer, double-click on the entry-point file
for the merged help system to open the merged help system.

Note: Ensure you click under the Merge Output group in Output Explorer. You must click
under the Merge Output group in Output Explorer in order to view the merged output.
If you click under one of the other groups, you will only see the output generated for
the specific group selected.

13. Review the merged help system you created based on the merge settings you specified and confirm
that your merged help system displays using the help system name and table of contents group
hierarchy that you want.
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Deploying Output
This section explains how you can use ePublisher to deploy output to multiple locations, such as to
folders on a network, or to a Web server.

Deploying Output | 179



Output Deployment
By default ePublisher places output files in the following location on your local computer:

If you are creating a project using ePublisher Express, by default ePublisher creates the Output
folder in the My Documents\ePublisher Express Projects\ProjectName folder, where
ProjectName  is the name of the project.

If you are creating a project using ePublisher Designer, by default ePublisher creates the Output
folder in the My Documents\ePublisher Designer Projects\ProjectName folder, where
ProjectName  is the name of the project.

If you would like to deploy your output files to another location in addition to this default location after
ePublisher generates output, such as a folder on a network, you can deploy your output to one or more
output destinations using ePublisher. The output destination is the location where you would like
to deploy your generated output files. In ePublisher, the output destination consists of the following
components:

Output name

Output destination location

To deploy your output, you must perform the following steps:

1. Create one or more output destinations. For more information, see “Creating Output Destinations”.

2. Specify an output destination for each target. For more information, see “Specifying Output
Destinations for Targets”.

3. Deploy output to output destinations. For more information, see “Deploying Output to Output
Destinations”.
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Creating Output Destinations
Before you can deploy your output, you must create output destinations. You can specify one output
destination or multiple output destinations. Specify multiple output destinations when you want to deploy
your output to multiple locations. For example, assume that you place your generated output to a web
server computer, and you use both a staging server and a production server. You can create one output
destination in ePublisher for the staging server, and another output destination in ePublisher for the
production server.

Output destinations are not project or target specific. When you define output destinations in ePublisher,
ePublisher saves the output destinations you define and allows you to use the output destinations you
specify across multiple ePublisher projects and targets.

When you deploy output to an output destination, ensure you specify a descriptive name for the output
destination. When you work with output destination, you can only see the name of the output destination.
You will not be able to see the actual path you specified to the output destination. Type a descriptive name
for the output destination that allows you to easily identify each output destination you specify.

For example, if you are deploying WebWorks Help output for a product to both a staging server and a
production server, type Production Server ProductA WebWorks Help  for the first output destination.
When you create your second output destination, type Staging Server ProductA WebWorks Help for
the second output destination.

To create an output destination

1. On the Target menu, click Target Settings.

2. Click Add deploy target.

3. Complete the following steps:

a. Click Add > Folder.

b. In the Name field, type a descriptive name for the output destination.

c. In the Directory field, type the path to the folder you want to specify as the output
destination, or click the folder icon and then browse to and select the folder where you
would like to deploy your output.

d. Click OK.

After you create an output destination, you must specify which target is associated with the output
destination before you can deploy output. For more information, see “Specifying Output Destinations for
Targets” and “Deploying Output to Output Destinations”.
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Specifying Output Destinations for Targets
After you create an output destination, you must associate the output destination with an target before you
can deploy output.

To specify an output destination for a target

1. On the Project menu, select the target next to Active Target for which you want to specify an
output destination.

2. On the Target menu, click Target Settings.

3. In the Deploy to field, select an output destination.

Note: You must create an output destination before you can specify an output destination for
a target. For more information about creating output destinations, see “Creating Output
Destinations”.

4. Click OK.

After you specify an output destination for a target, you can generate output and deploy the output to the
output destination.
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Deploying Output to Output Destinations
After you create output destinations, specify output destinations for targets and generate output, you
can use the Deploy command in ePublisher to copy your output files and place them into the locations
you specified as output destinations. When you deploy output, ePublisher copies the target output files
and places the output files in the location you specified as the output destination. For more information
about creating output destinations and specifying output destinations for targets, see “Creating Output
Destinations” and “Specifying Output Destinations for Targets”.

To deploy output to an output destination

1. On the Project menu, select the target next to Active Target for which you want to deploy output.

2. On the Target menu, click Deploy. ePublisher deploys the output files to the specified output
location.
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Working with Target Settings
Based on your ePublisher implementation, after you create a project using Stationery, you can customize
target settings for the targets available in your project if you have appropriate permissions. You can only
customize target settings in a project if you have target setting modification permissions.

If you are using ePublisher Designer, you have target setting modification permissions. If you are using
ePublisher Express, you may or may not have target setting modification permissions. When you install
ePublisher Express, you must select the Allow users to modify Target Settings and Properties check
box in order to have permissions to modify the target settings for the targets available in your project. If
you do not select this check box during installation, you will not be able to customize target settings in
projects. However, you can enable target setting modification permissions after you install ePublisher
Express if needed. For more information, see “Working with Contract IDs”.

If you have permissions to modify the target settings in projects, you can customize the following target
settings for most output formats:

Note: If you are using ePublisher Express, any customizations you make to target
settings will be overwritten the next time you synchronize your ePublisher
Express project with Stationery. For more information, see “Synchronizing
Projects with Stationery”.

Accessibility settings. For more information, see “Specifying Accessibility Settings”.

Baggage Files settings. For more information, see “Specifying Baggage Files Settings”

Company information. For more information, see “Specifying Company Information”.

File processing behavior for front matter, index files, and table of contents files. For more
information, see “Specifying File Processing Behavior for Front Matter, Index, and Table of
Contents Files”.

When to create new pages. For more information, see “Specifying Page Breaks Settings”.

How you want to name your page files and image files when generating output. For more
information, see “Specifying Page, Image, and Table File Naming Patterns”.

Index settings. For more information, see “Specifying Index Settings”.

How links to files or external URLs display in browser windows. For more information, see
“Specifying How Links to Files or External URLs Display in Browser Windows”.

Character encoding settings for targets. For more information, see “Specifying Character Encoding
for Targets”.

Language used by targets. For more information, see “Specifying the Language Used by Targets”.

PDF generation settings. For more information, see “Specifying PDF Generation Settings”

Table of contents settings. For more information, see “Specifying Table of Contents Settings”.

Report settings. For more information, see “Specifying Report Settings”.

184 | Working with Target Sengs



Output format-specific settings, such as settings specific to the WebWorks Help output format or
the Microsoft HTML Help output format. For more information, see “Specifying Output Format-
Specific Settings”.

Variable settings. For more information, see “Setting Variables in Projects”.

Condition settings. For more information, see “Setting Conditions in Projects”.

Cross-reference settings. For more information, see “Setting Cross-References in Projects”.

After you make any customizations to the target settings for the targets available in your project, generate
output so that you can review your changes and verify that the generated output displays and functions
properly. You can generate output for all the source documents and groups in your project, or you can
generate output for a single group or source document. For more information about generating output, see
“Generating Output”.
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Specifying Accessibility Settings
In ePublisher, accessibility refers to how users with disabilities access electronic information and how
writers and producers of online content produce accessible output that can function with assistive devices
used by individuals with disabilities. Creators of online content, such as writers who product online
content and help systems and others who are responsible for producing accessible help, or Section 508
compliant content, must follow certain guidelines established by the W3C and the U.S. government.
If you are responsible for producing accessible online content, you must provide alternate text and
descriptions for all images and image maps and summaries for all tables included in the online content.
Ensure you specify this information when you prepare your source documents for output generation. For
more information, see “Creating Accessible Online Content in FrameMaker” and “Creating Accessible
Online Content in Word”.

To specify accessibility settings for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Accessibility, specify the appropriate values for the Accessibility settings. For more
information about Accessibility settings and values, click Help.

4. Click OK.
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Specifying Baggage Files Settings
In addition to your source files content inside HTML and PDF files can be indexed by enabling Baggage
File settings. In ePublisher you can access to the Baggage File settings only if your target is WebWorks
Reverb (Reverb 1 and 2). There are several settings that allows you to customize the way Reverb handles
the baggage files.

You can specify the following settings:

Baggage files info list

Copy baggage file dependents

Index baggage files

Index external links

We will explain each setting briefly below.
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Baggage files info list
The baggage files info list  allows you to control index behavior and assign titles and descriptions
to external files and URLs linked to in source documents. This is useful if the automatically-assigned
titles and descriptions that display in the output search results are not relevant or are missing.

If your baggage files or external URLs do not have adequate title and summary values defined, then
you can also use the baggage files info list  to provide these values. These values are used for
displaying search results.

If you have external URL links or baggage files in your source content that you do not want included in
the search index, then use the attribute @noindex .

When specifying the path for baggage files, you can either use an absolute path or a path relative to the
baggage files info list  file.

You can specify the location and filename of the baggage files info list  using the Target Settings
dialog (explained below). By default the filename is called: baggage_list.xml  and is available to
override in the Advanced > Manage Format/Target Customizations menu. In addition to renaming this
file, you can also specify an absolute path or a relative path from the project file directory. Furthermore,
you can use a variable for getting the directory location of the first document in the project. Using this
variable called: $FirstDocDir; , you can locate the baggage files info list  file in this directory.
This is a useful way to use your stationary with multiple projects.

To use this variable you need to specify it first in the Target Setting value like this:

$FirstDocDir;/baggage_list.xml .

Note: If you change the path of the baggage files info list  target setting, then
even if you have overridden this file, the overridden file will be ignored and
the file specified will be used instead. However, if you just change the base
filename, then ePublisher will look for this file as if it were an override.

To get the path of the Baggage Files info list file we follow these steps

1. If you change the default value or just change the name (without specifying a path) Reverb tries
to get the file from the Targets folder first and then from the Formats folder. The file will be located
in the Transforms folder, so you can easily do an override of it if you want to keep the default
name, otherwise you can add the new file there with the name you defined in the Target Settings.

2. If you define an Absolute or Relative path Reverb will calculate the relative path relative to the
project file and will take the absolute path as is.

If you don’t specify a title and/or a summary for a baggage file we will try to do it for you.

In case of an HTML file for getting a title (if you didn’t define one in a baggage list file) we will search
for:

1. A <title>  tag defined in the <head>  section of the HTML.

2. The base name without the extension of the HTML file.
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In case of a PDF file for getting a title (if you didn’t define one in a baggage list file) we will get the base
name without the extension of the PDF file.

In case of an HTML file for getting a summary (if you didn’t define one in a baggage list file) we will
search for:

1. The attribute @content  in the <meta>  tag defined in the <head>  section of the HTML with
attribute @name=”summary” .

2. All the text inside the first tag, contained in the <body>  tag, with attribute @class=”summary” .

3. The attribute @content  in the <meta>  tag defined in the <head>  section of the HTML with
attribute @name=”description” .

4. All the text inside the first <p>  tag, contained in the <body>  tag.

In case of a PDF file for getting a summary (if you didn’t define one in a baggage list file) we will get the
first 300 letters from the content of the PDF file.

The attribute @noindex  accepts 2 values: true |false , or you can even not define this attribute at all,
and it will take the value false  by default. If you define @noindex="true"  it means Reverb won’t index
that file.

The attribute @path  is for specifying the path to the file (relative or absolute) or the external URL. It
should be an existing path to an HTML page or PDF, either local or in the web.

Note: Any text you write in this file, if it contains a reserved character you’ll have
to change it to use the entity corresponding. For example, instead of “&” use
“&amp;”.

The following code will show you how to structure a baggage list file, as well as some examples for the
entries:

<?xml version="1.0" encoding="UTF-8" ?>

<Files version="1.0" xmlns="urn:WebWorks-Baggage-List-Schema">

<File path="http://example.com/" noindex="true"/>

<File path="https://example.com/myfavoritepage" title="My favorite page"
summary="Favorite pages can make your day better"/>

<File path="Source-Docs\some_pdf.pdf" title="Some PDF title" summary="Some PDF
summary"/>

<File path="C:\Documents\another_pdf.pdf" title="Another PDF title" summary="Another
PDF summary"/>

...

</Files>
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Copy baggage file dependents
If you have this setting Enabled in your Target Settings, all the dependents of your HTML baggage files
will be copied to the baggage  folder inside the corresponding group in the output folder. These mean the
final user will be able to open the HTML baggage file and it will look pretty similar to the original one.
Right now we support the dependences corresponding to these tags:

<link>  tag inside the <head> tag that it’s not an external URL or starts with “javascript: ”

<script>  tag that it’s not an external URL or starts with “javascript: ”

<img>  tag that it’s not an external URL or starts with “javascript: ”

<input>  tag that it’s not an external URL or starts with “javascript: ”

<iframe>  tag that it’s not an external URL or starts with “javascript: ”

<video>  tag that it’s not an external URL or starts with “javascript: ”

<audio>  tag that it’s not an external URL or starts with “javascript: ”

<object>  tag inside the <body> tag that it’s not an external URL or starts with “javascript: ”
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Index baggage files
If you have this setting Enabled in your Target Settings, Reverb will index all the baggage files allowing
them to show up in Search Results. You can override this behavior on a file by file basis by specifying the
attribute @noindex="true"  in your Baggage files info list.

In order to handle most any type of HTML file Reverb uses Tidy (tool for cleaning up HTML files) for
creating a well-formed XHTML temporary copy of the files, which are valid XML files that ePublisher
can read.
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Index external links
If you have this setting Enabled in your Target Settings, Reverb will index all the external links you
have in your source documents and in your Baggage files info list. That means you’ll have in your Search
Results links to your external URLs if they match with the searched phrase.

The Reverb format downloads the file to the Data directory and then uses Tidy (tool for cleaning up
HTML files) for creating an XHTML copy of the files, which are valid XML files that ePublisher can
read.

Note: If your URL needs to execute some JavaScript code to get the content of
the page, Reverb won’t be able to index the dynamic content of the page.
To simulate the actual content that Reverb will index at a particular URL,
temporarily disable JavaScript in your browser and visit that link.

To specify baggage files settings for a target (only for Reverb targets):

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Baggage Files, specify the appropriate values for the Baggage Files settings. For more
information about Accessibility settings and values, click Help.

4. Click OK.
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Specifying Company Information
You can add your company’s contact information to each generated output page. ePublisher can display
the company contact information on the bottom and/or top of your output pages. Where the company
information displays depends on what the Stationery designer specified in the Stationery file.

To display the company information in the header area, see “Header Settings”.

To display the company information in the footer area, see “Footer Settings”.

You can specify the following company information:

Company email address

Company fax number

Company logo image

Company name

Company phone number

Company web page

To specify company information for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Company Information, specify the appropriate values for the company information
settings. For more information about the company information settings and values, click Help.

4. Click OK.
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Specifying File Processing Behavior for Front Matter, Index, and Table of
Contents Files
You can specify file processing behavior for front matter, index files, and table of contents files. For
example, you can specify whether or not you want to generate output for front matter included in your
source documents.

To specify file processing behavior for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under File Processing, specify the appropriate values for file processing settings. For more
information about the file processing settings and values, click Help.

4. Click OK.
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Specifying Page Breaks Settings
When ePublisher processes source documents, it creates new topic pages based on settings specified by
the Stationery designer in the Stationery. However, you can modify how you would like ePublisher to
handle the page breaks.

To specify page break settings for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Files, in the Page break handling field, select the value you want to specify. For more
information about the values, click Help.

4. Click OK.
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Specifying Page, Image, and Table File Naming Patterns
You can specify page, image, and table file naming patterns that you want ePublisher to use when
generating output.

For example, you can specify if you would like to include the following items in page, image, and table
file names when generating output:

Target name

Name of the group in Document Manager that contains the topic

Page heading text or title

You can use image naming patterns to specify names for embedded image output files. However, if you
insert your images by reference in Adobe FrameMaker or use the Link to File or Insert and Link option
in the Insert Picture window in Microsoft Word, ePublisher preserves the original file names.

Note: You can also use Filename markers to specify page and image output file
names.

To specify page, image, and table file naming patterns for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Files, specify the appropriate values for the page, image, and file naming patterns you want
to use. For more information about file settings and values, click Help.

4. Click OK.
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Specifying Index Settings
In ePublisher, you can specify if you want to generate an index for your help system. If you choose to
generate an index for your help system, you must have index markers in your source documents.

To specify index settings for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Index, specify the appropriate value for each index setting. For more information about the
index settings and values, click Help.

4. Click OK.
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Specifying How Links to Files or External URLs Display in Browser
Windows
ePublisher allows you to specify how you want links that open baggage files or links that open external
URLs displayed in your output. For the definition of a baggage file see “Targets”.

To specify link settings for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Links, specify the appropriate value for each links setting. For more information about the
links settings and values, click Help.

4. Click OK.
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Specifying Unknown File Links Behavior in Reverb
In the output format, WebWorks Reverb 2.0, relative file links that do not resolve to an actual file (i.e.
baggage file) are not active when loaded in the browser. In this situation, Reverb assumes that this link
is not available in the current session and thus prevents the user from activating them and getting an
unknown file error.

If you wish to preserve these types of links in your output (there are circumstances where preserving this
behavior can be useful), then you will need to enable the target setting called: Preserve Unknown File
Links .

To enable preservation of unknown file links

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings.

3. Under Links, enable the setting: Preserve Unknown File Links .

Specifying Unknown File Links Behavior in Reverb | 199



Specifying Character Encoding for Targets
In ePublisher, encoding refers to the character encoding method used to convert bytes into characters.
Programs use encoding when they display HTML documents. Documents in English and most other
Western European languages typically use the widely supported character encoding UTF-8. If you are
producing output localized for other languages, such as Japanese, Korean, Simplified Chinese, Traditional
Chinese, Greek, Turkish, or Eastern European, Cyrillic, or Baltic languages, you must specify the correct
encoding for each target for which you generate output.

Ensure the encoding you specify when you generate your output matches the encoding used in the
environment where your output will be posted. For example, if your output will be posted on a web
server, the encoding you specify when you generate your output should match the encoding used on
the web server. If your output and the computer or web server hosting your output do not use the same
character encoding method, some characters may not display correctly when users view your output.

To specify character encoding for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Locale, specify the appropriate value for the Encoding setting. For more information about
the encoding setting values, click Help.

4. Click OK.
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Specifying the Language Used by Targets
In ePublisher, locale refers to the language used when displaying output for a target. If you produce
localized output, specify the correct language for each target in your ePublisher project.

To specify the language to use for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Locale, specify the appropriate value for the Locale setting. For more information about the
locale setting values, click Help.

4. Click OK.
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Specifying PDF Generation Settings
ePublisher can generate PDFs for each source document, for each top-level group in your project, or for
each source document and each top-level group in your project.

To specify PDF generation settings for a target

1. On the Project menu, select the output format next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under PDF, specify the appropriate values for the PDF settings. For more information about PDF
settings and values, click Help.

4. Click OK.

202 | Specifying PDF Generaon Sengs



Specifying Table of Contents Settings
ePublisher allows you to specify whether you want to generate a table of contents, the file name you
want to specify for your table of contents file, and how you want your table of contents to display in your
generated output.

ePublisher provides table of contents settings to help you address how you want your table of contents
to display. By default, ePublisher uses the table of contents levels specified in the project or in the
Stationery file to create a table of contents for your help system based on the heading levels in your
source documents. However, if you have source documents where writers skipped heading levels, you can
specify how you want ePublisher to display skipped headings in the table of contents.

For example, assume that you have an ePublisher project that uses a Stationery file that specifies Heading
1, Heading 2, and Heading 3 as levels in the output table of contents. Then assume that in the source
document, you skipped several Heading 2 levels. ePublisher displays an empty table of contents icon,
similar to the following figure, in the location of the skipped Heading 2 levels unless you specify how you
want to manage skipped heading levels in the generated table of contents.

You can specify the following behavior for table of contents where writers skipped headings:

If you want ePublisher to automatically insert empty table of contents entries for skipped
heading levels, select the Don’t collapse value. The following figure shows a table of contents
with this option selected.

If you want ePublisher to automatically insert labeled entries for skipped heading levels, select
the Re-label value. ePublisher displays the heading text from the table of contents entry below the
current entry as the table of contents label. The following figure shows a table of contents with this
option selected.
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If you want ePublisher to automatically remove empty table of contents entries and move the
heading that follows an empty table of contents entry up a level to replace the skipped table of
contents level, select the Smart collapse value. The following figure shows a table of content with
this option selected.

If you want ePublisher to remove all skipped heading levels and table of contents entries and
place all table of contents headings at the same level, regardless of the table of contents level
specified in the Stationery, select the Fully collapse value. The following figure shows a table of
contents with this option selected.

To specify table of contents settings for a target

1. On the Project menu, select the target next to Active Target for which you want to specify
settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under Table of contents, specify the appropriate values for the table of contents settings. For more
information about table of contents settings and values, click Help.
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4. Click OK.
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Specifying Report Settings
You can use reports to identify problems in your source documents. If an ePublisher report detects
problems in your source document, ePublisher displays a notification alert in the report. You can specify
which types of settings you want to use to validate your generated output and the type of notification
you want to receive if ePublisher detects an issue when validating your output. For more information
about using reports to validate your output and the different types of notifications you can receive, see
“Validating Output Using Reports”.
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Specifying Output Format-Specific Settings
You can specify output format-specific settings for the following output formats:

WebWorks Reverb

PDF - XSL-FO

eBook - ePUB 2.0

Eclipse Help

Microsoft HTML Help

Oracle Help

PDF

Sun JavaHelp

WebWorks Help

You must have the target that uses the output format selected in your project before you can see the output
format-specific settings in the window. For example, to see WebWorks Help output format-specific
settings in the window, you must have a target that uses the WebWorks Help output format selected as
your active target. If you have a target that uses the Microsoft HTML Help output format selected as your
active target, you will not be able to see WebWorks Help output format-specific settings in the window.
You will only be able to see Microsoft HTML Help output format-specific settings.

To specify output format-specific settings for a target

1. On the Project menu, select the target next to Active Target for which you want to specify output
format-specific settings.

2. On the Target menu, click Target Settings. You must have target modification permissions to
modify target settings. For more information, see “Working with Target Settings”.

3. Under the name of the output format, specify the appropriate values for each output format-specific
setting. For more information about output format-specific settings and values, click Help.

4. Click OK.
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Setting Variables in Projects
In a project, you can use the variable values defined in your source document. You can also change the
value of any variable in your source document in a project. Changing the value of a variable in a project
does not change or affect the value of the variable in your source document. You can use the value of the
variable you defined in your project when you generate output. Before you can work with variables in
projects, you must insert variables in your source documents.

To set a variable in a project

1. On the Project menu, select the target next to Active Target for which you want to customize
variable settings.

2. On the Target menu, click Variables. You must have target modification permissions to modify
variable settings for a target. For more information, see “Working with Target Settings”.

Note: For Microsoft Word documents only, if you use variables that are built-in DocProperty
types such as Author  or Company , then you will need to manually add these variables into
the project or stationery as they are not detected when scanned by ePublisher Designer.
However, once added into either the stationery or project then they will be available for
customization from that point forward.

3. In the Name column, find the variable you want to modify.

4. If you want the your ePublisher project to use the variable value defined in your source
document, click in the Value field for the variable, and then select Use document value from the
drop-down list.

5. If you want to change the variable value ePublisher uses when generating output, click in the
Value field for the variable, and then type in a new value for the variable.
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6. Click OK.

7. Generate your output. For more information, see “Generating Output”.

8. Review your output and confirm that variables display appropriately in your generated output. For
more information, see “Viewing Output”.
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Setting Conditions in Projects
In a project, you can use the conditions defined in your source document to control the visibility of
content to which you have applied conditions. You can also change the visibility specified for any
condition in a project. Changing the visibility specified for any condition in a project does not change the
visibility specified for the condition in your source documents. Before you can work with conditions in
projects, you must apply conditions to content in your source documents.

To customize a condition in a project

1. On the Project menu, select the target next to Active Target for which you want to customize
condition settings.

2. On the Target menu, click Conditions. You must have target modification permissions to modify
condition settings for a target. For more information, see “Working with Target Settings”.

3. In the Name column, find the condition for which you want condition to set the value.

4. Specify the appropriate value for the condition. For more information about condition values, click
Help.

5. Click OK.

6. Generate your output. For more information, see “Generating Output”.

7. Review your output and confirm that conditionalized content displays appropriately in your
generated output. For more information, see “Viewing Output”.
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Setting Cross-References in Projects
Cross-references help users access related information quickly in printed and online content. When you
convert your source documents to online help, if you have cross-references in your source documents,
ePublisher automatically converts all cross-references to hypertext links. Typically, cross-references used
for printed materials have a different format than cross-references used for online help. For example,
cross-references in printed content typically include page numbers, while cross-references in online help
typically do not include page numbers, because page numbers are out of context in online help.

In ePublisher, you use the Cross-Reference Rules window to add, edit, or delete cross-reference formats
for your project. A cross-reference format is a combination of text and code that defines how you want
your cross-reference to display. For example, your source documents may display the following cross-
reference format: “Modifying Cross-Reference Formats on page xxx”, where xxx is the page number
where the topic “Modifying Cross-Reference Formats” begins. However, you may modify the cross-
reference format in ePublisher so that when you generate online content, the “Modifying Cross-Reference
Formats” topic displays as a hyperlink without a page number, such as Modifying Cross-Reference
Formats in Projects.

ePublisher obtains the cross-reference formats and values in the Cross-Reference Rules window from
your source documents. You can modify cross-reference formats in ePublisher. For more information
about cross-reference building blocks or codes, see your content authoring tool documentation.

The following figure shows the Cross-Reference Rules window in ePublisher.

Seng Cross-References in Projects | 211



Modifying Cross-Reference Formats in Projects
Modify cross-reference formats when you want cross-references in your online content to use a different
format than your printed content.

To modify a cross-reference format in a project

1. On the Project menu, select the target next to Active Target for which you want to modify cross-
reference formats.

2. On the Target menu, click Cross Reference Rules. You must have target modification
permissions to modify a cross-reference format for a target. For more information, see “Working
with Target Settings”.

3. Specify the appropriate value for each cross reference. For more information about cross reference
values, click Help.

4. Click OK.

5. Generate your output. For more information, see “Generating Output”.

6. Review your output and confirm that cross-references display appropriately in your generated
output. For more information, see “Viewing Output”.
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Adding Cross-Reference Formats to Projects
If you are using Adobe FrameMaker or Microsoft Word documents as your source documents for
ePublisher, then you can take advantage of the Cross-Reference Formats capability in ePublisher to
modify cross references when generating output.

ePublisher obtains the cross-reference formats and values in the Cross-Reference Rules window from
your source documents. You can also add cross-reference formats in ePublisher.

For example, if you started to use a new cross-reference format in your source document and the
Stationery designer has not yet added this new cross-reference format to the Stationery associated with
your project, you can add the new cross-reference format to your project and specify the cross-reference
format you want to use for your new cross-reference format. After you add a new cross reference format
ePublisher recognizes the new cross reference formats and applies the cross-reference format you specify.

To add a cross-reference format to a project

1. On the Project menu, select the target next to Active Target for which you want to add a cross-
reference format.

2. On the Target menu, click Cross Reference Rules. You must have target modification
permissions to add a cross-reference format for a target. For more information, see “Working with
Target Settings”.

3. In the Document type field, select the content authoring tool for the cross-reference format you
want to add.

4. Click the Add New Cross Reference icon.

5. In the Name field, type a name for the new cross-reference format you want to add to the project.

6. In the Replacement field, type a combination of text and code or building blocks that define how
you want your new cross-reference to display. For more information about cross-reference building
blocks or codes, see your content authoring tool Help.

7. Click OK.

8. Click OK again to close the window.

9. Generate your output. For more information, see “Generating Output”.

10. Review your output and confirm that cross-references display appropriately in your generated
output. For more information, see “Viewing Output”.
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Deleting Cross-Reference Formats from Projects
ePublisher obtains the cross-reference formats and values in the Cross-Reference Rules window from
your source documents. You can delete cross-reference formats in ePublisher. Delete cross-reference
formats when you no longer want to use the cross-reference format in your source documents.

If you delete the cross-reference format in your ePublisher project, but your source documents continue
to use the cross-reference format, ePublisher will detect the deleted cross-reference format in your source
documents and add it to your project again the next time you scan your source documents or generate
output.

To delete a cross-reference format from a project

1. On the Project menu, select the target next to Active Target for which you want to delete a cross-
reference format.

2. On the Target menu, click Cross Reference Rules. You must have target modification
permissions to delete a cross-reference format for a target. For more information, see “Working
with Target Settings”.

3. In the Document type field, select the content authoring tool associated with the cross-reference
format you want to delete.

4. In the Name column, select the cross-reference format you want to delete.

5. Click the Delete Cross Reference icon.

6. Click OK.
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File Mappings for Source Documents
This section explains how to configure file mappings for source document types in a project.
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File Mappings
In ePublisher, a file mapping is an association between a file extension and an ePublisher adapter. An
ePublisher adapter is an ePublisher component that links the content authoring tool that you used to
develop your content with ePublisher. ePublisher currently provides adapters for the following content
authoring tools:

Markdown++ (helper)

Adobe FrameMaker

Microsoft Word

XML

In ePublisher, you can add any source documents that can be opened with Adobe FrameMaker, Microsoft
Word, DITA-XML to your ePublisher project through the use of file mappings. By default, ePublisher
provides a list of file extensions that are preset to use either Microsoft Word, Adobe FrameMaker, or
the built-in XML adapter. For example, you can add .txt  files to your ePublisher project by specifying
the adapter ePublisher should use in order to open the .txt  file. You can specify whether you want the
Adobe FrameMaker, Microsoft Word, or XML adapter to open the .txt files you add to your project.

Certain file extensions, such as .book , .fm , and .bk  files, are unique to a specific adapter. For
example,.book , .fm , and .bk  file can only be opened by Adobe FrameMaker. .rtf , .xml , and
.doc  are specific to Microsoft Word. If you try to generate output or an output preview using a file
type associated with an ePublisher adapter and the file type cannot normally be opened with the content
authoring tool associated with the ePublisher adapter, ePublisher displays an error message. The built-
in XML adapter ePublisher provides is configured out-of-the-box to support DITA-XML. You can also
configure ePublisher Stationery to support other XML types. However, XML input formats other than
DITA-XML may not be supported by the WebWorks Technical Support team.

If you have an ePublisher Contract ID that enables only the Microsoft Word, the Adobe FrameMaker,
or the built-in XML adapter, then you can use only that adapter when you use ePublisher. Although the
option to choose another adapter may be available in the ePublisher user interface, you will not be able to
generate output or preview output using the other adapters. You can only use the adapters enabled by your
Contract ID.
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Modifying File Mappings
ePublisher provides a default list of file mappings in which file extensions have been preset to use
a specific adapter. However, in some cases you may need to modify file mappings for a project. For
file extensions that can either be opened with Microsoft Word or Adobe FrameMaker, such as .txt
files, you can specify the adapter you want ePublisher to use for the file extension. You can modify file
mappings for a specific project or for all of your ePublisher projects.

To modify a file mapping

1. If you want to modify a file mapping for a specific project, complete the following steps:

a. On the Project menu, click Project Settings.

b. In the File Extension column, click the file extension for which you want to modify the file
mapping.

2. If you want to modify a file mapping for all of your ePublisher projects, complete the following
steps:

a. On the Edit menu, click Preferences.

b. On the File Mappings tab, in the File Extension column, click the file extension for which
you want to modify the file mapping.

3. In the Adapter column, select the ePublisher adapter you want to associate with the file extension.
The ePublisher adapter you associate with the file extension will be the ePublisher adapter that
opens files with the specified file extension.

4. Click OK.

5. Click OK again. Each new ePublisher project you create after you modify the file mapping will use
the ePublisher adapter you associated with the file extension.
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Creating New File Mappings
If there is a file extension that you would like to use but the file extension is not available in ePublisher
in the default list of file extensions, you can create a new file mapping. To create a new file mapping,
add a new file extension and associate, or map, the file extension to an ePublisher adapter. You can use
the new, or custom, file mapping to specify that ePublisher open files using the new file extension with
Adobe FrameMaker, Microsoft Word, or the built-in XML adapter. When you create a new file mapping,
ePublisher saves information about the new file mapping you created, and you can apply the new file
mapping to all of the subsequent projects that you open.

When you create a file mapping and specify an ePublisher adapter for the file extension, ensure the file
extension can be opened using the content authoring tool associated with the adapter outside of ePublisher
before you create the new file mapping. If the file extension cannot be normally opened using the content
authoring tool, then ePublisher will also not be able to generate output from the source document using
the ePublisher adapter.

For example, assume your Contract ID enables licensing for ePublisher Express for FrameMaker. Next
assume that you add HTML as a file mapping and associate the .html  file extension with the Microsoft
Word adapter. When you create the file mapping for the .html  file extension with the Microsoft Word
adapter, ePublisher allows you to add the HTML file to your project. However, since you do not have a
valid license key for the ePublisher Express for Microsoft Word, ePublisher displays the following error
message.

To create a new file mapping

1. If you want to create a new file mapping for a specific project, complete the following steps:

a. On the Project menu, click Project Settings.

b. Click the Add icon.

2. If you want to create a new file mapping for all of your ePublisher projects, complete the
following steps:

a. On the Edit menu, click Preferences.

b. On the File Mappings tab, click the Add icon.

3. In the File extension field, type the file extension you want to use for the file mapping. For
example, you can add .html  as a file extension.
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4. In the Adapter field, select the ePublisher adapter you want to associate with the file extension.
The ePublisher adapter you associate with the file extension will be the ePublisher adapter that
opens files with the specified file extension. For example, you can select Microsoft Word as the
adapter for the .html  file extension.

5. Click OK.

6. Click OK again. Each new ePublisher project you create after you modify the file mapping will use
the ePublisher adapter you associated with the file extension.
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Deleting File Mappings
Delete a file mapping when you no longer want to use the file mapping in your ePublisher project.

To delete a file mapping

1. If you want to delete a file mapping for a specific project, complete the following steps:

a. On the Project menu, click Project Settings.

b. In the File extension field, select the file extension for the file mapping you want to delete.

2. If you want to delete a file mapping for all of your ePublisher projects, complete the following
steps:

a. On the Edit menu, click Preferences.

b. On the File Mappings tab, in the File extension field, select the file extension for the file
mapping you want to delete.

3. Click the Delete icon.

4. Click OK.

5. Click OK again. Each new ePublisher project you create after you delete the file mapping will not
use the ePublisher adapter you deleted.
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Scheduling and Integrating
Processes with AutoMap

How ePublisher Supports Automation
Preparing Projects, Stationery, and Source Files
Working with Jobs
Using Scripts for Additional Custom Processing
Using the Command-Line Interface

This section describes how to automate output generation and integrate this task with your other
processes. For example, you can have the build process for a software product automatically build all the
targets you define in your project using the latest version of source documents checked into your version
control system or content management system.
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How ePublisher Supports Automation
ePublisher provides several components to help you process source documents and publish the generated
output. The ePublisher AutoMap component helps you schedule and perform all your processing tasks,
and it also provides automated pre- and post-processing capabilities to complete your production and
publication processes.
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What Is ePublisher AutoMap?
ePublisher AutoMap is the automation tool that enables you to automate the content transformation
process, batch processing, and integration with content management or version control systems. This
component lets you schedule ePublisher projects. For example, you can schedule the output generation
to occur overnight. Then, when you arrive the next morning, your transformed content is ready for you.
You can also automatically generate and deploy deliverables to meet your specific needs, such as updating
Web site content based on updated source documents. You can automatically create ePublisher projects
and generate output without manually opening ePublisher or your source documents.
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Benefits of Using ePublisher AutoMap
ePublisher AutoMap automates the process of transforming your source documents to your output
formats. This component lets you transform content at scheduled times and work seamlessly with your
content management and version control systems. The following list highlights several ePublisher
AutoMap features that save you time and effort:

Automates the output generation using existing projects, including synchronizing with the
Stationery

Creates projects using the specified Stationery and applies it to your content

Creates merged output from multiple books

Allows you to customize conditions, variables, and cross references on a per-job and per-target
basis

Redirects and deploys output automatically

Provides a full-featured command-line interface for performing batch transformations from other
systems or scripts

Integrates with content management and version control systems

Offers flexible scheduling options

Notifies relevant people when a job succeeds or fails

Automatically updates your online content, help, or Web-based information
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Version Control System (VCS) Integration
ePublisher AutoMap allows you to specify scripts for retrieving files from version control systems such
as:

CVS

ClearCase

Visual Source Safe

Subversion

Mercurial

Documentum

Perforce

Git

ePublisher AutoMap can work with any version control system that is scriptable from the command
line. For more information, see “CVS Version Control Checkout Example”. To see more version control
integration scripting examples see wiki.webworks.com/HelpCenter/Tips/VersionControl
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Content Management System (CMS) Integration
Using the same scripting integration as used for version control system integration, ePublisher AutoMap
can also work with many industry standard content management systems such as: Vasont CMS and SDL
LiveContent.
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Preparing Projects, Stationery, and Source Files
ePublisher AutoMap can transform your source documents with no special modifications. Prepare your
project, Stationery, and source documents just like you do when you generate output with the other
ePublisher components. In ePublisher AutoMap, you use a job to define the output generation and the
applicable options. After you create your job, ePublisher AutoMap performs one of the following tasks:

If you created the job based on a project, ePublisher AutoMap synchronizes the project with the
Stationery, and then it generates the output defined by the project.

If you created the job based on a Stationery, ePublisher AutoMap creates a new project based on
the Stationery, adds all the source documents defined by the job, and then it generates the output
defined by the project.

Preparing Projects, Staonery, and Source Files | 227



Starting ePublisher AutoMap
ePublisher AutoMap features an easy-to-use console that allows you to schedule output generation using
your source documents to run either immediately or at a specified time.

To start ePublisher AutoMap

In the WebWorks program group, click ePublisher AutoMap > WebWorks ePublisher AutoMap.

To start ePublisher AutoMap without administrative privileges

If are running in a restrictive environment that does not allow elevation of user permissions to
Administrator rights, then you will need to run ePublisher AutoMap from the following batch file.
This file lives in the installation directory underneath WebWorks\ePublisher\<version>\ePublisher
AutoMap\ . The file is called WebWorks.Automap.Administrator.restricted.bat .

Note: You will not be able to launch or schedule jobs when starting ePublisher
AutoMap this way. However you will be able to create and configure jobs.
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Setting ePublisher AutoMap Preferences
The Preferences window lets you specify default options and preferences that affect the behavior of
ePublisher AutoMap. These preferences allow you to customize the console for your specific needs.
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Specifying the Job, Staging, and User Formats Folder Locations
ePublisher AutoMap has several folders where it stores job-related information, such as job files and log
files. You can customize the location of these folders.

Job Folder

ePublisher AutoMap stores the following types of job-related files in the job folder:

log file
A text file that contains information about the last transformation process. ePublisher AutoMap
creates the log file when you run the job. You can view the log file with any text editor.

job file
A proprietary XML formatted file that contains information describing the job. When you create a
job, ePublisher AutoMap creates the job file and stores the information you specify in the console.
The job file name is the name of the job with a .waj  (WebWorks AutoMap Job) file extension.

Note: ePublisher AutoMap maintains the job files. Do not edit these files.

The default job folder is the My Documents\ePublisher AutoMap\Jobs  folder.

Staging Folder

ePublisher AutoMap stores information needed for transforming the source documents in the staging
folder. This information includes the automatically generated ePublisher project, intermediate data files,
and the output files. The staging folder provides a working folder for processing each job. ePublisher
AutoMap then writes the final output files to the target output destination specified when the project was
created.

Note: ePublisher AutoMap creates the files in the staging folder. Do not edit these
files.

The default staging folder is the My Documents\ePublisher AutoMap\Staging  folder.

User Formats Folder

When ePublisher AutoMap processes a job, it searches the user formats folder for custom user formats.
The default user formats folder is the My Documents\ePublisher Designer User Formats  folder.

To specify the job, staging, and user formats folder locations

1. Start ePublisher AutoMap.

2. On the Edit menu, click Preferences.

3. Click the General tab.
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4. In the Job Folder field, type the path to the folder or network share where you want ePublisher
AutoMap to store the job and log files. You can click Browse and navigate to the folder or network
share.

5. In the Staging Folder field, type the path to the folder or network share where you want ePublisher
AutoMap to store the job projects and output created during your transformations. You can click
Browse and navigate to the folder or network share.

6. In the User Formats Folder field, type the path to the folder or network share where ePublisher
AutoMap checks for the custom user formats to use for creating jobs. You can click Browse and
navigate to the folder or network share.

7. Click OK to save your preferences.
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Automatic Scanning for Conditions and Variables
When ePublisher AutoMap displays windows that list conditions and variables, you can specify whether
ePublisher AutoMap automatically scans the source documents for updated conditions and variables.
Since your source documents may not have new conditions or variables, ePublisher AutoMap attempts to
save time by default and it does not automatically scan for new conditions and variables. You can click
Scan Documents on a window to have ePublisher AutoMap scan your source documents and update the
window contents.

If you want ePublisher AutoMap to always display updated condition and variable values, select the
Always scan for variables and conditions option. Depending on the number and size of files included in
the job, each scan may require several minutes before ePublisher AutoMap can display the conditions and
variables windows.

To enable automatic scanning

1. Start ePublisher AutoMap.

2. On the Edit menu, click Preferences.

3. On the General tab, select Always scan for variables and conditions.

4. Click OK to save your preferences.
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Keeping or Deleting Temporary Files
You can choose whether ePublisher AutoMap keeps or deletes the temporary files created in the staging
folder when it runs a job. By default, ePublisher AutoMap does not delete these files. You need these
files only if you want to examine the actual project and intermediate files created and used during the
transformation process. If you do not want to examine these files, you can disable allow ePublisher
AutoMap to delete the files and reduce the amount of disk space used.

To delete temporary files

1. Start ePublisher AutoMap.

2. On the Edit menu, click Preferences.

3. On the General tab, select Delete temporary files after generating.

4. Click OK to save your settings.

Keeping or Deleng Temporary Files | 233



Defining File Mappings
ePublisher allows you to map files based on their file extension to a source document adapter that
processes that input format. This capability provides the flexibility you need:

You can define which source application processes a file that can be handled by multiple source
applications. For example, both Adobe FrameMaker and Microsoft Word can open text files with a
.txt  extension. The File Mappings tab allows you to choose which application to use for each file
based on the file extension.

You can define custom file extensions. For example, you may choose to use a non-standard file
extension for your Microsoft Word source documents, such as .word  instead of .doc . The File
Mappings tab allows you to add your custom file extension and map it to the appropriate source
application adapter.

You can add new input formats as they become available. ePublisher provides a powerful
framework in which Quadralay and their partners can develop new input formats, such as custom
XML formats. Since XML is a common format, the source files are usually given unique and
descriptive file extensions. The File Mappings window ensures that your projects are ready to
handle any input sources.

Note: ePublisher AutoMap lists only the source application adapters installed
with the product. Your Contract ID specifies the adapters for which you are
licensed. adapter you want to use.

To modify your file mappings

1. Start ePublisher AutoMap.

2. On the Edit menu, click Preferences.

3. Click the File Mappings tab.

4. If you want to add a new file mapping, complete the following steps:

a. Click Add.

b. In File extension, type a file extension to be mapped.

c. In Adapter, select one of the installed source adapters, and then click OK.

5. If you want to modify an existing file mapping, in the Adapter column next to the file extension
you want to modify, select the installed source adapter you want to use for files with that file
extension.

6. If you want to delete an existing file mapping, complete the following steps:

a. In the File Extension column, select the file extension you want to delete.

b. Click Delete.

7. Click OK to save your preferences.
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Defining Output Destinations
ePublisher AutoMap allows you to create and manage output locations independent of your jobs. This
flexibility allows you to define your output locations and then select the one you want to use when you
create a new job. You can also create a new output location as the final part of the job creation process.
ePublisher AutoMap allows you to deploy the final output files to a folder on a local or shared file system,
such as C:\helpdocs  or \\server\share .

To define output destinations:

1. If you use the ePublisher AutoMap user interface to schedule an ePublisher Express project, you
must set the deployment destination in the ePublisher Express project. For more information, see
“Creating Output Destinations”.

2. If you use the ePublisher AutoMap CLI to run an ePublisher Express project, you can set the
deployment destination in the ePublisher Express project or in the CLI. For more information, see
“Creating Output Destinations” and “Using the Command-Line Interface”.

3. If you use ePublisher AutoMap to schedule a Stationery project, you must set the deployment
destination in the job settings, and you must set the deployment destination independently for each
target. Specify the deployment destination in the job settings by completing the following steps:

a. Start ePublisher AutoMap.

b. Select the job to edit in the ePublisher AutoMap main window.

c. On the Job menu, click Edit.

d. Select the Target Configuration tab.

e. In the left pane, select the target for which you want to set the output destination.

f. On the Info tab, in the Deployment area, specify the deployment destination information.

g. Click OK.

4. If you use the CLI to run a Stationery project, you can set the deployment destination in the
ePublisher AutoMap job settings or in the CLI. Set the deployment destination in the job settings
by completing the following steps:

a. Start ePublisher AutoMap.

b. Select the job to edit in the ePublisher AutoMap main window.

c. On the Job menu, click Edit.

d. Select the Target Configuration tab.

e. In the left pane, select the target for which you want to set the deployment destination.

f. On the Info tab, in the Deployment area, specify the deployment destination information.

g. Click OK.
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For more information about setting the deployment destination in the CLI, see “Using the
Command-Line Interface”.
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Defining Email Notifications
ePublisher AutoMap can send an email notification after running a job. The notification provides
information about whether the job ran successfully or encountered any errors. You can also specify
whether to include the log file as a text file attachment to the email.

To configure email notification

1. Start ePublisher AutoMap.

2. On the Edit menu, click Preferences.

3. Click the Notification tab.

4. Select Enable Email Notification.

5. Specify the email addresses and email server information. For more information about a field, click
Help.

6. Click OK to save your preferences.

Note: You can quickly enable or disable email notification without modifying the
other preferences by toggling the Enable email notification check box.
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Selecting Console Language (English, German, French, and Japanese)
In addition to the English language, the ePublisher consoles have been translated into German, French,
and Japanese languages. When ePublisher starts, it detects the operating system locale and displays
the corresponding ePublisher console. You can display the console for a locale that is not the operating
system default. For example, you can display the German console on an English version of Windows.

To select the language for the console

1. Start your ePublisher console.

2. On the Edit menu, click Preferences.

3. In the User interface language field on the General tab, select the language you want the console
to display.

4. Click OK to save your preferences.

5. Close and restart the console to view the console in the selected language.
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Working with Jobs
This section describes how to create and manage ePublisher AutoMap jobs. A job is a set of tasks that
ePublisher AutoMap can perform based on a Stationery or a project. You can immediately run a job, or
you can schedule a job to run at a later time. By default, job files are stored in the following folder:

My Documents\WebWorks ePublisher AutoMap\Jobs

You can change the default location in the ePublisher AutoMap preferences. Job files have a .waj  file
extension. Job files depend on other files located in the job folder and should not be moved or copied
independently.

ePublisher AutoMap displays a unique icon to help you identify project-based jobs and Stationery-based
jobs. Each job name is preceded by the corresponding icon.

After you schedule a job in the ePublisher AutoMap user interface, you can close the ePublisher
AutoMapuser interface, and the job will still run based on the schedule you specified.

When ePublisher AutoMap runs a job either from a schedule or from a command prompt, Windows opens
a command prompt that displays the log as it is generated. When the job finishes, the command prompt
closes. After the job runs, you can view the log file using one of the following methods:

If you use ePublisher AutoMap to schedule an Express or Stationery project, the log is stored
in the Job  folder. You can view the log by clicking View log on the Job menu in the ePublisher
AutoMap user interface.

If you use the CLI to run an Express project, there is no entry in the ePublisher AutoMap user
interface. You can find the log in the Express project directory and view it in Notepad.

If you use the CLI to run a stationery project, the log is stored in the Job  folder. You can view the
log by clicking View log on the Job menu in the ePublisher AutoMap user interface.

Note: The ePublisher AutoMap user interface displays the last time that the Windows Scheduler
ran the stationery project. It does not display the time the CLI ran.
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Creating a Project-Based Job
Project-based jobs allow you to schedule ePublisher AutoMap to generate the output defined by an
existing ePublisher project. You first create the ePublisher project as needed, or you can use an existing
project. Then, you create a project-based job so ePublisher AutoMap can use the project to generate the
output defined by the project.

To create a project-based job

1. Start ePublisher AutoMap.

2. On the File menu, click New Job.

3. Click ePublisher project on the New Job window.

4. Type the path or click the Browse Folder icon to select the ePublisher project you want to
schedule, and then click OK.

5. In the Job Name field, type the desired job name.

Note: The Choose ePublisher project field displays the previously selected ePublisher project.
You can change the selected project.

6. If you want to run a pre- or post-build script before or after the job runs, complete the following
steps:

a. Click the Edit Script button for the Pre-build or Post-build script field.

b. Type or paste your script into the editor, and then click OK. For more information about
scripts, see “Using Scripts for Additional Custom Processing”.

7. Click Next.

ePublisher displays the Target Selection window. This window lets you select which targets to
generate as part of this ePublisher AutoMap job. Depending on your project, there may be multiple
targets listed in the Target Selection window.

8. Select the check box in the Build column next to each target you want to generate, and then click
Finish.

9. Schedule the job as needed, and then click OK. You can also schedule the job at a later time. For
more information, see “Scheduling Jobs with Windows Scheduler”.

Project-based jobs deploy output only if a deployment target is set in the project itself. This deployment
information is specified in the target settings in ePublisher. ePublisher AutoMap reads only the
deployment target name from the project. Therefore, you must make sure an output destination with
the same name and is defined in ePublisher AutoMap or you may receive a deployment error. For more
information, see “Defining Output Destinations”.
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Creating a Stationery-Based Job
Stationery-based jobs provide a powerful solution that can save your time and increase productivity.
These jobs can also reduce errors when generating online and print content. Stationery-based jobs allow
you to associate your source documents with your ePublisher Stationery. This combination lets you
apply a single Stationery to many different source documents, reusing the transformation defined by the
Stationery. This method ensures accuracy and consistency across many different projects and output files
for your organization.

To create a Stationery-based job

1. Start ePublisher AutoMap.

2. On the File menu, click New Job.

3. Select ePublisher Stationery on the New Job window.

4. Type the path or click the Browse Folder icon to select the Stationery upon which you want to base
this job, and then click OK.

5. In the Job Name field, type the desired job name.

Note: The Choose ePublisher Stationery field displays the previously selected Stationery. You
can change the selected Stationery.

6. If you want to run a pre- or post-build script before or after the job runs, complete the following
steps:

a. Click the Edit Script button for the Pre-build or Post-build script field.

b. Type or paste your script into the editor, and then click OK. For more information about
scripts, see “Using Scripts for Additional Custom Processing”.

7. Click Next.

ePublisher displays the Documents window. This window lets you configure the groups and
documents you want to generate output for in this job. You can either manually add the documents
or you can run a script to retrieve documents within a group.

For example, you may want to retrieve documents from a version control or content management
system. You can provide a script to retrieve and prepare your documents as needed. This script runs
before the transformation, which ensures that you always have the most current version of your
content without having to perform a manual update before each transformation.

8. If you want to manually add groups of documents to the job, complete the following steps:

a. Click New Group.

b. Specify a name for the group.

c. Click Add Document, and then browse and select your source documents.

d. Repeat this process to add more groups and source documents, and then click Next.
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9. If you want to use a script to add a group of documents, complete the following steps:

a. Click New Group.

b. Specify a name for the group.

c. Click Edit Script.

d. Type or paste your script into the editor, and then click OK.

10. Click Next.

ePublisher displays the Target Selection window. This window lets you select which targets to
generate output for as part of this ePublisher AutoMap job.

11. Select the check box in the Build column next to each target you want to generate, and then click
Next.

ePublisher displays the Target Configuration window. The Stationery defines the configuration
options for each target. You can override these configuration options for each target in a Stationery-
based job. Depending on the output format of the selected target, the Target Configuration window
provides tabs for adjusting various options, such as conditions and variables.

The information presented on each tab is relative to the target selected in the Target Name column.
You can adjust values for each target independent of the other targets. For example, you can have
two WebWorks Help 5.0 targets where the conditions are set differently depending on the target
audience.

12. If you want to override the configuration settings defined in the Stationery for a target, complete
the following steps:

a. Select the target you want to modify in the Target Name column.

b. Specify the appropriate values for the configuration options on each tab for that target. For
more information about the fields on a tab, click Help.

13. Click Finish.

14. Schedule the job as needed, and then click OK. You can also schedule the job at a later time. For
more information, see “Scheduling Jobs with Windows Scheduler”.
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Duplicating an Existing Job
Sometimes it is more convenient to make a copy of an existing job and adjust its options instead of
creating a new job. ePublisher AutoMap allows you to duplicate an existing job. Then, you can modify
the options as needed for your new job.

To duplicate an existing job

1. Start ePublisher AutoMap.

2. Select the job you want to copy in the ePublisher AutoMap main window.

3. On the Job menu, click Duplicate.

4. Specify the new job name, and then click OK.

5. Specify the scheduling options as needed, and then click OK. For more information, see
“Scheduling Jobs with Windows Scheduler”.

Once the new job exists, you can modify the job for your specific needs. For more information, see
“Editing an Existing Job”.
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Editing an Existing Job
When you edit an existing job, ePublisher AutoMap presents the windows used to create the job as tabs of
the Edit Job window. Select the appropriate tab that contains the information you want to modify.

To edit an existing job

1. Start ePublisher AutoMap.

2. Select the job to edit in the ePublisher AutoMap main window.

3. On the Job menu, click Edit.

4. Select the appropriate tab and modify the values as needed. For more information about a field,
click Help.

5. Click OK.
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Scheduling Jobs with Windows Scheduler
Immediately after creating a new job, ePublisher AutoMap starts the Windows Scheduler to allow you to
schedule your job. ePublisher AutoMap uses the Windows Scheduler built into the Microsoft Windows
operating system. The Windows Scheduler allows you to schedule a job to run at pre-determined times
and repeating intervals. If you do not want to schedule the job, click Cancel. You can schedule the job at
a later time, and you can modify an existing schedule.

When you schedule a job and then click OK, Windows prompts you for your Windows user name and
password. For more information about using the Windows Scheduler, see the Windows operating system
online help. To open the Windows online help, click Help and Support on the Start menu.

To schedule a job or change the schedule for an existing job

1. Start ePublisher AutoMap.

2. Select the job to schedule or reschedule in the ePublisher AutoMap main window.

3. On the Job menu, click Schedule Job.

4. Specify the appropriate values, and be sure to add a Trigger that designates what schedule the Job
will run, and then click OK.

5. If you select the Run whether user is logged on or not option, you will need to specify your
Windows user name and password, and then click OK. Since you are scheduling a task in Windows
Scheduler, you must provide your Windows user name and password to add the task. If you are part
of a Windows domain, include the domain name, such as domain\user.
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Deleting an Existing Schedule for a Job
You can create multiple schedules for a job. These schedules are known as Triggers and can be modified
in the Triggers tab in the Windows Scheduler interface. You can also delete one or more of these existing
schedules. The only way to fully delete a task for a Job is to do so via the Windows Task Scheduler
interface or to delete the Job itself.

To delete an existing job

1. Start ePublisher AutoMap.

2. Select the job to delete the schedule for in the ePublisher AutoMap main window.

3. On the Job menu, click Delete.
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Running an Existing Job
You can run a job at any time whether it is scheduled or not. This feature allows you to test the job while
you are configuring it. You can also run a job to quickly generate output based on a set of predefined
settings.

To run an existing job

1. Start ePublisher AutoMap.

2. Select the job you want to run in the ePublisher AutoMap main window.

3. On the Job menu, click Run.
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Viewing a Job Log File
When a job runs, ePublisher AutoMap creates a log file that documents the steps performed for that job.
You can view this log file when one exists. ePublisher AutoMap keeps the log file only for the last time
the job ran. Previous log files are not kept.

To view a log file

1. Start ePublisher AutoMap.

2. Select the job to view the log for in the ePublisher AutoMap main window.

3. On the Job menu, click View Log.

248 | Viewing a Job Log File



Canceling a Job
When you cancel a running job, ePublisher AutoMap, Microsoft Windows, Adobe FrameMaker, and
Microsoft Word must do some clean-up work. During this process, Windows may display the standard
Microsoft Windows End Program window. Do not click the End Now or Cancel buttons. The window
will close usually in less than 15 seconds once everything has finished properly.

To cancel a running job

1. Start ePublisher AutoMap.

2. Select the running job you want to cancel in the ePublisher AutoMap main window.

3. On the Job menu, click Stop.
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Deleting an Existing Job
If you no longer need a job, you can delete it from the ePublisher AutoMap main window.

To delete an existing job

1. Start ePublisher AutoMap.

2. Select the job to delete in the ePublisher AutoMap main window.

3. On the Job menu, click Delete.

4. Click Yes to confirm that you want to delete the selected job.
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Using Scripts for Additional Custom Processing
You do not need to write scripts to use ePublisher AutoMap. However, scripts allow you to extend
ePublisher AutoMap and integrate it with other products and custom workflows. You can define scripts to
run before and after a job generates content, to run before and after each target generates content, and to
retrieve source documents on a per group basis.
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Writing Scripts
You can write scripts directly in the ePublisher AutoMap script editor window, or you can cut and paste
scripts from another text editor. The ePublisher AutoMap script editor supports only text-based scripts.
Any formatting or additional information available in a third-party script editor is lost when the script is
pasted into the ePublisher AutoMap script editor.

ePublisher AutoMap treats scripts like DOS batch files. The script must be complete and valid or it will
fail when the job runs. Although you can write all your scripts directly in the ePublisher AutoMap script
editor; this approach may not be your best option.

When calling complex scripts, you may want to create and store those complex scripts in your file system
and simply call those files from the script you create in the ePublisher AutoMap script editor. Since the
script editor treats the scripts like DOS batch files, you can call other batch files, applications, or scripts
written in any scripting language, such as VBScript, Perl, and Python. You can also pass parameters and
script variables to the files you call. However, some variables have meaning only for certain types of
scripts. For example, the DeployFolder variable is specific to a target and does not having meaning in a
pre-build or post-build job script.
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Working Folder
Windows associates batch files with a working folder. The working folder is the current working directory
used by an application or batch file for processing. For example, if a batch file creates a new file without
specifying a path, the file is created in the working folder. If a batch file attempts to read a file without a
specifying a path, Windows assumes the file is in the working folder.

The working folder for an ePublisher AutoMap batch file is the job folder itself. You can locate this
folder using the job directory ${JobDir}  scripting variable. For more information, see “Using Scripting
Variables Example”.
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Opening and Using the Script Editor
ePublisher AutoMap includes an editor for specifying and writing job scripts. This editor provides a text
area for writing or pasting your script and a list of ePublisher AutoMap variables that you can use in your
scripts or pass to other scripts and applications.

To open the script editor and edit a script

1. Start ePublisher AutoMap.

2. Select the job to edit in the ePublisher AutoMap main window.

3. On the Job menu, click Edit.

4. Click the appropriate Edit Script button to open the script editor window for the script you want to
edit.

5. Click in the text editing area.

6. Type your script, or press Ctrl+V to paste it from the clipboard.

7. If you want to insert an ePublisher AutoMap scripting variable, complete the following steps:

a. Click in the editor window where you want to insert the variable.

b. Double-click the variable name in the Script Variables pane to insert it. You can also type
the variable name surrounded by ${} . For example, to include the project directory variable
in your script, type ${ProjectDir} .
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Scripting Variables
The following table provides a summary of the available scripting variables.
 

Variable Description Scope

FileListName Returns the name of the file that
contains the list of source documents.

Document scripts only

FileListPath Returns the path of the file that
contains the list of source documents.

Document scripts only

GroupName Returns the name of the documents
group that is currently being
processed.

Document scripts only

BuildAction Returns whether the current build
action is pre-build or post-build.

Job scripts, target scripts, and
document scripts

JobDir Returns the path of the job .waj  file. Job scripts, target scripts, and
document scripts

JobFile Returns the name of the job .waj
file.

Job scripts, target scripts, and
document scripts

JobName Returns the name of the job. Job scripts, target scripts, and
document scripts

ProjectDir Returns the path of the temporary
project file that ePublisher AutoMap
created for the job.

Job scripts, target scripts, and
document scripts

ProjectFile Returns the name of the temporary
project file that ePublisher AutoMap
created for the job.

Job scripts, target scripts, and
document scripts

DeployFolder Returns the deployment directory
path.

Target scripts only

ErrorCount Returns the number of errors reported
during the generation process.

Target scripts only

TargetDeployKey Returns the deployment target name. Target scripts only

TargetName Returns the name of the target being
generated.

Target scripts only
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Variable Description Scope

TargetOutputDir Returns the output path of the target. Target scripts only
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Scripting Examples
The following list highlights a few of the ways you can use scripts to customize and integrate the content
publication process:

You can write scripts to get the latest version of files from your version control system or content
management system. For more information, see “CVS Version Control Checkout Example”.

You can use variables within scripts. For more information, see “Scripting Variables” and “Using
Scripting Variables Example”.

You can customize the log file created when ePublisher runs a job. For more information, see
“Show Time and Date Example” and “Using Scripting Variables Example”.

You can use post-processing scripts to customize the deployment process. These scripts can modify
files and even rebuild the final deliverable. For example, you can use scripts to further customize
the generated files and then automatically run Microsoft HTML Help Workshop to rebuild the
.chm  file.
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Show Time and Date Example
This example simply displays the time and date in the log file by calling the time and date commands
built into the DOS command-line interface. In this case, the script was added as a pre-build step for the
job running before the first target starts generating output.

The following output shows the time and date included in the log before the first target starts the
generation process. This information can automatically timestamp a job log file. You can also use these
values in your script to log elapsed time and make decisions.

WebWorks Automap

09:57 AM

Mon 6/23/2008

Scanning 1 document(s)...

Building target: WebWorks Help 5.0

Generation started at 9:57:15 AM

Initializing file information

Updating documents.

Applying settings to WebWorks.doc, 1 of 1.
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Using Scripting Variables Example
This example creates a simple mini-report inside the log file for each target in the job. This simple
example demonstrates the use of the scripting variables. In this case, the values of the variables are
displayed as part of the report using the echo command built into the DOS command-line interface.

The following figure shows some of the variable names surrounded by single quotes. You do not need to
enclose variable names in quotes. These quotes are there only to show emphasis on the variable values in
the mini-report example.

The following output shows the mini-report displayed immediately after the target starts to be built. You
could add this same script as a post-build step for the target and a similar mini-report would be created
when the target is done being generated.

Building target: WebWorks Help 5.0

   

--- Target Mini-Report for WebWorks Help 5.0 ---

‘WebWorks Help 5.0’ is running from the ‘Scripting Demo’ job located at C:\Documents
 and Settings\doc\My Documents\WebWorks Automap\Jobs\Demo.

Currently running the ‘PreBuild’ script for the WebWorks Help 5.0 target. ‘WebWorks
 Help 5.0’ will deploy to ‘Online Help’ located in the C:\AutoMapOutput\Help Systems
\Online Help folder.

So far, 0 errors have occurred.

--- End of WebWorks Help 5.0 mini-report ---

   

Generation started at 9:57:15 AM

Initializing file information
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Updating documents.

Applying settings to WebWorks.doc, 1 of 1.
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CVS Version Control Checkout Example
The previous example scripts demonstrate some simple capabilities of using scripts in ePublisher
AutoMap. This example shows how to check out source files from a version control system at the start of
a job.

Version control systems let you store files and retain information concerning different versions of those
files. You can store multiple versions of files, revert to previous versions of files, and share files among
large groups of people. The advantage of using a version control script to retrieve source files rather
than adding them directly to a project ensures that your job is always working with the latest checked in
version of each source file.

Each version control system works in a slightly different way. ePublisher AutoMap is not tied to a specific
version control solution. ePublisher AutoMap provides an abstract way of retrieving a list of source files
to transform. There are a few rules about how this list is named and formatted, but the actual creation of
the list is left to the script and scriptwriter.

The scripting capabilities in the Documents panel are not limited to checking files out of a version control
system. The only requirement is that the FileList.txt file includes a list of files and paths to be
transformed. You can access the FileList.txt  file and the path to it using the ePublisher AutoMap
${FileListName}  and ${FileListPath}  scripting variables. For more information, see “Scripting
Variables”.

The following script example calls getfilesaction_cvs.vbs , which is installed with ePublisher
AutoMap. By default, this script is located in the following location:

\Program Files\WebWorks\ePublisher AutoMap\Scripts\getfilesaction_cvs.vbs

The getfilesaction_cvs.vbs  script is written using the Visual Basic Scripting (VBS) capabilities built
into Microsoft Windows to check out files from a CVS (Concurrent Version System) server and create a
file list to be processed by ePublisher AutoMap. This script is not meant to be used in its current form.
This script provides a starting point that includes everything you need to set up a working script for your
particular environment.

The getfilesaction_cvs.vbs  script includes comments to help someone with scripting experience
understand the actions it performs. Since this script provides only a starting point, you need to modify this
script for your environment. For example, you need to set the CVS attributes for your user name, server
name, and type of authentication. You also need to adjust for how CVS is installed and called in your
environment. These areas of the script are highlighted in the following figure:
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The following figure shows an example of how to call the getfilesaction_cvs.vbs  script. The
parameters passed indicate the module to checkout and to filter on the .doc  extension. When this script
runs, it checks out the indicated module from CVS, filters those files based on the .doc  extension, and
adds those .doc  files to the FileList.txt  file. That file list is then used by the job as the list of files to
process and transform.

This example is only one possible way of creating a list of files to transform. Once you understand the
mechanism that ePublisher AutoMap uses to retrieve its list of source documents to transform, you can
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create that list using the process you prefer. Whether you want to use a script or an application, ePublisher
AutoMap can run it from the script editor as long as it is available to ePublisher AutoMap.
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Using the Command-Line Interface
In addition to the ePublisher AutoMap console that allows you to create, edit, and schedule jobs,
ePublisher AutoMap also provides a command-line interface (CLI). The CLI gives you control of
ePublisher AutoMap from the Windows command-line interface. You can use the CLI and the supported
options in scripts and batch files to automate and streamline your processes.
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Running ePublisher AutoMap from the Command Line
You can run ePublisher AutoMap from the command line using the ePublisher AutoMap
WebWorks.Automap.exe  command-line application. This application is installed at the root of your
ePublisher AutoMap installation location. The default location for this file is:

Program Files\WebWorks\ePublisher AutoMap\WebWorks.AutoMap.exe

Notes:  
If you install ePublisher AutoMap in another location, the WebWorks.Automap.exe  file is installed
in that location and you need to adjust your specified path.

The WebWorks.Automap.exe  file depends on other files installed in the ePublisher AutoMap
folder. Do not move or copy the WebWorks.Automap.exe  file.

To run ePublisher AutoMap from the command line

1. Open a Windows command prompt by completing the following steps:

a. On the Start menu, click Run.

b. Type cmd , and then click OK.

2. Enter the following command to change to the default ePublisher AutoMap folder:

CD \Program Files\WebWorks\ePublisher AutoMap

3. Enter the WebWorks.AutoMap.exe  command with the appropriate options.

If you run the WebWorks.AutoMap.exe . command without any options, ePublisher AutoMap displays a
typical usage syntax statement.
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CLI Syntax and Reference
The ePublisher AutoMap command-line interface can run a job or an ePublisher project. The command-
line interface uses the following syntax:

WebWorks.Automap.exe [-f] [-n] [-c] [-l] [-u] [-j] [-d directory]

[{[-s directory] jobfile}|{[-t targets] projectfile}]

The supported command-line options are defined in the following table.
 

Option Description

-c Deletes cached information and builds the output from scratch. Use this
option only when passing an ePublisher project .wrp  file. This option is
equivalent to selecting Regenerate All. The default is to generate only what is
needed and to use all available cached information. You can also specify this
option as --clean .

-d directory Specifies an alternate deployment directory. This setting overrides the
specified default values. You can also specify this option as

--deployfolder directory.

-u Scans all source documents for new styles, conditions, variables and xrefs.
After the conversion is completed the resulting Express project file will be
saved with all the updated information. You can also specify this option as --
update .

-j Just scans all source documents for new styles, conditions, variables and
xrefs. Saves Express project file without running a conversion.You can also
specify this option as --justupdate .

-f Does not send an email notification when this job is finished. This setting
overrides the default value specified in the ePublisher AutoMap preferences.
You can also specify this option as --nonotify .

-l Deletes all files in the deployment location before deploying the newly-
generated output. This option ensures that all files in the deployment folder
are from this last generation process. You can also specify this option as

--cleandeploy .

-n Generates output and does not deploy it. This setting overrides the default
deployment settings specified in the job or ePublisher project. You can also
specify this option as --nodeploy .

-s directory Specifies the staging directory to use. Use this option only when passing a job
.waj  file. This setting overrides the default value specified in the ePublisher
AutoMap preferences. You can also specify this option as
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Option Description
--stagingdir directory.

-t targets Builds only the specified targets. Separate multiple targets with a comma and
no space on either side of the comma. Use this option only when passing an
ePublisher project .wrp  file. The default is to build all targets. You can also
specify this option as --target targets.

jobfile Specifies the name of the ePublisher AutoMap .waj  job file.

project Specifies the name of the ePublisher .wrp  project file.

As with other command-line applications, specify the command-line options on the command line after
the application name itself. Separate multiple command-line options with a space. Review the following
additional notes concerning ePublisher AutoMap command-line options:

The command-line options have both shortened and verbose formats. For example, you can specify
the clean option as –c  or --clean . Both options mean exactly the same thing and you can mix the
shortened and verbose formats across the options.

Some options require additional information. For example, the staging folder option requires the
name of the directory and is specified as --stagingdir directory . You need to include the
equals sign without spaces on either side.

In cases where you specify paths with spaces, enclose those paths in double quotes to correctly
handle the paths. You do not have to enclose paths without spaces in double quotes, but you
can without an issue. For example, c:\projects  works without enclosing it in double-quotes.
However, c:\my projects  does not work as expected. The correct format for the latter path is
”c:\my projects”.
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CLI Examples
The following examples illustrate how to use the command-line interface.
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Running a Project and Updating the Express project file
The following example runs the c:\Projects\MyProject.wrp  project and updates MyProject.wrp  with
the new styles, conditions, variables and xrefs:

WebWorks.AutoMap.exe –u ”c:\Projects\MyProject.wrp”
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Running a Project and Generating Only One Target
The following example runs the c:\Projects\MyProject.wrp  project and generates only the WebWorks
Help  target:

WebWorks.AutoMap.exe –t ”WebWorks Help” ”c:\Projects\MyProject.wrp”
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Running a Project from Scratch and Deploying to a Clean Location
The following example runs the c:\Projects\MyProject.wrp  project and generates all targets defined
in the project. This example also deletes the cached information in ePublisher to ensure it generates all the
content from scratch, and it deletes all the files in the deployment location before deploying the newly-
generated files:

WebWorks.AutoMap.exe --clean --cleandeploy ”c:\Projects\MyProject.wrp”
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Running a Project and Deploying to an Alternate Location
The following example runs the c:\Projects\MyProject.wrp  project and generates all targets defined
in the project. This example also deploys all the newly generated files to the \\TestServer\Review
folder:

WebWorks.AutoMap.exe -d ”\\TestServer\Review” ”c:\Projects\MyProject.wrp”
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Running a Job Without Sending Notification When Done
The following example runs the c:\Jobs\MyJob.waj  job and does not send any email notification when
the job is done:

WebWorks.AutoMap.exe --nonotify ”c:\Jobs\MyJob.waj”
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Running a Job and Deploying to a Clean Location
The following example runs the c:\Jobs\MyJob.waj  job and deletes all the files in the deployment
location before deploying the newly-generated files:

WebWorks.AutoMap.exe --cleandeploy ”c:\Jobs\MyJob.waj”
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Running a Job Without Deploying the Content
The following example runs the c:\Jobs\MyJob.waj  job and does not deploy the generated output files.
This example also uses the C:\Temp\Stage  folder as the staging folder when running the job:

WebWorks.AutoMap.exe --nodeploy -s ”C:\Temp\Stage” ”c:\Jobs\MyJob.waj”

The staging folder provides a working folder for processing the job. ePublisher AutoMap stores the
automatically generated ePublisher project, intermediate data files, and the output files in this folder.
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